New Record Problem when filtering

I'm using Access 2003 and have what at first seems like a common problem.  On 
one of my forms if a user hits the scroll button on the mouse, it scrolls to 
a new record which then causes problems.  I don't have sufficient rights to 
deploy a dll file so I got around it by changing the AllowAdditions setting 
to "No".  Theoretically that should have worked and indeed it does if I open 
up a form directly.  But in this database I often open up a form to a 
particular record using the "Where Condition" argument of the DoCmd.OpenForm 
command.  When I do that, it opens the form to the correct record, but then 
ignores the fact that I have Allow Additions set to "No" and allows the user 
to create a new record.  If I open the same form directly without a filter, 
then it does not allow additions.  Any suggestions?
0
Utf
1/3/2008 8:19:01 PM
access.formscoding 7493 articles. 0 followers. Follow

1 Replies
649 Views

Similar Articles

[PageSpeed] 7

This site has a mousewheel control that doesn't require a dll:
http://www.lebans.com/mousewheelonoff.htm
-- 
Dave Hargis, Microsoft Access MVP


"Allison Wonderland" wrote:

> I'm using Access 2003 and have what at first seems like a common problem.  On 
> one of my forms if a user hits the scroll button on the mouse, it scrolls to 
> a new record which then causes problems.  I don't have sufficient rights to 
> deploy a dll file so I got around it by changing the AllowAdditions setting 
> to "No".  Theoretically that should have worked and indeed it does if I open 
> up a form directly.  But in this database I often open up a form to a 
> particular record using the "Where Condition" argument of the DoCmd.OpenForm 
> command.  When I do that, it opens the form to the correct record, but then 
> ignores the fact that I have Allow Additions set to "No" and allows the user 
> to create a new record.  If I open the same form directly without a filter, 
> then it does not allow additions.  Any suggestions?
0
Utf
1/3/2008 8:44:01 PM
Reply:

Similar Artilces:

new to access
i am fairly new to access 2003, i have created several database, very basic ones, and i am trying to learn how i can enter information in one data base and have it distributed into the rest of them. i manage 4 buildings for a school, ihave one database for each building and i have to enter what rooms i put students in, ihave another database for new arrivals, once there entered in new arrival data base, i then have to enter them in to the proper building, i have one for students checking out, once enterd in the checkout database i have to go into that buildings database and remove them. this i...

Filtering a form
Hello everyone, I've run into a problem i'm not sure how to solve. I have a form that with the click of a button filters the form based on the value in a text box. I also have my own controls for record navigation for navigating through the filtered form. There is a text box called "Total Records" that is supposed to display the total number of records in the form after it is filtered using Me.Recordset.RecordCount as the source. This doesn't appear to work properly; for example with one search, Me.Recordset.RecordCount returns "2" when the...

Adding new store prices to hq
I have the new store prices on Excel (upc code, price) but i need to import those prices to Store Ops. My understanding is that i can not use the import tool on customer source because I am using HQ? The items are already imported I just need prices to be imported. Any Ideas? hi GO to Store Manager, then Wizard, run the Inventory Wizard and then Chose the Task 110 then from the Select Items to Update select Manually Item click next next till you get the which says Inventory Wizard Workpad screen. Click on Import and then import the file. if you still have problem let me know. Regards A...

text box filter by form
For some reason that I just can't explain, a text box on a form associated with a single primary key field behaves unexpectedly when I do a filter-by-form. Instead of listing all of the records from the source table as choices in combo box mode, I only see "Is Null" and "Is Not Null" as choices. I have an older form from another database that behaves as I hoped this one would, yet there seems to be no property differences between the two text boxes. Can anybody explain what I'm missing please? Having "Is Null" and "Is Not Null" as filt...

problem with csv
HI When I have my regional settings at Canada (French) and I open a CSV file it does not See the commas as column separators So when you open your document it is all in one cell But if I set myself to English (Canada) it opens like it should at each comma it’s a new column Does any know how to fix this please help? Angelo Presumably you want to have the settings at Canada (French)? If you can't find a way to change the default list separator, then you could always use Data | Text-to-columns with comma as the separator and parse your file into columns that way. Hope this helps. ...

Purchase new home procedure with Money 2007
What is the best way to record the purchase of a new home? I am sure this is 'documented' somewhere but would like some detailed steps on what to do - like what/how to record all the fees for the buy, asset account, transferring items to that account, loan amount, etc. Anyone got a more or less detailed list of what to do? Tom -- See http://umpmfaq.info/faqdb.php?cat=23 for some insights. "Tom Simpson" <tom@nospam.com> wrote in message news:OP8MLttKIHA.484@TK2MSFTNGP06.phx.gbl... > Anyone got a more or less detailed list of what to do? ...

Data Entry Form and Subform problems
Hi, I have a form and subform that I am trying to use for data entry. However, it's not working out as planned. I have two tables: tblAccount [AccountID] (PK) [DefaultAddressID] ....more fields tblAddress [AccountID] (Combined PK) [AddressID] (Combined PK) .... more fields tblAccount holds Account records including the default address to be used in all transactions, although an account can have more than one address. tblAddress holds all the addresses for all accounts with a combined primary key of AccountID and AddressID. tblAccount.AccountID is an autonumber field. tblDefaultAddre...

after XP-SP2 problems with Outlook Web Access
After XP-SP2 Outlook Web Access reacts strange: If I trie to answer to an email the answer windows (form) hasn't any text field. I already added the Web-Site to trusted sites - but nothing changed. Any ideas? Resetted all the Internet Explorer options and Zone Settings, Cleared the Temporary Internet Files, etc already? If so state your version of OWA and ask in an Exchange newsgroup as OWA is part of Exchange not Outlook. -- Robert Sparnaaij [MVP-Outlook] www.howto-outlook.com Tips of the month: -What do the Outlook Icons Mean? -Create an Office 2003 CD slipstreamed with Service...

Problem with public folders #2
I move mailbox and public folder from an old server (Win2K/Exchnage 2K) to new server (Win2K/Exchange 2K). I follow the instructions on the KB 307917, for public folder replication. Accindentally, I uninstal Exchange 2000 on the old server before to remove public folders replicas on the new exchange server. Outlook client can work on the public folders of new server, but I can not work with public folder (to remove public folders replicas) with Exchange System Manager (ESM). I Want to use folder proprierties to remove replica from old server. I can not see the public folder on the root publi...

IMAP reply
I am using Outlook 2003 with IMAP. Whenever I send a reply to an email that I have read (not bolded) Outlook changes that email to unread (and makes it bold). I've searched the 'Net but have yet to find anyone else describing this same problem. Any suggestions? Thanks in advance! Steve ...

Outlook attachment problem #2
Dear All, I have a client who received an email from her client with attachments. At the end of the email a line written in Italic like the following: (See Attached file: 000_TG_Koh Chang.pdf)(See attached file:000_TGTrang.pdf) However, there is no way you can download, view, or save the attachments. The strange thing is when you forward the email. You will see the attachments show on under the subject line. When you double click it, you can see the attachments as usual. Why cannot see the attachment at the first time? Why it shows when forwarding? Many thanks Regards, Andrew Lau ...

Move OWA emails to new mailbox
I have an OWA account where they are change their email address. I know I can get new emails to them but how can I get emails that are stored on the server moved to the new OWA account. On 14 Jul 2006 11:45:08 -0700, wcutler@gmail.com wrote: >I have an OWA account where they are change their email address. I >know I can get new emails to them but how can I get emails that are >stored on the server moved to the new OWA account. Explain that again, you don't make sense here, even if you did ask the question three times. On 14 Jul 2006 11:45:08 -0700, wcutler@gmail.com wrote: ...

New users not appearing in the address list
Hi, We have created three new users who have not had the Recipient Update policy applied, even though the Recipient Update Services have all manually been told to update (schedule is still set to Run Always). The users appear in the Exchange System Manager under 'Recipients \ All Address Lists \ All Users' and 'Recipients \ All Global Address Lists \ Default Global Address List', yet they do not appear in the Outlook Address list (and therefore we cannot set up Outlook for these users). There are no errors or warnings in the event logs. Can anyone advise me, please? W...

a range area referred anywhere and repeatively on a new worksheet page
Hi I have a grid / table which has prices on which i wish to do calculations on so i entered the information and then named it as a range pricegrid (pricegrid refers to cells between (a1:d26)) I then create a new worksheet which i wish to refer to pricegrid on the same page. if i am refer to =pricegrid on the next worksheet and the rows and columns exactly aligns with the value everything works i now want to move to a14 and want to use =pricegrid it will show value as it cant display in a different area i presume i can use the offset function but how can i create value on ...

New identities/accounts
I have 2 identities on OE and when I go through Message > Accounts > Add etc. I fill in the details and the new account shows in the accounts panels but the Inbox, Sent Items etc. don't show in the main OE screen. Does OE only allow two identities? BTW, for hotmail (actually, an address ending in .live.co.uk) should I use POP3 and SMTP? Which ports? WTIA. You are confusing Identities and Accounts. You can have one or more identities (File, Identities) each identity can have one ore more accounts (Tools, Accounts). Identities are used to keep mail separate as...

Money problems
My copy of "money" was upgraded to 2005 Delux edition in 2005. Las year I purchased the 2007 edition whioch stated that "data on previous editions would automatically be converted: but attempts then .and again now result in a message to the effect that it could not install data from pevious editions. Due to lack of capacity on my old computer I have purchase a new one and as I no longer have the 2005 installation disk I intended to add the old hard drive on the new machine. Unfortunately the New machine runs on "vista" and is incompatable with the XP system....

contacts w/wrong names problem
I have a user whos contacts look really jumbled in spots. His contacts "disapear". Upon further investigation (he has 4000+ contacts) other peoples names are being put on other contacts. So bryan smith will appear twice, and john carpenter is missing, however, johns info just has brians name on it. How is this possible? Import gone wrong? Data corruption? He is "missing" several contacts, which I suspect are the same issue. Please post a coherent question that includes accurate and specific details others could understand. Include versions and precise steps t...

Filter tasks in Outlook Today
Does anybody know how to make my own outlook today page, where I can filter tasks based on categories? Eg. I want to columns with tasks, one displaying private tasks, and one displaying Work related tasks. I allready have the tasks categorised. As I understand, this reads out all the tasks, but I am not able to make it filter by category. <OBJECT ID="TaskList" CLASSID="CLSID:0468C085-CA5B-11D0-AF08-00609797F0E0"> <PARAM NAME="Module" VALUE="Tasks"> </OBJECT> Is this possible? Running oultook 2003 I think (I'm no expert on ...

Problem with Office installation
Version: 2008 Operating System: Mac OS X 10.5 (Leopard) Processor: Intel I installed the trial version of office and then upgraded to the full version, downloading it online. It installs fine, but when I try to run any of the office programs, I get a message that says: "A problem has been detected with the Microsoft Office installation. Try running the Office Installer again to resolve the problem." I've reinstalled it at least 5 times now, and I still get the same message. I've uninstalled office and then installed it. I've restarted my computer. Nothing will make that ...

Contact filtering anomaly (Outlook 2000)
I have a category called 'Out of touch'. It is never the only category of a contact (ie: each 'Out of touch' contact belongs to at least another category) I want to have a view where I see all my contacts NOT belonging to 'Out of touch'. However, when I do : Customize current view / Filter / Advanced / [Categories] [doesn't contain] [Lost touch] I get no results at all. This actually happens with any category that I want to eliminate from the view. Any idea of what I am doing wrong? Thanks, W. ...

Statement filter date
I am printing statement with a filter date of 6-2-08 to 7-1-08 but the entries before 6-2-08 are still coming up in the statement. Can anyone please help me make the filter date work? It is showing all transactions from the date we started using the RMS. Thank you. On Jul 8, 9:31=A0pm, Receipt does not print over $100 entry <Receiptdoesnotprintover100en...@discussions.microsoft.com> wrote: > I am printing statement with a filter date of 6-2-08 to 7-1-08 but the > entries before 6-2-08 are still coming up in the statement. Can anyone pl= ease > help me make the filter date wo...

problems with outlook 2003 #2
When I open outlook2003 I get a bunch of errors. The reading pane give me the following error: "The item cannot be displayed in the Reading Pane. Open the item to read its contetents." When I open an email I get the following error: "Can't open this item. Out of memory or system resources. Close some windows or programs and try again." I also received an error when it tried to open the reminders. It worked fine for a couple of days after installing it. Yesterday I had problems with it and rebooted and it worked fine afterward. Today I have rebooted and still have th...

Purchasing Invoice Entry Batch Posting Problem
I am using GP 9 with Service Pack 3 and am facing the above problem. The problem is that when we post Purchasing Batches of Purchasing Invoice Entry Origin, it stop at certain percentage (not same every time). After waiting for a long time when we close Progress window it neither gives any error nor sends the batch in Recovery and continue to show the batch in Purchasing Batches. We have done the following but no success. 1. Reconcile 2. Checklinks 3. Recreated SQL Process 4. Have tried suggestions in https://mbs.microsoft.com/knowledgebase/KBDisplay.aspx?scid=kb;en-us;859917 i.e. Tri...

problems with charts copied into Word 2000
using Excel 2000 SR1 & Word 2000 created a simple chart in excel, copied it, switched to word and did edit / paste special - link when the chart is viewed in word (and after i've resized it) the rhs of the chart is truncated (about 2cm - compared to how it looks in excel) - moving the legend etc didn't seem to make a difference i've not seen this problem before and couldn't find anything in google groups that helped (still can't cope with the new interface!). any ideas? Cheers JulieD ...

Forms and Records
I have a form (personnel view) that is based on a query that pulls information from several tables together. I want to be able to update certain fields so I created a form that you can open (with a button) from the personnel view form. When I open the update form I want it to go to the record from the previous form. Try allowing the command button wizard to do that for you. One option in the wizard is find a record. "TexasBill" wrote: > I have a form (personnel view) that is based on a query that pulls > information from several tables together. > I want to ...