IsHyperlink not working for Unbound Textbox

My Access 2003 form contains unbound text boxes with the IsHyperlink 
property set to True but the pointer does not change to a hand as the mouse 
passes over. The mouse pointer does change to a hand if the text box  is 
bound to  a data source.
Please tell me  how to make the mouse pointer change to a hand as it passes 
over an unbound text box. 

0
DRedDog
5/8/2010 5:56:46 AM
access.forms 6864 articles. 2 followers. Follow

4 Replies
2014 Views

Similar Articles

[PageSpeed] 9

On Sat, 8 May 2010 01:56:46 -0400, "DRedDog" <dreddog69@hotmail.com>
wrote:

When unbound, the change of the mouse pointer happens when you hover
over the text in the textbox, not over the empty space in the textbox
(unless you go out of your way and fill it with Space characters).

-Tom.
Microsoft Access MVP


>My Access 2003 form contains unbound text boxes with the IsHyperlink 
>property set to True but the pointer does not change to a hand as the mouse 
>passes over. The mouse pointer does change to a hand if the text box  is 
>bound to  a data source.
>Please tell me  how to make the mouse pointer change to a hand as it passes 
>over an unbound text box. 
0
Tom
5/8/2010 10:19:24 PM
Thanks for your response but my mouse pointer remains an I beam when it 
passes over the text in the text box control.

DT

"Tom van Stiphout" <tom7744.no.spam@cox.net> wrote in message 
news:joobu55ngh1htassi8aepuojvlt1gl1qvj@4ax.com...
> On Sat, 8 May 2010 01:56:46 -0400, "DRedDog" <dreddog69@hotmail.com>
> wrote:
>
> When unbound, the change of the mouse pointer happens when you hover
> over the text in the textbox, not over the empty space in the textbox
> (unless you go out of your way and fill it with Space characters).
>
> -Tom.
> Microsoft Access MVP
>
>
>>My Access 2003 form contains unbound text boxes with the IsHyperlink
>>property set to True but the pointer does not change to a hand as the 
>>mouse
>>passes over. The mouse pointer does change to a hand if the text box  is
>>bound to  a data source.
>>Please tell me  how to make the mouse pointer change to a hand as it 
>>passes
>>over an unbound text box. 

0
DRedDog
5/9/2010 12:58:26 AM
"DRedDog" <dreddog69@hotmail.com> wrote in message 
news:5142E812-DCCA-4795-ACA0-A6CF38BA65C3@microsoft.com...
> My Access 2003 form contains unbound text boxes with the IsHyperlink 
> property set to True but the pointer does not change to a hand as the 
> mouse passes over. The mouse pointer does change to a hand if the text box 
> is bound to  a data source.
> Please tell me  how to make the mouse pointer change to a hand as it 
> passes over an unbound text box.


So far as I can tell, setting IsHyperlink to Yes/True for an unbound text 
box doesn't make it behave as a hyperlink;  it just causes it to be 
formatted as hyperlinks are formatted.  You can use code to make it behave 
as a hyperlink, and even (with a little difficulty in Access 2003) make a 
hand cursor appear when mousing over it.

It's not hard to do, but maybe there's an easier way to accomplish your 
goal.  Why exactly are you using an unbound text box as a hyperlink, rather 
than a label with a hyperlink address, or a control bound to a hyperlink 
field?  What are you really trying to do?

-- 
Dirk Goldgar, MS Access MVP
Access tips: www.datagnostics.com/tips.html

(please reply to the newsgroup)

0
Dirk
5/9/2010 1:21:04 PM
"Dirk Goldgar" <dg@NOdataSPAMgnostics.com.invalid> wrote in message 
news:udTf9p37KHA.1888@TK2MSFTNGP05.phx.gbl...
>
> So far as I can tell, setting IsHyperlink to Yes/True for an unbound text 
> box doesn't make it behave as a hyperlink;  it just causes it to be 
> formatted as hyperlinks are formatted.

Note:  I believe ADPs are different from MDBs in this regard.  Although I 
haven't used hyperlinks in ADPs, I gather from various side comments in help 
topics that in ADPs, setting a control's IsHyperlink property to True makes 
it behave as a hyperlink, while in MDBs the underlying field must have the 
Hyperlink data type.

-- 
Dirk Goldgar, MS Access MVP
Access tips: www.datagnostics.com/tips.html

(please reply to the newsgroup)

0
Dirk
5/9/2010 1:30:07 PM
Reply:

Similar Artilces:

Outlook doesnt prompt to work online/offline
OS: XP Office: 2002XP MS doesnt always prompt to work online/offline when opening outlook. The problem is that it might give u the option the 1st time you open outlook, but the 2nd and 3rd time it will not prompt you, it will just open outlook (online). I have disconneted the pda/pocket pc from the computer to make sure that it was not keeping a link between the two. I have closed outlook and killed the Outlook.exe that was running, but it still wont give the option. Anyone had this problem? Thanks ...

SUMPRODUCT Works Sometimes Why
I have use this formula before, but i try it again on another sheet and now it does not work. This Works: =SUMPRODUCT(('Dec Actual'!$F$2:$F$100="0103")*('Dec Actual'!$G$2:$G$100=B101)*('Dec Actual'!$I$2:$I$100)) This does not: =SUMPRODUCT(('Source'!A5:A350="A")*(Source'!B5:B350=A8)*('Source'!AM5:AM350)) > it does not work. Means??? -- Don Guillett SalesAid Software donaldb@281.com "Mestrella31" <mestrella@mxn.com> wrote in message news:A88DF055-648D-46E7-A66F-5C6AF9359E0E@microsoft.com... > I have us...

Does ? work under excel search?
Hi, Wondering if there is any way to search/find the ? inside of a cell? It does not work for me unless the ? is by itself in a cell. I need to dig out this symbole from within a cell. For example, cells may have "abc?123" in it and I need to find and delte it. Is it feasible? Thanks Hi Harry in the find what box type ~? in the replace with box leave blank click on options and ensure that match entire cell contents is not checked run the replace Cheers JulieD "harry" <harryliuusa@yahoo.com> wrote in message news:eqFRJCIsEHA.1712@tk2msftngp13.phx.gbl... &g...

SetWindowPos ZOrder does not work with overlapping controls?
Hello NG, I have a problem with the ZOrder of SetWindowPos. In my CDialog, I use a bitmap CStatic to display a background picture. On that, I want to show some controls. I do it as follows: m_stcBackgroundPic.SetWindowPos(&wndBottom, 0,0,1024,496, SWP_HIDEWINDOW); m_btnDoSomething.SetWindowPos(&wndTop, 10,10,100,60, SWP_HIDEWINDOW); m_stcEditCaption.SetWindowPos(&wndTop, 10,175,150,30, SWP_HIDEWINDOW); m_ctlEdit.SetWindowPos(&wndTop, 170,175,170,30, SWP_HIDEWINDOW); Later, I show the controls with ShowWindow in the same order as above (first the background pic, then the butt...

Rules only work when I first start Outlook 2003
Hi all. I have a problem with my rules in Outlook 2003. I've upgraded from OL XP, and now my rules only seem to work when I first start up OL 2003 and it checks my mail. I'm using several POP accounts and I want the mails moved to specific folders depending on the mail account they come in on. The rules worked fine when I was running OL XP, but now they only run on the first mail check as soon as I open OL. Any subsequent mail checks, either automatic (every 5 mins) or manual just sends any new mail to the Inbox. I have read about an OL prob where the rules don't work on the fir...

Accessing Spreadsheet Documents (Works Suite 2003)
I recently converted over from a Mac to Windows. I had several spreadsheet documents that I converted using Maclink. They converted over okay. But, when I try to use them, and then wanted to save them, I have to save in Works 7.0. Then when I try to open them up I get the following type message: BUW1, contains a formula reference outside the area that Works can access. There are other similiar references like: LDI1, KMS1, AND MX1. I do not know how to remove these problems so that I may utilize the documents. Please help. Thanks. JB I'd suggest asking this in a Works gr...

HELP: Deleted Items Limit Set to 0 days does not work!
Hi Gurus, I've set the Deleted Items Limit to 0 days from the Deletion Setting at the Mail store level but when i delete an item from one of the mailbox it does not removed from the server immediately. Has anyone come accross this issue? Please advice. Thanks in advance On Wed, 2 Feb 2005 20:20:23 +0800, "hanafiah" <hanafiahh@hotmail.com> wrote: >Hi Gurus, > >I've set the Deleted Items Limit to 0 days from the Deletion Setting at the >Mail store level but when i delete an item from one of the mailbox it does >not removed from the server immediat...

work 04-30-07
Michael Johnson On August 1, 1996, Michael Johnson electrified the world by winning an Olympic gold medal in the 200-meter dash with a time of 19.32, shattering his own world record and capping one of the greatest individual track and field performances in Olympic history. Johnson became the first person in history to win both the 200 meters and 400 meters in the same Olympic Games. These performances in front of an American audience highlight a decorated career for Johnson, who will be competing in his third Goodwill Games in 1998. Some of Johnsons accomplishments include: � W...

Business Portal "Copy to Excel" not working in Query pages
Hi, I am using Business Portal 4.0. When browsing through one of the queries pages in Business Portal, i clicked "Copy to Excel" icon. I got an error saying "The Office Web Components (OWC) must be installed to copy results to Excel." at the bottom. I am using Office 2007 on my machine. I came to know that Microsoft Office Web Components will no longer be shipping in Microsoft Office. I tried installing Office 2003 Add-in: Office Web Components from http://www.microsoft.com/downloads/details.aspx?familyid=7287252C-402E-4F72-97A5-E0FD290D4B76&displaylang=en a...

IInternetProtocol Start Method not working correctly
Hello, I've been searching and searching and found nothing to help me out. Here's my situation: I need to capture URL Requests (clicks or address bar entries) and if it matches a specific URL like "http://somedomain.com/blorg.exe" I want to be able to intercept that and tell IE i'll take care of it myself, OR, if it does not pass my criteria, let IE handle the click. I DO NOT want to register my own protocol like mark://somedomain.com/.... I need to be able to look at the whole URL This is what I've done so far: I have created a namespacehandler in the HKCR are...

AutoSummarize not work
I try to access the autosummarize tool box but always I have no dialog box appear. I coudn't do work it . please tell me what shall i do? Are you using Word 2007? It seems as if the feature is no longer supported in that version. Although you can add the AutoSummary Tools command to the Quick Access Toolbar, nothing happens when you click AutoSummary Tools | Auto Summarize. -- Stefan Blom Microsoft Word MVP (Message posted via NNTP) "Moataz" <Moataz@discussions.microsoft.com> wrote in message news:13E5455D-1AA0-4B32-AAFB-6F70E67D99B6@microsoft.com...

Help working out hourly production rates in spreadsheet please.
Hi all, Stuck on this one now. In my spreadsheet i have 3 columns that contain the following info for my production machines Total shift time (this will usually be 7:45 or 8:30 - formatted in hh:mm format) Downtime per shift (any value upto max shift time - formatted in hh:mm format) Kgs produced. I would like to keep the time in hh:mm format as i do further calculations on these - % downtime, total downtime, total shift hours etc (and also cos it took be ages to figure out how to add up in time and i couldn't believe how simple it was when i figured it out) What i would like to be abl...

Advanced Find doesn't work
After having updated my Office 2000 version with service release 1a and service pack 3 the Outlook 2000 advanced find function no longer works. It doesn't deliver any results and pretends to continue searching forever. Anyone any ideas about this problem? Thanks, Steve Same problem here....except it doesnt seem to keep searching. It will only find something within the last day or so. "Steve Kraft" <anonymous@discussions.microsoft.com> wrote in message news:00a501c3c472$93d71c90$a601280a@phx.gbl... > After having updated my Office 2000 version with service > rele...

inserting equations in Word document from MathType not working anymore
Version: 2008 Operating System: Mac OS X 10.6 (Snow Leopard) Processor: Intel I've just starting using Snow Leopard after worked with Tiger previously. I'm noticing some odd behavior that's different than before. <br><br>I have the MathType 6 Insert Eqn button installed in Office 2008 for Mac. When I click on that, MathType opens. So far, so good. I type in my equation, but, when I'm finished editing or creating my equation, I'm used to clicking on the red button to close the MathType window and return to my Word document. When I do that now, my Word d...

Chart Wizard won't work
I have classwork to perfoerm on EXCEL, but I am unable to use the Chart Wizard because it is grayed out, and unavailable. I have made certain that I have selected ranges with data in them, so what do I do next??? Perhaps it's not installed? Some versions of MS Office do not install the wizards when the default install method is used. Use Custom install, and choose "Run all from my computer". ************ Anne Troy www.OfficeArticles.com "peg2unic" <peg2unic@discussions.microsoft.com> wrote in message news:255A90EF-B896-48EF-86DC-5988EEC707C1@microsoft.com....

Landscape orientation doesn't work
I've checked my page and printer settings but I can't seem to print in landscape (ideally, landscape legal size). I've also posted this in 'worksheet f(x)'. Can anyone assist? p.s. I've even repaired/re-installed with my office 2000 CD but problem persists. Did you also check File>Page Setup>Page, orientation? -- Kind Regards, Niek Otten Microsoft MVP - Excel "Gerry Simone" <anonymous@discussions.microsoft.com> wrote in message news:c93f01c48a06$533f49f0$a601280a@phx.gbl... > I've checked my page and printer settings but I can...

Problem with getting warning banner message working in OWA
We are using Exchange 2003 with a front-end & back-end server setup and using forms based authentication. Has anyone successfully implemented a Warning banner for OWA that users have to click the OK button before getting to the login page? I have tried out the steps provided at http://www.somorita.com/E2K324seven/Ch21-OWA-WarningBanner.doc but the warning banner still doesn't show up. Would greatly appreciate if anyone has implemented could provide any information to get this working. Thanks in advance. Mark While you are looking at the logon page in IE, use the View/Source...

Customize outlook today doesn't work anymore
When I am in Outlook2000 "Outlook Today" screen, I used to be able to press "Customize outlook today" and organize tasks in due date descending order. I can no longer activate "Customize outlook today" button anymore. Can someone help me? Thanks, Bryant Harris ...

RPC stopped working
I was working from home last Monday and I was connected to my Exchange server using RPC over HTTPS. I am in Windows 7 64bit and Outlook 2003. When I try to log back into the RPC connection now, it keeps prompting me for my password over and over again and never lets me in. It was working find and now it has just stopped. Does anyone have any ideas about how I can fix this? Where does the boss's new router fit into the timeline? (I assume it's a new router at home, not in the Exchange network). If you both were affected at about the same time, its more likely an is...

Working window in Access "sticks" to Maximum size
Hello, I'm trying to figure out how to 'unstick' a working form/report/table, etc in Access. Even if I design an entry form at say, 3" by 5" wide, it'll automatically maximize to fill up the entire working screen next to the navigation bar. To my knowledge, I have never set any property to maximize every window. . . Did I miss a global setting, or is it an option I can turn off? Thanks, Tripler "Tripler of the SDMB" <Tripler of the SDMB@discussions.microsoft.com> wrote in message news:96E65DF9-A187-4710-A6AC-2350A66F38D1@microso...

Outlook 2003 'Move' Rule doesn't work as it should.
Hi, Having probs here with trying to use the 'Move' Rule in Outlook 2003 to shift emails from a specific senders address (from peolple or distrubution list) to a custom folder within my Inbox for that sender. The rule merely copies the e-mail to my custom folder and leaves the original in my Inbox. I have to create a second rule to delete the original from my Inbox and that can't be right. I know it isn't just me that is having this problem so maybe someone out there has found a fix for this bug? Zook Add Stop processing action to the Move rule. -- Diane Poremsky [MVP -...

how do i work out what price to charge
i am a nail technician, and would like help with working out what i spend every month( on supplies e.g nails, nail polish , nail polish remover, fuel( car) , etc etc ), then be able to have a total figure at the end where i charge for a certain job, i.e french nails $30... by being able to work out how much im spending a month, compared to how much im earning... i'll soon realise whether or not im under charging myself look forward to your response kind regards Good questions. You could start with a simple table, say with 5 columns: Date, Category, Description, Expense, Revenue....

Input box replace text in textbox
How can I modify the macro below with input box code to replace "2008" by "2009" using an input box - so that i can replace "2008" by "2010" more easily if required - thxs Sub masschange() Dim ws As Worksheet Dim longstr As String Dim i As Long For Each ws In ActiveWindow.SelectedSheets For Each shp In ws.Shapes 'shp.Select If shp.Type = msoOLEControlObject Then If TypeOf shp.OLEFormat.Object.Object Is MSForms.TextBox Then If shp.Type = msoOLEControlObject Then If TypeOf shp.OLEFormat.Obje...

Send mail no longer works
Using Outlook 2003 SP2 and all updates. Account is set up as a POP3 account, can receive and reply to mail but can not send new mail messages. No errors occur, when pressing send the mail goes to the outbox and then goes to the sent items folder, no error messages. Mail never gets delivered. I can ping the mail server, can telnet to the mail server on port 25 and get a 250 ok response when issuing a helo command. Her .pst file is 1.15gig in size. Is there a limit to how big a .pst file can be? I ran the Inbox repair tool and it did find errors but said it corrected them. At a total l...

Office Notifications no longer work
Sometime in the last month, my Office notifications have stopped working. The Microsoft Office Notifications application is running and I have made sure that it launches at startup, but that hasn't helped the problem. I have repaired permissions since this problem began and have run both Norton Disk Doctor and Alsoft DiskWarrior as part of my regular routine, not specifically for this problem. Again, no effect toward the problem. I am running a dual 1.8 GHz G5 with OS 10.3.9. Office 2004 (Entourage v 11.1.0 (040913)). Any suggestions to fix this? -- Roy Behymer I think you're mor...