Cant get "Platform Builder" to appear under "Project Types" in VS2005

Hi Everyone,

We've just purchased PB 6 and am trying to install it on one of our
development stations, but no matter how many times I've installed/
deleted/reinstalled VS2005 and WinCE 6 I cannot for the life of me get
it to appear in the project types list for when creating a new
solution.  It wont even allow me to open an existing project from the
demo WinCE 6 folder.  I'm now in to my 3rd day of battling with this !

Though the PB icon shows on the splash screen as it starts, as does
some of the CE6 'getting started' stuff on the start page.

It has had the trial versions of VS2005 and PB6 installed on it in the
past, both of which worked just dandy.

It also has VS2008 and PB5 installed on it, though I believe both were
when the trial versions were installed anyway.

Does anyone have any suggestions as to where to look to solve my
problem?

Many thanks in advance

Col
0
Mr
2/9/2010 2:26:20 PM
windowsce.platbuilder 744 articles. 0 followers. Follow

4 Replies
710 Views

Similar Articles

[PageSpeed] 51

On Feb 9, 2:26=A0pm, Mr Col <co...@icrtouch.com> wrote:
> Hi Everyone,
>
> We've just purchased PB 6 and am trying to install it on one of our
> development stations, but no matter how many times I've installed/
> deleted/reinstalled VS2005 and WinCE 6 I cannot for the life of me get
> it to appear in the project types list for when creating a new
> solution. =A0It wont even allow me to open an existing project from the
> demo WinCE 6 folder. =A0I'm now in to my 3rd day of battling with this !
>
> Though the PB icon shows on the splash screen as it starts, as does
> some of the CE6 'getting started' stuff on the start page.
>
> It has had the trial versions of VS2005 and PB6 installed on it in the
> past, both of which worked just dandy.
>
> It also has VS2008 and PB5 installed on it, though I believe both were
> when the trial versions were installed anyway.
>
> Does anyone have any suggestions as to where to look to solve my
> problem?
>
> Many thanks in advance
>
> Col

I think this is an install order problem...
You can get PB5, VS2005/PB6 and VS2008 all to coexist only if you have
installed them in that order. I suspect that you may have to uninstall
VS2008 first, then re-install VS2005/PB6 and then re-install VS2008.
But wait to see what other comments you get before doing this, just in
case there is a better solution!
Andrew.
0
AndrewScholan
2/9/2010 3:14:35 PM
Try a clean installation in a virtual PC.
Time lost because the virtual PC is a bit slower, is gained back easily by 
avoiding trouble like you have now. ( once I had to do an XP reinstall before 
it worked again)
Make a copy of your virtual CE6 machine before every change, and you are 
safe always.


Kind Regards,
Rob.



"Mr Col" wrote:

> Hi Everyone,
> 
> We've just purchased PB 6 and am trying to install it on one of our
> development stations, but no matter how many times I've installed/
> deleted/reinstalled VS2005 and WinCE 6 I cannot for the life of me get
> it to appear in the project types list for when creating a new
> solution.  It wont even allow me to open an existing project from the
> demo WinCE 6 folder.  I'm now in to my 3rd day of battling with this !
> 
> Though the PB icon shows on the splash screen as it starts, as does
> some of the CE6 'getting started' stuff on the start page.
> 
> It has had the trial versions of VS2005 and PB6 installed on it in the
> past, both of which worked just dandy.
> 
> It also has VS2008 and PB5 installed on it, though I believe both were
> when the trial versions were installed anyway.
> 
> Does anyone have any suggestions as to where to look to solve my
> problem?
> 
> Many thanks in advance
> 
> Col
> .
> 
0
Utf
2/9/2010 3:21:01 PM
The proper installation order is the following :
Visual Studio 2005
Windows Embedded CE 6.0
Visual Studio 2005 SP1
Visual Studio 2005 SP1 Update for Vista (if you have Vista)
Windows Embedded CE 6.0 SP1
Windows Embedded CE 6.0 R2
Windows Embedded CE 6.0 R3

-- 
Paolo Patierno
Embedded Software Engineer


"Mr Col" wrote:

> Hi Everyone,
> 
> We've just purchased PB 6 and am trying to install it on one of our
> development stations, but no matter how many times I've installed/
> deleted/reinstalled VS2005 and WinCE 6 I cannot for the life of me get
> it to appear in the project types list for when creating a new
> solution.  It wont even allow me to open an existing project from the
> demo WinCE 6 folder.  I'm now in to my 3rd day of battling with this !
> 
> Though the PB icon shows on the splash screen as it starts, as does
> some of the CE6 'getting started' stuff on the start page.
> 
> It has had the trial versions of VS2005 and PB6 installed on it in the
> past, both of which worked just dandy.
> 
> It also has VS2008 and PB5 installed on it, though I believe both were
> when the trial versions were installed anyway.
> 
> Does anyone have any suggestions as to where to look to solve my
> problem?
> 
> Many thanks in advance
> 
> Col
> .
> 
0
Utf
2/9/2010 4:02:11 PM
I agree with this.  Uninstall VS<anything>, uninstall PB/CE.  Install VS2005, 
service packs, etc.  Install CE6, PB updates, R2, R3, etc., etc., all in 
order.  Open VS2005 and verify that you can open a CE6 project or create a 
new OS configuration.  Once that has been verified, install VS2008 and its 
updates.

I've never had the type of problem the OP is detailing, but installing 
things in more-or-less release date order avoids most problems...

Paul T.

"AndrewScholan[MCTS]" wrote:

> On Feb 9, 2:26 pm, Mr Col <co...@icrtouch.com> wrote:
> > Hi Everyone,
> >
> > We've just purchased PB 6 and am trying to install it on one of our
> > development stations, but no matter how many times I've installed/
> > deleted/reinstalled VS2005 and WinCE 6 I cannot for the life of me get
> > it to appear in the project types list for when creating a new
> > solution.  It wont even allow me to open an existing project from the
> > demo WinCE 6 folder.  I'm now in to my 3rd day of battling with this !
> >
> > Though the PB icon shows on the splash screen as it starts, as does
> > some of the CE6 'getting started' stuff on the start page.
> >
> > It has had the trial versions of VS2005 and PB6 installed on it in the
> > past, both of which worked just dandy.
> >
> > It also has VS2008 and PB5 installed on it, though I believe both were
> > when the trial versions were installed anyway.
> >
> > Does anyone have any suggestions as to where to look to solve my
> > problem?
> >
> > Many thanks in advance
> >
> > Col
> 
> I think this is an install order problem...
> You can get PB5, VS2005/PB6 and VS2008 all to coexist only if you have
> installed them in that order. I suspect that you may have to uninstall
> VS2008 first, then re-install VS2005/PB6 and then re-install VS2008.
> But wait to see what other comments you get before doing this, just in
> case there is a better solution!
> Andrew.
> .
> 
0
Utf
2/9/2010 4:02:27 PM
Reply:

Similar Artilces:

Cant get "Platform Builder" to appear under "Project Types" in VS2005
Hi Everyone, We've just purchased PB 6 and am trying to install it on one of our development stations, but no matter how many times I've installed/ deleted/reinstalled VS2005 and WinCE 6 I cannot for the life of me get it to appear in the project types list for when creating a new solution. It wont even allow me to open an existing project from the demo WinCE 6 folder. I'm now in to my 3rd day of battling with this ! Though the PB icon shows on the splash screen as it starts, as does some of the CE6 'getting started' stuff on the start page. It has had the ...