BT - WLAN sharing problem on WM 6

Hi guys

I have an iPaq 210, WM 6, that I'd like to use as a WiFi card for an WinXP SP2
PC. 
Here's my problem, which often happens (not always):

1. I turn on Bluetooth on the iPaq

2. I connect the PC to the iPaq using the "Explore my Bluetooth Places" wizard,
"BT network access", then "Connect". It says "connected". Then on the XP
"Network Connections" window, it says "acquiring network address", and shortly
after: "connected". PC's IP address: 192.168.1.125, default gateway (the iPaq):
192.168.1.6. In fact, I've setup this static IP address on the iPaq using the
ICScontrol utility. Both computers see each other and ping works both ways. In
other words, BT PAN is up and working. So far so good.

3. Here's the problem: I then turn on the WLAN (Wi-Fi) on the device (iPaq),
connecting to an access point. Once the WiFi connects, ping stops working
between the PC and the iPaq. Then I can't get to the Internet from the PC using
the iPaq. 
(XP "Network connections" still says: "connected" on the BT PAN network
though).

When I disconnect the WLAN on the iPaq, BT ping starts working again.

What to do?

TIA 

Gail
0
gailh
3/31/2010 8:00:03 PM
windowsce.platbuilder 744 articles. 0 followers. Follow

2 Replies
685 Views

Similar Articles

[PageSpeed] 40

Did you set up Internet connection sharing on the device?  I have no idea if 
this is even supposed to work, but that's where I'd start.

Paul T.

"gailh" wrote:

> Hi guys
> 
> I have an iPaq 210, WM 6, that I'd like to use as a WiFi card for an WinXP SP2
> PC. 
> Here's my problem, which often happens (not always):
> 
> 1. I turn on Bluetooth on the iPaq
> 
> 2. I connect the PC to the iPaq using the "Explore my Bluetooth Places" wizard,
> "BT network access", then "Connect". It says "connected". Then on the XP
> "Network Connections" window, it says "acquiring network address", and shortly
> after: "connected". PC's IP address: 192.168.1.125, default gateway (the iPaq):
> 192.168.1.6. In fact, I've setup this static IP address on the iPaq using the
> ICScontrol utility. Both computers see each other and ping works both ways. In
> other words, BT PAN is up and working. So far so good.
> 
> 3. Here's the problem: I then turn on the WLAN (Wi-Fi) on the device (iPaq),
> connecting to an access point. Once the WiFi connects, ping stops working
> between the PC and the iPaq. Then I can't get to the Internet from the PC using
> the iPaq. 
> (XP "Network connections" still says: "connected" on the BT PAN network
> though).
> 
> When I disconnect the WLAN on the iPaq, BT ping starts working again.
> 
> What to do?
> 
> TIA 
> 
> Gail
> .
> 
0
Utf
3/31/2010 11:09:25 PM
As you are using WiFi and BT PAN simutaneously which introduces a dual homing 
situation on your WM device. For security reason, connection manager may 
supress the packe unless a connection has been configured as secured.

You may refer to this doc to provision your wifi and BT as secured.
http://msdn.microsoft.com/en-us/library/bb737605.aspx

Also use ConnMgrQueryDetailedStatus 
(http://msdn.microsoft.com/en-us/library/bb416284.aspx) to veriy the result.

"gailh" wrote:

> Hi guys
> 
> I have an iPaq 210, WM 6, that I'd like to use as a WiFi card for an WinXP SP2
> PC. 
> Here's my problem, which often happens (not always):
> 
> 1. I turn on Bluetooth on the iPaq
> 
> 2. I connect the PC to the iPaq using the "Explore my Bluetooth Places" wizard,
> "BT network access", then "Connect". It says "connected". Then on the XP
> "Network Connections" window, it says "acquiring network address", and shortly
> after: "connected". PC's IP address: 192.168.1.125, default gateway (the iPaq):
> 192.168.1.6. In fact, I've setup this static IP address on the iPaq using the
> ICScontrol utility. Both computers see each other and ping works both ways. In
> other words, BT PAN is up and working. So far so good.
> 
> 3. Here's the problem: I then turn on the WLAN (Wi-Fi) on the device (iPaq),
> connecting to an access point. Once the WiFi connects, ping stops working
> between the PC and the iPaq. Then I can't get to the Internet from the PC using
> the iPaq. 
> (XP "Network connections" still says: "connected" on the BT PAN network
> though).
> 
> When I disconnect the WLAN on the iPaq, BT ping starts working again.
> 
> What to do?
> 
> TIA 
> 
> Gail
> .
> 
0
Utf
4/3/2010 8:17:01 AM
Reply:

Similar Artilces:

Shared Workbook Query
Hi, I have set up a shared workbook for 20+ users. I am aware that share workbooks in Excel (I have version 2002) have limited functionality an that you cannot for example merge cells. However, if there are merged cells in another worksheet and someon wants to copy across text (which includes merged cells) into the share workbook it removes the merged formatting. At present I have to take the share off the workbook and then cop across the data (which includes merged cells) then reshare the workboo so that the formatting is maintained. Is there any other way around this problem so that peo...

Outlook problem #43
Hi When i try to synchronize my emails i receive error message saying something about "File saving was damaged use ScanDisk to repair this file" After this comes account and server name. ?? any suggestions ?? Scandisk or scanpst? If scanpst.exe, then what happened when you ran it? -- Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the (insert latest virus name here) virus, all mail sent to my personal account will be deleted without reading. After furious head-scratching, Marcin Gajek asked this group: | Hi | When i tr...

Match & Index function
Hello - I am trying to use the Match and index functions together. Typically, I have been able to match and pull in the data without a problem. But now that I am using a text file that I export into excel, I am running into problems. Basically, the formula won't work (even though I have tried trimming the data, changing all columns to text, general, and number. The only way that the formula works is when I copy and paste the actual reference cell into the reference array from the range that I am seeking to pull in the data. So for example, my formula reads: =INDEX(Sheet2!B:B,MATCH(Shee...

Active Directory user authentication problem
Hi There I have a piece of code that I am using to authenticate users of active directory, is very straightforward, here it is. IADsOpenDSObject *pDSO = NULL; //this is just a result code HRESULT hr = S_OK; hr = ADsGetObject(L"LDAP:", IID_IADsOpenDSObject, (void**) &pDSO); if (SUCCEEDED(hr)) { IDispatch *pDisp; hr = pDSO->OpenDSObject(CComBSTR("LDAP://uk.mycompany.com"), CComBSTR(username), CComBSTR(password), ADS_SECURE_AUTHENTICATION, &pDisp); } My problem is that the HRESULT error code returned when someone trys to login incorrec...

Sharing Calendar, can you share contacts too?
We have an administrative secretary, who maintains 3 high level administrator's calendars... we use outlook 2003 with exchange 2003, she opens their shared calendars and edits them... Maybe I'm overlooking a really simple answer... but is there a way she could similarly edit their personal address books (they all use palm pilots and want their own individual contact lists).... Any ideas appreciated... Thanks! Sure, just need to delegate rights to those folders and she can "Open Other user's Folder" and choose Contacts. "Ken Montgomery" <KenMontg...

CRM Mobile First Time registration problems
Well, I've tried everything in the troubleshooting guide3, and everything I can find on the forums/groups, but still no luck. I am trying to get CRM Mobile running for internal connection, installing on the CRM server itself. I have temporarily disabled certs and SSL, to allow for troubleshooting, and I also have a traffic tracer running. When I run CRM Mobile, it simply hangs while registering the device- it will sit there for 45 minutes, if I let it. When monitoring the traffic, I have seen that it successfully calls the /ssCERDA/ sqlcesa30.dll twice, and then it goes on to /CRMMobil...

Problem using '=' with System.Type
Hi I have the following code; ByVal MyType As Type Dim frame As StackFrame If frame.GetMethod().DeclaringType = MyType Then Problem is I am getting the "Operator '=' is not defined for types 'System.Type' and 'System.Type'." error on the last line. How can I fix this? Thanks Regards Am 23.03.2010 02:27, schrieb John: > Hi > > I have the following code; > > ByVal MyType As Type > Dim frame As StackFrame > If frame.GetMethod().DeclaringType = MyType Then > > Problem is I am getting the "Ope...

Sharing Outlook between profiles?
I am running a 2k server (no exchange server) and need the laptops that connect into the domain to be able to view and send emails when connected, and when disconnected. The laptops have just been reloaded after using Novell. The advantage of the novell client was that it used the same local profile for connecting into the domain, and when using the workstation only. With the 2k server however, it uses one profile for the domain, and one for the local workstation. This is where Outlook 2000 is falling over... Please help... ...

CToolTipCtrl problem
Hello, I need help, I'm trying use tool tip in list control, the problem is that tip must be changed for each item. How to do this? After tip is showed there is no other notifications from control when mouse was moved over another item in list control Thank you If you want to change the text, while the tooltip is displayed, you can use SetWindowText to change it.That means you will need to get hold of the control if you did not create it. -- Ajay Kalra [MVP - VC++] ajaykalra@yahoo.com "Raphael" <rafalski30@gazeta.pl> wrote in message news:EA00F864-5105-4C43-9912-8C1...

problem Backing up to thumb drives
When back up to a 4.0 gig cruzer lock thumb drive I get a dialog box that tells me "Money has filled the current disk" "Please insert Backup Disk 2 into the H:\ drive so that we may continue to build your backup." I have 2 of these drives, both have plenty of empty space available and the results are the same on both. I can use a 256 mb thumb drive to back up to without getting this message. Any ideas? Thanks, In microsoft.public.money, BJV wrote: >When back up to a 4.0 gig cruzer lock thumb drive I get a dialog box that >tells me "Money has filled the...

Problems using GetFileVersionInfo
I'm trying to get the file's information from the VS_VERSIONINFO block. I added the header file "winver.h" and included the "version.lib" in the settings. I use the following to start with... // ---- code ----- void GetInfoDlg::GetFileInfo( LPCTSTR lpszFile ) { DWORD dwZero, dwInfoSize; dwInfoSize = GetFileVersionInfoSize( (LPTSTR)lpszFile, &dwZero ); if( dwInfoSize > 0 ) { LPBYTE lpBuf = new BYTE[dwInfoSize]; GetFileVersionInfo( (LPTSTR)lpszFile, 0, dwInfoSize, &lpBuffer ); // get info // TODO: Query the i...

Windows 7 taskbar API problems
Folks The background is that an Access MDE/ACCDE created by a developer is not conceptually the same as an Excel spreadsheet or Word document file created by the user. My Auto FE Updater utility automatically downloads any new version created by the developer from the server to the workstation as well as doing lots of other stuff such as creating shortcuts on desk tops. If this was a user created Access database file which resides in the users My Documents folder, or similar, than they are conceptually the same as a Word or Excel file. The problem is if the user right-clicks on...

Trendline problem
This is a multi-part message in MIME format. ------=_NextPart_000_002D_01C7C4A2.66A824B0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hi all, One of our staff had created Trendlines (Polynomial type with order 2) = in 2003 and 2007 version with the same set of data. But the equations = created for the Trendline from the two Excel versions are different. = The problem is on the numeric portion of x^2 part of the equation. Is = this a bug in 2007 (or 2003)? Any idea? Does M$ aware about this? el ------=_NextPart_000_002D_01C7C4A2.6...

Sharing calendar
Hello, there are 3 computers with outlook 2003 and Business Contact Manager. I want to share an calendar so on all computers you can see the appointments. Two of them are laptops and need te appointments online. What is the best way to do this (for free) thanx, Marco None. All cost money. --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the (insert latest virus name here) virus, all mail sent to my personal account will be deleted without reading. After searching google.groups.com and finding no answer, Marco J.L. asked: | Hello...

from field upload file problem
www.icingpictures.co.uk win xp FP 2003 online order form url http://www.icingpictures.co.uk/online_order_form.htm Problems with online order form - upload files form field Everything on form works fine 100% except one aspect. Maximum file size it can upload. I can successfully upload up to 8 files simultaneously using the from providing the file sizes are small (under 2MB). If I try and upload either one file or a number of files and the combined size is around 2MB plus – I get a user name and password prompt – obviously customers using the form would not know this and th...

Problem with rs232
Hello, I posted the same problem in http://groups.google.de/group/comp.lang.c++/browse_thread/thread/2f2102b9dcb845c9/0adb2648d9a46265?hl=de#0adb2648d9a46265 and it was the wrong place! I am developing a serial-communication application for a pocket-PC and a PC. I am trying to make a serial-port connection via Bluetooth. All goes well: Bluetooth connection and COM ports starting at both sides. The problem is by sending Data via the COM port. For example whenn I send: "Foo Data to send". I receive at the other side: "F.o.o. .D.a.t.a." where the "." Are 0s (asci...

Can I transfer my contacts from BT Yahoo to outlook
How do I transfer my contacts from BT Yahoo to Outlook How would we be expected to know what BT Yahoo is? Seems to me you should determine to which file formats "BT Yahoo" can export and match it with one of the formats Outlook can import. In Outlook, use File > Import and Export > "Import from another program or file" to determine which format to use. -- Russ Valentine "ahmclross" <ahmclross@discussions.microsoft.com> wrote in message news:A0373AD9-CE24-47C0-9D87-872F21C071B5@microsoft.com... > How do I transfer my contacts from BT Y...

Printing problems with 5x7 invitation.
Ok, I have set up a custom page size to 5x7 for some invitations. When I go to print my text starts printing about 3 inches to the right. So over half my invitation is cut off. It is acting like it wants to print the invite on a 8 1/2 x 11 sheet and place it in the middle, with crop marks. My printer is a network copy machine, which normally excepts odd size paper so I am thinking that it is a setting within Publisher. Any suggestions would be helpful, I am using Publisher 2003. I will also look into the copy machine printer settings. Thanks Suzanne You need to make sure your...

PCIe Driver read problem
Under 32bit Windows XP SP2, I develop a driver for a special designed PCIe device using FPGA as PCIe moudel. With WDK 7200, I choose "KMDF" as a driver model. First "MmMapIoSapce" map the device DDR in to my virtual space, then use "RtlCopyMemory" read for mapped Virtual Address. Also tried "READ_REGISTER_BUFFER_XXX" for Physical Address. This two functions behave the same.Is There any problem here? When I read for 2 DWORDs, the FPGA get tow seperated requests, each require for 1 DWORD. This makes the read operation too slow, only 4MBps(I...

MMS to email problems.
If I send an MMS from my mobile phone to my email address it should come through with one .TXT and one .JPG attachment. Well, it used to on my old phone. The email I now receive in Outlook (2002 with latest updates and running XP Pro) is a blank email (although from the size you can see the stuff is there somewhere). There is no paper clip showing and no attachments. However, if I click on 'forward', then save as draft, the two attachments become visible and are able to be opened. I can receive JPG's in normal email. I have tried turning off all the attachment security optio...

Connection problem 10-27-07
In my reading, I came to believe that once you opened a connection (in this case in an access 2000 form) the connection remained open until the form was closed. The code below gives me an error in the click event indicating that there is no open connection. Thank you. Option Compare Database Private Sub Form_Load() Dim cn As ADODB.Connection Dim rs As ADODB.Recordset Set cn = CurrentProject.AccessConnection Set rs = New ADODB.Recordset End Sub Private Sub cmdTest_Click() 'after entering data and clicking button, update the table With rs .Source = "Select * from tblTest"...

Spreadsheet problem
I am trying to input figures into a spreadsheet that was sent to me but some cells are showing ####'s after I input the figures instead of a view of the figures. How do I get rid of the ####'s to view the figures? Make the font smaller, or widen the column. George Gee "Shaq32" <Shaq32@discussions.microsoft.com> wrote in message news:91E5D695-6B5E-4806-9C51-4C8A9F6606D5@microsoft.com... >I am trying to input figures into a spreadsheet that was sent to me but >some > cells are showing ####'s after I input the figures instead of a view of > the ...

Reporting Services SUM(IIF(...) Problem
I have on my report a list grouped by username. What I need is to count the number of times the grouped username appears in another column within the dataset (both inside and outside the grouping). I have tried everything I can think of (which is why I am here.) What I have so far is some code and a "SUM(IIF(..." statement. In the code below you will find the values I use to get/set the list's current username and the values of the related text boxes. The code to set and retrieve the username work. (I can set the value of a textbox inside the list to =Code.Username and get...

Two problems with CImageList (Add and Draw)
Hello I have two simple yet irritating problems with CImageList. 1. The program extracts icons from other running programs. Each icon is added to an image list [which is created like this: ..Create(16,16,ILC_COLOR32 | ILC_MASK,c,1)]. From time to time CImageList::Add fails (returning -1), although the HICON looks ok (I've noticed that it always fails with an icon extracted from IE window). My question is, what are the possible reasons which force CImageList::Add to fail? 2. Some icons (for example from OE, IE, calculator) have a "shadow" but CImageList::Draw ignores that shad...

Problem with trendline formula
I have added a trendline to a line chart where I am plotting a value y axis against a date series x axis and have shown the trendline equation on the chart. The only trouble is - it is wrong. When I calculate the formula (so as to be able to forecast future periods) the values clearly are not those that are being displayed on the chart. I have tried doing the same using no x axis (i.e. defaults to 1,2,3,4 etc.) rather than using my dates, and this produces a correct trend equation. Am I goin mad - or is there a problem with Excel? I am working in Excel 2000, and am using the follow...