SBS2k3: website under companyweb throwing 404 not found

The default 2k3 companyweb website functions correctly. We want to create a 
virtual directory under http://companyweb/our_domain_name. The directory is 
located under  C:\Inetpub\Intranet\our_domain_name. The directory is set for 
internet sharing under Companyweb.On IIS it is listed under Companyweb with 
Application Name  4\our_domain_name and starting point 
<companyweb>\our_domain_name.

Directory browsing is allowed and under documents the default content page 
is added and placed first. It is plain html and the site has no ASP or other 
scripts. All very basic. Still it throws 404 not found errors. I tried 
adding a managed path under SharePoint administration but no change.

Help appreciated for setting up an Intranet site in SBS2003 and/or setting 
up a site under companyweb.

TIA,

Fred 


0
Fred
2/10/2010 10:54:52 AM
windows.server.sbs 1975 articles. 0 followers. Follow

3 Replies
1114 Views

Similar Articles

[PageSpeed] 13

Fred B. wrote:

>
>The default 2k3 companyweb website functions correctly. We want to create 
>a virtual directory under http://companyweb/our_domain_name. The directory 
>is located under  C:\Inetpub\Intranet\our_domain_name. The directory is 
>set for internet sharing under Companyweb.On IIS it is listed under 
>Companyweb with Application Name  4\our_domain_name and starting point 
><companyweb>\our_domain_name.
>
>Directory browsing is allowed and under documents the default content page 
>is added and placed first. It is plain html and the site has no ASP or 
>other scripts. All very basic. Still it throws 404 not found errors. I 
>tried adding a managed path under SharePoint administration but no change.
>
>Help appreciated for setting up an Intranet site in SBS2003 and/or setting 
>up a site under companyweb.

I wouldn't try creating additional web "stuff" inside Companyweb - it's 
managed by Sharepoint, and that's going to make things complicated.

If you desperately need basic web site stuff, I'd build it under the 
Default Web Site (so it's accessible on port 80) if possible. If you're 
really worried about breaking any of SBS functionality, the other option 
would be a whole new Web Site at the top level, and use Host Headers (like 
Companyweb does) or a different port.

Of course, the obvious question is why not just use Companyweb for your 
intranet - that _is_ why it's there...

-- 
Steve Foster
------------
Please reply only to the newsgroups.
For SSL Certificates, Domains, etc, visit.: https://netshop.virtual-isp.net
0
Steve
2/10/2010 3:24:15 PM
Hi Steve,

We are using conpanyweb. It do however not understand why we are not able to 
add some  static non-SharePoint html pages under 
http://companyweb/our_domain_name. They are there, specified the correct 
physical path and virtual path but we still get a 404 not found error.

For example http://companyweb/subsite/index.html page is there, virtual 
directory set, result however 404.

TIA,

Fred

-- 
..
"Steve Foster" <steve.foster@picamar.co.uk> wrote in message 
news:xn0gq89a9w4g5me01t@msnews.microsoft.com...
> Fred B. wrote:
>
>>
>>The default 2k3 companyweb website functions correctly. We want to create 
>>a virtual directory under http://companyweb/our_domain_name. The directory 
>>is located under  C:\Inetpub\Intranet\our_domain_name. The directory is 
>>set for internet sharing under Companyweb.On IIS it is listed under 
>>Companyweb with Application Name  4\our_domain_name and starting point 
>><companyweb>\our_domain_name.
>>
>>Directory browsing is allowed and under documents the default content page 
>>is added and placed first. It is plain html and the site has no ASP or 
>>other scripts. All very basic. Still it throws 404 not found errors. I 
>>tried adding a managed path under SharePoint administration but no change.
>>
>>Help appreciated for setting up an Intranet site in SBS2003 and/or setting 
>>up a site under companyweb.
>
> I wouldn't try creating additional web "stuff" inside Companyweb - it's 
> managed by Sharepoint, and that's going to make things complicated.
>
> If you desperately need basic web site stuff, I'd build it under the 
> Default Web Site (so it's accessible on port 80) if possible. If you're 
> really worried about breaking any of SBS functionality, the other option 
> would be a whole new Web Site at the top level, and use Host Headers (like 
> Companyweb does) or a different port.
>
> Of course, the obvious question is why not just use Companyweb for your 
> intranet - that _is_ why it's there...
>
> -- 
> Steve Foster
> ------------
> Please reply only to the newsgroups.
> For SSL Certificates, Domains, etc, visit.: 
> https://netshop.virtual-isp.net 


0
Fred
2/16/2010 11:56:15 AM
Fred B. wrote:

>Hi Steve,
>
>We are using conpanyweb. It do however not understand why we are not able 
>to add some  static non-SharePoint html pages under 
>http://companyweb/our_domain_name. They are there, specified the correct 
>physical path and virtual path but we still get a 404 not found error.
>
>For example http://companyweb/subsite/index.html page is there, virtual 
>directory set, result however 404.
>

Because that's not how Sharepoint works.

Basically, IIS hands over processing of requests within a Sharepoint 
website to Sharepoint. Normal IIS processing doesn't apply.

You should be able to use the FrontPage licence that comes with SBS2003 to 
modify the design of Companyweb, which would let you incorporate your 
static pages into Sharepoint "the Sharepoint way" (they just become Custom 
Pages, IIRC).

-- 
Steve Foster
------------
Please reply only to the newsgroups.
For SSL Certificates, Domains, etc, visit.: https://netshop.virtual-isp.net
0
Steve
2/16/2010 2:53:31 PM
Reply:

Similar Artilces:

Reported error (0X800CC0F) the connection to the server was interrupted
I am receiving this error message on a client workstation, none of the other 4 users on the LAN are receiving this error. They are using Outlook 2002 connected through an ADSL modem. The user still can send and receive e-mails but this error message always appears. Any one have any ideas? Reported error (0X800CC0F) the connection to the server was interrupted Sean probably one or more files have been damaged in outlook (express). Just reinstall outlook or have it repaired through the original disc. "Sean" <fake@fake.com.au> schreef in bericht news:3gvm10d6gfh4rip45u5ja0r...

SBS2K3 future expansion and upgrade path
We are now running SBS2K3 full with also the optional SQL 2005 and ISA server. I know ;-( but in our case it runs smoothly. Our network also includes a Windows 2003 server running Progress database server and a Windows 2003 Terminal Server. We have a future interest in a SharePoint (MOSS) 2007 server with a separate SQL 2008 server to take it down from the SBS2k3 box. So for next year I am looking at buying SQL server 2008 enterprise and MOSS 2007/10. Instead of buying multiple hardware boxes, I am now looking at the possibility of using Virtualization on a HP DL380 G6 2x qu...

Creating Access forms for a website/intranet
I saw a post from December 05 that talks about what I am interested in pursuing and I am hoping that things have evolved since then. I have an Access database with some fairly complex forms that I would like to "publish" to a website (it's really an intranet). The answer from Rick Brandt to the 05 post was that you can't really do that; you have to create Data Access Pages in Access that "run in a browser and allow simple interaction with the database. They are not the same as an Access form, but they can be used in an intranet when rich features and security a...

can't login to some websites
Recently installed Windows 7 Home Premium on new home-built computer. I've noticed that I can't login on some websites using any browser (have tried IE8, Firefox, and Chrome). Websites I can't login to: Newegg.com (address: https://secure.newegg.com/NewMyAccount/AccountLogin.aspx?tojump=0&nextpage=https://secure.newegg.com/NewMyAccount/DashBoard.aspx) XFX support (address: http://www.xfxforce.com/en-us/Help/Support.aspx) I can login to Newegg if I select the "Remember my Newegg ID" box. The XFX support site has no such option. Also, is it a coinci...

Companyweb pages display incorrectly
We just had a number of problems with SharePoint services on our SBS 2008. The problems were the now well-documented ones about Companyweb giving 404 errors after install of a service pack and security upddate. We worked through various articles and now have the databases, SharePoint Central Admin and (to an extent) Companyweb sites functioning again. The problem is that the companyweb site now displays in 'texct mode' on all browsers. All the frames and formatting seem to be missing but all the data in our document library is present and correct. Perversely the Centra...

Multiple domains on SBS2k3
I have a question about multiple domains on SBS2k3 Prem. all services packs installed. Our company has just been sold, the new company wants a new internet domain name. We will be getting new server with SBS2008 prem. Until that time we need to set up exchange to except the new email addresses, host the new web page along with the old one. I believe I have the exchange thing figured out KB article 268838. question: is there anything that needs to be done to ISA, Active directory, or anyother SBS component? We need to maintain the existing web site and domain name for a little...

website hosting
Here is the link to the web hosting company that I use for my 3 sites. http://frontpage-web-hosting.org/ ...

"FOUND ORPHANED REQUEST" error
This error occurs several times a week, preceeded by this error: runningjobs!WindowsService_1!f9c!05/17/2010-06:52:24:: e ERROR: Error in timer Database Cleanup (NT Service) : Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerStorageException: An error occurred within the report server database. This may be due to a connection failure, timeout or low disk condition within the database. ---> System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. We are running SQL 2008...

Unable to load CRM website
I have installed Microsoft for the first time. It is on a Windows 2003 ENT server that is also running SQL server with service pack 3a. When logged on the server with domain admin account and using "http://localhost" I get "The page cannot be found HTTP Error 404 - File or directory not found. Internet Information Services (IIS)" This is from the default install; I have not moved or edited the IIS instance or the default "Microsoft CRM Server 1.0" web site. Under IIS it shows the web site is up and running. I also checked and made sure that "(All...

portfolio.custom attribute.view in aspx."attribute not found"
I created custom attributes. I want to modify the "project.aspx" template to have them available for my users as in a display in the documentation. I made formatting changes to the "project.aspx" file, including adding the new custom attributes. When the "project.aspx" is dispayed, these custom fields say "attribute not found". Help? Chas On Dec 14, 3:50=A0pm, Chas Roberts <ChasRobe...@discussions.microsoft.com> wrote: > I created customattributes. =A0I want to modify the "project.aspx" templa= te to > have th...

Some funny videos I found
'Humping the ball' (http://www.vapshare.com/2899/humping-the-ball.html) - 'How not to tow a car' (http://www.vapshare.com/2889/how-not-to-tow-a-car.html) - 'Cat + Fan = bad mix' (http://www.vapshare.com/2699/cat-+-fan.html) - 'Non swimmer' (http://www.vapshare.com/2640/non-swimmer.html) - 'Head vs Bumper (Mayor ouch factor)' (http://www.vapshare.com/2686/head-vs-bumper.html) - 'Angry crackhead' (http://www.vapshare.com/2689/angry-crackhead.html) Enjoy ;) -- mikeyboy82 good i like'em "mikeyboy82" wrote: > > 'Humping...

website ads
I have tried several spyware, adware software to remove these unwanted website ads that take over my home page and pop ups for me to log-in. The pop-ups do not come up while surfing they just come up on desktop. I ran a deep virus scan with norton sec suite and have not found any trojons. The ads come and go and have caused my search engine Bing or Google to redirect the links I ran a search for that show up correctly from the seaqrch but as soon as I click the link I get redirected to these ads. Even though the websites address is different it changes it to these ads. Contact ...

trash in your website
Please remove the junk from your list of topics - porno ...

I cannot open a website when sent through my outlook 2003
...

OWA Pub Folder on Website
Can I create public folders calendars and have them available for the world to see? But only we can edit them? I want to add a calendar to our School District website and the Calendars in OWA 2003 on Exchange 2003 would be easy to manage. > Can I create public folders calendars and have them > available for the world to see? But only we can edit > them? Yes you can! Create a public calendar folder in your preferred manner. In Exchange System Manager, create a virtual HTTP server or a virtual directory with the desired name (let's say School as an example). Have this point t...

Error message: Style 'Percent' not found
Hi guys, I get the above error message in excel when i click on the percentage icon, any solutions to this silly problem. Thanks in advance Pantelis You're getting this because your "Percent" style has been deleted or is otherwise inaccessible. (Check Format / Style... and look for "Percent".) You can import the default styles from another workbook to correct this issue. Open the workbook with which you're having this problem (let's call it Book1 for now) and then click "New Workbook" to create a new book with the default styles intact (let...

website prevents excel import web query
can it be that a website prevents import web query from importing data? this is the website http://www.capital.gr/xa/allstocks.asp and it seems that it imports everything but the stock prices... can that be? is there a way around this, thanks, S, ...

Thesaurus not found
Office Word 2007 My thesaurus is missing. If I try to check a word in the thesaurus I get an error--something like "thesaurus not found." (Sorry, I'm not at that computer now, so I can't quote the exact error. If this is critical, I'll retrieve it.) How (where) do I install the missing component? Thanks! Ken Isaacson SILENT COUNSEL, a legal thriller www.KenIsaacson.com Open Control Panel and change the installation of Office. If you have disk space - choose full installation. -- Best regards Malin D Office consultant/Trainer "Ken...

Retained Earnings Account Not Found
Hello: Upon year-end close in the General Ledger, the following error message is appearing: "Retained Earnings Account Not Found". It has been determined that this has to do with divisional retained earnings. The two retained earnings accounts are: 2999-01-00-00-100-00 and 2999-01-00-00-400-00. According to a TK article, this sort of closing to divisional retained earnings will not work. Why is that? Also, is the "remedy" to close to just one of these two accounts and simply conduct a manual reclassification entry afterward? childofthe1980s B...

SBS2K3 Server going nuts
Hello All, I have a couple of earlier post but things are really bad now. Keep getting bluescreens on PFN now am getting on Memory Management wiht techincal info of STOP 0x0000001A 0x00003452, 0xD2B49201, 0xC052DE4, 0x00000080 Aslo I am seeing application error on spoolsv.exe as well as tcpsvcs.exe. I am rebooting the server about 6(six) time a day, already on 7 today. Am I better off reinstalling or try to fight through the problems? Thanks in advance. Unless there are several jmillerWV posting in this group, you have at least three threads open on the same subject without...

CRM v3 + W2k3r2 - Install issue
hi all, I wanted to try CRM v3 on w2k3r2 server with sql2000sp4. The problem is that when the verification goes on during install, i've got an MS SQL Server Reporting Services error: Erreur lors de l'acc�s � l'URL http://CRM�: Le serveur distant a retourn� une erreur�: (404) Introuvable. Erreur HTTP 404 - Fichier ou rpertoire introuvable. I've checked with IE the by default web site, it looks ok. Has anyone an idea?? thanks, Thomas The report server URL should look like http://servername/reportserver. It is not the CRM server URL. If you browse to the repo...

can't publish website
I am trying to publish my website using Pub. 2007. I am publishing to godaddy. I have uploaded it after many try's. But only the background shows up. I think this has come up many times with GODADDY. You will find your content displaced away to the right. Please ask Pub WEB related questions at microsoft.public.publisher.webdesign and include your operating system as well as your PUB and IE versions and include your URL if possible so others can help you. John G. "Tom Tanner" <Tom Tanner@discussions.microsoft.com> wrote in message news:0DD841D7-9AC0-4993-9199-28...

Synching nokia mobile phone with exchange2003 sbs2k3
Hello, Environment is: SBS 2k3 premium R2, windows XP pro clients, Outlook 2007 On a network which doesn't have OMA enabled (yet?) has anyone experience of synching a nokia 5800 via pc-suite, or ovi-suite (apparently ovi means door in finnish), - all we need is tasks and appointments to sync. Have seen a few posts on nokia forum where people say it works ok when syncing their phones on their Vista laptops but not on the XP workstations. Some of the solutions relate to the date range for the sync period e.g. 1 week in the past 2 weeks in the future, and are on XP but n...

Access denied on one client, SBS2K3
Just finished the tutorials on CRM 1.2. One of the last things to do was create a user from the Settings screen. I then added a license to the user, created role of CEO- Business Manager, logged off/back on as that user and opened CRM. CRM loads, but gives me a message of "Access Denied, You do not have sufficient access rights or privileges to perform this action." I have no problem logging on in CRM as that user on the server. Also, in Users the new user shows up under "Local Users" on the server. Clearly something is mixed up somewhere, but I have no idea how or ...

Accessing the companyweb from the server
I am not able to open up the companyweb from the server console logged in as administrator. Why is that and what can I do to correct this problem? This is a multi-part message in MIME format. ------=_NextPart_000_0027_01CAF831.BFAA1080 Content-Type: text/plain; charset="Utf-8" Content-Transfer-Encoding: quoted-printable http://blogs.technet.com/sbs/archive/2009/04/17/authentication-issues-acc= essing-companyweb-from-the-server-itself-after-963027.aspx --=20 Cris Hanna [SBS - MVP] (since 1997) Co-Contributor, Windows Small Business Server 2008 Unleashed http://ww...