Server 2003 slow copying from external drives

I just re-installed SBS 2003 when the drives  in the RAID array failed.  I 
rebuilt it without a RAID.

I am experiencing excrutiatingly slow copying from external USB drives.  All 
Windows freeze while copying a large file (2GB+) from the external drive to 
the C drive.

I have tried more than one external drive to eliminate drive problems as a 
cause.

I have scanned the c: drive (chkdsk /R /X c:) for errors and found none.

Copying from internal drive to internal drive does not cause the freezing or 
very slow copy speeds.

This is a Dell Poweredge sc420 with dual Hitachi 500 GB drives and 1 GB RAM.

I have searched the web over but have yet to find a solution. 

Any help you could offer would be greatly appreciated.
0
Utf
6/29/2010 8:42:59 AM
windows.server.general 1084 articles. 0 followers. Follow

5 Replies
676 Views

Similar Articles

[PageSpeed] 2

"Jim Hubbard" <JimHubbard@discussions.microsoft.com> wrote in message 
news:7D520057-6527-4F1C-82A7-08A8E59B09A3@microsoft.com...
>I just re-installed SBS 2003 when the drives  in the RAID array failed.  I
> rebuilt it without a RAID.

Rebuilt without RAID,...that was a big mistake.  RAID is the only thing that 
is going to save your rearend in the event of a drive failure, that most 
certaily *will* happen eventually,..it is inevitable.   Considering that SBS 
is a horrible mess when it comes to Disaster Recovery because of its design, 
that's make the RAID even more important.

> I am experiencing excrutiatingly slow copying from external USB drives. 
> All
> Windows freeze while copying a large file (2GB+) from the external drive 
> to
> the C drive.

USB drives are slow,...always have been.  If the USB port you plug into is 
not a USB version 2.0 then it will be even worse.


-- 
Phillip Windell

The views expressed, are my own and not those of my employer, or Microsoft,
or anyone else associated with me, including my cats.
-----------------------------------------------------


0
Phillip
6/29/2010 1:42:18 PM

"Phillip Windell" wrote:

> "Jim Hubbard" <JimHubbard@discussions.microsoft.com> wrote in message 
> news:7D520057-6527-4F1C-82A7-08A8E59B09A3@microsoft.com...
> >I just re-installed SBS 2003 when the drives  in the RAID array failed.  I
> > rebuilt it without a RAID.
> 
> Rebuilt without RAID,...that was a big mistake.  RAID is the only thing that 
> is going to save your rearend in the event of a drive failure, that most 
> certaily *will* happen eventually,..it is inevitable.   Considering that SBS 
> is a horrible mess when it comes to Disaster Recovery because of its design, 
> that's make the RAID even more important.
> 
> > I am experiencing excrutiatingly slow copying from external USB drives. 
> > All
> > Windows freeze while copying a large file (2GB+) from the external drive 
> > to
> > the C drive.
> 
> USB drives are slow,...always have been.  If the USB port you plug into is 
> not a USB version 2.0 then it will be even worse.
> 

Even if they were pre-2.0 USB ports, that would not explain everything else 
onscreen freezing while you copy data from an external drive.


0
Utf
6/29/2010 3:54:48 PM
I recently ran into a couple situations where the "onboard" USB ports were 
not version 2.0 but they had an additonal USB Card in the machine which was 
Version 2.0,...so it really mattered which USB port I plugged into 
concerning speed.


-- 
Phillip Windell

The views expressed, are my own and not those of my employer, or Microsoft,
or anyone else associated with me, including my cats.
-----------------------------------------------------


0
Phillip
6/29/2010 3:55:09 PM
"Jim Hubbard" <JimHubbard@discussions.microsoft.com> wrote in message 
news:3871699B-BDA7-455D-AB45-8C49C0B55F45@microsoft.com...
>
>
> "Phillip Windell" wrote:
>
>> "Jim Hubbard" <JimHubbard@discussions.microsoft.com> wrote in message
>> news:7D520057-6527-4F1C-82A7-08A8E59B09A3@microsoft.com...
>> >I just re-installed SBS 2003 when the drives  in the RAID array failed. 
>> >I
>> > rebuilt it without a RAID.
>>
>> Rebuilt without RAID,...that was a big mistake.  RAID is the only thing 
>> that
>> is going to save your rearend in the event of a drive failure, that most
>> certaily *will* happen eventually,..it is inevitable.   Considering that 
>> SBS
>> is a horrible mess when it comes to Disaster Recovery because of its 
>> design,
>> that's make the RAID even more important.
>>
>> > I am experiencing excrutiatingly slow copying from external USB drives.
>> > All
>> > Windows freeze while copying a large file (2GB+) from the external 
>> > drive
>> > to
>> > the C drive.
>>
>> USB drives are slow,...always have been.  If the USB port you plug into 
>> is
>> not a USB version 2.0 then it will be even worse.
>>
>
> Even if they were pre-2.0 USB ports, that would not explain everything 
> else
> onscreen freezing while you copy data from an external drive.

I had this happen (still happening) when a machine had an add-on USB Card 
for v2.0 and the USB Drives were Western Digital "My Book" 1tb drives.  The 
server did not actually freeze,...the processes just took all the resources 
of the server to the point that it would not even respond to any network 
access to the machine from Clients either.

Have never solved that one.  These drives are used to do backups, so we had 
to schedule them to always run late at night when nothing else was using the 
machine.  Sometimes the WD drive would crap out and Windows would think they 
were not even partitioned,...re-partition, re-format gets tham going 
again,...until it happens again later.  Was planning to try a different 
brand/model of USB drive but that has not happend yet (not up to me to buy 
the other drives and no one has done it).  Personally I suspect it was the 
add-on USB card that was the problem but the person in charge doesn't think 
so, so that therory has never been tested.


0
Phillip
6/29/2010 5:49:52 PM
We just replaced our USB backup devices with eSATA drives.  This in a Dell PE 
2800, dual, dual cord Xeon, Windows Server 2003 Enterprise, 16GB RAM, 8 300GB 
Ultra SCSI drives in a RAID 5.  Our backup times on the 3 USB devices was 
~27.5 hours (backing up 2.5TB on 6 servers)  On 2 eSATA drives it is now 
~11.5 hours!

BUT, I found out something else.  Having 3 USB drives connected to this 
server - WITHOUT ANYTHING being read or written to them, slowed this system 
down.  And with the backup processes running, quite slugish.  It is now more 
responsive with the eSATA devices and the backup RUNNING than it was with the 
3 USB drives connected and NO backup jobs running.  

There is something not so nice that USB drives do to a box!
0
Utf
7/2/2010 7:35:30 PM
Reply:

Similar Artilces:

NO DEFAULT SMTP SERVER..
Hello, I had a problem with exadmin.dll, unregistered it, copied new one and registered it and now the default smtp server is gone under SMTP in my systems manager but everything still works.... HELP where is it ? and how can i get it back ? tnnx. Philippe ...

Upgrading from server 2000 to server 2008R2?
We would like to upgrade our servers to Windows server 2008 R2. Currently we have two Windows 2000 (SP 4) domain controllers, we want to replace the Forest Root Domain box with new hardware & upgrade the other DC to server 2008 R2. I understand it's not possible to upgrade from 2000 straight to 2008 but is server 2003 still available to ugrade to in between? I'm also not sure of what the implications of retiring the Forest Root Domain box would be? Would the best plan be to add the new 2008 server (domain function & forest function level: 2000); upgrade the se...

Can Recovery Storage Groups be used if original server gone?
We had an Exchange server die on us a few months back due to hardware issues. All accounts were moved to another box and that one was flattened and taken out of the Exchange org. It was replaced by new hardware that does NOT have the storage groups or databases that the old one did. We have a request to recover data from an info store back up prior to the events above and are running into problems with our backup vendor. Would it be possible to use a Recovery Storage Group to retrieve this data? The mailbox still exists (but may have been moved via Exmerge) so I believe I will pas...

MS Project Server Admin // Denver, CO
MS Project Server Admin Location: Denver, CO Duration: 6 months Pay Rate: DOE =95 MSProject Server ver 2010, SQL database and Sharepoint 2010 =95 Ongoing support and maintenance involving activities such as =96 Monitoring logs, Patches, resolving support tickets, Dev/Test/Prod support =95 Routine troubleshooting =95 Technical APS maintenance (Project Server & SharePoint 2010) =95 User administration / Password resets etc. =95 Work with Microsoft for any critical issues that might need intervention from Microsoft =95 Application of Patches & migration to Production =95 SQL services mo...

cant get outlook 2003 to run in windows 7
installed office 2003 standard (sp3) in windows 7 and get a trouble message when launching. A popup box called configuring outlook comes up with the task "migrating account settings" highlited. This is followed by the trouble message box called microsoft office outlook stating "unable to open your default email folders. Outlook would not start because a data file to send and receive could not be found". I went back into the windows control panel>user accounts>mail and verified a pop email exists but there no entries under the data tab. I selected add (...

Removed server, exchange still looking for it?
Exchange 5.5, I removed a server from the site using exchange admin, and now am getting event 9318, saying MTA can't contact it. Why is it doing that? I had the same problem after a 5.5 to 2000 migration. Rebooting the Exchange server that was trying to connect resolved the problem. MTA must keep the information cached. Tim "dlw" <dlw@discussions.microsoft.com> wrote in message news:C431500C-F78D-47E5-AAC5-B8C611592E97@microsoft.com... > Exchange 5.5, I removed a server from the site using exchange admin, and > now > am getting event 9318, saying MTA can...

"On Slow Connections Download Only Headers" Doesn't works
Server: Win2003 + Exchange2003 + RAS (VPN Acces) Client: WinXP SP2 + Outlook2003 Usually when I connect to the LAN status bar shows "Connected". When I use GPRS or Dial-up + VPN and I have checked in Outlook "On Slow Connections Download Only Headers" than the connection status been rightly detected slow connections speed (less than 128Kbs) and shows "Connected (Headers)". It is one month ago when this function last works. Now I must select manually "Download Headers". I don't really know what was happened with this function. I have installed ...

Small Business Server in Windows Server 2000 Environment
I have a requirement to install Microsoft CRM for about 10 CRM Users. The existing Windows 2000 has about 120 users with two Exchange Servers. Is it possible to set up a separate Small Business Server to run CRM within the Windows 2000 domain as this is the most cost effective way of implementing CRM for such a low User count? ...

windows 2008 server cord and windows 2008 std
we have 20+ New server to install windows 2008 for trading purpose. still can not decide to install server core or std full, can someone advise what is the benefit to install core rather than std edition or to install std edition ? DD, There is: Server Standard Server Standard Core Server Enterprise Server Enterprise Core Core is (not quite correctly called) 'Server without Graphical User Interface (GUI)'. There are several reasons why Core was introduced: - *Nix purists were saying that there's no real need/use for GUI on a server and *real* sysadmins ar...

Windows 7 and Outlook 2007, domain laptop can do outlook via RPC but non domain laptop can not. SBS 2003
I have no problems connecting to exchange while outside the building with my domain laptop, username/password screen comes up, enter it in and i connect. If I try with a non domain laptop with the same settings and the same cert, i just keep getting a username/password screen. I tried all the combinations with no luck. I am currently using the free cert that I created when installing SBS 2003. We have bought a new cert to replace it though. Any idea's? Is it because of the cert? Thanks ...

Outlook won't leave messages on the server
I have tried and tried to keep Outlook 2003 from deleting my email off my server. I have found the check box under advanced send\receive setting in "options" and I have tried variations of the 3 check boxes in this window and they work until I close Outlook and reopen it, then all of my settings return to the default of deleting my email off the server. Wasn't MS suppose to stop doing things like this? Any help in steering me to the answer (which i am sure is here) to this question is appreciated. Regards Paul A. Walters Hi, Goto Tools --> Email Accounts --> V...

Project Server Provisioned
Hello, I have provisioned Project Server and added it to the trusted zone, but it still comes up unresolved. Hello, You mean PWA home page is not loading or issue with connecting from MS Project Professional? Also mention the version of Project Server. Thanks Chak pVector Technologies http://www.pvectortech.com http://www.epmcentral.com On Apr 16, 11:04=A0am, me <mtyso...@yahoo.com> wrote: > Hello, I have provisioned Project Server and added it to the trusted > zone, but it still comes up unresolved. On Apr 16, 12:20=A0pm, Chak <chak...@hotmail.com>...

OT: SVN server
Hi, Sorry for the OT, I am not 100% sure where to ask. I want to setup a subversion repo on a personal website. Would anyone know the best forum/NG to ask such a question? (Or where I could find a tutorial for installing such a repo). Thanks Simon Simon wrote: > Hi, > > Sorry for the OT, I am not 100% sure where to ask. > > I want to setup a subversion repo on a personal website. > Would anyone know the best forum/NG to ask such a question? > (Or where I could find a tutorial for installing such a repo). > > Thanks > > Simon ...

can not print one check in 2003 money
Odd problem I can not print 1 check in money 2003 for some reason. if i make out a check and put it for PRINT.. it will not show up the blue highlight on the left side of the screen. If i go to the file-print checks the error message i get is " You don't have any checks to print on any accounts" If i make a 2nd check then the blue highlight will show up ... it will print both checks just fine and recognize that there are 2 checks to print. This also works for 3 checks.. 4 checks.. etc it also numbers them correctly in the printing and ledger. Close Money, go to Start, Run an...

Windows Server 2008 RC2 in Windows Server 2003 Domain
I'm having trouble with one domain controller that has all of the FSMO roles (I have 6 Domain controllers in total running server 2003) I updated my schema to version 47 (Windows server 2008 RC2) and would like to add a new physical server with W2K8 R2 on it and transfer all of the FSMO roles on it. I don't want to upgrade all DC's yet to 2008 R2 yet, so the domain functional level will stay the same for a while (Windows Server 2003). Is there anything I should watch out for with this scenario? Or by just adding a W2k8 R2 box with all the FSMO roles and then decomm...

XML 2003 represents a variety of industries...more...
Premier XML Industry Event Slated for Dec. 7-12 in Philadelphia; Presenters Include Adobe, BEA, Microsoft, IBM, Sun, Hewlett-Packard, Oracle Alexandria, Va. Sept. 30, 2003 - IDEAlliance, a leading trade association dedicated to fostering XML and other information technology standards, today announced the full program for XML Conference and Exposition 2003, being held Dec. 7-12, at the Pennsylvania Convention Center in Philadelphia, Pa. The annual event is the world's largest XML trade conference. "This conference continues to grow because of our commitment to programs that off...

does outlook 2000 or 2003 ever integrated msn messanger
my question is has microsoft integrated msn messanger or any messanger function to outlook 2000 or 2003 using exchanger server thanks for the info sal gil professional solutions Yes -- Dab Cut off: yourhead to respond "Sal Gil" <anonymous@discussions.microsoft.com> wrote in message news:0bc001c3be7c$0e1efd80$a001280a@phx.gbl... > my question is has microsoft integrated msn messanger or > any messanger function to outlook 2000 or 2003 using > exchanger server thanks for the info > > sal gil > > professional solutions ...

Using Access 2003 convert numeric month to text for reports
Hello everyone, Looking for a way to create a report using data that has dates formated as 01/01/2003 ( basically mm/dd/yyyy ) but want to display on the report sorted under categories ( using a query to sort the categories ) but printed out as long version of the month. January 2005 etc. Thanks for the help. You can place a text box on the report based on the date column (call the text box txtMonth or some such). the text box can be formatted as: =(Format([DateCollum],"MMMM, YYYY")) the above would show January, 2005 for today's date.... -- ...

Copy and reverse journal entries
Ability to copy and reverse posted journal entries, i.e. not having to rekey the same journal entry and reverse the debits and credits. ...

outlook 2003 #180
Would anyone know how to download my businnes contacts to my Palm fro outlook 2003 Michael <anonymous@discussions.microsoft.com> wrote: > Would anyone know how to download my businnes contacts to > my Palm fro outlook 2003 Most people do it with the sync software that comes with the Palm, typically Chapura Pocket Mirror, available here: http://www.chapura.com/free_downloads.php -- Brian Tillman Sometime when I reply or forward a message, I do not get the icons with the arrow indicating that I replied or forward a message. Has anyone seen this? "Brian Tillman" ...

Exchange Router setup/Setting More than one Exchange Server up in one organisation with two active directories?
Forgive the version difference, but on Exchange 2003 is there a way to install a secondary Exchange Server on a different domain and somehow have it routed to from the other domain or act as a connector to be able to see those emails without removing them? I don't know enough about routing on Exchange to figure if its capable. Or perhaps I need to utilise a different registered email domain and I should use this for testing instead of trying to somehow route emails from one to the other? eg instead of companyname.com I could use companynamecrm.com or something. Would I still want to setu...

pop3 server response
When opening outlook recently it has been saying my pop3 server hasn't respoded in 60 seconds and asks if I would like to wait longer for the server to respond. but sometimes it goes right through. is there any reason why this might be happening. i can only get e-mail about 60% of the time. any help would be greatly appreciated. J.H. Try removing and reinstalling your mail account settings. --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the Swen virus, all e-mails sent to my actual account will be deleted w/out reading. After...

Exch 2003 Enterprise defrag
I am moved from SBS2K to Exchange 2003 Enterprise. I exported each users mailbox and imported into Exch. In doing so, hundreds of log files were created in the MDBDATA directory. I thought the defrag that ran between 12:00 and 6:00 am would clean this up. On Exhcange 2k3 do I take the database offline then run exeutil /d priv1.edb the same way as on SBS? Will that clean up the MDBDATA directory? DG The logs are typically deleted after a full backup...have you run a backup on that box? "Dan" <gill_daniel@yahoo.com> wrote in message news:O99JpbMKFHA.3336@TK2MSFTNGP10...

Manually run message rules on the server
Hi, Is there a way to run message rules (created by the end-user on Outlook) on the server, say on a daily basis ? The reason is that that person has ~50 rules, moving all incoming messages from his inbox to specific folders. Since he now owns a BES-enabled BlackBerry, these rules prevent him from getting his emails onto his handheld. The idea would be to run all the rules once a day, on his behalf, on the server. Exchange 2007 SP1 Thanks Christian Some rules, like moving messages to another folder in the same mailbox, will run server-side by default, depending on how they're create...

E-Mail Messages Reappear When Server is rebooted
Hello All, I had reason to reboot a windows2003 SBS a few months ago. When it rebooted clients reported old emails had reappeared in their inbox. I was then on a windows2000 SBS site yesterday and when I rebooted the server old emails reappeared. The Windows2003 server rebooted today and again old email reappear. I cannot find any info on web re: this problem. Any help would be appreciated. Sam wrote: > Hello All, > > I had reason to reboot a windows2003 SBS a few months ago. When it > rebooted clients reported old emails had reappeared in their inbox. I > was then on...