Why I get error code c2440

Hi Everybody,

Iwould apprecite it if you could help.

Allen.



//Why I got the following error message? for the 4th line:

// error C2440: '=' : cannot convert from

//'long (*)[3]' to 'long *' Types pointed

//to are unrelated; conversion requires

// reinterpret_cast, C-style cast or

//function-style cast





#include <iostream>

using namespace std;


int main()

{

const int max = 4; //(1)

const int max2 = 3; //(2)

long *pprime; //(3)

pprime = new long[max][max2]; //(4)


return 0;

}


0
5/7/2006 9:32:29 PM
vc.mfc 33608 articles. 0 followers. Follow

4 Replies
647 Views

Similar Articles

[PageSpeed] 23

Change line 3 in your example to:

long (*pprime)[max2]; //(3)

max2 must be a constant (as it is in your example) for this to work; max 
doesn't have to be a constant (but it can be).

Remember to use the array delete operator when you're finished using the 
allocated array.

delete [] pprime;



"Allen Maki" wrote:

> Hi Everybody,
> 
> Iwould apprecite it if you could help.
> 
> Allen.
> 
> 
> 
> //Why I got the following error message? for the 4th line:
> 
> // error C2440: '=' : cannot convert from
> 
> //'long (*)[3]' to 'long *' Types pointed
> 
> //to are unrelated; conversion requires
> 
> // reinterpret_cast, C-style cast or
> 
> //function-style cast
> 
> 
> 
> 
> 
> #include <iostream>
> 
> using namespace std;
> 
> 
> int main()
> 
> {
> 
> const int max = 4; //(1)
> 
> const int max2 = 3; //(2)
> 
> long *pprime; //(3)
> 
> pprime = new long[max][max2]; //(4)
> 
> 
> return 0;
> 
> }
> 
> 
> 
0
Okie (47)
5/7/2006 10:31:01 PM
 /*

When I used the 2 following lines in a simple code, the code will compile 
with no error:

long (*pprime)[max2];

pprime = new long[max][max2];

But if I separate the two lines by putting the first in a class

and the second line in the constructor of the same class I will have the 
under mentioned error messages.



Can you tell me what is wrong?



 */



#include <iostream>

using namespace std;



    const int max  = 5;

      const int max2 = 4;



class Array

{

public:



  long (*pprime)[max2];

  int  capacity;

  int  capacity1;



  Array(int max, int max2)



  {  capacity  = max;

     capacity1 = max2;





       pprime = new long[max][max2]; 
<------------------------------------------error

       //error(1) C2540: non-constant expression as array bound

     //error (2)C2440: '=' : cannot convert from 'long (*)[1]' to 'long 
(*)[4]'



  }

};



int main()

{

  return 0;

}

"Allen Maki" <allen_class@hotmail.com> wrote in message 
news:u8QRA3hcGHA.1264@TK2MSFTNGP05.phx.gbl...
> Hi Everybody,
>
> Iwould apprecite it if you could help.
>
> Allen.
>
>
>
> //Why I got the following error message? for the 4th line:
>
> // error C2440: '=' : cannot convert from
>
> //'long (*)[3]' to 'long *' Types pointed
>
> //to are unrelated; conversion requires
>
> // reinterpret_cast, C-style cast or
>
> //function-style cast
>
>
>
>
>
> #include <iostream>
>
> using namespace std;
>
>
> int main()
>
> {
>
> const int max = 4; //(1)
>
> const int max2 = 3; //(2)
>
> long *pprime; //(3)
>
> pprime = new long[max][max2]; //(4)
>
>
> return 0;
>
> }
>
> 


0
5/8/2006 1:04:13 AM
Inside the { and } of your constructor, max and max2 are not constants - the 
globals const int max and const int max2 have been masked by the 
(non-constant) arguments with the same name in the constructor's argument 
list.


 Array(int max, int max2)
{ 
capacity = max;       // This is max from the argument list
capacity1 = max2;  // This is max2 from the argument list
 
pprime = new long[max][max2];  // Again...
....
}


try this:

class CSomething
{
	static const long m_max2 = 3;    // This must be initialized with a constant 
	long	m_max;

	long	(*pprime)[m_max2];

public:
	CSomething(long max = 4);     // provide a default value (4 here) if you want
	~CSomething();
};

// Allocate the array in the constructor
CSomething::CSomething(long max /* = 4 */)
{
	m_max = max;     // this will be 4 if parameter not specified 

	pprime = new long[m_max][m_max2];
}

// De-allocate the array in the destructor
CSomething::~CSomething()
{
	if(pprime)
		delete [] pprime;
}


now, in your program...

int main()
{
	CSomething	thing1;           // Allocates 4 (default) X 3 array
	CSomething	thing2(2);      // Allocates 2 X 3 array
	CSomething	*thing3;

	thing3 = new CSomething(5);  // Allocates 5 X 3 array

	...

	delete thing3;     // Destructor deallocates the array

	return 0;
	// Destructors for thing1 and thing2 are automatically called
}


"Allen Maki" wrote:

>  /*
> 
> When I used the 2 following lines in a simple code, the code will compile 
> with no error:
> 
> long (*pprime)[max2];
> 
> pprime = new long[max][max2];
> 
> But if I separate the two lines by putting the first in a class
> 
> and the second line in the constructor of the same class I will have the 
> under mentioned error messages.
> 
> 
> 
> Can you tell me what is wrong?
> 
> 
> 
>  */
> 
> 
> 
> #include <iostream>
> 
> using namespace std;
> 
> 
> 
>     const int max  = 5;
> 
>       const int max2 = 4;
> 
> 
> 
> class Array
> 
> {
> 
> public:
> 
> 
> 
>   long (*pprime)[max2];
> 
>   int  capacity;
> 
>   int  capacity1;
> 
> 
> 
>   Array(int max, int max2)
> 
> 
> 
>   {  capacity  = max;
> 
>      capacity1 = max2;
> 
> 
> 
> 
> 
>        pprime = new long[max][max2]; 
> <------------------------------------------error
> 
>        //error(1) C2540: non-constant expression as array bound
> 
>      //error (2)C2440: '=' : cannot convert from 'long (*)[1]' to 'long 
> (*)[4]'
> 
> 
> 
>   }
> 
> };
> 
> 
> 
> int main()
> 
> {
> 
>   return 0;
> 
> }
> 
> "Allen Maki" <allen_class@hotmail.com> wrote in message 
> news:u8QRA3hcGHA.1264@TK2MSFTNGP05.phx.gbl...
> > Hi Everybody,
> >
> > Iwould apprecite it if you could help.
> >
> > Allen.
> >
> >
> >
> > //Why I got the following error message? for the 4th line:
> >
> > // error C2440: '=' : cannot convert from
> >
> > //'long (*)[3]' to 'long *' Types pointed
> >
> > //to are unrelated; conversion requires
> >
> > // reinterpret_cast, C-style cast or
> >
> > //function-style cast
> >
> >
> >
> >
> >
> > #include <iostream>
> >
> > using namespace std;
> >
> >
> > int main()
> >
> > {
> >
> > const int max = 4; //(1)
> >
> > const int max2 = 3; //(2)
> >
> > long *pprime; //(3)
> >
> > pprime = new long[max][max2]; //(4)
> >
> >
> > return 0;
> >
> > }
> >
> > 
> 
> 
> 
0
Okie (47)
5/8/2006 5:12:01 AM
max and max2 don't have to be constants.  For example, it is perfectly normal practice to
write something like
	int n = GetCount();
	LPINT ints = new int[n];
and it works just fine.  

But code of the form of a declaration where you want to initialize it are not supported.
The statement
	long (*pprime)[m_max2];
is not legal if m_max2 is not a constant.  So the correct behavior would be in a
constructor to first delcare the value as
	long *pprime;

	CSomething(int n) { pprime = new long[n]; }
you are trying to combine too many unrelated concepts into a single statement here, as far
as I can tell.

Now as far as 
	pprim = new long[max][max2];
I'm not even sure this is legal C++.  What it should mean is "allocate an array of long
elements, then take the [max2]th element, and return that".  At least that's what I think
I'm seeing.  2D arrays are not natural data structures.  If I were going to have a 2D
array, I'd do something like
	pprime = new Array2D(max, max2);
where Array2D is a separate class which creates 2D arrays.
				joe

On Sun, 7 May 2006 22:12:01 -0700, Okie <Okie@discussions.microsoft.com> wrote:

>Inside the { and } of your constructor, max and max2 are not constants - the 
>globals const int max and const int max2 have been masked by the 
>(non-constant) arguments with the same name in the constructor's argument 
>list.
>
>
> Array(int max, int max2)
>{ 
>capacity = max;       // This is max from the argument list
>capacity1 = max2;  // This is max2 from the argument list
> 
>pprime = new long[max][max2];  // Again...
>...
>}
>
>
>try this:
>
>class CSomething
>{
>	static const long m_max2 = 3;    // This must be initialized with a constant 
>	long	m_max;
>
>	long	(*pprime)[m_max2];
>
>public:
>	CSomething(long max = 4);     // provide a default value (4 here) if you want
>	~CSomething();
>};
>
>// Allocate the array in the constructor
>CSomething::CSomething(long max /* = 4 */)
>{
>	m_max = max;     // this will be 4 if parameter not specified 
>
>	pprime = new long[m_max][m_max2];
>}
>
>// De-allocate the array in the destructor
>CSomething::~CSomething()
>{
>	if(pprime)
>		delete [] pprime;
>}
>
>
>now, in your program...
>
>int main()
>{
>	CSomething	thing1;           // Allocates 4 (default) X 3 array
>	CSomething	thing2(2);      // Allocates 2 X 3 array
>	CSomething	*thing3;
>
>	thing3 = new CSomething(5);  // Allocates 5 X 3 array
>
>	...
>
>	delete thing3;     // Destructor deallocates the array
>
>	return 0;
>	// Destructors for thing1 and thing2 are automatically called
>}
>
>
>"Allen Maki" wrote:
>
>>  /*
>> 
>> When I used the 2 following lines in a simple code, the code will compile 
>> with no error:
>> 
>> long (*pprime)[max2];
>> 
>> pprime = new long[max][max2];
>> 
>> But if I separate the two lines by putting the first in a class
>> 
>> and the second line in the constructor of the same class I will have the 
>> under mentioned error messages.
>> 
>> 
>> 
>> Can you tell me what is wrong?
>> 
>> 
>> 
>>  */
>> 
>> 
>> 
>> #include <iostream>
>> 
>> using namespace std;
>> 
>> 
>> 
>>     const int max  = 5;
>> 
>>       const int max2 = 4;
>> 
>> 
>> 
>> class Array
>> 
>> {
>> 
>> public:
>> 
>> 
>> 
>>   long (*pprime)[max2];
>> 
>>   int  capacity;
>> 
>>   int  capacity1;
>> 
>> 
>> 
>>   Array(int max, int max2)
>> 
>> 
>> 
>>   {  capacity  = max;
>> 
>>      capacity1 = max2;
>> 
>> 
>> 
>> 
>> 
>>        pprime = new long[max][max2]; 
>> <------------------------------------------error
>> 
>>        //error(1) C2540: non-constant expression as array bound
>> 
>>      //error (2)C2440: '=' : cannot convert from 'long (*)[1]' to 'long 
>> (*)[4]'
>> 
>> 
>> 
>>   }
>> 
>> };
>> 
>> 
>> 
>> int main()
>> 
>> {
>> 
>>   return 0;
>> 
>> }
>> 
>> "Allen Maki" <allen_class@hotmail.com> wrote in message 
>> news:u8QRA3hcGHA.1264@TK2MSFTNGP05.phx.gbl...
>> > Hi Everybody,
>> >
>> > Iwould apprecite it if you could help.
>> >
>> > Allen.
>> >
>> >
>> >
>> > //Why I got the following error message? for the 4th line:
>> >
>> > // error C2440: '=' : cannot convert from
>> >
>> > //'long (*)[3]' to 'long *' Types pointed
>> >
>> > //to are unrelated; conversion requires
>> >
>> > // reinterpret_cast, C-style cast or
>> >
>> > //function-style cast
>> >
>> >
>> >
>> >
>> >
>> > #include <iostream>
>> >
>> > using namespace std;
>> >
>> >
>> > int main()
>> >
>> > {
>> >
>> > const int max = 4; //(1)
>> >
>> > const int max2 = 3; //(2)
>> >
>> > long *pprime; //(3)
>> >
>> > pprime = new long[max][max2]; //(4)
>> >
>> >
>> > return 0;
>> >
>> > }
>> >
>> > 
>> 
>> 
>> 
Joseph M. Newcomer [MVP]
email: newcomer@flounder.com
Web: http://www.flounder.com
MVP Tips: http://www.flounder.com/mvp_tips.htm
-- 
NewsGuy.Com 30Gb $9.95 Carry Forward and On Demand Bandwidth
0
newcomer (15974)
5/9/2006 2:58:11 AM
Reply:

Similar Artilces:

MSCOMCTL.OCX runtime error
I am trying to use an older program (developed probably around 2003/4). When I attempt to run it I get the following message: > > Run-time error '339': > > Component 'MSCOMCTL.OCX' or one of its dependencies not correctly > registered: a file is missing or invalid > I found this website from google, this specific thread: http://forums.techarena.in/vista-help/845481.htm so I decided to try doing what was suggested in that thread. None of the things that were suggested helped, then it mentioned something about dependency walker. I opened the ...

i get error 404 not found when trying to download
I'm trying to download nokia pc suite to windows xp to upload gallery onto the computer but get error message404 not found - how can i download this pc suite please -- Krysy Albutt Krysy Albutt wrote: > I'm trying to download nokia pc suite to windows xp to upload gallery > onto the computer but get error message404 not found - how can i > download this pc suite please Care to enlighten us how this pertains to: - 1) Microsoft 2) Publisher 3) Windows If you're having problems downloading from the *NOKIA* site where do you think you should be directing your ...

How to get Calendar to send me reminders
I have changed my e-mail address but for some reason I cannot get Calendar to send reminders to my new address - I think I have carried out all that is necessary to effect the changover but I am not getting reminders sent. Can anyone help please? Is the Calendar Live ID based and accessible at Calendar.live.com ? -- ....winston ms-mvp mail "Dabardevon" wrote in message = news:FDC2B3B2-EDE4-41B1-BFC4-C0F9ED59CFB9@microsoft.com... I have changed my e-mail address but for some reason I cannot get = Calendar to send reminders to my new address - I think I have...

Running code when hyperlink clicked
Hello, I am definitely baffled. I am trying to run code when a hyperlink is clicked. I am using Excel 2007, the hyperlink is created in a cell on Sheet 1 using "=hyperlink()", the hyperlink is to a video clip, and events are definitely enabled. I had tried two things, either of which would be fine: 1. I put the following code in Sheet1, and it did not respond at all. What am I doing wrong? Private Sub Worksheet_FollowHyperlink(ByVal Target As Hyperlink) Sheets("Sheet1").Range("B1") = "It Ran" End Sub 2. I put the following...

Some recipients get the attachment, some get winmail.dat
This one has me baffled. We are using Exchange 2000 and Outlook 2000 and have been for 8 months. No previous problems with attachments (.doc, .xls, .jpg). About 2 weeks ago, we started hearing from certain recipients that the attachment wasn't arriving; instead they were getting an unreadable file called winmail.dat. MS says that this is because the sender is using Rich Text to format the email. We have changed the senders to use Plain Text and still have the same problem. If the email is sent to several recipients, some will get the attachment fine, some will not. This didn'...

How to get the CScrollBar's Handle in CTreeCtrl?
Hey,All: I thought I have a problem when I trid to get the CScrollBar's handle from my CTreeCtrl extended handle. Can anybody tell me whether I can get the handle of the CScrollBar from the CTreeCtrl? Thanks in advance! Carl :-| Carl wrote: > Hey,All: > > I thought I have a problem when I trid to get the CScrollBar's handle from > my CTreeCtrl extended handle. > Can anybody tell me whether I can get the handle of the CScrollBar from the > CTreeCtrl? > > Thanks in advance! > Carl > :-| > > Sorry, it is not that simple. The scroll bars that...

Outlook 2003 error #16
My PC crashed last night, and when I restarted it, Outlook 2003 gave an error message that the personal folders had been improperly terminated, and it was trying to recover. That message disappeared after a few seconds, and a normal-looking Outlook window came up. But now, when I try to send/recieve email, I get the error message: Task 'Verizon Main - Receiving' reported error (0x80040600) : 'Unknown Error 0x80040600' Is there a way to recover Outlook without losing the inbox, which contains numerous unread emails? Running Vista Home Premium edition. In the first in...

Unhandled Exception error on few accounts
Hello, On just a few accounts, if I go to History or Activities, I get the following unhandled exception: [SoapException: Server was unable to process request.] System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) +1496 System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) +218 Microsoft.Crm.Platform.Proxy.ActivityPointerWebService.RollupByObject(Guid rollupById, String rollupByName, RollupType rollupType, QueryBase queryExpress...

A Crystal Beginner
I am using Crystal 9.2.4.77 and have loaded the Crystal enhancements. Now I want to do against the CRM database. What do I do? I thought I would create a data source to the CRM SQLserver, which I did, then connect to it through Crystal Reports. That works, but when I drill down on the AAA_MSCRM database to choose my tables, it shows me dbo as the only option (where did this come from??) and under that are just a few generic tables. No CRM tables. Something's not quite right. What am I missing? file - log on to aps server "KBLawson" <klawson@aetinc.com> wrote in ...

Cannot get fast forward or fast reverse to work with WMP 11
I am running Vista Home Premium on a HP G 217-EM Notebook which comes pre-installed with Windows Media Player 11. When I play cds and try to fast forward or fast reverse by keeping the fast forward or fast reverse buttons constantly depressed nothing happens. Why is this, and can anyone come up with a solution? Many thanks This doesn't work on my system either, so it's probably just a limitation of WMP. Fast forward and fast reverse should work fine when you rip the CD's to MP3 or WMA files, and play these files instead. Regards -- Tim De Baets http://www....

GP 10 new install (trial)
Hello, I installed a trial version of GP 10 on a standalone PC to evaluate it. Install seems to complete without problem (includes SQL 2005 install) but when I first want to run Utilities I get an error message " an error occurred while using the bcp utility - data was not correctly copied to the server..." It says it's either a BCP install or ODBC issue. Re-installed everything, same result. Would anybody have a clue? This problem occurs if the User Account Control (UAC) feature is enabled in Windows Vista. However, you must disable the UAC feature if you want to run M...

Combo Box Yes/No error
Hello. I have a form that I want to add a function in the footer that will allow me to sort the records based on whether they are active or inactive. The field in my table is a yes/no check box that is check for yes and unchecked for no. I have tried to use a combo box with 2 columns, Active and Inactive with corresponding fields yes/no check boxes. I set it up as a 2 column count combo box and hid the yes/no column so active/inactive would appear. I get an error that the expression is too complex.... The information is passed to my query to the Active Yes/No column by using: [Forms]![E...

"Compile error in hidden module: GlobalCodeModule"
Hi, we have 3 versions of office installed 2003, 2007, 2010. We have had no problems with that until a week ago or so. In Word 2003 we have code in a global template which uses a treeview control from mscomctl.ocx. I'm not sure that this is the problem though. I have tried to uncheck the reference to theat control and save the template, but then I get another error message "The disk is full. etc etc". I can't save the template after removing the reference or doing any other editing in that template. This not only occurring on my computer. I suspect a rec...

Get paid while you get online!!
I found a great Internet company - Cashfiesta.com - that has created a product everyone can benefit from. They pay you while you work or play on your computer. All you need to do is keep their software - the FiestaBar=99 - active while you are online. They even pay you when your friends are using their computers. Unlike other companies, Cashfiesta gives you control over how much money you earn. They have an individual payrate based on the number of Special Offers you sign up for. As some of these offers are free, you can increase your payrate up to 33 times without spending a penny. It's...

Can't get auto-update (update) to install
Version: 2008 Operating System: Mac OS X 10.4 (Tiger) Processor: Power PC I've been trying to manually check for updates to Word 2008, and I get a &quot;critical update&quot; notice, asking me to install auto-update. When I try to install it, I cannot. It just keeps repeating the attempt, in an &quot;endless loop.&quot; What to do? <br> Thank you. ...

Spreadsheet getting corrupted
Hello All: I have a relatively large spreadsheet. I am getting errors (see after my signature line). What could be causing these errors? Is it that the spreadsheet is too large? Thanks Deguza -------------------------------------------------------- Microsoft Office Excel File Repair Log Errors were detected in file 'C:\Documents and Settings\deguza\My Documents\sales\Sales_2006_2007.xls' The following is a list of repairs: Global PivotTable report information was repaired due to integrity problems. Global PivotTable report information was repaired due to integrity problems. Glo...

Reg getting the next IV Document Number field !
Hi, I am creating a window in dexterity similar to the item transaction entry window (Transactions>Inventory> Transaction Entry). In the Item transaction Entry window, the Document number field defaults to the next document number when we move the focus to that field. I wanted to know if there is any function , or table that i can access to get the next document number in the new window that i am creating. Thanks, swetha -- swetha >In the Item transaction Entry window, the Document number field defaults to the next document number when we move the focus to that field.< T...

How do I get??
Sorry if this seems a fairly easy question to you guys. I have a spreadsheet and I need to get the current system time into a cell. The format of the time is hh:mm am/pm. Any assistance would be most helpful. Hi try =INT(NOW()) in this cell and format is to your needs -- Regards Frank Kabel Frankfurt, Germany PM wrote: > Sorry if this seems a fairly easy question to you guys. > > I have a spreadsheet and I need to get the current system time into a > cell. The format of the time is hh:mm am/pm. > > Any assistance would be most helpful. PM, in the cell you want pu...

Get notified when Out of Office is on
I am using Outlook 2007. With 2003, when returning from leave, I used to get a notification that the Outlook out of office was still on and asking me if I wanted to switch it off. This reminder no longer appears with 2007. How can I switch this setting on so that I get the notification? "Mary Ann" <MaryAnn@discussions.microsoft.com> wrote in message news:ED5533A7-D0EA-41B8-B1A0-A9D15FB6FD98@microsoft.com... >I am using Outlook 2007. With 2003, when returning from leave, I used to get > a notification that the Outlook out of office was still on and asking me ...

Error 3314
I previously set a property to True in a subform field in order to prevent users from leaving a Null value. Error 3314 appears when trying to click in the field to enter information. So, you can't even do what the error message is asking you to do. In addition to that, you can't click anywhere else in the main form until Error 3314 is dealt with (trapped!). I don't really have time to deal with this problem, so I decided to just not make it a required field (setting No instead of Yes in design view). Nothing changed! I've even refreshed the tables and this subform ...

over VPN, it gets stuck when sending outgoing email
When I use VPN to connect to work from home, the outlook can not finish sending outgoing emails. The progress bar moves to the end but then stops there forever. It can never finish. The receiving of new incoming emails work fine. All other network functionality works, e.g. internet browsing, telnet, ftp, etc, all work fine. My system is win2k. I use linksys wireless DSL router. I'd appreciate any hint! Are you using Exchange server? I'd set up your mail profile to prompt you to work offline or online - when using VPN, work offline with scheduled syncs. If not using exchange, pos...

Error -2147024773 when changing passwords in OWA
Hi, Mac clients cant seem to change their Windows password using OWA. The error number -2147024773 appears during the password change process. Can anyone help? Other information: Exchange Server 2003/Windows Server 2003 in mixed mode: with SSL installed and the "Change Password Feature in Outlook Web Access" enabled (KB327134) Macs: OS 9 using IE4.5 and IE5. Windows PCs can change passwords without problem. Intermittently I can change the password on the IE4.5 Mac but most of the time I get the error above. Thanks, Martin Can user's who are using a PC change their domain...

Server error in '/' Application 08-16-03
When I want to save some information (web based) like a quick Contact, I receive the following error: Server Error in '/' application. A potentially dangerous Request.Form value was detected from the client ............ anyone an idea ? Thx Hi Everyone, I was having the same error when trying to edit my Business Unit(New Install). I tried your suggested fix but now I cannot open the CRM app from the browser (server nor client) It opens up the IIS default page. How can I correct this? Help!!! Thanks, Jaime >-----Original Message----- >You need to uninstall the 1.1 .N...

Getting Control ID in Active X control
GetWindowLong return 0. You need to call GetDlgCtrlID from outside the activex control as the function available within the control returns an arbitrary value of zero. Take a look at this article http://xendra.ens.uabc.mx/~sinfante/loo/libro/ch17_4.htm particularly the paragraph preceeding the title "MFC and Ambient Properties". This really begs the question why you want the ID in the first place as activex controls have to be fully self containing to operate - with a few exceptions where sibling controls need to be able to locate each other. - Tim "ytv" <...

Get photos from a camera
I have an asp.net intranet application that I need to upload 1 or all photos from a digital camera at a PC workstation. We are using DataGrids and GridViews to display them on the web once they are uploaded but need something at the client. I assume I need some sort of ActiveX process or something. Has anyone run into a solution for this need? Thanks. -- David "DavidC" <dlchase@lifetimeinc.com> wrote in message news:2B061F4F-B548-4AA4-96FA-2F87383192D2@microsoft.com... > I have an asp.net intranet application that I need to upload 1 or all > photos ...