Tooltip reading "First record"

In an MFC MDI application I am getting an undesired tooltip reading "First 
Record" when the mouse pointer goes over the scroll bars of my CView-derived 
window.  Can anyone help me get rid of it?

====
Details:

1.  I have added

        CToolTipCtrl  mvToolTip;

as a member of my  CView-derived class and the CView-derived window is added 
to this as a "tool" in OnIntialUpdate.

2.  In PreTranslateMessage(MSG* pMsg) I have

if( ::IsWindow( mvToolTip.m_hWnd ) && pMsg->hwnd==m_hWnd )
{
  switch(pMsg->message)
  {
  case WM_LBUTTONDOWN:
  case WM_MOUSEMOVE:
  case WM_LBUTTONUP:
  case WM_RBUTTONDOWN:
  case WM_MBUTTONDOWN:
  case WM_RBUTTONUP:
  case WM_MBUTTONUP:
          mvToolTip.RelayEvent( pMsg );
          break;
  }
}


3. In OnToolTipNeedText() I fill in the tooltip text for the appropriate 
point on my View window.

It all works fine and returns tool tips when the mouse pointer is over the 
view window.

**Except*** I also get a tool-tip reading "First Record" when the mouse 
pointer is
over a scroll bar on the document window.

I am not supplying this text with my CToolTipCtrl, and it doesn't seem to be
coming from there at all, although it wasn't there before I added it.

It differs from the MFC supplied text on the window buttons in that a Dutch
tester gets "First Record" in English, even though the "close" "minimise"
etc tooltips come in Dutch.

Searching for the text, it appears to originate in the resource file
"prompts.rc" in the MFC source code.

Does anyone have any ideas on how to get rid of it?

[I found an archived question on this from the year 2000 in this newsgroup, 
but no definitive answer.]

Dave
-- 
David Webber
Author MOZART the music processor for Windows -
http://www.mozart.co.uk
For discussion/support see
http://www.mozart.co.uk/mzusers/mailinglist.htm 


0
dave1 (356)
5/6/2006 4:23:35 PM
vc.mfc 33608 articles. 0 followers. Follow

0 Replies
511 Views

Similar Articles

[PageSpeed] 32

Reply:

Similar Artilces:

"First Record" in tooltip
My tooltip seems to work fine since it appears the way I expect it to. . However, no matter what I try the tooltip always displays "First Record". Can someone explain to me why this happening and how to solve it. Thanks. > My tooltip seems to work fine since it appears the way I expect it to. . > However, no matter what I try the tooltip always displays "First Record". Can > someone explain to me why this happening and how to solve it. > What tooltip is this (toolbar or on a control in a dialog)? How are you changing it(dynamically or resource editor)? --...

Tooltip reading "First record"
In an MFC MDI application I am getting an undesired tooltip reading "First Record" when the mouse pointer goes over the scroll bars of my CView-derived window. Can anyone help me get rid of it? ==== Details: 1. I have added CToolTipCtrl mvToolTip; as a member of my CView-derived class and the CView-derived window is added to this as a "tool" in OnIntialUpdate. 2. In PreTranslateMessage(MSG* pMsg) I have if( ::IsWindow( mvToolTip.m_hWnd ) && pMsg->hwnd==m_hWnd ) { switch(pMsg->message) { case WM_LBUTTONDOWN: case WM_MOUSEMOVE: ca...

Access jumps to first record when switching to another application
Hi, does anyone know what conditions would cause access to jump to the first record of a form when you switch from the database to another application? I have an unbound main form with a tab control, each tab has a form with subforms. This behavior happens with continuous forms, single forms, and datasheet forms. I don't have any events on the main form or the tab control. Some of the subforms have a current event for synchronizing forms but that is it. This is an Access 2003 database split into frontend/backend. Thanks ...

FindFirst sticking with first record?
I have a combo box that queries from a table of people to get a list of names, ordered lastname, firstname, peopleID. There are several people in this list that have the same last name, and no matter which person I choose with that last name, Access chooses the first person with that last name. (So effectively, if I have Smith Jon 1, Smith Jane 8, Smith Harold 9074395, it'll always stick with Smith Harold 9074395.) The VBA behind this is: Private Sub Combo26_AfterUpdate() ' Find the record that matches the control. Dim rs As Object Set rs = Me.Recordset.Clone rs...

Setting the first record in list box
Hi Folks, i am trying to set the first record in a list box (no multiselect) but the problem I have is that the list box items are created from a dynamic query that fisrt looks up the values. How do i tell the list box that to select the first record and to highlight this when the form is displayed? As always your help is appreciated. Regards, John Dumay John Dumay wrote: > i am trying to set the first record in a list box (no multiselect) but the > problem I have is that the list box items are created from a dynamic query > that fisrt looks up the values. How do i tell th...

How do I record the date of the first record entry.
I have a small database and I want to record, in a table field, the date at which a record is added (but not edited). I want this to be permanent. Should I make the "primary key" this date? Please help, Frank "Frank Martin" <fm@general.com.au> wrote in message news:Osijfdy8KHA.3276@TK2MSFTNGP02.phx.gbl... > I have a small database and I want to record, in a table field, the date > at which a record is added (but not edited). In table design view, add the field to record when the entry was made. In the lower pane of table design, set...

Find the first record from four fields
I have to find the first occurance for data that comes from four fields. 1. PO Number 2. PO Item 3. PO Line 4. PO Date Since there can be many items coming in on different PO's with different lines on different dates. I need to find the first occurance by date. Any help would be great. Thanks Easiest solution would be two queries SELECT [Po Number], [po item], [po line] , Min([po date] as Earliest FROM [Your Table] GROUP BY [Po Number], [po item], [po line] Now use that saved query in another query SELECT [Po Number], [po item], [po line] , [po date] FROM [Your Table] INNER JOIN ...

Error on first record of integration
I am always getting the following error on the first record of each integration (I run a group, which contains 2 separate integrations): Could not set foreground locking value to 0 I found the knowledge article which says to increase the time between the macro to launch GP (scheduled task) and the Run Integration Group (scheduled task), so I did (set to 5 minutes instead of 2). It only takes 30 seconds total to completely log into the company. However, the error still occurs on both integrations. Why would the first record on the second integration fail as well if it was a timing i...

How to select first record in listbox?
Hi All, I have a listbox set to multi-select. I sometimes resort the list by rebuilding its SQL in VB code and requerying it. I then want to update the form that relies in the selection in the listbox for its SQL, but nothing in the listbox is selected. I tried setting the listbox "Value" property with: Me!lstItems.Value = Me!lstItems.ItemData(0) but it didn't work. I assume this is either because the box is in multiselect mode, so the bound column is inaccessible, or because I don't know what the heck I'm doing. So, how can I make the firs...

First record now shows negative amounts
Yesterday we had an issue where selecting an employee would bring up a message window saying that they could not be inactivated or deleted due to a pay run currently in progress. The payroll batches showed no such runs in progress. We then were instructed by support to clear the data on the payroll check work table. Now when we look at the first record(employee) they have an outragous amount for wages (262500) for the month and hours worked is (20480) and days worked is (7569) the amounts are the same for quarter and year data. This is on the employee summary. Any ideas? You may w...

Combo Box and First Record
Hello, I based my combo box on a query that is sorted and my Table is updating but when I open my form, there is information in all the fileds except the field with my combo box. When I select an item from the combo box, everything fills in correctly but I want the form to be completely blank when it is open, open on a new record? Thanks again Set the Data Entry property of the form to Yes. -- Lynn Trapp MCP, MOS, MCAS "Lovespar" wrote: > Hello, I based my combo box on a query that is sorted and my Table is > updating but when I open my form, there is...

set value of first record only
How can I set the value for the first record of a recordset? I want to set the value of the first recorde to 1. all records thereafter will use the Now() time field for their values. This is for a form that logs the time (in seconds) each time a new record is created; but the problem is that if the user waits too long before creating the first record, I get, for example a value of 25 seconds, which is too long, so i would prefer if it was just given the value of 1 (second). I don't mind if the first record has the real value at first, and is then overwritten with the value of '...

First record on sub form
Can anybody please help me and let me know how to goto the first record in a subform by code. the main form is called 'frmSale' it has a sub form control called 'subSale' and the subform itself is called frmSubSale I have tried a few ways but get the error that the form is not open when I use the DoCmd.GoToRecord acDataForm, "SubSale", acFirst Any help most apreciated Steve - from a land down under This kind of thing should move to the first record in the subform: Dim rs As DAO.Recordset With Forms!frmSale!subSale.Form Set rs = .RecordsetClone ...

Continuous form First record
On a continuous subform with only one field (suffix) I need to automatically enter 0 when the field gets focus and then set the focus to the next record in the subform, leaving the 2nd record blank and ready for the user to enter a number. I have tried in the field's OnGotFocus event the following code. If IsNull(Forms!InPutFrm!SuffixSubFrm!Suffix) Then Forms!InPutFrm!SuffixSubFrm!Suffix = 0 EndIf I had the code to go the next record after that but as you can quickly see, that puts a 0 in the second record and I get an error message that it created a duplicate. So I now need help...

First record in all my tables acts as if blank
I'm using Office 2003, and I have an odd occurrence. The first record of all my tables look as if they are blank, but contain data? If I extract the record to excel, I see data, but in access it looks blank. As if the background colar and font colar are both set for white, but it only affects the first records of each table, I see normal data for rest of table records? I tried diffrent files and same pattern exist. Is there a options setting that controls this feature? I tried a repair of office but the issues still exist? Marc How are you defining "the first recor...

Subform requery returns to first record
Greetings folks. I have a Main form and sub form, linked by pk of main form table. The pk of the sub's record source is an identity field. I have navigation buttons on the sub so users can scan through all the records. The problem is that there is a command button on the sub that does a requery of the sub. After the requery is complete the user is returned to the first record in the sub's set of records. I would like the sub to remain on, or return to the current record after the refresh. I put a text box, txtID on the sub that is bound to the sub's ID field. Then I put an ...

Lookup window should default to first record in table
Right now if you click on the looking glass, it opens the window at the record that is already on the field prior to clicking the looking glass. It would be nice if it only did that on the change script so if you didn't change the field at all, when you open the looking glass it brings you to the first record in the table. ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote for this suggestion, click the "I Agree" button in the message pane. If you do not see the button, follow this link to open ...

Assign Values Based on First Record in Group
All - I've got a simple spreadsheet that looks like this: Last Name First Name DOB Start Date End Date Problem is this. In the first row, of each "group" there is a "group desigination" in the "Last Name" field that I would like to assign to all records in that group. All other values for that record are missing. Consider the following: Plumbrook Smith Bob 1/30/2000 1/10/2012 1/21/2012 Jones Bill 1/4/2001 1/7/2012 1/9/2012 Ravenna Smith Jen 1/30/2000 1/10/2012 1/21/2012 Jones Barb 1/4/2001 1/7/2012 1/9/2012 My Goal is t...

Need to stop form from going to first record
I've searched the forum archives and haven't found the same scenario I'm in. There's a few similar problems but the proposals in those didn't work for me so I'm posting a new plea for help. I have a small 3-user database. It's a Access 2000 front-end with a SQL back-end. The application has a main form that handles 99.99% of the user interaction (the rest is look-up list editing forms). There are no sub-forms or tabs or anything else remotely complicated about the form. Anyway the problem I've run into is that whenever a record is updated and then saved th...

set first record to zero in a calculated field
I have a query which compares the current record's create time with the previous record's create time, which gives me the number of seconds elapsed between button presses. All works fine, except the first record is blank. I want it to say either zero or 1 second, regardless of what the query say's. This is the SQL (which creates a sub query from the exisitng table in order to compare current with previous record.) SELECT tbl_Waypoints_Reveal_Target.Run_No, tbl_Waypoints_Reveal_Target.Run_waypoint_List_ID, tbl_Waypoints_Reveal_Target.Run_waypoint, tbl_Waypoints_Reveal_Targe...

access 2003 jumps to first record of form when switching to another application
Hi, does anyone know what causes access (2003) to jump to the first record of a form when you switch to another application? I have a main form with a tab control. Each tab has various forms/subforms. This behavior is happening with single forms, continuous forms, and datasheet forms. It's really disconcerting when your working on a record to have the application jump to another record everytime you switch to another app. The database is split into front/backend. Many Thanks ...

access 2003 jumps to first record of form when switching to another application
Hi, does anyone know what causes access (2003) to jump to the first record of a form when you switch to another application? I have a main form with a tab control. Each tab has various forms/subforms. This behavior is happening with single forms, continuous forms, and datasheet forms. It's really disconcerting when your working on a record to have the application jump to another record everytime you switch to another app. The database is split into front/backend. Many Thanks Is there any code in the Activate event of the form? -- Bob Larson HTH :) ____________________________________...

Allen Browne's Search Screen clears the first record combo boxes
I am using Allen Browne's Search Screen and can't seem to stop the first record's entries being blanked out with the reset button. I changed the original cmdReset_Click() to only set the header fields to Null but my first record's fields also reset with each control. I am using combo boxes in the detail section (to display words instead of record id numbers) which isn't part of the original database. Can someone help? Greatly appreciated, Terri Terri, can you confirm whether: a) the data is being lost, or b) the data is not being displayed properly. There is a di...

findFirst record bookmark not working
Hello, I am trying to keep focus in a specific record in frmDetalheMovFinanc , and it works fine if i set breakpoints in my code. But when I clear all break points, it moves focus in that subform to another record Can you help me Thanks Carlos Code that I have in the OnCurrent event of my form On Error Resume Next If Not IsNull(Me.OpenArgs) Then Dim pass Dim frm As Form pass = Me.OpenArgs pass = Eval(pass) ' if i dont do this it reads a string Set frm = Forms![frmMovFinanc]![frmDetalheMovFinanc].Form frm.Requery ' if i put a break point here the code works fine and when the for...