OT: SVN server

Hi,

Sorry for the OT, I am not 100% sure where to ask.

I want to setup a subversion repo on a personal website.
Would anyone know the best forum/NG to ask such a question?
(Or where I could find a tutorial for installing such a repo).

Thanks

Simon
0
Simon
5/14/2010 7:13:51 AM
vc.mfc 33608 articles. 0 followers. Follow

9 Replies
1327 Views

Similar Articles

[PageSpeed] 20

Simon wrote:

> Hi,
> 
> Sorry for the OT, I am not 100% sure where to ask.
> 
> I want to setup a subversion repo on a personal website.
> Would anyone know the best forum/NG to ask such a question?
> (Or where I could find a tutorial for installing such a repo).
> 
> Thanks
> 
> Simon


Check out VisualSVN.

       http://www.visualsvn.com/

(I see the web site is more fancy now. :))

Pretty easy, if you understand SVN.  Make sure you get the command 
line SVN tools as well.

That said, I like what I saw but we didn't use it because we were just 
too much into CVS, all our batch files, everything was setup for CVS 
and didn't want to get into the learning curve again.  The only reason 
it was considered was to offer a web based VCS and if you starting 
fresh or can afford to convert from CVS, then its pretty good.   But 
that idea was nixed and put aside for now.

--
HLS
0
Hector
5/14/2010 7:47:16 AM
Hello,

Simon wrote:
> Sorry for the OT, I am not 100% sure where to ask.
> 
> I want to setup a subversion repo on a personal website.

What OS is that website running on?
I once setup an SVN repository on a linux/apache server
and that was rather straight forward based on the tutorials
available on the net.

Best regards,

Oliver
0
Oliver
5/14/2010 9:16:44 AM
>> Sorry for the OT, I am not 100% sure where to ask.
>>
>> I want to setup a subversion repo on a personal website.
>
> What OS is that website running on?

I would prefer linux/apache server, but as I don't have the site yet I 
can choose at a later stage.
I have servers here, (at work), that I can test with.

> I once setup an SVN repository on a linux/apache server
> and that was rather straight forward based on the tutorials
> available on the net.

Maybe my google skills are not what they used to be, but I cannot really 
find anything very straight forward, (admittedly the windows 
installation seems easy enough).

Most non Windows tutorials seem to off on a tangent very quickly.

Simon


0
Simon
5/14/2010 9:32:20 AM
>
> Check out VisualSVN.
>
> http://www.visualsvn.com/
>

Thanks I'll have a quick look at it.

>
> Pretty easy, if you understand SVN. Make sure you get the command line
> SVN tools as well.
>

We, (at work), have been using SVN for a long time now, so I am familiar 
with it, but the repo is located on a networked machine for now, not 
really a server situation as it would be needed over the internet.

Simon
0
Simon
5/14/2010 9:34:48 AM
On 5/14/2010 2:13 AM, Simon wrote:
> Hi,
>
> Sorry for the OT, I am not 100% sure where to ask.
>
> I want to setup a subversion repo on a personal website.
> Would anyone know the best forum/NG to ask such a question?
> (Or where I could find a tutorial for installing such a repo).
>
> Thanks
>
> Simon

Have you tried http://subversion.apache.org/ ?
0
BobF
5/14/2010 2:18:23 PM
On 5/14/2010 4:18 PM, BobF wrote:
> On 5/14/2010 2:13 AM, Simon wrote:
>> Hi,
>>
>> Sorry for the OT, I am not 100% sure where to ask.
>>
>> I want to setup a subversion repo on a personal website.
>> Would anyone know the best forum/NG to ask such a question?
>> (Or where I could find a tutorial for installing such a repo).
>>
>> Thanks
>>
>> Simon
>
> Have you tried http://subversion.apache.org/ ?

Sorry for the late reply I was away.

Thanks, I did see Apache, and I did install the files on the server.

But they don't seem to have documentation about creating a new repo 
itself and getting it to play alongside the website.

Following other docs online, I did manage to create a repo, but it is 
not accessible from the outside, I am guessing there is a server setting 
or a .htacess entry that is required.

I will have a better look at it, (and other suggestions), later in the 
week when I am not at work.

Thanks

Simon

0
Simon
5/18/2010 7:21:38 AM
On 5/18/2010 2:21 AM, Simon wrote:
> On 5/14/2010 4:18 PM, BobF wrote:
>> On 5/14/2010 2:13 AM, Simon wrote:
>>> Hi,
>>>
>>> Sorry for the OT, I am not 100% sure where to ask.
>>>
>>> I want to setup a subversion repo on a personal website.
>>> Would anyone know the best forum/NG to ask such a question?
>>> (Or where I could find a tutorial for installing such a repo).
>>>
>>> Thanks
>>>
>>> Simon
>>
>> Have you tried http://subversion.apache.org/ ?
>
> Sorry for the late reply I was away.
>
> Thanks, I did see Apache, and I did install the files on the server.
>
> But they don't seem to have documentation about creating a new repo
> itself and getting it to play alongside the website.
>
> Following other docs online, I did manage to create a repo, but it is
> not accessible from the outside, I am guessing there is a server setting
> or a .htacess entry that is required.
>
> I will have a better look at it, (and other suggestions), later in the
> week when I am not at work.
>
> Thanks
>
> Simon
>

Sorry I can't help more on the server side.  I only use TSVN will local 
repositories.


0
BobF
5/18/2010 1:37:02 PM
Hello,

Simon wrote:
> Thanks, I did see Apache, and I did install the files on the server.
> 
> But they don't seem to have documentation about creating a new repo 
> itself and getting it to play alongside the website.
> 
> Following other docs online, I did manage to create a repo, but it is 
> not accessible from the outside, I am guessing there is a server setting 
> or a .htacess entry that is required.

I no longer have the links to the docs I used to setup an apache, https
accessed svn repository. But I had to use dav_svn (some webdav thingie
for svn).

So you should be able to come up with some descriptions of you google
for "dav svn" or "dav_svn".

Just what I can remember:
1) Setup your repos wherever you like
2) apache needs read/write access to them
3) apache https uses its own user base setup with some .htpassword
    files and you can configure a mapping from that users to the svn
    users.
4) In one of the apache site configuration scripts you have to setup
    your dav_svn stuff. Thats mostly telling the location of the
    repository and which htpassword files to use.

That is not an explanation at all, but it should give some starting
points for googling.

Best regards,

Oliver
0
Oliver
5/18/2010 2:13:19 PM
Hello,

Oliver Regenfelder wrote:
> I no longer have the links to the docs I used to setup an apache, https
> accessed svn repository. But I had to use dav_svn (some webdav thingie
> for svn).

One source of information would be:

http://svnbook.red-bean.com/

Chapter 6 covers server configuration and apache dav svn as part
of it.

Best regards,

Oliver
0
Oliver
5/18/2010 2:22:20 PM
Reply:

Similar Artilces:

OT...check this out...OT
http://www.escapeyesterworld.com/ try all the controls -- John Inzer Thanks John...pretty nifty. -- Brian Kvalheim Microsoft Publisher MVP http://www.publishermvps.com This posting is provided "AS IS" with no warranties, and confers no rights. "John Inzer" <oobie@doobie.xyz> wrote in message news:uuhImG%23mFHA.3988@TK2MSFTNGP10.phx.gbl... > http://www.escapeyesterworld.com/ > try all the controls > > -- > > John Inzer > > ...

Exchange 2003 server can't see other Exchange server on network
Hello, I'm in the process of migrating an SBS 2003 server to a different, more powerful SBS 2003 server. This has been a much more harrowing task than I had anticipated, as SBS doesn't let you just simply set up a second PDC, replicate AD and Exchange and go on your way. I've had to set up an entirely new domain on the new server and use the Active Directory Migration tool and the Exchange Migration Tool to migrate AD users and Exchange mailboxes. However, I still need to migrate the public folders. Server1 can see Server2 in the exchange management tool, and I've use pfMigra...

After Office2003 install, Outlook changes POP3 server
After I upgraded all my computers at work to Office 2003, each system now (post logoff/login) have the Incoming mail server (POP3) and User name modified. the POP3 is changed to local host, and the username is modified with and inclusion (ex normal: John Doe ex now with modification: Joh Doe/myemail.domain.com). I am using Windows 2000 server, and the only changes I have made since I noticed this issue was after I installed Office 2003. Now, every morning, my employess have to modify these settings back to the original to make thier email work. Any suggestions what the problem is? Any he...

Paging through Exchange Server 2000
I am trying to set up an account that will be paged through Exchange Server 2000 once the email is sent to the pager but the signal is not going through. I do not get any returns through my inbox. Is there other options to set this up? Did the same thing here. We have a UPS and we want it to page or call someone. I had to allow relay to the ipaddress of the UPS. If you use a OS system on a UPS then you have to let that systems ip be able to relay. In one instance it would mail a local mailbox and we had to set up a rule to send a mail outside our organization when it came in to th...

The Server is sending too much data
Hi everyone, I'm having a little issue with my media player playing a mms stream from the windows media server. The stream plays for more than half but then it stops and I get the error 'The server is sending too much data' Any help would be appreciated On May 14, 5:15=A0pm, cwdjrxyz <spamtr...@cwdjr.info> wrote: > On May 14, 9:21=A0am, Chris N <chris.nie...@gmail.com> wrote: > > > Hi everyone, > > I'm having a little issue with my media player playing a mms stream > > from the windows media server. > > The stream plays f...

The Ed Crowley Server Move Method what if your Exchang server is a BDC
Im planning to youse the ed crowly server move methode .but our exchange 5.5 server is a BDC. How to do the move ? ...

Home Server
I've seen post here that Windows Home Server makes a good Backup solution. I have set one up at home and so far works great. Problem I'm having is access to the server remotly. Is RDP blocked or some firewall setting preventing access remotly ? I can RDP to the box on the lan just fine but even though I've opened Port 3389 on the Router I can't access it remotly. (strange because it works on the lan) I can RDP remotly to my XP Pro Notebook connected to the same router if I change the IP to my notebook. (My ISP does not block ports) I have never tr...

Microsoft exchange server #2
I reinstalled Microft Office due to hard drive problems. Now it is asking for "Microsoft Exchange server" and "Mailbox". What do I put in "Microsoft Exchange server" box? What do I put in "Mailbox" box? acanduds@hotmail.com Dick <anonymous@discussions.microsoft.com> wrote: > I reinstalled Microft Office due to hard drive problems. > Now it is asking for "Microsoft Exchange server" > and "Mailbox". > What do I put in "Microsoft Exchange server" box? > What do I put in "Mailbox" box? Were ...

VC and Cobra and OTS
Hello, Can i use VC to build a project using cobra and OTS to communicate with other UNIX system? Do you mean CORBA? WTH "So Sick" <Sug@sug.com.hk> wrote in message news:OJ6KUh%232DHA.1264@TK2MSFTNGP11.phx.gbl... > Hello, > > Can i use VC to build a project using cobra and OTS to communicate with > other UNIX system? > > > > yes ..... sorry. "WTH" <spamsucks@Ih8it.com> wrote in message news:u09iMT$2DHA.2460@TK2MSFTNGP10.phx.gbl... > Do you mean CORBA? > > WTH > > "So Sick" <Sug@sug.com.hk>...

New Exchange server under the same OU
Hi every one I did Add new exchange server as a backend server so now I have 2 exchange servers OLD and New Exchange what I'm facing the user which has been moved to new exchange server can send mail OK But they can recieve only from poeple in new exchange server they can not recieve from poeple in Old exchange server nor from Internet my connector is was configured to route email from old exchnage I just added the new exchange to same connector any idea what I'm missing Thanks On Tue, 30 Aug 2005 00:30:01 -0700, "mailman" <mailman@discussions.microsoft.com> wrote...

OT
OT - OFF - TOPIC Hola amig@s; El gobierno Colombiano en su continuo inter�s de ofrecer oportunidades acad�micas y profesionales a todos sus habitantes y a todos los interesados en capacitaci�n ha preparado una de las mejores plataformas de educaci�n virtual, con cursos virtuales "certificados" con cero costo. Los invito a visitar la WEB del Servicio nacional de Aprendizaje, nacionales o extranjeros pueden acceder a una de las plataformas educativas gratuitas mejor estructuradas y pagadas por todos los Colombianos. Hay cursos de inform�tica, office, outlook , cursos de Excel...

Client and Server Side Rules
I need to find out what rules are available for Outlook and Exchange and which ones are server side and which are client side rules. On Tue, 23 Nov 2004 10:36:15 -0500, "Rancehood" <Rancehood_No_Sp_am@hotmail.com> wrote: >I need to find out what rules are available for Outlook and Exchange and >which ones are server side and which are client side rules. > It's all down to what the rule wants to do, some need the client and some don't. If you look in the Outlook client you will see the ones annotated with "Client" if they are not capable of runnin...

CRM and Member Server
I am going to implement CRM and have been doing a lot of research and I have not yet found an article where is says CRM has to be on a domain controller or member server. Can I install CRM on a Member of my Windows 2000 Server environment? Thanks in Advance Len Len, Unless you are running SBS then there are actually issues if you install on the domain controller. Matt "Len" <lcampbell@pennsys.com> wrote in message news:063f01c3bdad$79316ce0$a001280a@phx.gbl... I am going to implement CRM and have been doing a lot of research and I have not yet found an article wher...

Autoreply from server....
Hi - am trying to help out a client with an autoreply need on Exchange 2k with OL2002....it needs to be a server side rule, and I've followed the steps in http://office.microsoft.com/assistance/preview.aspx?AssetID=HA010347871033&CTT=6&Origin=EC010553071033 (Have Microsoft Exchange Server Send Custom Reply Messages with Outlook 2002) and set up an .oft file - rule setup is fine. I set up the rule - it doesn't work. Nothing happens, even if I have OL open & look to see if I get an error message. If I try to run the rule manually against the existing inbox items, I get a &qu...

lotro gold in all eu server wowmmocom.com
http://www.wowmmocom.com The Lord of the Rings (EU)--Belegaer - 10 $: 10.49 --------------------------------------------------- The Lord of the Rings (EU)--Evernight - 10 $: 10.19 ------------------------------------------------------- The Lord of the Rings (EU)--Maiar - 10 $: 10.69 ---------------------------------------------------- The Lord of the Rings (EU)--Snowbourn - 10 $: 18.69 ----------------------------------------------------------- The Lord of the Rings (EU)--Eldar - 10 $: 10.25 ------------------------------------------------------ The Lord of the Rings (EU)-...

OT...Ping...Brian Kvalheim...OT
Hey...Brian... Check your e-mail. If you didn't receive anything from me...give me a current address. -- John Inzer Hmmmm you didn't send me anything John Inzer wrote: || Hey...Brian... || || Check your e-mail. || || If you didn't receive anything from || me...give me a current address. || || -- || || John Inzer Did not receive anything. I am at bkvalheim@hotmail.com -- Brian Kvalheim Microsoft Publisher MVP http://www.publishermvps.com This posting is provided "AS IS" with no warranties, and confers no rights. "��MS-Publisher��" wrote: >...

Using Publ;ic SSL Cert on CAS servers
Hello all, We've got 2x exchange 2007 front end servers configured to use CAS and HT roles setup in an NLB cluster. To secure PDA's and OWA we've purchased from Entrust 2x Public Certificates to install on both servers. We've installed one of the certs on one node to test but when connecting to the node to use OWA we have the same error regarding having a certificate error. Is there anything else required to make this work? Our SAN names on the certs have only FQDN names of the servers and NLB cluster, do we need a single label name on the cert for this to ...

ot question
except for being something i need to do in an mfc app i'm working on this doesn't really have anything to do with mfc.... but its as bad a place to start as any other group i watch. i need a kind of generic algorithm to take an array of 3d points that describe a surface, then given two coordinates of another point interpolate the third coordinate on the surface. picture it like you have a set of random latitude, longitude and elevation points, then want to find the elevation of any given latitude and longitude coordinate. (over a small area, don't worry about spherical earth and...

Exchange 2000 Instant Messaging Server not working properly
After I upgrade my windows enviroment from 2k to 2k3.The exchange enviroment is still in Exchange 2000 native mode. But my Instant Messaging Server start having problem. User can not login into the services intermitantly. Is there any solution or explaination for this? ...

War Between Access and SQL Server
....at least, that's how the twitter item worded it. Danny Lesandrini wrote a nice article: Top 10 Reasons Why Access Still Rocks for Developers http://tinyurl.com/yjs6kfw => http://www.databasejournal.com/features/msaccess/article.php/3862011/ article.htm ....which got this foolish response: Top 10 Reasons Why Access Still Doesn't Rock http://tinyurl.com/ye48zln => http://www.brentozar.com/archive/2010/02/top-10-reasons-why-access-st ill-doesnt-rock/ I've posted a bunch of responses taking issue with the whole article, which completely misses the poin...

Outlook 2000
How can I get back contact list in outlook after running exmerge for exchange 5.5? ...

EAS - SMTPProxy Registry Entry
Hi, I am having a problem with EAS where users in a certain domain cannot connect. It appears the issue is the users primary SMTP address is not listed in the 'default' recipient policy. So having digged around I have found a KB article 886346 describing the fix as adding the SMTPProxy registry entry. What the article doesn't mention is on which server, I assume it's the mailbox server but it could be the frontend server, I'm not sure. If somebody could confirm which server to make this change to it will be much appreciated. ...

Project Server/Exchange Server SMTP connectivity
Is there an easy way to test the smtp connectivity between Project Server and Exchange Server. Retreiving tasks with the Outlook add-in seems to work fine, but notifications, updates, etc don't seem to be happening. Also, Am I correct that mail messages are sent only once a day using the smtp set up in Project Server? Hi Peter, From the Project Server you should be able to telnet on port 25 to your Exchange server (google for telnet 25 and you'll get some good pages and you'll be able to check it out). Outlook connnecting is a red herring, it doesn't use SM...

is single exchange server a RPC-HTTP Back end server?
setting up RPC over HTTPS, server says RPC-HTTP not enabled. I select the RPC-HTTP tab and what is selected is "Not part of an Exchange managed RPC-HTTP front-end or back-end server." so I am supposed to select "RPC-HTTP back-end server"? I guess if you only have a single exchange server, it is considered a "back-end" server? we have other servers, but this is the only one running exchange 2003. gary okay, here is a little more info: the option "RPC-HTTP front-end server" is greyed out, cannot select it. if I select the RPC-HTTP back-end serv...

Your FROM ADDRESS has been rejected by server. SERVER
Hello We had recently got the following error for one of our user in our exchange 2000 server Bu after that & before that there was no problem .But this is crucial as this should not repeat again .. Where the problem will be . Can any one help. Your FROM ADDRESS has been rejected by server. SERVE ERROR: 554 Command not implemented. Bounced back mail attached Bye - Deepak .R Where did you see this message? This usually means you are submitting an outgoing message directly using SMTP and the FROM address on the message doesn't match the user that authenticated to send the mess...