CMonthCalCtrl #5

How do you disable this control? I tried using EnableWindow(FALSE) but that 
didn't work. 

Thanks, Neil
0
NeilB (111)
12/7/2007 5:18:00 PM
vc.mfc 33608 articles. 0 followers. Follow

4 Replies
572 Views

Similar Articles

[PageSpeed] 40

What do you mean by not work.  EnableWindow(FALSE) will disable the month 
arrow buttons and disables date selection.  Otherwise there are no visual 
indications that the control is disabled.

AliR.


"Neil B" <NeilB@discussions.microsoft.com> wrote in message 
news:7752DFC6-683F-4148-B55E-D0DD0DCBF17C@microsoft.com...
> How do you disable this control? I tried using EnableWindow(FALSE) but 
> that
> didn't work.
>
> Thanks, Neil 


0
AliR3470 (3235)
12/7/2007 5:44:32 PM
It disables it for me.  It doesn't look any different, but you can't move 
the date around or click elsewhere on the control and have it respond.  It 
just doesn't dim out.  It seems to be disabled though.

Tom

"Neil B" <NeilB@discussions.microsoft.com> wrote in message 
news:7752DFC6-683F-4148-B55E-D0DD0DCBF17C@microsoft.com...
> How do you disable this control? I tried using EnableWindow(FALSE) but 
> that
> didn't work.
>
> Thanks, Neil 

0
tom.nospam (3240)
12/7/2007 5:52:51 PM
You've answered the question. Although the control was inactive I was 
expecting the control to dim when it was disabled.

Thanks, Neil

"Neil B" wrote:

> How do you disable this control? I tried using EnableWindow(FALSE) but that 
> didn't work. 
> 
> Thanks, Neil
0
NeilB (111)
12/8/2007 1:31:00 PM
I'm guessing the author's of the control just didn't want to go to the 
trouble of changing all those control parts.  There are lots of calendar 
controls available (www.codejock.com, www.bcgsoft.com, etc.) that work a lot 
better.

Tom

"Neil B" <NeilB@discussions.microsoft.com> wrote in message 
news:C848E595-F993-4AE3-B480-BFD05EEA3284@microsoft.com...
> You've answered the question. Although the control was inactive I was
> expecting the control to dim when it was disabled.
>
> Thanks, Neil
>
> "Neil B" wrote:
>
>> How do you disable this control? I tried using EnableWindow(FALSE) but 
>> that
>> didn't work.
>>
>> Thanks, Neil 

0
tom.nospam (3240)
12/8/2007 10:07:31 PM
Reply:

Similar Artilces:

ESEUTIL 6.5 on a 5.5 database: disaster
Trying to repair a partially corrupt Exchange 5.5 database, I ran ESEUTIL from Exchange 2003 (6.5) on it. It analyzed and repaired the db, but now it can't be mounted anymore, due to version mismatch. Ok, I know I shouldn't have done this, but why is nowhere stated that using a newer ESEUTIL is going to make your database unusable?!? The utility itself didn't say a word about this issue. Any way to recover? Massimo P.S. I have a copy of the original database, so it's not a big problem. But I'm quite concerned by the behaviour of ESEUTIL. In news:%23yxd0hzWGHA...

Exchange Administrator 5.5
I have a problem with the Exchange 5.5 Administrator program. I have an organization with three sites. All servers in the org are in the same domain. I can connect to the servers in two sites but not to the server in the third site. I can ping the server, that works OK. I have checked, and double checked, the permissions and that's also OK. When I try to connect I get the following message: A connection could not be made to the Microsoft Exchange Computer The Microsoft Exchange Computer does not respond Microsoft Exchange Directory ID No: DS_E_COMMUNICATIONS_PROBLEM Any ideas????? O...

out of office assistant #5
I can't bring up the "out of office assistant" to post a message while on vacation. Why can't I bring this up. Thanks in advance for any help The Out of Office Assistant is only available if you are connected to an Exchange server. You can spoof the OOA using the Rules Wizard, but Outlook must be kept running in order for the rule to work. Look here for more information: http://www.slipstick.com/rules/autoreply.htm -- Jocelyn Fiorello MVP - Outlook *** Replies sent to my e-mail address will probably not be answered -- please reply only to the newsgroup to preserve ...

setting up mac in exchange 5.5
Is this possible? Thanks for any help in advance Ann, it's unclear exactly *what* you're asking about when you say "is this possible"? If a mail client happens to be on a Macintosh, say, an IMAP or POP3 client, then yes, they'll be able to use Exchange. If the mail client is MAPI-based, then yes, they'll be able to use Exchange. if the mail client is actually a web-browser using OWA (Outlook Web Access), then yes, they'll be able to use Exchange. Now, there are a variety of ifs/gotchas/maybe's depending on _WHAT_ you're wanting to do in detai...

Exchange 5.5 #42
One of my users is reporting that everytime he sends e-mails to a particular domain, it gets delivered multiple times, Eventhough on IMS it shows as host unreachable? The second issue is that one of my other users has received an e-mail from one of our vendors and the strange thing is that the allias Peter.Atkins is correct but the @... matches their domain and not our and yet the e-mail was delivered? Any thought and feedback would be much appreciated ...

Missing Sales Summary Information GP7.5
Hello, We recently ran into an issue where a customer's sales summary information for 2005 is missing in the Customer Yearly Summary Inquiry window . However, the customer has had sales this year. The sales summary can be seen in the Customer Summary screen. Has anyone run into this before? Is there any fix? Thanks, -- Jessie Have you tried running a reconcile? "Jessie" wrote: > Hello, > > We recently ran into an issue where a customer's sales summary information > for 2005 is missing in the Customer Yearly Summary Inquiry window . However, > t...

Exchange 5.5 problem #5
Hello all, I have following problem with directory information routing: 1.Quite big organization about 120 sites. 2. 5 one server sites in my scope of responsibility (lets say one central site and 4 remote sites) 3.One of the servers(lets say "central server" in my "central site") acts as bridhead to the rest of the organization: has 4 X400 connectors to the 4 my sites and one X400 connector to the bridhead server of the rest of the organization. The same with directory replication connectors. 4.There is a site some 4 hops away from the central site (lets say ABC site) THE ...

ADC
The active directory connector ran fine and replicated exchange attributes to the proper AD accounts. Now a new AD account for a single mailbox need to be the new primary account - i.e. get the exchange attributes. I tried deleting the ADC global name, but all this does is recreat the old account in AD. How can I get an old mailbox that was connected to a new deleted AD account to replicate correctly to a new account? ...

Exch 5..5 in W2Kdomain add permissions
I'm running Exch 5.5 in W2k mixed mode domain that was upgraded from NT4.0. When I add a new mailbox and try to add another user (on Permissions tab of the properties of that mailbox) this error shows: "MS Exch Administrator: The list of servers for this workgroup is not currently available. MS Windows NT ID no: 0xc00217e6" Anyone know if there's a way for multiple users to access the newly created mailbox in this environment? ...

CMonthCalCtrl #4
Calendar control is setting timer. Upon receiving timer message it sends MCN_SELCHANGE notification. What is a reason for that? -- RainMan Hi RainMan, Currently I am looking for somebody who could find the cause for the timer. We will reply here with more information as soon as possible. If you have any more concerns on it, please feel free to post here. Thanks for your understanding! Best regards, Gary Chang Microsoft Online Partner Support Get Secure! - www.microsoft.com/security This posting is provided "AS IS" with no warranties, and confers no rights. ----------------...

Post Migration from 5.5 to 2003
Does anyone know of any gremlins relating to the "move mailbox" method from Exchange 5.5 to Exchange 2003. I've got a group of users that use about 5 public folders for calendars and one of the members lost her permissions. I've gone in through Exchange System Manager and assign her Publishing Editor or even Owner permissions and she is added with the permissions, but when you close out and go back in, she is no longer in the permitted users list. There are only five other users on the list. Hi Bill, Check also: HOW TO: Migrate from Exchange Server 5.5 to Exchange...

Exchange 5.5 #5
When trying to change something under the Configuration, I get 3161 Security violation? Help ...

Exchange 5.5 and FW-1
FW-1 using Sendmail can't forward alert messages thru exchange, gives error "can't communicate with Port 25". Is this an exchange issue? any known fix? can anyone help at all? if it helps FW-1 is running FreeBSD with Sendmail 8.*..... Check your firewall >-----Original Message----- >FW-1 using Sendmail can't forward alert messages thru exchange, gives >error "can't communicate with Port 25". Is this an exchange issue? any >known fix? can anyone help at all? if it helps FW-1 is running FreeBSD >with Sendmail 8.*..... >. > Mak...

Out of office message #5
I have a computer here running Outlook 2002. The user will turn on his out of office notification but when someone sends him a message they will never get a response back saying that he is out of the office. So as a test I created his email account on another machine and the same thing happened. I have ruled out a computer issue. The only thing I can think of now is something has to be wrong with his user account. But I wanted to see if anyone else has come across something like this before I can his entire user account. For those that might be wondering we are running AD and Exchange 5...

Exch 5.5 logs
Hi, Can I use Exch 5.5 to see if a user received an email about 10 days ago? I'm using a tape backup every night so if the user received then deleted it the same day, I wouldn't see it on there. Will there be a record in the logs? (I'm not using circular logging.) Thanks in advance, Steve Hey, 5.5 console > Tools > Message Tracking. Of course this will have to be enabled. Oliver On Mon, 12 Feb 2007 17:07:10 -0000, "Steve Gr" <MSDNNospam235@nospam.nospam> wrote: >Hi, > >Can I use Exch 5.5 to see if a user received an email about 10 days...

CMonthCalCtrl
I have problem in using the CMonthCalCtrl. The CmnCtrl1 sample from MSDN can show the problem When I pick a day from the month dialog it gave the date with 12 days offset. When I use the MultiSelect option the date OK. The first time of Today picking it is also OK. Are Anybody there know how to solve this problem. (for get going on in my app I use multiselect for picking one day also.) Attached screens that demonstrate the problem. Thanks, David. Hi David, Thanks for you posting in the group! There is a workaround for the sample bug: use the SYSTEMTIME structure instead of CTIME as f...

Orphaned Exchange 5.5 Objects
Hi All, I'm having an Exchange 5.5 orphaned object problem. I've managed to re-create the problem in a test environment, which is a step in the right direction :) I have a single exchange organisation consisting of 2 sites, each site has only a single exchange server. These are connected with an x.400 connectors, with a directory connector running over the top of this. I have created a level public folder which an instance of which is replicated to the other site. This folder exists in the public information store on both sites. Each of the sites then creates sub folders under...

Error installing SP4 for 5.5
Everything goes smooth (other thna it take forever to copy a zillion html. and gif. files) until near the end when I am informed that the World Wide Web publishing service cannot be started, the install quits after that. In the Event Log I get ID 116: Source: W3SVC The service metabase path '/LM/W3SVC/' could not be opened. The data is the error code. 0000: 03 00 00 00 (bytes) Does this explain WHY it cannot restart W3SVC? Alan "A Kincer" <nospamakincer@kiusa.com> wrote: >Everything goes smooth (other thna it take forever to copy a zillion html. >and gi...

POP3 and Exchange 5.5
I cant seem to get POP3 to work. POP3 is installed on the server. I cant telnet to port 110 internally. It is not a network issue, more of a setup on the server issue. Pleas Help Jim "Jim Potter" <anonymous@discussions.microsoft.com> wrote: >I cant seem to get POP3 to work. >POP3 is installed on the server. >I cant telnet to port 110 internally. >It is not a network issue, more of a setup on the server >issue. >Pleas Help Please supply more information. If you can connect to port 110, what is it that doesn't work? USER? PASS? LIST? RETR? DELE? -- R...

5.5 MIGRATION
Here is my scenario: I have a native mode win 2000 domain trusting an NT 4.0 domain. My exchange 5.5 exists in the NT 4 domain. We are decommissioning that nt4 domain and need to migrate the exchange 5.5 into the native mode win 2k domain. My objective to have a new exchange server with a new org name and site name while retaining the mailboxes, folders, and public folders Since the win 2k domain is native mode, I have not found a viable solution to get the exchange inside the win 2k domain. I need help please!! Here is what I am trying to do. I have created a new exchange 5...

Logging #5
Hello- My outbound queue in exchange is constantly filled with junk domains, with messages from "postmaster@mydomain.com" .. This leads me to believe that there is obviously a compromised machine on the network.. I'd like to be able to see what IP address each of these messages are originating from, but the logging facilities in exchange don't seem to reveal the IP. Could someone please direct me in the right direction? Thanks, Rob rob wrote: > Hello- My outbound queue in exchange is constantly filled with junk > domains, with messages from "postmaster@mydom...

Exchange 5.5 and DST 2007
Hello all, First off I oppoligize as I have read most if not all the post on this in here bu am still unclear as to the full scope of the situation. I know the main problem falls within CDO and exchange. I have Exchange 5.5 running on Windows 2000 Server on one of my networks. We are planning on finally moving to 2007 this year but there is no way it will happen before the time change. We do not use OWA or Blackberry against this server. Only Outlook 2000 and Outlook 2003. I have been reading alot on this but am confused at the impact in my case. Does the CDO problem affect outlook? If I ins...

rebuild of exchange 5.5 on win2k server
ok, my nt4, exch 5.5, server crashed, setup new win2k server box, installed 5.5, can't do 2k or 2003 exchange yet, no active directory.. only issue is that when installed 5.5 on new box it DOESN'T have SMTP? so inside corporate email works, but not internet email service, which doesn't even show up on the list of services? anyone have any knowledge base article or MAYBE even have had this happen? please SEND HELP... AL In Exch Admin click File\New Other\Internet Mail Service and floow wizard. Al Smith wrote: > ok, my nt4, exch 5.5, server crashed, setup new win2k server...

CMonthCalCtrl #5
How do you disable this control? I tried using EnableWindow(FALSE) but that didn't work. Thanks, Neil What do you mean by not work. EnableWindow(FALSE) will disable the month arrow buttons and disables date selection. Otherwise there are no visual indications that the control is disabled. AliR. "Neil B" <NeilB@discussions.microsoft.com> wrote in message news:7752DFC6-683F-4148-B55E-D0DD0DCBF17C@microsoft.com... > How do you disable this control? I tried using EnableWindow(FALSE) but > that > didn't work. > > Thanks, Neil It disables it fo...

how to set up a 8.5 x 5.5 booklet
I want to be able to set up AND print an 8.5 x 5.5 booklet on Publisher 2007 I can set one up; but it only prints "one page" and I can't seem to change the print to "2 page" How many pages does your booklet have? In the print screen type the pages you want to print. If you look at print preview, click the multiple page icon, you will see what page is next to what page. These are the numbers you need to type. If you have a four page booklet, type 1,4 for the front & back covers. Type 3, 2 for the center pages. -- Mary Sauer http://msauer.mvps.org/ "WindS...