CListView Problem

Hello Friends,
   I am having problem in displaying different sizes of images and 
underneath them I having some text to display.  My Main issue is that 
whenever the row is not having sufficient height then the text is being 
displayed as three dots (...) and whenever I select the image then It is 
displaying me the full text and when deselected then again three dots.  I 
want to remove these three dots at the run time depending upon the height 
required by the text to be displayed.  Please help.

Thanks in advance.
0
Utf
11/26/2004 12:45:02 PM
vc.mfc 33608 articles. 0 followers. Follow

1 Replies
592 Views

Similar Articles

[PageSpeed] 57

Look into owner drawn flag. That will let you override the default drawing,
and can do all your drawing yourself, including the text I presume. I'm not
sure it will actually solve your problem as I don't know if the item
rectangle is increased and reduced depending on whether it is selected or
not and whether you can draw outside of it.


"Neelesh K J Jain." <Neelesh K J Jain.@discussions.microsoft.com> wrote in
message news:77601D9C-5025-4D7A-9824-DC8C8D74FAE9@microsoft.com...
> Hello Friends,
>    I am having problem in displaying different sizes of images and
> underneath them I having some text to display.  My Main issue is that
> whenever the row is not having sufficient height then the text is being
> displayed as three dots (...) and whenever I select the image then It is
> displaying me the full text and when deselected then again three dots.  I
> want to remove these three dots at the run time depending upon the height
> required by the text to be displayed.  Please help.
>
> Thanks in advance.


0
no6060 (315)
11/29/2004 7:13:57 AM
Reply:

Similar Artilces:

451 Temporary local problem
Hi all Lately i've been getting this message back when i try to send e-mail. It's annoying as hell to say the least as the mail server i use is fine and has been behaving itself. Any idea's ?? I running XP proff on a laptop with NAV 2002 running. Thanks andrew Well, if you're getting that error message, the mail server you use is *not* fine - that's your server saying that it can't handle mail right now. Contact your mail service provider and ask what's going on. -- Jeff Stephenson Outlook Development This posting is provided "AS IS" with no war...

template download problem
I've previewed templates on the Microsoft Office Webpage with no problem. When I click to edit it in Word a connection window opens, the status bar moves and it all appears as if the template is downloading. Then nothing happens. no error messages are given. Any thoughts on the solution? THanks ...

Is this a problem?
What's the sense of this: J P Morgan Chase reports earnings on April 18, 2007 (i.e. Wednesday). Microsoft MSN MoneyCentral Money provides a user with the opportunity to see extracts of "key developments" regarding "earnings announcements" in the Microsoft Money screen, lefthand navigator box . Yet when a person selects those "earnings announcements", he is provided with previous announcements from: July 17, 2003; September 17, 2002; and June 06, 2001 ! http://news.moneycentral.msn.com/ticker/sigdev.asp?iPage=earnings&cmdGo=Go&symbol=JPM Un...

URGENT
Hey everyone. I'm having trouble logging onto OWA (which all of our salespeople use). internally, I can log on using the server name / exchange (http://dc1/exchange) but when I goto the website URL (even internally) I get a permission denied error. I have a separate site with exchange and all of the other virtual directories under it. This just started today. Any help would be greatly appreciated. Oh, I'm using Exchange 2003. I'd bet it is going to the wrong website. Personally I setup the Default Website to be OWA - then add a second website if you want to host othe...

Network Problems
I have an XP Professional workstation running Office 2002. Our outlook is connected to an Exchange Server. If the computer sites idle for a few minutes, we receive the following error: "There was a problem reading one or more of your reminders. Network problems are preventing connection to the Microsoft Exchange Server". This is the only computer at our office that has this problem. It is also the only one with AOL installed. Any ideas? ...

CListView
Hello: Is there a way to derive a class from CListCtrl and make a CListView use that CListCtrl? Thank you, Dan No, but look at this DiLascia article which explains the possibility of using CCtrlView (in special circumstances) and gives a good alternative to CCtrlView if the special circumstances can't be met. MSDN November 2001, C++ Q&A "Understanding CControlView, Changing Scroll Bar Color in MFC Apps" http://msdn.microsoft.com/msdnmag/issues/01/11/c/default.aspx "Uranium-235" <Uranium235@discussions.microsoft.com> wrote in message news:CA1F9906-ADC...

problem with custom number format
Hello, Win xp and Excel 2003 I am trying to use a customer number format of 17 characters in length 00000000000000000 I can format the colum ok but whenever I enter the data eg 10000000000000001 it changes the last 1 to a zero If I enter for example 10000000000000011 it changes the 2 last 1's to a zero as well. Any ideas? Thanks, td. XL only retains 15 digits of precision. Assuming that you don't need to do math with your customer number (you must be planning to have a _lot_ of customers!), preformat the cell as Text, or enter it with a leading apostrophe: '...

Initial login problems via RPC over HTTP...
I have a problem that has been plaguing me since Microsoft implemented RPC over HTTP. It seems if I'm on the internal network, I can configure RPC over HTTP, logon and never have a problem. But if I'm out of the office and configure RPC over HTTP, my initial logon always fails. My domain, ID and password are never accepted and I cannot log into Outlook. Once I go into the office it works just fine and I never have logon problems again. Has anyone seen this issue and know why it happens? I've been looking for an answer for this for 3 years. Thanks in advance. When you first confi...

Quick Print Problem
On all my machines when I select the "Keep Current Document Displayed" option and do the CTR Q sequence the program goes un responsive. If I unselect that option everything seems to work. Is anyone else experiancing this? Running GP10 SP4 ------=_NextPart_0001_9A9CAD77 Content-Type: text/plain Content-Transfer-Encoding: 7bit It works for me. Same as when I originally developed the code as part of Named Printers. :-) Do you have any customisations active of the Sales Transaction Entry window? David Musgrave [MSFT] Escalation Engineer - Microsoft Dynamics GP Micro...

Problem With Comments
I am creating a large spreadsheet by hand with about 1000 rows by 30 columns. About half of the cells need comments, but after I use a few hundred comments they start to reassign to different cells. Example, I make a comment on cell A1, and then create a comment much later on cell C453, cell A1's comment box moves from being adjacent to cell A1 to being adjacent to cell C453 and has the comment I want for cell C453, but the comment points to cell A1! It appears that Excel X has some kind of limit on the number of comments on a spreadsheet. Is there any way to get around this? ...

CListView Problem
Hello Friends, I am having problem in displaying different sizes of images and underneath them I having some text to display. My Main issue is that whenever the row is not having sufficient height then the text is being displayed as three dots (...) and whenever I select the image then It is displaying me the full text and when deselected then again three dots. I want to remove these three dots at the run time depending upon the height required by the text to be displayed. Please help. Thanks in advance. Look into owner drawn flag. That will let you override the default drawing, ...

formula change problem
I have a working formula that looks like this: Code ------------------- .Offset(P, 5).Formula = "=IF(RC[-1]>100,IF(RC[1]=""Y"", if(rc[2]=""US"",""TRUE"")),""FALSE"")" ------------------- and I want to change it to: Code ------------------- .Offset(P, 5).Formula = "=IF(.offset(P, 4) > 100, " & _ "IF(.offset(P, 6) =""Y"", " & _ "IF(.offset(P, 7) =""US"",""TRUE"")),""FALSE&q...

problems downloading UpdateOutlook2003EmailFilter(KB914454)
Wanna share a little more detail? Any particular error? Nikki "Ian" <Ian@discussions.microsoft.com> wrote in message news:5CE49572-FB48-4FCE-8A2F-37A8DABB47E9@microsoft.com... > I couldn't get the update to install on any of my computers. I uninstalled Office, reinstalled it, updated it; no problem. Ended up doing that on all 3 machines. Seems like an MS update problem. While I am on the subject. This last 6 updates that came through last week would not download automatically. I had to get them via microsoft update. Maybe I didn't give them enough...

printer problems
I am trying to generate a report that takes a bitmap then 'tiles' it to fill a large area At the end of the process I may have a sheet of letter size paper with a few thousand small images plastered over it. It displays on screen OK and the print preview too but when I send it to an HP officejet printer it takes forever and then brings my whole machine to a grinding halt ( i think the machine is running out of memory - I have 500Mb Ram) On everything else the printer is perfect I tried printing to AdobeAcrobat and the resulting PDF was over 2.5GB! If I print to a TIF (TifXch...

OWA: open .oft file problem
Hi...we have exchange 2003 with OWA available to clients recently, and we realized that for those .oft files at public folder, the OWA could not open it. How to get around this? how could .oft files covert to OWA format, ex.html...? Thanks, fshguo. ...

GP 10: Check printing format problems
When printing a check from the Payables Transaction Entry window, the check does not print with the same alignment from different workstations, eventhough the same printer and check format is used on all workstations. By alignment I mean the pay to name, check date, and check numerical amount are in different positions. Would a different operating system be the cause of this, some have XP others have Vista or would there be another reason for this? Yes, absolutely - a different printer driver can cause this. However, usually it will be a slight difference in alignment, so if they are ...

MDI application and CListView
I need to create MDI application of Windows Explorer style. In generated classes I am seeing that right view in document window is CListView. I need on this place my own class derived from CListCtrl. Is possible to superseede CListView with my CMyListCtrl with some other adjustments so that it will be functional ? When I tried it , sources are buildable, but if application runs and creates new document, it stops in CMDIChildWnd::Create() , because HWND hWnd = (HWND)::SendMessage(pParentWnd->m_hWndMDIClient, WM_MDICREATE, 0, (LPARAM)&mcs); returns NULL, so document is not created. ...

Pivot Table Problem #3
I have just found out that Pivot Tables keep a history of old data and includes them with the new ones in the list for that particular data field, and because I only want the new data - I have to manually go in the drop down list for that data field and uncheck the old data so that it won't appear in the table. Does anyone know how to stop the old data from appearing in the drop down list so that it only shows the new data as options? This would help me a lot. Thanks in advance =) There's information here on clearing old items in a pivot table: http://www.contextures.com/xlP...

cached password problem
I have a user who whenever she changes her network password it breaks the authentication in outlook and IM. I am running xp machines and exchange 2000. She can change her password fine and authenticate to the domain and have full network access but both her IM and outlook break. Her outlook promptes for a password everytime it connects but works, her IM prompts for username password and domain everytime she connects. The problem can be fixed by deleting her local profile and relogging allowing a new profile to be built. But then recurs the next password change cycle. Is there a way to force s...

Gmail problem in Outlook 2010
I can sometimes send to my POP gmail account, but haven't been able to receive mail from that account at all. Gmail is the only acct. I use for email, and have had no problems in setting up gmail with its various settings in OL 2000. A little context: a few days ago I got a new computer, I installed Win 7, I then installed my old Office Pro 2000 suite including OL 2000. OL 2000 was generally able to send/receive from my gmail acct., but as is common, OL 2000 kept having problems so I decided to buy Office Pro 2010. I uninstalled Office 2000, and installed Office 2010. OL 2010 incorpor...

Outlook 2002 connector: problem connecting with Domino server because of NAMELookup2 problem
Hi, I'm trying to use Outlook 2002 Connector to connect with a Domino R5 server, but I can get no connection. From the log file I see that the connector uses a NAMELookup2 with the correct Domino server to get the name of the mail file, but the name its gets back is corrupted. There are spurious characters at the end of the mail file name. From the MSOCLog.txt file <<67c 25 16:37>> User name : : CN=Jean-Paul Smeets/O=Someorg <<4f8 25 16:37>> NAMELookup2 called with m_pServerName=someserver Flags=0 pNameSpaces=0x13646F4 NumNameSpaces=1 pNames=0x12E6CC NumNames=1 ...

Problem with product customisation
I really need to have suuplie name in the main list of products but for some reason its doesnt appear in the allowable options with all the other fields you can add. I really need this to be there. I know it can be added to the drop down for the product but it really doesn't suit our business to have to click on the product everytime we want to see who the supplier is. Surely theres a way to do this. Anyone? You can add Vendor Name to the Main List of Products, is this what you were trying to do? Regards, Chris "George" wrote: > I really need to have suuplie name...

sp3 install/uninstall problem
Hi all I need to revert back to ie6 from ie7 but have to uninstall sp3 first. Here is my problem Winver and add or remove programs both tell me that SP3 is installed, but when I attempt to uninstall SP3 the computer tells me it cannot be unnstalled because it is NOT INSTALLED. Appreciate any helpful response. TIA. OS Winxp Pro, Media Center Edition franktee KWV What problems are you having that you think uninstalled IE7 might resolve? What anti-virus application or security suite is installed and is your subscription current? What anti-spyware applications (other than Defe...

POP3 problem with Exchange 2000 #2
Hi folks I am really hoping someone can help me out here I am running a windows 2000 server with exchange 2000. The server is partitioned as follows; C:\ 5.13GB, D:\ Exchange 49.2, E:\ 49.7, 32.2GB unallocated. I had the AV originally on C:\ but moved it to E:\ this morning. There is also a plug-in for exchange installed as part of the AV suite. Users can send ok, the problem is in receiving email. I looked at ESM and in POP3 current connections it shows a list of users trying to send email If I reboot the server, everything is fine for a while and then the problem recurs. There doesnt s...

Email Problem
When we attempt to send a sales document via email, once Outlook opens and users select "To:" to select whom to send the email to, Outlook loses focus. You have to minimize Great Plains to get back to Outlook. This started only after we upgraded to ver 7.5. Any suggestions? Install Service Pack 5. "Mike W" wrote: > When we attempt to send a sales document via email, once > Outlook opens and users select "To:" to select whom to > send the email to, Outlook loses focus. You have to > minimize Great Plains to get back to Outlook. This >...