CDialog Event Notification Problem

Hello

  I'm having problems receiving WM_KEYDOWN events in a COleControlModul
derived app.  The app is an .ocx and is instantiated from a 3rd party program
The only window is a modeless CDialog derived class.  I need event notificatio
of user keystrokes on dynamically created CEdit controls

  OnCommand is firing from dynamically created CButtons. I am also receiving
messages for a dynamically created MSHFlexGrid though an EVENTSINK_MAP

  I am not receiving OnChar, OnKeyDown, etc. when the focus is set on one o
the CEdit controls

  Any help would be greatly appreciated. Thanks
David
0
6/10/2004 4:01:02 PM
vc.mfc 33608 articles. 0 followers. Follow

0 Replies
544 Views

Similar Articles

[PageSpeed] 32

Reply:

Similar Artilces:

Calender Problems
Everytime I try to put something on my calender, I get this message: The operation failed. An object could not be found I have a brand new computer, brand new Outlook 2003. It just started having this problem today. Please help. Are you using a .PST file? If so, try running the Inbox Repair Tool against it to see if it finds any errors. Search your drive for a file called scanpst.exe and run it. -- Jocelyn Fiorello MVP - Outlook *** Messages sent to my e-mail address will NOT be answered -- please reply only to the newsgroup to preserve the message thread. *** In news:35E3C5AF-27A...

Changing an MFC CDialog to a control inside another CDialog
Hi everyone, In my MFC application i have a CDialog window which is shown (modal) when clicking on a specific button. After some changes in my application, I decided that I need the controls on that secondary CDialog to be shown always inside the main window. Is there a way to change the secondary CDialog derived window to a control (like CStatic, etc) inside my main window, and not a child window? Maybe changing the devired class (CDialog to CStatic)? or changing some properties in the CDialog and calling its Create method with a specific parameters? Thanks. Menny wrote: > Hi everyone,...

Contact modem call problem
How can I set a default modem to use in contacts telephone calls in Outlook? Every time I start up my PC I find the same default modem (it is a bluetooth modem), so I have to change it to my favourite one. Is there a registry key I can modify to force to use my favourite modem every time Outlook starts? Thanks!! Mauro Won't Outlook's dialing options let you select the line to use? Does here. -- Russ Valentine [MVP-Outlook] "Mauro" <pippo@pippo.it> wrote in message news:%23KB4SI50EHA.3236@TK2MSFTNGP15.phx.gbl... > How can I set a default modem to use in con...

posts, search problems & response problems
Is it just me, or are others having a problem with searching these posts? For example, I searched for the exact two-word Subject I submitted my post under, and a completely different post came up (not the reply to my post either). Also, I requested (checked the box) to be notified when my post received a response, and always request reply notification, but never get it. What am I doing wrong? TammyJ wrote: > Is it just me, or are others having a problem with searching these posts? For > example, I searched for the exact two-word Subject I submitted my post under, &...

Problems with GAL so weird!!!
I have 6 exchange servers in my Exchange org and one of them has a problem with its GAL, all other servers do not experience this problem? Here goes.... When going to send a mail on the affected server, you click the To: button and select the names you want to include in the e-mail. everything works fine however if you select an address surname begining with the letter M it goes to the bottom of the GAL? any other name is ok.all other servers do not experience this problem? It just seems to be the addresses starting with the letter M? does this mean my dir.edb is corrupt? This is really co...

Startup Event?
Is there some type of event that fires in Great Plains at startup where I can put in some VBA code to check a shared drive for updated forms? Access has an Autoexec marco that can fire off custom procedures when the user logs in, is there anything like that in GP? ...

fill down problem #2
the spreadsheet on which i am currently working doesn't seem to fill down properly for any formulae, when i drag the handle down. instead it just copies the data from the original cell, rather than calculating new values for each cell below. any thoughts welcome. thanks cal $$$ -- Don Guillett SalesAid Software dguillett1@austin.rr.com "cal" <albert.kidd@dens.park> wrote in message news:cdu1g.20282$LH2.18250@newsfe2-win.ntli.net... > the spreadsheet on which i am currently working doesn't seem to fill down > properly for any formulae, when i drag the ha...

Creating a CDialog derived class for a Dialog??
I am trying to convert a project from Win32 to MFC. I created a new dialog resource, but when I try to do the right-click add class thing from the dialog editor, it doesn't do anything. I am using VS.NET 2003 Pro. In the dialog that pops up to create the new class, I change it to derive from CDialog, it already has the ID for my dialogbox resource selected, and I enter a new class name, and it generates the .h and .cpp names. I click Finish and NOTHING happens. I try it again from the main menu, but this time it pops an error box saying "Object Required". I am stumpe...

Lots of nice red 9562 & 9551 stop errors in event log
We are running Exchange 2003 (SP1) in mixed mode. We have deployed one Exchange 2003 server so far. The ADC has been successfully deployed and is replicating from the DS to AD. SRS endpoints have been changed. A native mode domain hosts the UD groups and some have already been converted to USG's. However, there are some worrying stop and warning errors in the App event log on the Exchange 2003 server. I believe these may be due to zombie ACL's trying to be synchronised to AD, but would really like an explanation. I have seen a KB article, but it didnt help very much. Here are the fu...

query problem after changing to SQL server
I use queries in Excel to create custom reports out of our accounting database. We recently changed to an SQL server and now I can't run any of these reports since the address of the database changed. Any suggestions?? I can't figure out a way to access the query to edit the address since I don't have each query saved outside of the spreadsheet. You need to change the Querytable objects' connection string and/or SQL text. See: http://www.dicks-clicks.com/excel/ExternalData5.htm#ChangeConn Jamie. -- ...

Event ID 3038
Recently I have received numerous EventID 3038 in my event viewer. I read Article 296879. I'm just curious is this as straight forward as the instruction. Before yanking IMC I would defrag database and run ISINTEG on it (be sure to have usable backup before you start). fanman36 wrote: > Recently I have received numerous EventID 3038 in my event > viewer. I read Article 296879. I'm just curious is this as > straight forward as the instruction. -- Help fight spam - designate sending servers for your domain. http://spf.pobox.com I've defraged the database, but I hav...

Using the lookup attribute twice problem
Hi, I created a relationship attribute (Many-to-1) in a custom entity, so it will be a lookup field in the form. Now, I noticed that I can only use this lookup attribute once in a form, but the requirement is to use the same lookup field in the same form twice, first is for the Contact text field (lookup) and second, is for the Assistant text field (lookup), which both fields uses the Contact entity. Any ideas? On May 9, 11:47 pm, "Benjamin Fallar III" <fal...@pldtdsl.net> wrote: > Hi, I created a relationship attribute (Many-to-1) in a custom entity, so it > will...

Public folder permission problem
I started working for a company that hosts a large public folder tree. This company has many users accessing it and several users with Publisher / Editor permissions. These permissions were not working correctly. To resolve the problem I changed the users permissions with an account that had owner permissions. This did not work. Although the permissions now appeared correct the users still had the same permissions as before. To resolve this issue I removed the root folder and recreated it. I then assigned the permissions that i wanted and moved all of the sub folders back in. The permissions ...

After Update Event 05-08-10
After Update Event Hi All, I am having a table like the below:- Table Name : DCData Field Name Type Document Presented Yes/No Date Date/Time I have created a form Using Wizard and get the fields from DCdata Table to my form. Form Name: DCData (F) I require a after update event macro for my [Document Presented] field (Yes/No) if the person check the [Document Presented] check box then the form should show the [Date] field otherwise if it is unchecked then the [Date] field should not be visible and cannot be accessed by the users. (Using Access 2003) Awa...

problem in folder option
dear sir/medem please help me,on the matter of windows troubleshooting.. sir my folder option is hide from my operating system ,pls tell me how can i repair it by any mothed or using third party tools thanks $ regards RIGHT CLICK ON YOUR FOLDER. A DIALOG BOX OR WINDOW WILL OPEN. GO DOWN TO PROPERTIES AND CLICK ON IT. ANOTHER DIALOG BOX WILL OPEN AND AT THIS TIME CHANGE THE SETTINGS IN THIS WINDOW. "sunil" <sunil100ni100@gmail.com> wrote in message news:uJHa3YCZKHA.2172@TK2MSFTNGP02.phx.gbl... > dear sir/med...

Simple problem from a simple man
Hi,I have a table which records several different scores for eachrecord / entry. Is there a way that the report based on the query , inturn based on the table, will show the scores below a certain level ina different coloured font?Cheers,TC...

problem with csv
When I export from a database I get the top line all in csv which appears to be in row A (which is the names of all the columns and the rest of the sheet is correct with all the data in relevant columns. How do I split that top row (which is Comma Separated) into coulumns automatically. I'm sure it is a simply process. thanks plato There is an easy way in Excel to split apart a cell without having to re-type its contents. Click on the cell. Pull-down Data > Text to Columns... > then check delimited and next check comma. The single cell should then split. Good Luck -- G...

Outlook2003 Security problem?
Hey all, We use Exchange2003 and Outlook2003 in cached mode. On some computers we force users to log on with a special account (lets say PROP01). But people want to reed there mail and preferable with outlook (Yes I tried to explain OWA). So they create profiles under the PROP01 (for each who uses the computer to do some testing) But, When someone else, by mistake uses a profile of someone else (Lets say User A, who is logged as PROD01, use the profile of user B) the see the mails and then are prompted for a user name and password. I thought outlook would NOT open prior to Authentication.....

CDialog
hi i want to create an open dialog box to select a folder When i used CFileDialog i could open only a file. CFileDialog cfdOpen(TRUE,NULL,NULL,OFN_HIDEREADONLY | OFN_OVERWRITEPROMPT,NULL,NULL); priya Hi priya To select a folder don't use CFileDialog use SHBrowseForFolder shell API. here is just an example BROWSEINFO bi; LPITEMIDLIST pidl; bi.hwndOwner = m_hWnd; bi.pidlRoot = NULL; bi.pszDisplayName = dir; bi.lpszTitle = dlgTitle; bi.ulFlags = BIF_RETURNONLYFSDIRS; bi.lpfn = NULL; bi.lParam = 0; pidl = SHBrowseForFolder(&a...

OMA problem
I'm running a 2003 SBS server with oma & owa enabled. I have set up 2 accounts which have exact same properties and user rights, and yes.... mailboxes. Both belong to Mobile User Group. First account can access the oma with cellular phone, however the other gets: "Item no longer exists. The item you are attempting to access may have been deleted or moved. Home " message everytime. Both theese accounts passes the authentication according the event viewer. Both of theese accounts CAN USE owa however.....with no problem at all. This is driving me nuts...... Anyone knows what...

Event ID:25
The reminder service did not start. Now I know from reading other posts that I am not the only one seeing this error, there is no information at MS regarding this yet it clearly is an issue for some. Does anyone have an idea about how to fix this??? ...

Outlook 2007 calendar only show 9 to 5 events
Someone told me that he could manage to set the calender view from 9am to 5pm? but he forgot how to set it again. Can i just set the display to show the events between 9 to 5? Thanks. You can open the menu tools -options, then select calender options, pop the dialog , select the proper time, that 's ok. "tony wong" <x34@netvigator.com> д���ʼ� news:e$khC0%23$HHA.4200@TK2MSFTNGP04.phx.gbl... > Someone told me that he could manage to set the calender view from 9am to > 5pm? but he forgot how to set it again. > > Can i just set the display to show the eve...

How to DoModal a CDialog initially invisible
Hi all, Under specific circunstances, I need to start my dialog-based app invisible. Unfortunately, as expected, when I call DoModal, the window is always visible, whatever I do (uncheck the visible box on dialog properties in the resources, ModifyStyle in OnInitDialog, ...) Is there a clean way to do that ? If not, what could be the cleanest dirty way ? ;) Thanks. -- Dansk Just don't call DoModal(). Place the code that you need to execute into a separate function in the same dialog class and call that function. class MyDialog : public CDialog { public: MyDialog() : CDia...

mass mailing problem
Hi everybody, I'm not sure whether it is the right newsgroup, but I will start here. Since a few days my mail server gets hijacked and someone is sending mass mail and spam through it I'm running SBS2003 and ISA server, so I thought it was save. I would need an advice how can I stop the mailing and prevent from happening again. Thanks for help Udo Get rid of the SBS. Go with individule resorces. >-----Original Message----- >Hi everybody, > >I'm not sure whether it is the right newsgroup, but I >will start here. Since a few days my mail server gets >hij...

Outlook 2003 connectivity problems
I have a Exchange Server 5.5 in my organization and I've recently installed Outlook 2003 in one new workstation. the problem is that after configuring an Exchange mailbox, outlook 2003 is always "Trying to reconnect" and "Retrieving data from server". With Outlook XP it works fine... Any ideas? Thanks in advanced. ...