401 hell!

We have a 3gb HQ db with 6 stores.  Whenever a 401 needs to send a large 
amount of data to HQ, the following happens:

HQ spikes all 8 CPUs at 100% for about 40 minutes then completes
Store HQ client times out, never registers that the 401 completed
Next time the store connects, same thing happens again until I delete the 
401 in question.

This is a major problem, because when we do a physical inventory, we need to 
do all sorts of gyrations to ensure that the data is uploaded and the 
offending 401 is then removed.

It's really not all that much data, what is it with the RMS db design that 
makes this SO INEFFICIENT??  I mean 50 thousand DB record updates is routine 
for many systems.

I have been working with MS support on this and the support tech claims it 
is "working" because it works when the store DB and HQ db reside on the same 
machine.  This is true but that's not a real world scenario.  They want to 
blame our net connection.  Plenty of apps run just fine on DSL lines (this 
one has 0.00% packet loss)

I seem to have hit a dead end with MS support, can anyone shed some light on 
this?  

0
DanielS (7)
3/7/2008 9:30:00 PM
pos 14173 articles. 0 followers. Follow

5 Replies
647 Views

Similar Articles

[PageSpeed] 19

"Daniel S." <DanielS@discussions.microsoft.com> wrote in message 
news:CBE84498-A316-4100-A513-0B75A5A867EE@microsoft.com...
> We have a 3gb HQ db with 6 stores.  Whenever a 401 needs to send a large
> amount of data to HQ, the following happens:
>
> HQ spikes all 8 CPUs at 100% for about 40 minutes then completes
> Store HQ client times out, never registers that the 401 completed
> Next time the store connects, same thing happens again until I delete the
> 401 in question.
>
> This is a major problem, because when we do a physical inventory, we need 
> to
> do all sorts of gyrations to ensure that the data is uploaded and the
> offending 401 is then removed.
>
> It's really not all that much data, what is it with the RMS db design that
> makes this SO INEFFICIENT??  I mean 50 thousand DB record updates is 
> routine
> for many systems.
>
> I have been working with MS support on this and the support tech claims it
> is "working" because it works when the store DB and HQ db reside on the 
> same
> machine.  This is true but that's not a real world scenario.  They want to
> blame our net connection.  Plenty of apps run just fine on DSL lines (this
> one has 0.00% packet loss)
>
> I seem to have hit a dead end with MS support, can anyone shed some light 
> on
> this?
>

Daniel,

I don't know a thing about the POS software, I've just been reading this 
group so I can help my BIL decide on software for his new store.  That said, 
I may be able to offer a suggestion.  You probably don't want to hear this 
but I would agree with MS about it being a network problem. Rather than me 
typing all the instructions, I'll provide some links for you to look at and 
then do some tests.

Your DSL line4 may "appear" to work perfectly with a normal traffic load but 
once you start to stress it, things begin to go to hell.  Start by testing 
the MTU (max transmission unit).  You can change the MTU and then stress 
test it yourself to see that an incorrect MTU setting (below max) still 
works and no packet loss until you load it down.

http://www.youtube.com/watch?v=m7Jh1BV1EOc&feature=related

http://help.expedient.com/broadband/mtu.shtml

The next site is a good tutorial on ATM

http://www.iec.org/online/tutorials/atm_test/

In short, ATM can be extremely difficult to test and you should contact your 
provider when you feel you've done everything you can internally to 
eliminate your hardware and wiring.


Bob S.



0
3/9/2008 1:05:46 AM
Scratch that first link.... and use this one.  Sorry. But just in case you 
do click on it, that is one helluva guitar player.


http://help.expedient.com/broadband/mtu_ping_test.shtml


Bob S.





0
3/9/2008 1:42:29 AM
Thanks for the link. I checked the MTU and found the max from the ping util 
to be 1464.  The router max was set to 1500. . . There was no MTU set in the 
registry for the LAN adapter.  Your post may well have been the solution.  

Prior to reading your post, I ended up using a PPTP VPN with the RAS 
funtionality in HQclient, and changing the HQ server address to it's lan 
address.  

So basically the HQclient now 'dials in' to the HQ VPN then initiates HQ 
comms through the VPN tunnel.

This seems to work.  

Now if I could just find out why it takes 40 minutes to update 50k items on 
an 8 core 2ghz Xeon box with 4gb RAM. . .


"BobS" wrote:

> Scratch that first link.... and use this one.  Sorry. But just in case you 
> do click on it, that is one helluva guitar player.
> 
> 
> http://help.expedient.com/broadband/mtu_ping_test.shtml
> 
> 
> Bob S.
> 
> 
> 
> 
> 
> 
0
DanielS (7)
3/9/2008 5:40:04 AM
You are right that transfering this amount of data over a DSL line is 
nothing. I have the same concerns about the processing. However, I was able 
to get around this be scheduling more frequent 401's. I went from hourly to 
every 10 minutes and all is well. Of course, it eats up log space quickly 
and I have to delete old completed worksheets every couple of weeks.


"Daniel S." <DanielS@discussions.microsoft.com> wrote in message 
news:CBE84498-A316-4100-A513-0B75A5A867EE@microsoft.com...
> We have a 3gb HQ db with 6 stores.  Whenever a 401 needs to send a large
> amount of data to HQ, the following happens:
>
> HQ spikes all 8 CPUs at 100% for about 40 minutes then completes
> Store HQ client times out, never registers that the 401 completed
> Next time the store connects, same thing happens again until I delete the
> 401 in question.
>
> This is a major problem, because when we do a physical inventory, we need 
> to
> do all sorts of gyrations to ensure that the data is uploaded and the
> offending 401 is then removed.
>
> It's really not all that much data, what is it with the RMS db design that
> makes this SO INEFFICIENT??  I mean 50 thousand DB record updates is 
> routine
> for many systems.
>
> I have been working with MS support on this and the support tech claims it
> is "working" because it works when the store DB and HQ db reside on the 
> same
> machine.  This is true but that's not a real world scenario.  They want to
> blame our net connection.  Plenty of apps run just fine on DSL lines (this
> one has 0.00% packet loss)
>
> I seem to have hit a dead end with MS support, can anyone shed some light 
> on
> this?
> 


0
3/9/2008 1:03:00 PM
On Mar 9, 9:03=A0am, "Jason" <microsoft.public....@natureisle.com>
wrote:
> You are right that transfering this amount of data over a DSL line is
> nothing. I have the same concerns about the processing. However, I was abl=
e
> to get around this be scheduling more frequent401's. I went from hourly to=

> every 10 minutes and all is well. Of course, it eats up log space quickly
> and I have to delete old completed worksheets every couple of weeks.
>
> "Daniel S." <Dani...@discussions.microsoft.com> wrote in message
>
> news:CBE84498-A316-4100-A513-0B75A5A867EE@microsoft.com...
>
>
>
> > We have a 3gb HQ db with 6 stores. =A0Whenever a401needs to send a large=

> > amount of data to HQ, the following happens:
>
> > HQ spikes all 8 CPUs at 100% for about 40 minutes then completes
> > Store HQ client times out, never registers that the401completed
> > Next time the store connects, same thing happens again until I delete th=
e
> >401in question.
>
> > This is a major problem, because when we do a physical inventory, we nee=
d
> > to
> > do all sorts of gyrations to ensure that the data is uploaded and the
> > offending401is then removed.
>
> > It's really not all that much data, what is it with the RMS db design th=
at
> > makes this SO INEFFICIENT?? =A0I mean 50 thousand DB record updates is
> > routine
> > for many systems.
>
> > I have been working with MS support on this and the support tech claims =
it
> > is "working" because it works when the store DB and HQ db reside on the
> > same
> > machine. =A0This is true but that's not a real world scenario. =A0They w=
ant to
> > blame our net connection. =A0Plenty of apps run just fine on DSL lines (=
this
> > one has 0.00% packet loss)
>
> > I seem to have hit a dead end with MS support, can anyone shed some ligh=
t
> > on
> > this?- Hide quoted text -
>
> - Show quoted text -

Are you Having all the stores connect at the same time? If so do one
at a time see if its a certian store that is causing the spike then
reindex that DB. have you checked anti virus exclusions and do you
have a anti virus software on a firewall box? If
0
3/21/2008 3:49:34 PM
Reply:

Similar Artilces:

Entering 401(k) vs. Roth 401(k) Contributions-reason to differenti
I have a 401(k) account that I've been tracking in Money for about 8 years. My employer recently offered the Roth 401(k), and I have recently switched all of me new contribuitions to the Roth 401(k). Is there any way, or maybe the more important question is any "reason", to indicate which contributions are to the regular 401(k) and which are to the Roth 401(k)? On my statements, all contribuitions appear to go into the same account, i.e., are not separated out by type. In microsoft.public.money, northwoods24 wrote: >I have a 401(k) account that I've been trackin...

401.3 error message
I'm having troubles with some users when they try to access CRM 3.0 by the web interface or Outlook client. The difference between the different users is the members group they belong to. The ones that belong to the administrator group doesn't have any problem but, the ones belonging to the domain users gruop can't get access. When they try to log in, CRM asks for user and pass 3 times and then, the "Not Authorized" access shows up. The error number is 401.3. Does anybody have any idea why??? Thanks a lot, Veronica veronica@commonsenseadvisory.com Hi Veronica, I...

OWA 2003 works for all sites but one (401.5 front end, 401.2 back
Sorry for the cross post but there is not much traffic on microsoft.public.exchange.setup We have a classic front end back end installation protected by ISA. We have just installed a new site and cannot connect to mailboxes there via OWA - MAPI works fine and there are no errors or warnings in the Event logs. The IIS log on the front end says 401.5 and the backend IIS log shows 401.2. If we connect directly to the backend after providing credentials we are able to see the mailbox. Other users with identical configurations from other sites are working fine. We were scratching our he...

stuck 401 worksheet
We have one store that is unable to complete a worksheet 401 upload. Client connects fine, earlier worksheets process, it starts processing the 401, but it never completes. Eventually, the connection times out. I've run the 'Check' and 'Reindex' processes on the store's database without effect. What else can I try? Try this: Delete the worksheet, create a new 401 at HQ and backdate the effective date to any time before the date of the 401 you deleted. See if this one completes. "Jim Early" <JimEarly@discussions.microsoft.com> wrote in messag...

Problem with 401 error
Hi everyone, sorry if this sounds like a noob question but I have been trying to start doing some CRM development, I am having a problem with a very simply request to get authoised. The code is straight from th SDK but it doesn´t get past the "bizUser.WhoAmI(); call and producing the following error: ErrorMessage: The request failed with HTTP status 401: Acceso denegado. I guess I´m missing a tick box or something in IIS or a reference. (NOTE: I know spitting the returned XML out to a label is ugly, but it doesnt get that far anyway) Many Many Thanks in advance. Code ...

401(k) portfolio versus Mutual Fund Reality ...
I have a situation where a mutual fund in my 401(k) has a stock id but the shares/cost are totally different. Example: DODGX is currently trading at $112. My 401(k) represents its value (NAV) at $13. Why the disparity? And is there a way to accurately track the investment's value in Money as well as activity; in particular, BUYS. When I first set up the investment account I created a cash account that goes with it so that Money will at least record income in the cash account when I get my paycheck. Then I manually (not to mention, painstakingly) calculate the percentage of shares and cost...

ERROR to send 401
I am having problems with envio of a worksheet the 401, when envio to the store and synchronize in the servant, remains patch in the message of LOADING DATA FROM STORE To HQ. AS PODRIA TO BE THE SOLUTION? ...

Any way to automatically distribute 401(k) contrib to each fund?
I set up Money 2004 to record my wife's paycheck, including the portion that is put into her 401(k). To keep track of the 401(k), I split that amount out into each mutual fund in the account. My question is this: do I have to manually split the 401 (k) money up every time or is there a way I can tell Money to put 15% in this fund, 20% in that fund, etc., and have it done automagically? Thanks! No. No. The best alternate that's easier than manual and not as cool as automagic is to create a scheduled transaction in your 401k cash account that is a Bill and has splits each of whi...

401 Worksheet
I tried runing a backdated 401 worksheet to recapture some lost data in HQ from the stores. I needed to go back several years. It was painfully slow and then it froze. Does anyone have suggestions on a better way to syncronize the store data to HQ. I read somewhere that before you run a 401 of such magnitude you should turn off the downloading of journals .. should speed things up for you. Also, suggest you run at the LAST connection of the night so that it has time to finish before another connection occurs. Scott "MAS" wrote: > I tried runing a backdated 401 worksh...

Regeneration Of 401 Worksheet
I have a HQ system running with a number of stores. When i generate a 401 worksheet and approve it, the stores connect at there scheduled times and process the worksheet succesfully, but no new 401 is regenerated. It is my understanding that as long as a schedule is present and the 401 is successfull, then the next one should be automatic. Can anyone give me any advice or help in where to look, to find out why this is happening? ...

401 regeneration
I have a HQ system that is not regenerating the 401 worksheet. It is my understanding that as long as a schedule exists and the worksheet is processed succesfully then a new one should be regenerated. Can anyone give me some advice or help in to why this might be happening? Russ Allan wrote: > I have a HQ system that is not regenerating the 401 worksheet. It is my > understanding that as long as a schedule exists and the worksheet is > processed succesfully then a new one should be regenerated. Can anyone give > me some advice or help in to why this might be happening? T...

Reports are not working, error 401 Unauthorized
We installed MSCRM 4.0 in one box. Reporting services are installed in another box. When we try to access reports with an MSCRM user using reporting services url (http://<reportservername>/reportserver) all the reports are working fine. But when we try to open the reports from MSCRM window, I am getting 401 unauthorized error. Find the below error details loged in event log Web service request SetParameters to Report Server http://<reportservername>/Reportserver failed. Error: The request failed with HTTP status 401: Unauthorized. Please post your suggestions to close th...

worksheet 401 error
Hi We are getting the following error when processing a worksheet 401 at one of our stores (the same worksheet processed fine at the other 18 stores) <<ExecuteCommand>> Error -2147467259: Subquery returned more than 1 value. This is not permitted when the subquery follows =, !=, <, <= , >, >= or when the subquery is used as an expression. UPDATE PurchaseOrderEntry SET Price Any suggestions on where to start looking/ See if there are any custom triggers on any of the tables, i had this problem with a custom trigger on th item table. -- Stephen Zwar...

Outlook, Brinkster and the Email from Hell
Once again I find myself at the threshold of one of life's greatest mysteries - namely a freezing in Outlook 2003 when downloading files to the inbox. This mystery has befallen me before, on various occassions. And, although I think I may have found what is causing it, I cannot seem to find out why. Microsoft admits no liability concerning this malady. Why should they? After all, they've already sold you their product and its not like their email is being impacted by your problem. Brinkster (the email host) admits no liability and (according to Ronald at Brinkster's tech...

HQ 401 worksheet
Hello, Here is my situation. I had 2 stores set up through a HQ installation. We lost the HQ server in a flood. We installed a new HQ server, sent a sync worksheet and a backdated 401 worksheet through to the first location. All the information back until the very first transaction uploaded to HQ. Now I did the same for the second location but it failed to upload. Now the second location's DB is considerably larger than the first.(1.1gb). I have been trouble shooting this problem all day. I can backdate a 401 a couple hours at a time and have it process no problem. Howeve...

CRM 1.2 Reporting Tools Hell
Hi We have installed Crystal Reports 9.2.2 on CRM 1.2. We worked fine for a couple of reports but then we received a memory instruction error. We checked many similar problems posted on Google and opther sites and it seems there is no solution As CRM 3.0 will use SQL Reporting Tools we decided to start using this tool with CRM 1.2. We Installed SQL Reporting Services as an alternative, but when the IIS web directory is activated CRM is giving an error. When we stop the SQL Web site CRM works fine This is frustrating ... Please advise -- Microsoft Navision Developer / Consultant Di...

401(k) deductions
Realizing I need to be more responsible financially led me to buy Money 05 Deluxe and get all my banking records in order. That's done, but now I want to add my 401(k) information. I have been contributing (through payroll deductions) to the 401(k) for about 3 years now; I should also mention I have most of my paper statements since the plan began. I did enter payroll deduction info for this year -- hopefully that will make tax time more bearable -- and part of that was tracking each paycheck dedcution going to my 401(k).That having been said, is there any benefit to being anal about th...

Tracking 401(k) contributions
I have my paycheck itemized so my 401(k) contirbutions are transfered to the contributions portion of that account. However, is various investments are purchased from the account (out of contributions) I can not track my year-to-date contributions. Since I can invest $15,500 annually, I need to adjust the amount of 401(k) contribuions so I do not fall short of this number. I am currently withhold a large amount and will reduce it as the year goes on. I NEED to know how much I have contributed year-to-date in order to track and adjust my % withheld of each paycheck to maximize my em...

401 hell!
We have a 3gb HQ db with 6 stores. Whenever a 401 needs to send a large amount of data to HQ, the following happens: HQ spikes all 8 CPUs at 100% for about 40 minutes then completes Store HQ client times out, never registers that the 401 completed Next time the store connects, same thing happens again until I delete the 401 in question. This is a major problem, because when we do a physical inventory, we need to do all sorts of gyrations to ensure that the data is uploaded and the offending 401 is then removed. It's really not all that much data, what is it with the RMS db design t...

Access System Settings and Reports throw 401 Unauthorized error
I got this 401 Unauthorized error when trying to access the System Settings within CRM. I got similar error 401 Unauthorized when trying to access the Reports from CRM. I was told this has to do with ReportServer. I was told to set up the expired page from 3 days to immediately, then reboot both server/client, but still does not help. I was then told to look into the file /ReportServer/reportservice.asmx to change some attributes, but my file is quite empty, it just has this header only: <%@ webService Language="c#" codebehind="ReportService.asmx.cs" class="...

HTTP Error-401.3
Hi, I've ms crm installed on windows server-2003. it was up and running. but after installing Visual studio(.NET) and MS-frontpage, when user tries to login using his credentials, he is not able to login. After three unsuccessful attempts it gives a foll. error. You do not have permission to view this directory or page due to the access control list (ACL) that is configured for this resource on the Web server HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource. Internet Information Services (IIS) Though administrator is able to login in t...

401(k)
I am completely confused on how to set up and track my 401(k) account using the quarterly updates I get in the mail and how to tie that in with the money that is taken from my paycheck. Also included in my quarterly statements is my profit sharing and employer match. Where can I find a 'dummies' version of how to do this. I tried the help section but still that is not helping me to understand how to do this correctly. Help is greatly appreciated. I want to start the new year off right this time. Thanks, Barb See the thread "401k Update from Paycheck" from the 27th. A...

CHttpFile::QueryInfoStatusCode() How to get SubCode for 401??
Hi, QueryInfoStatusCode() returns code 401 without the subcode identifier. How can I get the subcode (e.g. 401.1 - 401.7) for HTTP 401 errors??? Thx for your help! Regards, Harald ...

Style 401: Request Data Upload
after upgrading RMS 1.3 to RMS Dynamics 2.0 ... I'm facing a seriouse issue in processing work sheets ... all my sheet are processing properly but once it comse into Sheet 401: Request Data Upload, it being stuck after a while and gives me this error: "the connection is aborted du to timeout" I have tried many things to make the timeout longer but without any benefits please anybody could help me in resolving this? dose rms 2.0 sp2 would help or still the same? althoough i'm using a very fast connection .... There were some discussions a while back about this problem. ...

Distribute Campaign Activity: 401: Unauthorized #2
Hi all, We've got an evaluation CRM site put together (CRM 3.0 Server) on Windows 2003 Server/AD/SQL 2000. We've got 10 or so clients testing heavily to see if it whats we want from a CRM solution for our organisation. Everything generally is running ok, despite our client PC's currently not members of the domain (we are in a process of Novell>AD migration) - and thus we've had to do various fiddles to get clients to talk to the CRM server - such as caching of usernames/passwords on the client... We're currently experiencing this on the Distribute Campaign Activity/ ...