RPC over HTTP problem

I am running an exchange 2003 server in a mixed mode environment (both 
Exchange and domain environments) and one of the DCs is a windows 2003 DC. I 
follow the instructions from Microsoft web site to set it up and could not 
make it to work as it connects only to TCP/IP instead of HTTPS. The only 
things I could think of probably because I am running in a mixed mode windows 
2000 ? or is it because I havenot converted my Exchange 2003 to native mode?

Regards
Steven
0
ssor1 (11)
11/10/2004 12:43:03 AM
outlook 87536 articles. 10 followers. Follow

4 Replies
508 Views

Similar Articles

[PageSpeed] 32

Are all of your DC/GCs Windows 2003?  (This is a must.)

Are you using a certificate from an internal CA or 3rd party to secure the 
web/rpc proxy server?  If internal, does the client machine have a copy of 
the CA's certificate installed?  (Outlook 2003 will need verify the 
authenticity of the web certificate all the way back to the signing CA.)

Last but not least, the client workstation must be Windows XP (SP1) + patch 
Q331320, Windows XP (SP2), or Windows 2003.

/neo

ps - being in mixed mode for domain/exchange is fine.

"ssor" <ssor@discussions.microsoft.com> wrote in message 
news:1AE4FBFD-8B76-4789-9791-29134FDB6BD6@microsoft.com...
>I am running an exchange 2003 server in a mixed mode environment (both
> Exchange and domain environments) and one of the DCs is a windows 2003 DC. 
> I
> follow the instructions from Microsoft web site to set it up and could not
> make it to work as it connects only to TCP/IP instead of HTTPS. The only
> things I could think of probably because I am running in a mixed mode 
> windows
> 2000 ? or is it because I havenot converted my Exchange 2003 to native 
> mode?
>
> Regards
> Steven 


0
neo7948 (622)
11/10/2004 11:00:43 AM
I have 2 DCs, one of them is a windows 2000 DC which I had taken off from 
becoming a GC and another one is a windows 2003 DC and DC. Is if a problem, 
do I have to upgrade my windows 2000 DC to a windows 2003 DC?.
My client is already an Windows XP (SP1) + patch Q331320.

Thanks, Sopheat.

"neo [mvp outlook]" wrote:

> Are all of your DC/GCs Windows 2003?  (This is a must.)
> 
> Are you using a certificate from an internal CA or 3rd party to secure the 
> web/rpc proxy server?  If internal, does the client machine have a copy of 
> the CA's certificate installed?  (Outlook 2003 will need verify the 
> authenticity of the web certificate all the way back to the signing CA.)
> 
> Last but not least, the client workstation must be Windows XP (SP1) + patch 
> Q331320, Windows XP (SP2), or Windows 2003.
> 
> /neo
> 
> ps - being in mixed mode for domain/exchange is fine.
> 
> "ssor" <ssor@discussions.microsoft.com> wrote in message 
> news:1AE4FBFD-8B76-4789-9791-29134FDB6BD6@microsoft.com...
> >I am running an exchange 2003 server in a mixed mode environment (both
> > Exchange and domain environments) and one of the DCs is a windows 2003 DC. 
> > I
> > follow the instructions from Microsoft web site to set it up and could not
> > make it to work as it connects only to TCP/IP instead of HTTPS. The only
> > things I could think of probably because I am running in a mixed mode 
> > windows
> > 2000 ? or is it because I havenot converted my Exchange 2003 to native 
> > mode?
> >
> > Regards
> > Steven 
> 
> 
> 
0
ssor1 (11)
11/10/2004 9:29:02 PM
As far as I know, all DC/GCs must be Windows 2003 server and properly 
configured to accept rpc proxy connection to NTDS.  You might be able to get 
around this by going into ESM and specifying exactly which DC/GCs Exchange 
will refer clients to rather than letting Exchange auto-detect environment. 
Just remember that if you take away the auto detection ability, any changes 
to the environment will require someone to visit ESM and make changes.

Outside of that, you still didn't mention if you are using an Internal or 
Public CA to secure the IIS web server hosting the RPC Proxy virtual folder. 
While the connectivity might be called RPC over HTTP, it *must* make the 
connection over HTTPS and be able to verify the web certificate back to the 
signing CA.

"ssor" <ssor@discussions.microsoft.com> wrote in message 
news:4A81BF61-C443-4045-AFA7-747310849CB9@microsoft.com...
>I have 2 DCs, one of them is a windows 2000 DC which I had taken off from
> becoming a GC and another one is a windows 2003 DC and DC. Is if a 
> problem,
> do I have to upgrade my windows 2000 DC to a windows 2003 DC?.
> My client is already an Windows XP (SP1) + patch Q331320.
>
> Thanks, Sopheat.
>
> "neo [mvp outlook]" wrote:
>
>> Are all of your DC/GCs Windows 2003?  (This is a must.)
>>
>> Are you using a certificate from an internal CA or 3rd party to secure 
>> the
>> web/rpc proxy server?  If internal, does the client machine have a copy 
>> of
>> the CA's certificate installed?  (Outlook 2003 will need verify the
>> authenticity of the web certificate all the way back to the signing CA.)
>>
>> Last but not least, the client workstation must be Windows XP (SP1) + 
>> patch
>> Q331320, Windows XP (SP2), or Windows 2003.
>>
>> /neo
>>
>> ps - being in mixed mode for domain/exchange is fine.
>>
>> "ssor" <ssor@discussions.microsoft.com> wrote in message
>> news:1AE4FBFD-8B76-4789-9791-29134FDB6BD6@microsoft.com...
>> >I am running an exchange 2003 server in a mixed mode environment (both
>> > Exchange and domain environments) and one of the DCs is a windows 2003 
>> > DC.
>> > I
>> > follow the instructions from Microsoft web site to set it up and could 
>> > not
>> > make it to work as it connects only to TCP/IP instead of HTTPS. The 
>> > only
>> > things I could think of probably because I am running in a mixed mode
>> > windows
>> > 2000 ? or is it because I havenot converted my Exchange 2003 to native
>> > mode?
>> >
>> > Regards
>> > Steven
>>
>>
>> 


0
neo7948 (622)
11/12/2004 1:11:01 PM
Hi Neil,

It is now working internally and I am using the internal certificate which I 
installed on my Exchange server. It does not work from the Internet though. I 
have installed the certificate on the my Exchange 2003 server and exported 
and then imported to my ISA 2000 server and then I trusted it then 
web-published it. When connect externally it just could not make a connection.

Thanks

"ssor" wrote:

> I am running an exchange 2003 server in a mixed mode environment (both 
> Exchange and domain environments) and one of the DCs is a windows 2003 DC. I 
> follow the instructions from Microsoft web site to set it up and could not 
> make it to work as it connects only to TCP/IP instead of HTTPS. The only 
> things I could think of probably because I am running in a mixed mode windows 
> 2000 ? or is it because I havenot converted my Exchange 2003 to native mode?
> 
> Regards
> Steven
0
ssor1 (11)
11/24/2004 4:25:01 AM
Reply:

Similar Artilces:

RPC over HTTP problem
I am running an exchange 2003 server in a mixed mode environment (both Exchange and domain environments) and one of the DCs is a windows 2003 DC. I follow the instructions from Microsoft web site to set it up and could not make it to work as it connects only to TCP/IP instead of HTTPS. The only things I could think of probably because I am running in a mixed mode windows 2000 ? or is it because I havenot converted my Exchange 2003 to native mode? Regards Steven Are all of your DC/GCs Windows 2003? (This is a must.) Are you using a certificate from an internal CA or 3rd party to secure...

problem printing booklet
I'm not very familiar with publisher, so please be patient. I have a friend who created a booklet in publisher in landscape format. She typed the text on both sides of the page and when she prints it the text changes to portrait format with a smaller font. Can anyone tell me what she should do? Please email me directly with 'Publisher' as the email header. Thank you. In page setup, be sure your friend is choosing booklet (In older versions it maybe called "special fold"). It will automatically set to landscape (in older versions you will have to tick the landscap...

URGENT!!! Problem with row data being truncated in a copy worksheet sub
I have a sub that basically allows the user to e-mail a single sheet t a client. It does alot of formatting and makes a temporary workboo emails it then kills the file and returns them back to their mai workbook when they are done. :( The problem is this part here. THIS I HAVE TO FIX. It is truncatin rows that have more than 255 characters. If however i copy these row highlight on a sheet the same range of rows and paste all of the dat shows up. How can I adjust this one section so that all of the data i the rows shows up not just 255 characters. Range of rows on ActiveSheet is 1:298 Thanks...

Outlook 2002--HTTP Server Type greyed out
I would like to configure Outlook 2002 to work with my Hotmail account. I am running Win Xp Pro SP1. Using this for reference: http://support.microsoft.com/?kbid=287424 Upon selecting Tools>>>E-mail Accounts>>>Add a new E-mail Account>>>Server Type I find that the HTTP option is greyed out and unselectable. Any ideas? Thank You Yes it is a corporate network. I'll look into the admin-set policies on Monday. Thank you, Diane. >-----Original Message----- >are you using this on a corporate network? You administrator may have >disabled the ability...

Outlook 2007 via RPC
Hi, I have a XP workstation with Office 2007 working fine. If the computer is not a member of any domain, i can connect Outlook to an external RPC, this works fine, the install goes through fine too. If i then make that computer a member of a local Domain(not a member of the Domain that holds the RPC) and then log into that local domain with full supervisor rights I have connection problems.... "Cannot Open your Default e-mail Folders, You must connect to microsoft exchange with the current user profile before you can synchronize your folders with your offline folder file&q...

Problem DoCmd.GoToRecord with tabbed pages
I have a number of similar forms on each of which I've added a SpellCheck control. These check all records and then return to 'current' record. The current record number is stored using an unbound control txtRecordCheck The code works fine on non-tabbed forms: -------------------------------------------- Private Sub btnSpellCheck_Click() On Error GoTo Err_btnSpellCheck_Click 'Store current record number txtRecordCheck = Me.Recordcounter 'Run Spellcheck DoCmd.GoToRecord , , acFirst SendKeys "{F7}", 1 'Stop screen updating until view...

Problem with COM add-in
I have one com addin which works with outlook 2000/2002/2003. One can see its icon in standard tool bar. My problem is, on mouse over, the icon get distorted in outlook 2002. This is not the case with outlook 2000 and 2003. Waiting..... CC So nobody replied..... But fortunately I got the solution and its bit strange. Here it goes. Outlook 2002 do not support the toolbar bitmaps with 256 colors or higher(24 bit). If the bitmap used is of 16 color bitmap everything goes fine. I don't know if that's the sole solution and that's why I am putting my findings again here so tha...

RPC over HTTP setup help. RPC DIag returns no results.
I have been trying for several weeks to get RPC over HTTP workign in our environment. I refuse to put an ISA in place and am currently behing a Pix 520 ( which is not the issue, all logs show no denied traffic) I also see no error logs in either of my Exchange servers. Please any help is appreciated. From my Front end Server I see the followign when running RPCDIAG ** Microsoft Windows [Version 5.2.3790] (C) Copyright 1985-2003 Microsoft Corp. C:\Program Files\Windows Resource Kits\Tools>rpcdump /p ncacn_http Querying Endpoint Mapper Database... RpcMgmtEpEltInqNext:(Access is denied....

Strange problem with "On-Screen Keyboard" and CreateProcess
Hallo In my application (MFC MDI) I want to display an "On-Screen Keyboard". As WinXP has one on board (osk.exe), I've decided to use this one. This is the way I do it: PROCESS_INFORMATION pI; STARTUPINFO sI; memset(&sI, 0, sizeof(sI)); sI.cb = sizeof STARTUPINFO; if(!CreateProcess(NULL, m_oskPath, NULL, NULL, FALSE, 0, NULL, NULL, &sI, &pI)) { //Display Error SysErrMsgBox(GetLastError()); } else { //Do something with the keyboard ... //Either use the hard way //::TerminateProcess(pI.hProcess, 0); //OR maybe a better solution //BTW. WM_CLOSE does not ...

Problem breaking a link
I copied a worksheet from one spreadsheet to another. All the formulas had to be changed to refer to the new spreadsheet - no problem In Edit Links it still showed that there were links to the old (original) spreadsheet - on choosing the Break Link command, I answer Yes to the Are you sure? question, but the links are not broken - it still shows as being linked to the old spreadsheet Any suggestions Bill Manville's FindLink addin may help you find the hard to find links: http://www.oaltd.co.uk/MVP/Default.htm TJB wrote: > > I copied a worksheet from one spreadsheet to anoth...

http://companyweb/_layouts/3082/ows.js
We have SBS 2003 and windows 7 on clients. All works fine except a computer that since 2 month ago after a Microsoft update, when we go to companyweb and wants to edit fax list entrance, when we pick to edit appears this error (we are spanish): Mensaje: Se esperaba un objeto Línea: 12128 Carácter: 5 Código: 0 URI: http://companyweb/_layouts/3082/ows.js I try to translate: Missage: an object was expect line: 12128 Character: 5 Code: 0 URI: http://companyweb/_layouts/3082/ows.js Only with this computer and only when we try to edit our fax inbox, I put th...

Problem with SendMessage
Hi, I'm working on a application that sends messages to other applications( Win 2K+SP3,VC 6.0+SP5). So to set the text in an edit control, I use the following code ::SendMessage(hWnd,WM_SETTEXT,0,(long)(LPCTSTR)m_csVariableName); In some systems this works fine....but in some cases it doesn't. On the machines where it doesnt work, when I give a message box, the message is properly sent. ::SendMessage(hWnd,WM_SETTEXT,0,(long)(LPCTSTR)m_csVariableName); AfxMessageBox(m_csVariableName); Is there any way that I can wait for a couple of seconds just like AfxMessageBox() ( without th...

Problem setting up makefile
I am trying to setup multiple makefiles using common environment variables that point to path information. I am calling nmake using recursion through sub-projects. The problem is I cannot get nmake to maintain variables across projects. Simple example: In makefile1: ALL : ENV proj2 proj2: nmake .\proj2\makefile nmake .\proj3\makefile ENV: set AS=asm.exe The result is project 2 builds ok using asm.exe but when it is done AS is set to equal 'ml' and when I try to build project 3 it fails. After struggling with this for a while I have decided to create a batch file that sets u...

Exchange 2003 over HTTP RDP Issue
Hello everyone! A problem with Exchange 2003 over HTTP/RDP SERVER SIDE: I have a single Windows 2003 Server running IIS with Active Directory installed. The Server also has Exchange 2003 Installed and it is working perfectly. There are NO other Servers in the domain, this is a stand alone Server. I have purchased a Certificate and installed it on the Server from Verisign. The FQDN on the internet for this Server is www.domain.com, and the certificate is assigned to www.domain.com The Server is called computer.domain.com, and the windows firewall is turned on. The only ports that are ...

Word Drawing Problem
Version: 2008 Operating System: Mac OS X 10.6 (Snow Leopard) Processor: Intel A large light blue rectangle appears when I am making a drawing in Word that messes up object placement. How do I turn it off? Are you referring to a rectangle which has the circular "handles" at each of the 4 corners & squarish ones at the midpoint of each side? If so, that is the bounding box in which the drawing object is contained. Graphics are foreign bodies in the flow of a Word document � you can't remove the container without removing its content. When you deselect (click away fro...

Back-Order problem
I am trying to order an item for a customer which is not in stock. I pressed F2 and selected the item at which point an "Insufficient Quantity" window is pops up and I select "Back Order" for this item. Now POS shows the Total at the bottom (say $100) and I thought I am ready to F12/Tender but when I do that, it shows $0 Total and doesn't charge anything. It's strange... Anyone know why this is happening? There are two ways to handle back orders, and you can only choose one: accept no deposit or require 100% deposit. Your system is configured for accept n...

Problem Viewing Saved Publisher Documents
Why can I see only page 1 of saved Publisher documents? I open the file, see the first page, but there are no page numbers at the bottom of the window--page 2, 3, etc. Leinani <Leinani@discussions.microsoft.com> was very recently heard to utter: > Why can I see only page 1 of saved Publisher documents? I open the > file, see the first page, but there are no page numbers at the bottom > of the window--page 2, 3, etc. a) Maximize your window. They may have been chopped off the bottom by the taskbar. b) View > Status Bar -- Ed Bennett - MVP Microsoft Publisher ...

RPC
Since having to repair my windows installation i am now getting these error messages when i try to connect to my Exchange server: A system component, RPC required by outlook to connect to the e-mail server is not configured properly. for more information contact your system administrator. What can i do the resolve this. Do you have these registry keys? REGEDIT4 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\ClientProtocols] "ncacn_np"="rpcrt4.dll" "ncacn_ip_tcp"="rpcrt4.dll" "ncadg_ip_udp"="rpcrt4.dll" "ncacn_http"="...

UGHHH another url problem, attachment security problem
I sent a web page to myself and tried to open it on a win2Kcomputer. I get a message Attachmetn Security Warning this file may contain a virus that can be harm... save to disk, cancel ------ however when I try to save it- I get another message "Outlook cannot sar the URL rto afile, can't find this file . Make sure the path and file name are correct HOW do I fix this, I have looked and can't find the answer You may want to look into Microsoft KB article 829982. It will allow you to set .url's to be allowed by Outlook, and you may not have this problem anymore. http:/...

problem with Outlook #2
Hey all, I am having a little bit of a problem. I have setup an account for another user to use Outlook 2003. In other words, there is two users accounts created so me and my brother can use Outlook. The problem is when my brother uses his email account in Outlook and clicks on "SendTo link" on a webpage to contact a site, the email always comes up with my account and always comes in my inbox instead of his email inbox. What's wrong? 1.. Open the Mail Setup dialog box. How? In Microsoft Windows XP a.. In Control Panel, double-click User Accounts, and then cli...

RPC
I was asked the following question from one of our developers. "Do we have RPC (remote procedure calls) setup with Exchange 2003 and Outlook?" I am running Exchange 2003 SP1. How do I verify this? Thanks, Tyson If you have to ask your answer is probably no. See: http://support.microsoft.com/kb/833401/en-us hth DDS W 2k MVP MCSE "Tyson" <Tyson@discussions.microsoft.com> wrote in message news:447DD05E-FD4A-47E0-88CD-983A1374497A@microsoft.com... >I was asked the following question from one of our developers. > > "Do we have RPC (remote proce...

RPC over HTTP #7
I have an Outlook 2003 client that is connecting to exchange server via RPC over HTTP. Whenever Oultook is launched or an active sync is attempted with the client, the user is prompted to enter a username and password. Is there a way to turn this authentication off? Other systems on the network configured for RPC over HTTP access are not prompting for authentication. I'm puzzled by what is causing this. Thanks, Mike Do you have the authentication set to Simple or NTLM? --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. All unsolic...

Bizarre problem
I had a Bizarre problem with Outlook(2002). It started filling up my Inbox with a message that one of my colleagues had sent out using the same account earlier in the day(She had sent an email from her computer from Outlook since we both have access to that email account). Every time I hit Send/Receive it just received the same email over and over again. I logged on to the Web interface and the email was not there, so it was not on my ISP's server. I closed Outlook and opened it again and it would still do the same thing. I rebooted my computer, opened Outlook and it quit doing i...

Exchange 2003 on Windows Server 2000 / RPC over HTTP
Howdy all! Just wanted to verify that Exchange Server 2003 SP2 is indeed supported on Windows Server 2000 SP3 and above! Additionally, want to verify that in order to use RPC over HTTP you need to be running Windows Server 2003 and Exchange Server 2003 (read: that it will not work on a WIN2000/EXCH2003 setup). Thank you! -- Cary W. Shultz Roanoke, VA 24012 Correct. http://www.microsoft.com/exchange/evaluation/sysreqs/2003.mspx System Requirements for RPC over HTTP on Exchange Server 2003 http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3RPCHTTPDep/91dc76e8-e60f-4f9...

Problems with two large contacts
Hello, I have two contact with more than 1000 links to one (non existing) date. Contact size is about 32MByte (Properties of contact) When I try to open that contact Error is: "Cann't open one or more attachements" (my translation from german ;-) When I try to save modified contact (Attachements deleted) or try to delete it, error is: "not enough memory or system ressources. Try to close some windows or programs and try again" How can I get rid of these contacts (XPOST, FUP to microsoft.public.outlook) Thanks for Help, Christian Found solution: Use Outlook Express ...