Middle-click not working... sometimes

  • Follow


I have noticed recently that middle-clicking on a hyperlink in IE8 sometimes 
doesn't open a link in a new tab, but just opens the page in the current tab. 
 I haven't had this problem before, and it only started a few weeks ago.  I 
have noticed it on more than one computer.

Right-clicking and choosing "Open in new tab" seems to work every time.  Am 
I going nuts, or has something happened?
0
Reply Utf 2/17/2010 11:01:02 PM

See this recent, related discussion: 
http://groups.google.com/group/microsoft.public.internetexplorer.general/browse_frm/thread/77b0443d0972e86f

Always state your full Windows version (e.g., WinXP SP3; WinXP 64-bit SP2; 
Vista SP1; Vista 64-bit SP2; Win7; Win7 64-bit) as well as your IE version 
when posting in an IE-specific forum or newsgroup. Please do so in your next 
reply.

1. Does the behavior persist if you start IE in No Add-ons mode?

   => Start | (All) Programs | Accessories | System Tools | Internet 
Explorer (No add-ons).

Troubleshooting and Internet Explorer’s (No Add-ons) Mode [Applies to IE7 & 
IE8 in all OSS]
http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx

2. Does the behavior persist if you Reset IE Advanced settings (RIES)?
WinXP or Vista: http://support.microsoft.com/kb/923737
Win7 only: 
http://windows.microsoft.com/en-US/windows7/Reset-Internet-Explorer-settings

3. What anti-virus application or security suite is installed and is your 
subscription current?  What anti-spyware applications (other than Defender)? 
What third-party firewall (if any)?  If WinXP or Vista: Were any of these 
applications running in the background when you installed IE8?

4. Has a(nother) Norton or McAfee application ever been installed on this 
machine (e.g., a free-trial version that came preinstalled when you bought 
it)?


Domenic Alvaro wrote:
> I have noticed recently that middle-clicking on a hyperlink in IE8 
> sometimes
> doesn't open a link in a new tab, but just opens the page in the current
> tab. I haven't had this problem before, and it only started a few weeks
> ago.  I have noticed it on more than one computer.
>
> Right-clicking and choosing "Open in new tab" seems to work every time. 
> Am
> I going nuts, or has something happened? 

0
Reply PA 2/17/2010 11:17:16 PM

"Domenic Alvaro" <DomenicAlvaro@discussions.microsoft.com> wrote in message 
news:D3BB2150-CCCB-43B7-844F-E3654071587F@microsoft.com...
>I have noticed recently that middle-clicking on a hyperlink in IE8 
>sometimes
> doesn't open a link in a new tab, but just opens the page in the current 
> tab.
> I haven't had this problem before, and it only started a few weeks ago.  I
> have noticed it on more than one computer.
>
> Right-clicking and choosing "Open in new tab" seems to work every time. 
> Am
> I going nuts, or has something happened?

Middle Click?

I can click with the mouse wheel, that's the closest thing I have to a 
middle-click, but it only lets me jump to another open window. I can do the 
same thing by selecting one of the open programs on the Task Bar. Right 
Click opens a dialog box that allows several options, and Left Click open 
the link, sometimes in a new Tab, sometimes in a new Window. The link drives 
that bus, so I take whatever annoying behavior that results with a grain of 
salt. I've selected in TOOLS>OPTIONS to always open in a new tab, but it 
doesn't always work out the way I would prefer. I blame the dissapointment 
on the link and move on.






0
Reply Jeff 2/17/2010 11:30:25 PM

Finally somone else who has this problem.  This has been driving me
nuts, and I can't find any other discussion on the net about it.

It happened to me when I upgraded to Win 7 with IE 8.

Sometimes middle click opens a new tab, sometimes it opens in the same
window.  I get a rapid 'double click' sound when it does not work
properly.

AV = AVG free
Middle click also plays up in IE (no add ins)
Same behaviour for a USB mouse or my pen/tablet


-- 
mikeincairns
0
Reply undisclosed 2/24/2010 2:07:14 PM

I have the same problem.  Just started happening a few weeks ago and I didn't 
upgrade anything.  The problem occurs on my work and home computers.

IE8
Windows 7 Ultimate 64-bit

It used to be that a middle-click always opened a link in a new tab (the 
desired result).  But lately, it doesn't always work. Sometimes it goes to a 
new tab sometimes it opens in the current tab.  The inconsistent behavior is 
frustrating.
0
Reply Utf 2/24/2010 7:51:02 PM

Hello,

same situation this problem started few weeks ago. Midlle click sometimes works sometimes not.

Any idea how to fix?
0
Reply BlaMa 2/24/2010 8:54:26 PM

"Domenic Alvaro" <DomenicAlvaro@discussions.microsoft.com> wrote in message
news:D3BB2150-CCCB-43B7-844F-E3654071587F@microsoft.com...
> I have noticed recently that middle-clicking on a hyperlink in IE8
> sometimes
> doesn't open a link in a new tab, but just opens the page in the current
> tab.
> I haven't had this problem before, and it only started a few weeks ago.  I
> have noticed it on more than one computer.
>
> Right-clicking and choosing "Open in new tab" seems to work every time.
> Am
> I going nuts, or has something happened?


How are you doing your Middleclick?   E.g. I have a wireless mouse with a
scrollwheel where "clicking" with the scrollwheel is defined as Middleclick.
Well, frequently my attempts at clicking just move the pointer off the link
so I don't get a good click.   When I was using my Kensington trackball I
had a chord defined for Middleclick and that was a much more reliable
procedure.   Perhaps if I used a different button for Middleclick instead of
the scrollwheel I would have a better result.   But the only thing that I
really want Middleclick for anyway is starting AutoScroll, which works,
within the limitations of my use of the hardware, as described above.
IMO Ctrl-Click and Shift-Ctrl-Click would be better options if you are just
using Middleclick to open links in a new tab, foreground or background.


---  

0
Reply Robert 2/24/2010 9:03:22 PM

Finally! I thought I was going crazy. This has happened to me on 3
different machines now, one XP, one Vista and one Windows 7 Ultimate. 

Does this only happen in IE8 or does it also happen in Firefox?


-- 
Mech
0
Reply undisclosed 2/26/2010 3:29:27 AM

I have same problem on two cumputers one W7 second Win XP. Middle click on 
some links work on another not.

Big problem,
0
Reply Utf 2/27/2010 7:54:01 PM

My middle finger works...

Roman wrote:
> I have same problem on two cumputers one W7 second Win XP. Middle click on
> some links work on another not.
>
> Big problem, 

0
Reply PA 2/28/2010 12:27:26 AM

After using vista business for over a year the wheel click to open a new tab doesn't always work. I presume this is because of a windows update that wasn't tested fully. It is very annoying as you cannot now keep a google search unless by using the right click/new tab method. A very backward step!



Domenic Alvaro wrote:

Middle-click not working... sometimes
17-Feb-10

I have noticed recently that middle-clicking on a hyperlink in IE8 sometimes
does not open a link in a new tab, but just opens the page in the current tab.
I have not had this problem before, and it only started a few weeks ago.  I
have noticed it on more than one computer.

Right-clicking and choosing "Open in new tab" seems to work every time.  Am
I going nuts, or has something happened?

Previous Posts In This Thread:


Submitted via EggHeadCafe - Software Developer Portal of Choice 
Generic Feed Parsers Redux
http://www.eggheadcafe.com/tutorials/aspnet/42a9b6e2-809e-4ca7-b3f6-acd41f462063/generic-feed-parsers-redu.aspx
0
Reply Eddy 3/1/2010 6:06:24 PM

I have had the same problem.
Middle mouse button only opens a new tab about two thirds of the time.
0
Reply cy3 3/14/2010 8:53:22 PM

I am using XP Pro and IE 8 and the wheel mouse clicking thing has just started happening to me too.  I think it only happens clicking out of Google in Internet Explorer, so I don't know if Google have changed something.  It is driving me up the wall, as I use wheel mouse clicking to open links in new windows all the time.  Even searching for a solution to this problem in Google made it happen several times.
0
Reply It 3/15/2010 1:39:26 PM

Reboot.

"It makes me MAD" <user@msgroups.net/> wrote in message 
news:uEHMwTExKHA.5132@TK2MSFTNGP05.phx.gbl...
>I am using XP Pro and IE 8 and the wheel mouse clicking thing has just 
>started happening to me too.  I think it only happens clicking out of 
>Google in Internet Explorer, so I don't know if Google have changed 
>something.  It is driving me up the wall, as I use wheel mouse clicking to 
>open links in new windows all the time.  Even searching for a solution to 
>this problem in Google made it happen several times.
>
> ---
> frmsrcurl: 
> http://msgroups.net/microsoft.public.internetexplorer.general/Middle-click-not-working-sometimes 

0
Reply Bob 3/15/2010 3:06:59 PM

Rebooting did nothing.  I think the problem lies with Google or an IE update.
0
Reply It 3/17/2010 3:58:18 PM

14 Replies
3474 Views

(page loaded in 0.187 seconds)


Reply: