DPM 2007 Agent Errors - DCOM related.

  • Follow


Hi,

I'm not quite sure what has triggered this but our Secondary DPM Server has 
errors on all of its agents when checking the Management -> Agent tab. I have 
uninstalled and reinstalled the agent on one of the protected servers, 
however this has not resolved the issue. On checking the Error Logs of the 
server they are all reporting the following DPMRA Application Error:

A DPM agent failed to communicate with the DPM service on [DPMServerName] 
because access is denied. Make sure that [DPMServerName] has DCOM launch and 
access permissions for the computer running the DPM agent.

I have checked the DCOM settings by working through the following article:

http://technet.microsoft.com/en-gb/library/cc161655.aspx

I have also checked the DPM RA Service Properties within Component 
Services\Computers\My Computer\DCOM Config as well as the WSSCmdletsWrapper 
Properties as detailed in this article:

http://blogs.technet.com/askcore/archive/2008/05/09/troubleshooting-agent-deployment-in-data-protection-manager-2007-dcom.aspx

The Secondary DPM Server is also reporting an error when attempting 
communication with the Primary DPM Server.

I really don't know where else to look so any input would be very much 
appreciated.

Thanks in advance.
0
Reply Utf 2/22/2010 12:12:01 PM

I'm getting similar RPC errors in my secondary. I found below article and 
going to install theTCPIP hotfix to see if that will help get rid of them.

http://support.microsoft.com/default.aspx/kb/971411?wa=wsignin1.0



"David Roberts" wrote:

> Hi,
> 
> I'm not quite sure what has triggered this but our Secondary DPM Server has 
> errors on all of its agents when checking the Management -> Agent tab. I have 
> uninstalled and reinstalled the agent on one of the protected servers, 
> however this has not resolved the issue. On checking the Error Logs of the 
> server they are all reporting the following DPMRA Application Error:
> 
> A DPM agent failed to communicate with the DPM service on [DPMServerName] 
> because access is denied. Make sure that [DPMServerName] has DCOM launch and 
> access permissions for the computer running the DPM agent.
> 
> I have checked the DCOM settings by working through the following article:
> 
> http://technet.microsoft.com/en-gb/library/cc161655.aspx
> 
> I have also checked the DPM RA Service Properties within Component 
> Services\Computers\My Computer\DCOM Config as well as the WSSCmdletsWrapper 
> Properties as detailed in this article:
> 
> http://blogs.technet.com/askcore/archive/2008/05/09/troubleshooting-agent-deployment-in-data-protection-manager-2007-dcom.aspx
> 
> The Secondary DPM Server is also reporting an error when attempting 
> communication with the Primary DPM Server.
> 
> I really don't know where else to look so any input would be very much 
> appreciated.
> 
> Thanks in advance.
0
Reply Utf 2/22/2010 6:54:01 PM


We are also getting the same errors on our secondary DPM servers and it 
started on 2/24/2010.  Were you able to find a resolution?

"David Roberts" wrote:

> Hi,
> 
> I'm not quite sure what has triggered this but our Secondary DPM Server has 
> errors on all of its agents when checking the Management -> Agent tab. I have 
> uninstalled and reinstalled the agent on one of the protected servers, 
> however this has not resolved the issue. On checking the Error Logs of the 
> server they are all reporting the following DPMRA Application Error:
> 
> A DPM agent failed to communicate with the DPM service on [DPMServerName] 
> because access is denied. Make sure that [DPMServerName] has DCOM launch and 
> access permissions for the computer running the DPM agent.
> 
> I have checked the DCOM settings by working through the following article:
> 
> http://technet.microsoft.com/en-gb/library/cc161655.aspx
> 
> I have also checked the DPM RA Service Properties within Component 
> Services\Computers\My Computer\DCOM Config as well as the WSSCmdletsWrapper 
> Properties as detailed in this article:
> 
> http://blogs.technet.com/askcore/archive/2008/05/09/troubleshooting-agent-deployment-in-data-protection-manager-2007-dcom.aspx
> 
> The Secondary DPM Server is also reporting an error when attempting 
> communication with the Primary DPM Server.
> 
> I really don't know where else to look so any input would be very much 
> appreciated.
> 
> Thanks in advance.
0
Reply Utf 3/1/2010 4:28:02 PM

2 Replies
985 Views

(page loaded in 0.032 seconds)


Reply: