GP 6-->7.5-->9

I'm testing for an upgrade from GP 6 to 7.5 to 9 on VMWARE, win2003 server, 
sql2000sp3.

- I installed GP6, created all the companies and users
- Tested connectivity (ok)
- Restored production databases to test build
- Tested connectivity (ok)
- Ran 7.5 install
- After install required to run GP Utilities
- Logged on as dbase admin to Server: Dynamics
- Got welcome message, clicked Next and get the following message
"A previous version of Great Plains has been detected.
To proceed, you need to upgrade your Great Plains system database.
Other users are currently using Great Plains. You cannot update tables while 
anyone is using Great Plains."
- Back and Next buttons are both greyed out. Only Cancel is avail.

Thought maybe I had some process running, so I tried to reboot, but still 
get the same thing. I'm basically stuck here. What am I doing wrong? Am I 
missing something? Please help. Thank you.
0
Genek (6)
8/16/2006 6:51:02 AM
greatplains 29623 articles. 6 followers. Follow

5 Replies
735 Views

Similar Articles

[PageSpeed] 30

Never mind, I figured it out. The mistake was in my first step. I should not 
have created any user accounts. Apparently once they are associated to the 
databases, they get locked even if not in use. So basically this step needs 
to be left until the very end.

"Genek" wrote:

> I'm testing for an upgrade from GP 6 to 7.5 to 9 on VMWARE, win2003 server, 
> sql2000sp3.
> 
> - I installed GP6, created all the companies and users
> - Tested connectivity (ok)
> - Restored production databases to test build
> - Tested connectivity (ok)
> - Ran 7.5 install
> - After install required to run GP Utilities
> - Logged on as dbase admin to Server: Dynamics
> - Got welcome message, clicked Next and get the following message
> "A previous version of Great Plains has been detected.
> To proceed, you need to upgrade your Great Plains system database.
> Other users are currently using Great Plains. You cannot update tables while 
> anyone is using Great Plains."
> - Back and Next buttons are both greyed out. Only Cancel is avail.
> 
> Thought maybe I had some process running, so I tried to reboot, but still 
> get the same thing. I'm basically stuck here. What am I doing wrong? Am I 
> missing something? Please help. Thank you.
0
Genek (6)
8/16/2006 10:37:01 AM
On second thought, I've got a weird situation here. If I create all my 
companies in version 6, but do not restore the backups from production, then 
I can install 7.5 and it updates everything correctly. If I do a restore from 
production then run 7.5, I run into the same problem from my original post. 
It restores user accounts with the databases. I'm confused because shouldn't 
the upgrade work regardless of user accounts being attached to databases? The 
only other option seems to be to do the version upgrade and restore the 
databases after upgrading to 9. But I can't help but think that it will 
reject the restore since the backups are from versoin 6.

I don't know, can anyone please help me out.
Thanks!

"Genek" wrote:

> Never mind, I figured it out. The mistake was in my first step. I should not 
> have created any user accounts. Apparently once they are associated to the 
> databases, they get locked even if not in use. So basically this step needs 
> to be left until the very end.
> 
> "Genek" wrote:
> 
> > I'm testing for an upgrade from GP 6 to 7.5 to 9 on VMWARE, win2003 server, 
> > sql2000sp3.
> > 
> > - I installed GP6, created all the companies and users
> > - Tested connectivity (ok)
> > - Restored production databases to test build
> > - Tested connectivity (ok)
> > - Ran 7.5 install
> > - After install required to run GP Utilities
> > - Logged on as dbase admin to Server: Dynamics
> > - Got welcome message, clicked Next and get the following message
> > "A previous version of Great Plains has been detected.
> > To proceed, you need to upgrade your Great Plains system database.
> > Other users are currently using Great Plains. You cannot update tables while 
> > anyone is using Great Plains."
> > - Back and Next buttons are both greyed out. Only Cancel is avail.
> > 
> > Thought maybe I had some process running, so I tried to reboot, but still 
> > get the same thing. I'm basically stuck here. What am I doing wrong? Am I 
> > missing something? Please help. Thank you.
0
Genek (6)
8/17/2006 12:04:01 AM
After restoring the DYNAMICS database to your test SQL instance, check 
whether there are any records in the ACTIVITY table.
If so, remove them ALL.
You should now be able to do the upgrade!

------
Robert

"Genek" <Genek@discussions.microsoft.com> wrote in message 
news:78F6A948-2719-4CFB-9392-ED2B8FC747BE@microsoft.com...
> On second thought, I've got a weird situation here. If I create all my
> companies in version 6, but do not restore the backups from production, 
> then
> I can install 7.5 and it updates everything correctly. If I do a restore 
> from
> production then run 7.5, I run into the same problem from my original 
> post.
> It restores user accounts with the databases. I'm confused because 
> shouldn't
> the upgrade work regardless of user accounts being attached to databases? 
> The
> only other option seems to be to do the version upgrade and restore the
> databases after upgrading to 9. But I can't help but think that it will
> reject the restore since the backups are from versoin 6.
>
> I don't know, can anyone please help me out.
> Thanks!
>
> "Genek" wrote:
>
>> Never mind, I figured it out. The mistake was in my first step. I should 
>> not
>> have created any user accounts. Apparently once they are associated to 
>> the
>> databases, they get locked even if not in use. So basically this step 
>> needs
>> to be left until the very end.
>>
>> "Genek" wrote:
>>
>> > I'm testing for an upgrade from GP 6 to 7.5 to 9 on VMWARE, win2003 
>> > server,
>> > sql2000sp3.
>> >
>> > - I installed GP6, created all the companies and users
>> > - Tested connectivity (ok)
>> > - Restored production databases to test build
>> > - Tested connectivity (ok)
>> > - Ran 7.5 install
>> > - After install required to run GP Utilities
>> > - Logged on as dbase admin to Server: Dynamics
>> > - Got welcome message, clicked Next and get the following message
>> > "A previous version of Great Plains has been detected.
>> > To proceed, you need to upgrade your Great Plains system database.
>> > Other users are currently using Great Plains. You cannot update tables 
>> > while
>> > anyone is using Great Plains."
>> > - Back and Next buttons are both greyed out. Only Cancel is avail.
>> >
>> > Thought maybe I had some process running, so I tried to reboot, but 
>> > still
>> > get the same thing. I'm basically stuck here. What am I doing wrong? Am 
>> > I
>> > missing something? Please help. Thank you. 


0
Robert
8/17/2006 7:46:25 AM
Thanks for the reply Robert. I tried deleting that table, and it lets me 
proceed with the upgrade, but then I can't connect to the database since it 
needs that table. I'll try just deleting the records in the table.

Let me ask this question. In retrospect, do you think the reason for this 
problem is because the backup on production was done while users were 
connected? The table would end up being backed up with activity recorder but 
when you restore that table to the new server, there is no "normal" way to 
log that user off. I haven't tried this yet, but I'm betting that if you 
start sql service in single-user mode, then do the backup, this entire 
ACTIVITY business can be avoided. What do you think?

"Robert Cavill" wrote:

> After restoring the DYNAMICS database to your test SQL instance, check 
> whether there are any records in the ACTIVITY table.
> If so, remove them ALL.
> You should now be able to do the upgrade!
> 
> ------
> Robert
> 
> "Genek" <Genek@discussions.microsoft.com> wrote in message 
> news:78F6A948-2719-4CFB-9392-ED2B8FC747BE@microsoft.com...
> > On second thought, I've got a weird situation here. If I create all my
> > companies in version 6, but do not restore the backups from production, 
> > then
> > I can install 7.5 and it updates everything correctly. If I do a restore 
> > from
> > production then run 7.5, I run into the same problem from my original 
> > post.
> > It restores user accounts with the databases. I'm confused because 
> > shouldn't
> > the upgrade work regardless of user accounts being attached to databases? 
> > The
> > only other option seems to be to do the version upgrade and restore the
> > databases after upgrading to 9. But I can't help but think that it will
> > reject the restore since the backups are from versoin 6.
> >
> > I don't know, can anyone please help me out.
> > Thanks!
> >
> > "Genek" wrote:
> >
> >> Never mind, I figured it out. The mistake was in my first step. I should 
> >> not
> >> have created any user accounts. Apparently once they are associated to 
> >> the
> >> databases, they get locked even if not in use. So basically this step 
> >> needs
> >> to be left until the very end.
> >>
> >> "Genek" wrote:
> >>
> >> > I'm testing for an upgrade from GP 6 to 7.5 to 9 on VMWARE, win2003 
> >> > server,
> >> > sql2000sp3.
> >> >
> >> > - I installed GP6, created all the companies and users
> >> > - Tested connectivity (ok)
> >> > - Restored production databases to test build
> >> > - Tested connectivity (ok)
> >> > - Ran 7.5 install
> >> > - After install required to run GP Utilities
> >> > - Logged on as dbase admin to Server: Dynamics
> >> > - Got welcome message, clicked Next and get the following message
> >> > "A previous version of Great Plains has been detected.
> >> > To proceed, you need to upgrade your Great Plains system database.
> >> > Other users are currently using Great Plains. You cannot update tables 
> >> > while
> >> > anyone is using Great Plains."
> >> > - Back and Next buttons are both greyed out. Only Cancel is avail.
> >> >
> >> > Thought maybe I had some process running, so I tried to reboot, but 
> >> > still
> >> > get the same thing. I'm basically stuck here. What am I doing wrong? Am 
> >> > I
> >> > missing something? Please help. Thank you. 
> 
> 
> 
0
Genek (6)
8/17/2006 2:46:03 PM
Thanks for the help Robert. I deleted all the records and it does work now.

"Robert Cavill" wrote:

> After restoring the DYNAMICS database to your test SQL instance, check 
> whether there are any records in the ACTIVITY table.
> If so, remove them ALL.
> You should now be able to do the upgrade!
> 
> ------
> Robert
> 
> "Genek" <Genek@discussions.microsoft.com> wrote in message 
> news:78F6A948-2719-4CFB-9392-ED2B8FC747BE@microsoft.com...
> > On second thought, I've got a weird situation here. If I create all my
> > companies in version 6, but do not restore the backups from production, 
> > then
> > I can install 7.5 and it updates everything correctly. If I do a restore 
> > from
> > production then run 7.5, I run into the same problem from my original 
> > post.
> > It restores user accounts with the databases. I'm confused because 
> > shouldn't
> > the upgrade work regardless of user accounts being attached to databases? 
> > The
> > only other option seems to be to do the version upgrade and restore the
> > databases after upgrading to 9. But I can't help but think that it will
> > reject the restore since the backups are from versoin 6.
> >
> > I don't know, can anyone please help me out.
> > Thanks!
> >
> > "Genek" wrote:
> >
> >> Never mind, I figured it out. The mistake was in my first step. I should 
> >> not
> >> have created any user accounts. Apparently once they are associated to 
> >> the
> >> databases, they get locked even if not in use. So basically this step 
> >> needs
> >> to be left until the very end.
> >>
> >> "Genek" wrote:
> >>
> >> > I'm testing for an upgrade from GP 6 to 7.5 to 9 on VMWARE, win2003 
> >> > server,
> >> > sql2000sp3.
> >> >
> >> > - I installed GP6, created all the companies and users
> >> > - Tested connectivity (ok)
> >> > - Restored production databases to test build
> >> > - Tested connectivity (ok)
> >> > - Ran 7.5 install
> >> > - After install required to run GP Utilities
> >> > - Logged on as dbase admin to Server: Dynamics
> >> > - Got welcome message, clicked Next and get the following message
> >> > "A previous version of Great Plains has been detected.
> >> > To proceed, you need to upgrade your Great Plains system database.
> >> > Other users are currently using Great Plains. You cannot update tables 
> >> > while
> >> > anyone is using Great Plains."
> >> > - Back and Next buttons are both greyed out. Only Cancel is avail.
> >> >
> >> > Thought maybe I had some process running, so I tried to reboot, but 
> >> > still
> >> > get the same thing. I'm basically stuck here. What am I doing wrong? Am 
> >> > I
> >> > missing something? Please help. Thank you. 
> 
> 
> 
0
Genek (6)
8/18/2006 3:42:02 AM
Reply:

Similar Artilces:

Going Live with GP
I plan to start using GP Sept 1. We have not transferred any historical transaction from the old accounting system. All of our Vendors, Customers, Inv Items etc. are entered and we have tested all functions of AP AR GL. Does anyone have a checklist of things to do when starting with a new GP accounting system? I understand the basics things such as Enter open invoices in AP and AR Enter open POs Enter begining GL account balances fromt the old accounting system Begining bank balances and so on. I just want to make sure that I'm not overlooking something so a check list from someone ...

Migrating data from GP to GP
Hi, I have a GP7.5 installation when all data is, and a new GP8 installation on a different server. I need to migrate inventory data from the GP7.5 to GP8. I know that i should use the integration manager. But using it means that i should know the data source structure which is GP, and this is very complex because i need to migrate all inventory module, not a few data. PS: i don't what to make an upgrade because other modules are different in the 2 installations. Does anyone have any idea on this issue? Regards, Hanady Have tried just using DTS within SQL Server choosing your 7.5 s...

percentages #6
Confused... i can not seem to get the sum of $33.00 - 7% (it equals $30.69) ho do i do that on an excel worksheet? please help... -- johnsmit ----------------------------------------------------------------------- johnsmith's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=2635 View this thread: http://www.excelforum.com/showthread.php?threadid=39620 I dont get it... its probibly the most simple function... but I cant figure it out. Please Help -- johnsmith ------------------------------------------------------------------------ johnsmith's Profile: ...

outlook pst #5
Does anyone know if there is a limit as to how many pst files you can have in outloook 2003? I take it you mean how many open? Are you perchance wishing to create a seperate pst for each Contact? "rob" <taylorrob@battelle.org> wrote in message news:207801c4ac7e$331dbc20$a601280a@phx.gbl... > Does anyone know if there is a limit as to how many pst > files you can have in outloook 2003? ...

GP concurrent user and SQL 2005 CAL
assuming a 10 con-current licenses being installed on 15 workstation, with 15 users in GP. How many SQL 2005 CAL is needed ? HFlo, Server plus user client access license (CAL) licensing requires a separate Server license for each server on which the software is installed, plus a user CAL for each user accessing the server. The user CAL model will likely be more cost effective than device CALs if there are multiple devices per user (for example, a user has a laptop and handheld computer accessing SQL Server). Best regards, MG.- Mariano Gomez, MIS, MCP, PMP Maximum Global Business...

Questions about GP Client upgrade configuration
I'm getting ready to install a Service pack for GP7.5 and my ultimate goal is to get ready to upgrade to GP8.0. However right now upgrades are very tedious and below is the whole story. All the users/clients are identical! Let me describe what we have done in the past to upgrade and what I want in the future. In the past we sat down at each client machine performed the install. Then we logged in as an administrator (Ethoseries required this I think) so the product can finish loading what it needs. Again we do both steps on every client. In the future what I would like to do is in...

How do I create an A3 size document using Windows 7
A3 is not listed in the pre-set schedule of document sizes in Windows 7 (unlike previous versions of Windows). How do I create such a document using Windows 7? Does your printer support A3? Word/Windows will display the paper sizes supported by the default (or currently active) printer. -- Suzanne S. Barnhill Microsoft MVP (Word) Words into Type Fairhope, Alabama USA http://word.mvps.org "A3 documents in Windows 7" <A3 documents in Windows 7@discussions.microsoft.com> wrote in message news:F2647F06-5560-41A6-9C2F-462E6198C989@microsoft.com... > A3 is ...

EXC5.5: IMC crashing on mail with unknown addresses
Hi, We have a severe problem on two sites in our exchange organization. (Exchange 5.5 SP4 + postSP4 Hotfixes, Trend Micro SMEX 3.82_1160) When sending emails to addresses, which were moved in the organisation, the IMC seems to crash (bridge head server in a site of 5 exc servers, holding @3000 mailboxes, bridgehead itself has @5- max.50 mailboxes). On the address field properties of the sent email you only see the X.400 address of the old location of the user, no display name, etc. is set (old entry may be grabbed from a user out of the GAL due to replication delays). Checking IMC queue...

Unable to install 11.3.6 update...
This is really odd. When I try to install the 11.3.6 update for Office Mac (either from auto update or from download on Microsoft website), I get the standard error that I don't have the correct version installed. I have verified from the Read Me file as the error message says that I do have version 11.3.5 installed. I've verified my specs. Here are my specs: PowerBook G4 1.25 Mhz Mac OS 10.4.10 Office 2004 11.3.5 The only thing the Read Me recommends to do is to trash Office and reinstall from the disk and reapply updates. I REALLY don't want to have to do that. Any ideas o...

Fabrication and GP
I need to know how to process a transaction in GP. We are a sales - distribution center. We do some light fabrication. We need to find a way in GP to take one part or more parts, do fabrication work with them, then put them back into the system as a new part. For example, we take drum rollers and send them to a local fabricator who drills holes in them, inserts "brushes", then sends them back to us as a brush roller. They charge us for labor and the additional material and we have a new part. Currently, we either treat it as a parts sale / purchase. That part is clean, but a...

Upgrading from GP 9 to GP 10
While trying to upgrade from GP 9 to GP 10, I get an error when selecting the instance of the already installed GP 9: "Index was outside the bounds of the array". Any ideas? ...

GP 9 Upgrade and SQL Server 2000 sp4
per microsoft's documentation sql server sp4 must be installed before upgrading to GP 9. does anyone know if the sql server sp 4 install is necessary for the GP 9 upgrade? microsoft's documentation indicated that all service packs for GP 8 must be installed before upgrading to GP 9, but after speaking with support, they said the GP 8 service packs aren't necessary. bottom line: i'd like to avoid the sql sp4 install if necessary as i had to rebuild my test server after installing sp4 last week. thank you. Since the database requirements for GP 9.0 list SQL 2000 SP 4 a...

Payroll GP 10.0
Got this from a client and not sure what they are doing, but never heard of this any help would be great. As I am reviewing the Payroll Deduction Journal from the payroll I just ran yesterday, I have identified 5 employees whose deductions & benefits did not calculate. I happen to be one of the 5. There is $$$$$ that did not come off my pay as deductions; including my 401K. The common denominator seems to be when employee changes are made, deductions & benefits are made inactive; even though those benefits & deductions have no part in the changes being made. Pardon me, ...

Importing OE 6 folders from ME to XP?
Hello, My question is in regards to importing Outlook Express folders from a machine with Windows ME to a machine with Windows XP. The XP machine already has folders set up with many ancestry mails that cannot be lost. If I export from the ME to the XP machine will the current XP folders and mail be deleted from the XP machine or just added to the current XP OE folders? Sorry if this is confusing but I have been unable to find any answer on this. I just am not sure if the old OE folder contents will be added to the new OE folder contents without deleting the new OE folder mail. Thanks Ka...

MS CRM integration to GP
Hello Can any one update me wheather the mutiple company databases can be integrated to MSCRM. The senario is this. a company has mutiple entities using GP 7.5 and unique sql databases,require to integrate mscrm with gp. The integration that is supplied by MS only allows you to integrate with 1 company DB. You could probably use some of the components that are provided, but you will need to develop some of the integration logic yourself to address this. Matt On Sat, 24 Jan 2004 05:34:31 -0800, "ramki@loayoman.com" <anonymous@discussions.microsoft.com> wrote: >Hello &g...

Exchange 5.5 Enterprise version flips back to Standard version
We recently hit the 16GB limit on the IS, so upgraded to the Enterprise version. The upgrade was confirmed by seeing event 1217 when Exchange was started. All was OK until I tried to delete a large folder from a particularly large mailbox. The process stopped partway through, and I found that the IS service had stopped with the "Database full" event. Stopping and restarting all Exchange services cuased the IS to stay up for just 2 minutes. Event log shows that the systen seems to have flipped back to Standard mode, as event 1216 is now being generated on startup. I am convinc...

Reading Pane #5
Does using the reading pane really open you up for viruses and worms more than not using it? bfarr <bfarr@discussions.microsoft.com> wrote: > Does using the reading pane really open you up for viruses and worms > more than not using it? See the answers to your first post of this question. -- Brian Tillman ...

error in GP
When I try to generate a Historical Aged Trial Balance my computer freezes then gives me this error message. "The stored procedure pmHistoricalAgedTrialBalance returned the following results DBMS:208, GP:0 This is path I use to get to the report: Reports/Purchasing/Trial Balance/Historical Aged Trial Balance. We have been having problems with other reports because of the change from 2005 to 2006. I appreciate the assistance. ------=_NextPart_0001_AF5FCF35 Content-Type: text/plain Content-Transfer-Encoding: 7bit Hi Jason, This is Lisa. Thank you for your inquiry on the Historica...

Outlook 2003 Smart Tag Integration with MSN Messenger 7.0 vs Windows Messenger
Is there a way to use MSN Messenger 7.0 with the Outlook 2003 Smart Tag integration instead of useing Windows Messenger? Seems really silly that Outlook 2003 would use Windows Messenger a older product with less features then use MSN Messenger which is a newer product with more features. I've search all over the net for this answer and all I find is others asking the same questions but never and answer. -- Regards, Chris ...

Windows 7 checked HAL source file
I went through the following page about installing just checked build OS and HAL for Windows 7, as it stated for Vista and later http://msdn.microsoft.com/en-us/library/cc835892.aspx I cant find HAL SourceFileName from "%SystemRoot%\Inf\setuppapi.dev.log" file as hal.dll is not available I had halacpi.dll and halmacpi.dll file available in WDK i386 debug directory, these file names are not present on the log file(!) I just went on and used halmacpi.dll file as the HAL source file (as my target system is multiprocessor) and updated the boot entry as well, as less e...

GP General Ledger Distribution Reference Field Length
Is there a way of expanding the field length of the Distribution Reference field beyond 30 characters? No, I'm afraid it is not possible. "Pam" <Pam@discussions.microsoft.com> wrote in message news:6D76FF64-76BE-4FCE-812F-2AC8519BAB4D@microsoft.com... : Is there a way of expanding the field length of the Distribution Reference : field beyond 30 characters? Just curious, why do you need a longer field length - for drill down purposes or for report printing purposes? "Pam" wrote: > Is there a way of expanding the field length of the Distribution Refer...

Merging workbooks #6
I share information through excel and both parties update the same worksheet. Is there an easy way to merge or synchronize the two workbooks? ...

email Bounce "From: derived from envelope by postmaster@mail-9.uk.tiscali.com"
This is an odd one, and I just don't know where to look for answers... We have an SBS 2003 server, patched with all the usual POP3 connector patches, and it all seems to be working fine... Every once in a while, a client who sends in to us gets a bounce message... From: derived from envelope by postmaster@mail-9.uk.tiscali.com I've no idea where the message is coming from..., as he will send emails in quite happily for several weeks then he gets one of these..?, and it fails... He just resends it and it works fine... He is the only customer we have this problems...

Business Portal (BP) and Great Plains (GP)
We do not have all the fields in the Ledger Transaction Summary History Table (BP) available as we do in the Account Transaction table in GP i.e. can't find TRX Date in BP but have it GP. Is there any control when installing the BP software with respect to what fields for a table will be displayed and can be used in constructing queries in BP? How do we get access to additional fields in BP? Kimmer, Thanks for using the newsgroups. The Ledger Transaction Summary History entity maps to the Account Summary History table. The Account Transaction History table is not exposed th...

Microsoft Works # 9 calendar
I have activated Microsoft works # 9 calender reminder from the start up menu, but have still not received a reminder of events on start up or when using the calender. I used to get a pop up window with the calender as a reminder. Are there any simple fixes to this issue. Thanks. dutch7@comcast.net ...