eConnect SOP Transaction DEFPRICING Problem

Hi,

  I have just started to use eConnect and had successfully import some SOP 
Transaction into GP following the examples provided in the help document.
However, when I tried to calculate standard or extended pricing 
automatically by using the DEFPRICING, it gives me the following error:

********************************************************************************
System.Data.SqlClient.SqlException: Procedure 'sopExtPricingGetPrice' 
expects pa
rameter '@QuantityFrom', which was not supplied.

Server stack trace:


Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage 
req
Msg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& 
msgDa
ta, Int32 type)
   at 
Microsoft.GreatPlains.eConnect.eConnectMethods.eConnect_EntryPoint(String
ConnectionString, ConnectionStringType ConnectionType, String sXML, 
SchemaValida
tionType ValidationType, String eConnectSchema)
   at eConnect_CSharp_ConsoleApplication.test2.Main(String[] args) in 
c:\documen
ts and settings\kathy\my documents\visual studio 
projects\consoleapplication1\co
nsoleapplication1\test2.cs:line 40
********************************************************************************

Below is my code for setting up the taSopLineIvcInsert and taSopHdrIvcInsert,
I think there are some fields missing that cause the error, but I cannot 
figure it out 

********************************************************************************

salesHdr.SOPTYPE = 2;
salesHdr.SOPNUMBE = "ORDST2357";
salesHdr.DOCID = "STDORD";
salesHdr.BACHNUMB = "AARONFIT0001";
salesHdr.TAXSCHID = "USASTCITY-6*";
salesHdr.FRTSCHID = "USASTCITY-6*";
salesHdr.MSCSCHID = "USASTCITY-6*";
salesHdr.LOCNCODE = "WAREHOUSE";
salesHdr.DOCDATE = "06/02/2005";
salesHdr.CUSTNMBR = "AARONFIT0001";
salesHdr.CUSTNAME = "Aaron Fitz Electrical-2";
salesHdr.ShipToName = "WAREHOUSE";
salesHdr.ADDRESS1 = "11403 45 St. South";
salesHdr.CNTCPRSN = "Bob Fitz";
salesHdr.CITY = "Chicago";
salesHdr.STATE = "IL";
salesHdr.ZIPCODE = "98052-6399";
salesHdr.COUNTRY = "USA";
salesHdr.DEFPRICING = 1;

salesLine.ADDRESS1 = "11403 45 St.South";
salesLine.CUSTNMBR = "AARONFIT0001";
salesLine.SOPNUMBE = "ORDST2357";
salesLine.CITY = "Chicago";
salesLine.SOPTYPE = 2;
salesLine.DOCID = "STDORD";
salesLine.QUANTITY = 5m;
salesLine.TOTALQTY = 5m;
salesLine.ITEMNMBR = "256 SDRAM";
salesLine.LOCNCODE = "WAREHOUSE";
salesLine.DOCDATE = "06/02/2005";
salesLine.ReqShipDate = "07/07/2005";
salesLine.FUFILDAT = "07/07/2005";
salesLine.ACTLSHIP = "07/07/2005";
salesLine.DEFPRICING = 1;

********************************************************************************

I had searched in the knowledge base but had no luck. If anyone has seen 
this before, I'd greatly appreciate your help. Thank you.
0
Kathy1 (132)
6/7/2005 12:06:02 AM
greatplains 29623 articles. 2 followers. Follow

4 Replies
576 Views

Similar Articles

[PageSpeed] 35

This is a bug in RTFM version of eConnect 8.0, it is supposed to be
fixed in the current version but I have not verified that personally
0
gkappel1 (18)
6/7/2005 3:42:33 AM
Hi,
  Thank you for your response. I wonder if there is other way that I can get 
the unit price from GP? I'd greatly appreciate your help.

"George Kappel" wrote:

> This is a bug in RTFM version of eConnect 8.0, it is supposed to be
> fixed in the current version but I have not verified that personally
> 
0
Kathy1 (132)
6/7/2005 4:55:11 PM
I would upgrade eConnect that should solve your problem, it is on
CustomerSource

if for some reason that is not an option for you would need to figure
the price before before/while creating your XML, as far as I know the
only way reasonable way to do this is calling the sopExtPricingGetPrice
sql stored procedure from custom code


Kathy wrote:

> Hi,
>   Thank you for your response. I wonder if there is other way that I
> can get the unit price from GP? I'd greatly appreciate your help.
> 
> "George Kappel" wrote:
> 
> > This is a bug in RTFM version of eConnect 8.0, it is supposed to be
> > fixed in the current version but I have not verified that personally
> > 

0
gkappel1 (18)
6/8/2005 1:48:29 AM
You could look up the Unit Price using the taSopLineIvcInsertPre Stored
Procedure. and populate your document before it goes to the eConnect DLL.

Miles



"George Kappel" <gkappel@greentreeholdings.com> wrote in message
news:%23THdsw8aFHA.3384@TK2MSFTNGP09.phx.gbl...
> I would upgrade eConnect that should solve your problem, it is on
> CustomerSource
>
> if for some reason that is not an option for you would need to figure
> the price before before/while creating your XML, as far as I know the
> only way reasonable way to do this is calling the sopExtPricingGetPrice
> sql stored procedure from custom code
>
>
> Kathy wrote:
>
> > Hi,
> >   Thank you for your response. I wonder if there is other way that I
> > can get the unit price from GP? I'd greatly appreciate your help.
> >
> > "George Kappel" wrote:
> >
> > > This is a bug in RTFM version of eConnect 8.0, it is supposed to be
> > > fixed in the current version but I have not verified that personally
> > >
>


0
mcousens (24)
6/8/2005 8:24:38 PM
Reply:

Similar Artilces:

Outlook Connector Problem 03-16-10
PLEASE HELP I have installed Outlook Connector on my computer and I have added an account. However I get the message "the connection has been interupted" sometimes and no emails have been downloaded. It says Error instead of connected. When I click for more details it says an unknown error has occurred during sync ...

Regional setting problem
Hi, I have some problems with the localization, my computer is set to accept ',' (comma) as a decimal symbol but when I use the strtod, ecvt and even printf functions are still using the '.' (dot) as the decimal symbol in contrary to the documentation. can any one enlighten me? thanks in advance Iris Irisz wrote: >Hi, > >I have some problems with the localization, my computer is set to accept ',' >(comma) as a decimal symbol but when I use the strtod, ecvt and even >printf functions are still using the '.' (dot) as the decimal symbol i...

Problem after power failure
This is a multi-part message in MIME format. ------=_NextPart_000_0006_01C696A3.75BC2CE0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hi, I have an exchange server (sbs 2003) which was brutally shut down by a = power failure. When the server came back up, IIS Admin would not start up. This is obviously causing problems with exchange web access. in the event log, I have the following errors: The IIS Admin Service service terminated with service-specific error = 2148073478 (0x80090006). Unable to decrypt the secure property. Ignorin...

SOP Order Stuck
Hello, Great Plains 6.0 / SQL2000 I was almost finished entering a 400-line sales order when my computer frizzled and died. The order I was entering is now in limbo. From explorer, I can still see it as an uposted sales transaction. But, when I double-click it, I get a "This document has been posted" error. All the items from the sales order are now committed/fulfilled to this non-existant order. What can I do to edit this order? -Trevor You should be able to change the posting setting via SQL Server. The column name is PSTGSTUS (Posting Status). It should be blank o...

Serial# problem
I've got an iMac that had a previous installation of OfficeX on it. I = then=20 removed it and installed an Excel.X with a different serial number. =20 Meanwhile, I installed the OfficeX onto another computer. Now the new=20 installation says that the serial number is being used on another = computer. =20 Now, I DID use the uninstall when I removed OfficeX. So, how can I reset the serial #'s so that I can get this straightened = out? Doug See here: http://www.mcgimpsey.com/macoffice/office/pid.html DM "Douglas Gaither" wrote: > I've got an iMac that had a prev...

error opening up SOP Short History Invoice Form
Trying to use the SOP Short History Invoice Form instead of the blank one, but each time I selected it I get an error. "Cannot access this report because the dictionary containing it is not loaded" I'm on GP 8.00g44. Pete, Make sure you are not looking for a mdified report. someone might have modified the SOP Short History Invoice Form and given you acces to it. If you do not have the modifed report dictionary locally, or have permisions to see it on a shared drive, you will recieve this message. If your company is running Manufacturing for Great Plains, check to see i...

persmissions problem
This about the third time I've posted this issue. Here it is. Installed Exchange 2003 on network and using outlook 2002 which is not an issue. When regular users put the exchange server name and their name in outlook it won't resolve. Three boxes popup and ask for username, servername and domain which shouldn't happen. After putting that info a message comes back and says "your credentials are incorrect. If I use my admin account there is not problem. Outlook will only resolve admin accounts. Could someone please help. "coy" <anonymous@discussions....

Limit Direct Deposit Transaction Register to the current build
The DD Transaction Register will include all transactions for all builds currently in the Generate ACH window. If the client has prior builds in the Generate ACH window these transactions will also be listed on the report. They will see a break between each pay run (Name = Payroll), which will list the total for each pay run. We would like to suggest that this report only print the build the user marked in the Generate ACH window. ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote for this suggestion, click...

process.h resolve problem
I have created a new MFC\Dialog Based\User MFC in shared DLL\ project using Visual Studio 2005. I added a process.h and I added the following code. CString cmd("IExplore.exe"); Process * p = new Process(cmd, this); p->run(); For this code, I am getting compilation error. When I right click on Process and select Go to definition, I get "Resolve Ambiguity" dialog box with COleDispatchException and COleException. This code works for me in my my old projects created using older VS. I opened old project in VS.2005 and it converted the project file. If I open process.h, ...

Problem Updating Money 2000 to Broker Statement
I have downloaded activity reported by my broker to Money 2000 and am on the page entitled "Review Investment Activity". The page says to click "Next" to update Money to this statement. When I click "Next", the page freezes for about 15 seconds and nothing happens. The page showing my statements states that I have 97 items on the statement to have updated to Money. Does anyone know why Money is freezing when I click "Next" on the "Review Investment Activity" page or what I can do to update Money 2000 to the statement? In microsoft.p...

CTreeCtrl update problem
I have the code below. When I select an item, the item does not really get selected until the next time I select something (that could be something else). What is wrong? BOOL CMyOwnBrowseDialog::OnInitDialog() { CDialog::OnInitDialog(); _chdrive(3); if (chdir("C:\\") != 0) MessageBox("FEL", "FEL", MB_OK | MB_ICONERROR); m_StaticDir.SetWindowText("C:"); currentDirName = "C:"; HTREEITEM rootC = m_TreeDirectories.InsertItem ("C:"); if (m_TreeDirectories.Select(rootC, TVGN_DROPHILITE) == 0) AfxMessageBox("Fel"...

SMTP Mail Problem
I am attempting to send an SMTP mail from my VB.NET program using the code below. The code compiles and runs fine executes with no errors, but I am sending to one of my alternate addresses and the e- mail is not arriving. I was thinking that if there was something fundamentally wrong with my host servername or credentials, that the SMTPClient class would throw an SMTPException, but it does not. According to Microsoft Outlook, my outgoing server does not require authentication, and sending e-mails from there works fine for me. Can anyone tell me what I am doing...

Subform Deleting Problem
I've got a continuos sub form with a recordsource that's listed below. The subform dispays accounts and their passwords, etc. My problem is because I'm using a sql join statement, I can't delete any subform records from the subform. Normally, I would not use a join statement in a subform, but I was forced to do it in order to sort by the user's First and Last name that resides in a related users table (The accounts table has a userID field that links to users table). Given that situation, is there any way to delete records from a continuos subform if the subform has...

COUNTIF and automatic type conversion problem
Hello I like to have an unique validation rule for a columen which contains id's. I used a therefore simple rule with the build in function "COUNTIF" http://www.cpearson.com/excel/NoDupEntry.htm i.e. "=COUNTIF(E:E;E2)=1" My id's have the format "n.nn" i.e. "1.1", "1.2", "1.3" etc. and the cell format is set to "text". The above rule works fine as long as I have the following id's "5.1" "5.10" "5.100" The problem which I have now is that EXCEL seems to convert the value before th...

eConnect Certification
Is any certification exam available for eConnect? Please reply. Thanks, Karpagavalli. ...

Transaction logs on Front End Server
I keep getting an alert on the exchange 2003 Management pack regarding my exchange front end server. The warning I am getting is that the exchange transaction log files are equal to or older than the maximum days allowed. Now the front server does not contain any mailboxes but the Information service is running, so I am confused why I am getting these logs. I had one mailbox on this front server but I moved to the backend end server couple of months ago. So my question is that is it normal to have transaction logs on the front server. Or is it because we have not backed them up thats ...

Frustrating problem with AutoSum
Can anyone help? When setting up spreadsheets, I have noticed an inaccuracy in my AutoSum function. If I utilize this command for a column (vertical total), the total is correct. However, if I use the AutoSum for a row (horizontal total), the sum is frequently off by one penney. Why is this happening? Most likely the values in the cells are more than 2 decimals, displaying as only 2. For example, a cell with 33.995 will display as 34.00 if formatted to 2 places, but wil actually still be 33.995. Two of them will total 67.99, but will look wrong because it look slike 34+34=67.99. I su...

Outlook 2003 Personal Address Book forwarding problem
This Outlook 2003 is connected to a Exchange 5.5 Server The problem is this, everytime I try to forward any e-mail and use any distribution list on the Personal Address Book it does not want to send the e-mail but if I try to send it any other way it works fine. Thanks ...

eConnect
Currently we arre using eConnect 7.5 to move data between two systems and it seems to work fine but this tools does not wotk with other applications for data integration. Is there any other integration tools that we can use that will work not only with Great Plains but with other applications as well? We are looking into BizTalk, does anyone knows if this will work with Great Plains? Thanks "Mo Quamar" <anonymous@discussions.microsoft.com> wrote in message news:2577601c46074$70786df0$a401280a@phx.gbl... > We are looking into BizTalk, does anyone knows if this >...

Word Document Problem
While typing a Word document I somehow got the Outook Express "Send" heading at the top of my document. I feel really stupid but I don't know how to get it off. I've no idea what I did to make it appear but I need to make it disappear! Thanks! Click the E-mail button on the Standard toolbar to turn it off, or click File | Send To | Mail Recipient to accomplish the same thing; both are toggles. -- Suzanne S. Barnhill Microsoft MVP (Word) Words into Type Fairhope, Alabama USA http://word.mvps.org "Pat" <Pat@discussions.microsoft.com> wr...

SOP Invoices
I just want to make sure i understand that with each invoice template I create in SOP that they can have their own string of numbers in the system that will chronologically advance with each entry being entered. Please confirm this for me. Thanks That is correct - each invoice ID can have its own numbering scheme. For any where you don't specify a numbering scheme, they will all use the numbering from the Sales Document Numbers Setup screen in SOP. -- Victoria Yudin Dynamics GP MVP Flexible Solutions, Inc. "BK" <BK@discussions.microsoft.com> wrote in message ...

Problem Adding Records To Child Table
I have two tables: table A (parent) and table B (child) which have a one-to-many relationship. Fields A.1 and B.1 are both the primary key fields of tables A and B, and each is an autonumber field. Field B.2 is the foreign key field which links to field A.1. I have a query with SQL as follows: SELECT B.*, A.1, A.2 FROM B INNER JOIN A ON B.2 = A.1 ORDER BY B.1 When I open the query and go to the new record, I enter in B.2 the value for A.1 for one of the existing A records. The new record is added in the B table. No problem. However, when I base a form on the above SQL and then try to add a...

Entering Rollover Transaction
I rolled over my 401(k) from a former job to a rollover IRA I set up for the last time I had a rollover transaction. I have two problems: The amount in the source account is less than the amount of the rollover, and I don't have the amount that was sold to provide the distribution. When I select "transfer in" as the transaction type, I get the following message, the only option is to enter "quantity." All I have is the amount transferred from the source account. It was a different investment anyway. I don't have enough information to enter a sell transactio...

eConnect and TA00950...?
We have an install of Great Plains 8, and we're trying to use eConnect 8 via a .Net application to send data in. However, when I try to run the sample code, I keeping getting the following error: "Invalid object name 'Dynamics..TA00950'." Searching around, I can't find much of anything at all about this error message online. Any ideas what's causing this? Having the same problem. Anybody know the answer yet? -- jarn "glass_snake" wrote: > We have an install of Great Plains 8, and we're trying to use eConnect 8 via > a .Net applica...

Calender problem
Outlook xp professional Cannot figure out how to view my calender in different styles, all I have is one style. how do I restore/find the little tabs that alter the calender views. It is so frustrating Turn on the Advanced Toolbars - are you looking for the Current View window? Can you try to explain what you mean by "little tabs?" Which view are you in? Judy Gleeson [MVP Outlook] Acorn Training and Consulting www.acorntraining.com.au Everyone - turn on your Advanced Toolbars and learn how to use the Field Chooser and Group by Box!! "Timax45" <noanswer@hotm...