eConnect How to Specify the Company Database with eConnect Incoming Service

The article from the knowledge base "How to Specify the Company Database 
with eConnect Incoming Service" states that this can be accomplised by add 
the following node to the XML document.

<eConnectProcessInfo>
   <ConnectionString>data source=SERVERNAMER;initial 
catalog=SQLDATABASE;integrated security=SSPI;persist security 
info=False</ConnectionString>
</eConnectProcessInfo</eConnectProcessInfo>

The question is how do you get the eConnectProcessInfo into the XML document 
programmatically like the example I use below.

Thanks
grs


// eConnectType class holds all touch points for eConnect

eConnectType eConnect = new eConnectType();

try

{

// GLTransactionType holds all touch point objects that make

// up a General Ledger GL Transaction in eConnect

GLTransactionType glTransactionType = new GLTransactionType();


taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert[] glLineItems =

new taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert[2];

taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert creditLine =

new taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert();

creditLine.BACHNUMB = "BATCHNBR123";

creditLine.JRNENTRY = 1000001;

creditLine.CRDTAMNT = 2.50m;

creditLine.DEBITAMT = 0.00m;

creditLine.ACTNUMST = "00-0000-10700-0000-0000";

glLineItems[0] = creditLine;

taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert debitLine =

new taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert();

debitLine.BACHNUMB = "BATCHNBR123";

debitLine.JRNENTRY = 1000001;

debitLine.CRDTAMNT = 0.00m;

debitLine.DEBITAMT = 2.50m;

debitLine.ACTNUMST = "00-1000-60100-0000-EBAY";

glLineItems[1] = debitLine;


taGLTransactionHeaderInsert glHeader = new taGLTransactionHeaderInsert();

glHeader.BACHNUMB = "BATCHNBR123";

glHeader.REFRENCE = "AAA000000009";

glHeader.JRNENTRY = 1000001;

glHeader.TRXDATE = "2005-05-10";

glHeader.TRXTYPE = 0;


glTransactionType.taGLTransactionHeaderInsert = glHeader;

glTransactionType.taGLTransactionLineInsert_Items = glLineItems;


GLTransactionType[] glTransactions = {glTransactionType};

eConnect.GLTransactionType = glTransactions;

}

catch (System.Exception ex)

{

Debug.Write(ex.Message + "\n" + ex.StackTrace);

}

return eConnect;

}


0
gsmith4428 (25)
11/14/2005 4:58:07 PM
greatplains 29623 articles. 3 followers. Follow

3 Replies
2371 Views

Similar Articles

[PageSpeed] 24

Depending on how you push the xml into eConnect, you can either construct 
that node and add it to your xml document as the first node, or if you are 
using the API to programatically push the XML, the you would do something 
like this:

eConnectCall.eConnect_EntryPoint(ConnectionString, 
Microsoft.eConnect75.EnumTypes.ConnectionStringType.SqlClient, 
xmlDocumentString, EnumTypes.SchemaValidationType.None, "");

Where ConnectionString is your SQL connection string and xmlDocumentString 
is the complete XML document string.



"grs" wrote:

> The article from the knowledge base "How to Specify the Company Database 
> with eConnect Incoming Service" states that this can be accomplised by add 
> the following node to the XML document.
> 
> <eConnectProcessInfo>
>    <ConnectionString>data source=SERVERNAMER;initial 
> catalog=SQLDATABASE;integrated security=SSPI;persist security 
> info=False</ConnectionString>
> </eConnectProcessInfo</eConnectProcessInfo>
> 
> The question is how do you get the eConnectProcessInfo into the XML document 
> programmatically like the example I use below.
> 
> Thanks
> grs
> 
> 
> // eConnectType class holds all touch points for eConnect
> 
> eConnectType eConnect = new eConnectType();
> 
> try
> 
> {
> 
> // GLTransactionType holds all touch point objects that make
> 
> // up a General Ledger GL Transaction in eConnect
> 
> GLTransactionType glTransactionType = new GLTransactionType();
> 
> 
> taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert[] glLineItems =
> 
> new taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert[2];
> 
> taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert creditLine =
> 
> new taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert();
> 
> creditLine.BACHNUMB = "BATCHNBR123";
> 
> creditLine.JRNENTRY = 1000001;
> 
> creditLine.CRDTAMNT = 2.50m;
> 
> creditLine.DEBITAMT = 0.00m;
> 
> creditLine.ACTNUMST = "00-0000-10700-0000-0000";
> 
> glLineItems[0] = creditLine;
> 
> taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert debitLine =
> 
> new taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert();
> 
> debitLine.BACHNUMB = "BATCHNBR123";
> 
> debitLine.JRNENTRY = 1000001;
> 
> debitLine.CRDTAMNT = 0.00m;
> 
> debitLine.DEBITAMT = 2.50m;
> 
> debitLine.ACTNUMST = "00-1000-60100-0000-EBAY";
> 
> glLineItems[1] = debitLine;
> 
> 
> taGLTransactionHeaderInsert glHeader = new taGLTransactionHeaderInsert();
> 
> glHeader.BACHNUMB = "BATCHNBR123";
> 
> glHeader.REFRENCE = "AAA000000009";
> 
> glHeader.JRNENTRY = 1000001;
> 
> glHeader.TRXDATE = "2005-05-10";
> 
> glHeader.TRXTYPE = 0;
> 
> 
> glTransactionType.taGLTransactionHeaderInsert = glHeader;
> 
> glTransactionType.taGLTransactionLineInsert_Items = glLineItems;
> 
> 
> GLTransactionType[] glTransactions = {glTransactionType};
> 
> eConnect.GLTransactionType = glTransactions;
> 
> }
> 
> catch (System.Exception ex)
> 
> {
> 
> Debug.Write(ex.Message + "\n" + ex.StackTrace);
> 
> }
> 
> return eConnect;
> 
> }
> 
> 
> 
0
eddieF (17)
11/14/2005 5:29:02 PM
------=_NextPart_0001_003FD241
Content-Type: text/plain
Content-Transfer-Encoding: 7bit

Hello

The eConnectProcessInfo node should be used in this case to specify the 
company database in the connectionstring element.

The example in the previous response would be a great example for you to 
use.

If you are actually serialzing the XML document, you would want to include 
the eConnectProcessInfo node into the serialized XML document and obviously 
the connectionstring element.

The eConnectProcessInfo node will be the first node within your XML 
document.  Below is an example:

<eConnect>
     <IVInventorySiteType>
          <eConnectProcessInfo>
               <ConnectionString></ConnectionString>
               <ProductName></ProductName>
               <Sender></Sender>
               <Outgoing></Outgoing>
               <eConnectProcsRunFirst></eConnectProcsRunFirst>
               <MessageID></MessageID>
               <SiteID></SiteID>
               <DocumentName></DocumentName>
               <DateTimeStamp1></DateTimeStamp1>
               <DateTimeStamp2></DateTimeStamp2>
               <DateTimeStamp3></DateTimeStamp3>
               <DateTimeStamp4></DateTimeStamp4>
               <DateTimeStamp5></DateTimeStamp5>
               <Userdef1></Userdef1>
               <Userdef2></Userdef2>
               <Userdef3></Userdef3>
               <Userdef4></Userdef4>
               <Userdef5></Userdef5>
               <ProcReturnCode></ProcReturnCode>
          </eConnectProcessInfo>
               <taCreateInventorySite>
                    <LOCNCODE></LOCNCODE>
                    <LOCNDSCR></LOCNDSCR>
                    <ADDRESS1></ADDRESS1>
                    <ADDRESS2></ADDRESS2>
                    <ADDRESS3></ADDRESS3>
                    <CITY></CITY>
                    <STATE></STATE>
                    <ZIPCODE></ZIPCODE>
                    <COUNTRY></COUNTRY>
                    <PHONE1></PHONE1>
                    <PHONE2></PHONE2>
                    <PHONE3></PHONE3>
                    <FAXNUMBR></FAXNUMBR>
                    <Location_Segment></Location_Segment>
                    <STAXSCHD></STAXSCHD>
                    <PCTAXSCH></PCTAXSCH>
                    <INCLDDINPLNNNG></INCLDDINPLNNNG>
                    <CCode></CCode>
                    <USRDEFND1></USRDEFND1>
                    <USRDEFND2></USRDEFND2>
                    <USRDEFND3></USRDEFND3>
                    <USRDEFND4></USRDEFND4>
                    <USRDEFND5></USRDEFND5>
               </taCreateInventorySite>
     </IVInventorySiteType>
</eConnect>


Thanks

Paul

Microsoft Online Support Engineer

Get Secure! - www.microsoft.com/security

=====================================================

When responding to posts, please "Reply to Group" via

your newsreader so that others may learn and benefit

from your issue. 

=====================================================

This posting is provided "AS IS" with no warranties, and confers no rights
------=_NextPart_0001_003FD241
Content-Type: text/x-rtf
Content-Transfer-Encoding: 7bit

{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fprq2\fcharset0 MS Sans Serif;}}
\viewkind4\uc1\pard\f0\fs20 Hello
\par 
\par The eConnectProcessInfo node should be used in this case to specify the company database in the connectionstring element.
\par 
\par The example in the previous response would be a great example for you to use.
\par 
\par If you are actually serialzing the XML document, you would want to include the eConnectProcessInfo node into the serialized XML document and obviously the connectionstring element.
\par 
\par The eConnectProcessInfo node will be the first node within your XML document.  Below is an example:
\par 
\par <eConnect>
\par      <IVInventorySiteType>
\par           <eConnectProcessInfo>
\par                <ConnectionString></ConnectionString>
\par                <ProductName></ProductName>
\par                <Sender></Sender>
\par                <Outgoing></Outgoing>
\par                <eConnectProcsRunFirst></eConnectProcsRunFirst>
\par                <MessageID></MessageID>
\par                <SiteID></SiteID>
\par                <DocumentName></DocumentName>
\par                <DateTimeStamp1></DateTimeStamp1>
\par                <DateTimeStamp2></DateTimeStamp2>
\par                <DateTimeStamp3></DateTimeStamp3>
\par                <DateTimeStamp4></DateTimeStamp4>
\par                <DateTimeStamp5></DateTimeStamp5>
\par                <Userdef1></Userdef1>
\par                <Userdef2></Userdef2>
\par                <Userdef3></Userdef3>
\par                <Userdef4></Userdef4>
\par                <Userdef5></Userdef5>
\par                <ProcReturnCode></ProcReturnCode>
\par           </eConnectProcessInfo>
\par                <taCreateInventorySite>
\par                     <LOCNCODE></LOCNCODE>
\par                     <LOCNDSCR></LOCNDSCR>
\par                     <ADDRESS1></ADDRESS1>
\par                     <ADDRESS2></ADDRESS2>
\par                     <ADDRESS3></ADDRESS3>
\par                     <CITY></CITY>
\par                     <STATE></STATE>
\par                     <ZIPCODE></ZIPCODE>
\par                     <COUNTRY></COUNTRY>
\par                     <PHONE1></PHONE1>
\par                     <PHONE2></PHONE2>
\par                     <PHONE3></PHONE3>
\par                     <FAXNUMBR></FAXNUMBR>
\par                     <Location_Segment></Location_Segment>
\par                     <STAXSCHD></STAXSCHD>
\par                     <PCTAXSCH></PCTAXSCH>
\par                     <INCLDDINPLNNNG></INCLDDINPLNNNG>
\par                     <CCode></CCode>
\par                     <USRDEFND1></USRDEFND1>
\par                     <USRDEFND2></USRDEFND2>
\par                     <USRDEFND3></USRDEFND3>
\par                     <USRDEFND4></USRDEFND4>
\par                     <USRDEFND5></USRDEFND5>
\par                </taCreateInventorySite>
\par      </IVInventorySiteType>
\par </eConnect>
\par 
\par 
\par Thanks
\par 
\par Paul
\par 
\par Microsoft Online Support Engineer
\par 
\par Get Secure! - www.microsoft.com/security
\par 
\par =====================================================
\par 
\par When responding to posts, please "Reply to Group" via
\par 
\par your newsreader so that others may learn and benefit
\par 
\par from your issue. 
\par 
\par =====================================================
\par 
\par This posting is provided "AS IS" with no warranties, and confers no rights
\par 
\par }
------=_NextPart_0001_003FD241--

0
ppearson (4)
11/15/2005 5:10:25 PM
Paul and Eddie

Thanks for you help. Think I am making progress but....
Below is my new xml document. In cases where the program fails I usually go 
onto the server and use XML Document Sender and XML Document Pusher to get 
error messages. I get the following error message from XML Document Sender:

Version=8.0.2.0
Unique MessageId =
Error Number = 1010
Error Description = Integrated Security is required.
Please ensure that the ConnectionString input parameter is valid.
Example: Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security 
Info=False;Initial Catalog=TWO;Data Source=MySQLServerName
Error Source = ExecProcsXML.ExecStoredProc
Line Number=1120

Here is my xml can you help with the error.  Thanks again.

<?xml version="1.0"?>
<eConnect xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <GLTransactionType>
    <eConnectProcessInfo>
      <ConnectionString>Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist 
Security Info=False;Initial Catalog=BCCOM;Data 
Source=xxxSQL03</ConnectionString>
    </eConnectProcessInfo>
    <taGLTransactionLineInsert_Items>
      <taGLTransactionLineInsert>
        <BACHNUMB>BATCHNBR123</BACHNUMB>
        <JRNENTRY>1000001</JRNENTRY>
        <CRDTAMNT>2.50</CRDTAMNT>
        <DEBITAMT>0</DEBITAMT>
        <ACTNUMST>00-0000-10700-0000-0000</ACTNUMST>
      </taGLTransactionLineInsert>
      <taGLTransactionLineInsert>
        <BACHNUMB>BATCHNBR123</BACHNUMB>
        <JRNENTRY>1000001</JRNENTRY>
        <CRDTAMNT>0</CRDTAMNT>
        <DEBITAMT>2.50</DEBITAMT>
        <ACTNUMST>00-1000-60100-0000-EBAY</ACTNUMST>
      </taGLTransactionLineInsert>
    </taGLTransactionLineInsert_Items>
    <taGLTransactionHeaderInsert>
      <BACHNUMB>BATCHNBR123</BACHNUMB>
      <JRNENTRY>1000001</JRNENTRY>
      <REFRENCE>AAA000000009</REFRENCE>
      <TRXDATE>2005-05-10</TRXDATE>
      <TRXTYPE>0</TRXTYPE>
    </taGLTransactionHeaderInsert>
    <taMdaUpdate_Items xsi:nil="true" />
  </GLTransactionType>
</eConnect> 


0
gsmith4428 (25)
11/16/2005 8:15:35 PM
Reply:

Similar Artilces:

eConnect Certification
Is any certification exam available for eConnect? Please reply. Thanks, Karpagavalli. ...

Companies with Contacts in Outlook
Hello, I have noticed that all of our contacts that get automatically put into Outlook 2003 from Microsoft CRM 3.0 don't have a company listed for them. Is there any way that we can change a setting so when the CRM puts a contact into Outlook it will also put the company we have that contact listed under? We don't have contacts out by themselves we make sure they are created under an account. Any tips would be appreciated! Hi Check out Frank Lees Blog http://www.workopia.com/howto/DisplayParentAccountOutlookContactForm.htm which will show you how to view the parent account in the...

eConnect
Currently we arre using eConnect 7.5 to move data between two systems and it seems to work fine but this tools does not wotk with other applications for data integration. Is there any other integration tools that we can use that will work not only with Great Plains but with other applications as well? We are looking into BizTalk, does anyone knows if this will work with Great Plains? Thanks "Mo Quamar" <anonymous@discussions.microsoft.com> wrote in message news:2577601c46074$70786df0$a401280a@phx.gbl... > We are looking into BizTalk, does anyone knows if this >...

vlookup---using data outside the range specified in the formula
I am sure I can guess the logical answer to this question, but... I have a sheet (Sheet 1) in Excel 2007 with a list of courses. The Course ID is in Column B and course title in Column C. The remaining columns are used to keep track of content that is developed for each of the 10 weeks of the course. I use a COUNT formula to show how many cells in the "development week columns" are NOT blank. If no content, for example is developed for BUS 110 (thus, no dates of completion are includes in Columns X, Y, Z, etc.), a 0 is put in column A. If we completed three weeks, we p...

eConnect and TA00950...?
We have an install of Great Plains 8, and we're trying to use eConnect 8 via a .Net application to send data in. However, when I try to run the sample code, I keeping getting the following error: "Invalid object name 'Dynamics..TA00950'." Searching around, I can't find much of anything at all about this error message online. Any ideas what's causing this? Having the same problem. Anybody know the answer yet? -- jarn "glass_snake" wrote: > We have an install of Great Plains 8, and we're trying to use eConnect 8 via > a .Net applica...

E-mail database
I am new to Outlook, so I am still getting my feet wet and trying to maximize the program. I work for a professional association that has a email contact list of members of about 1500 different email addresses. When we get new email addresses to add to our list, i need to be sure that they are not duplicates of addresses we already have. Any ideas on how to do this, without making a separate contact for each email address in outlook? I tried an excel spread sheet, but that will not notify me of a duplicate, it will only show me duplicates it I sort it alphabetically. For example, ...

Report services in DPM failed
Hi, After I upgrade report services to SP2, I can not run the report services anymor. It pop ups message " DMP could not connec to SQL server Reporting services because o fIIS connectivity issues .... ID 3013" I googled and found solutions for ID 3013. Someone saying that follow the step should work 1. Click Start, click Run, type inetmgr, and then click OK. 2. In Internet Information Services (IIS) Manager, expand Web Sites, expand Default Web Site, and then click the virtual directory for the report server. 3. Under Features View, double-click Handler Mappings. ...

1 HQ licence with 2 databases
Hi all, Could i run 2 databases on 1 HQ license ? or the license will be specified for certain database ? You can as long as the total number of stores in both databses do not exceed the license dongle. You will require to have 2 different HQ Comm server on different machine [if you want both on same machine you need to know how to create 2 instances of HQ Comm server listening on different ports]. Afshin Alikhani - [afshin@retailrealm.co.uk] CEO Retail Realm "Anna" wrote: > Hi all, > > Could i run 2 databases on 1 HQ license ? or the license will be specified &g...

Suppress the 'Do you want to convert the database' message
Hi, We are getting ready to migrate to Office XP (with and without Access) from Office 97. When you open a 97 mdb in Access 2002, a Do You Want To Convert the Database message pops up. You can convert the database or open it as read-only. With our upcoming deployment, there are concerns that users may inadvertently convert a shared database and thereby make it unrecognized for other 97 users (ie those who have not gotten Office XP yet). There is a registry fix (KB 290291) that allows suppressing the above message and opens the database read-only by default. There have been a couple of post...

automatically copy incoming messages to public folder
Hello, I need exchange guru's help with this seems to be easy task... How can I automatically copy incoming/outgoing messages to public folder based on trigger words for all exchange users (server level - not a user's mailbox rules wizard approach) Thanks in advance. Ask in an Exchange group? --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the (insert latest virus name here) virus, all mail sent to my personal account will be deleted without reading. After searching google.groups.com and finding no answer, Ivan asked: | Hell...

Reporting Services with a shared data source
I am trying to create a series of reports that I can deploy through my dev, qa, staging, and production environments. My custom databases for dev, qa, and staging share a SQL server so each db has a different name. My solution to this is to use a shared data source so that I do not have to change my reports for each environment. When I upload a report through CRM with a shared data source other than the default MSCRM data source I get an error (error text at the bottom of this message). If I create a dummy report that I can upload through CRM and then replace that report with my sha...

One SRSS report for all companies?
I'm just starting to experiment with SQL Reporting Services, but one problem I'm having is figuring out how to make one report work for multiple companies. From everything I've read, it seems like the company (i.e., database) name is hard coded in the Data Source. Which means that, if I have 5 companies, I'd have to set up 5 versions of the report to access each company. Is this correct, or am I missing something? It seems so basic that I can't believe you can't do it via a parameter at run time or something. What are you SRSS experts using?? How does version 10...

What is the reference for eConnect PM_Apply_Ex
Hi, Good day. Currently my client need to use eConnect for the Auto Apply function. This scipt/function is called "PM_Apply_Ex". It use in Payable Management module. However, I do not know where is the base from. May I know which DLL that I suppose to add in to my eConnect project in order to use this functions. Your help is very much appreciated. Thanks. :) ThaiKen, this is an easy one however not the reply you are looking for. There is no dll that you can reference for this. The function you describe is a dexterity based script and can be accessed only from Dexterity. GP...

Service Call
We frequently have the need to move an item which is on a Service Call to a different ticket. Most of the time, these were put on a PO. Current functionality does not allow the part to be moved to a different Call without cancelling the PO and then re-creating it - not a good/reasonable solution. At a minimum, there should be a utility/button to remove the PO reference from the parts line thereby allowing the part to be deleted/moved. ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote for this suggestion, cl...

eConnect error
Hello, I have a problem when running an eConnect integration my developpers have written for me. Note that this integration works fine on their test system, and also note that previous versions of this integration (developped with eConnect 9.0, prior to installing hot fix 9.0.2.4) were working fine and still are (somehow proving that my eConnect install is OK). I have installed the hot fix as well, it seemed to install fine, but somehow I have the feeling things stopped working when my developpers started coding with the hot fix. Any idea ? I am getting a bit desperate now... Full error mes...

Sending email allows incoming mail to be received
I've got an interesting situation with my two mail servers. Both are exchange 5.5 and one is acting strictly as a gateway to the second one. This doesn't happen all of the time, but we can definitely reproduce the following situation. When someone sends emails to us (not any specific individual) the mail some how gets queued up until I send out an outbound email. Once I send an outbound email, the queue releases the mail addressed only to me. Then other times, it works perfectly. Has anyone seen or heard of this problem. Russ Are you sure it's on the server, not the clien...

Using Company Wide Mail Templates.
Hi, I do not know if i am at the right spot here, or if it is evne possible, but i got the following question. My boss would like me to make sure that every outgoing mail has the same looks. It starts by adding a signature that is the same for everyone, except with ofcourse personalized information. This was easily done by giving everyone a signature. The next question is however, to put the head of our website, also above our mail. This means that every user that sends a mail, the mail will have a nice header, underneath that header, the mail is typed, and then its ended with the si...

how to get a form to Open when the database opens
I wanted to have a form automatically load when the database is opened so I did this VBA command. It is all nice and good since it opens to an empty record for user input however I still don't know how to get it to load the form when the database opens?? What is cancel as integer? tia, ------- Private Sub Form_Open(Cancel As Integer) DoCmd.OpenForm "frmEmployees", acNormal DoCmd.GoToRecord , , acNewRec End Sub =?Utf-8?B?SmFuaXM=?= <Janis@discussions.microsoft.com> wrote in news:5B0D9286-994D-42FF-BB2F-819534213499@microsoft.com: > I wanted to have a form automa...

Service Items
Hello Everybody, and Happy New Year. We have a lot of items in our inventory which we setup as type "Services" so as not to have to track usage - items like thread and boxes. We are considering changing philosophy, and want to start tracking usage/cost on some of these items. I don't think we can switch them directly in Great Plains. Please correct me if I'm wrong. Has anyone tried switching them in SQL directly? What are the consequenses? These items appear on Bills of Material also. What other options are available to me? Any ideas and suggestions are welcome. T...

How to re-create organization_name_mscrm for Reporting Services?
Dear All, I encountered a problem related to reporting services, the scenario as following: - Existing environment: - 1. Microsoft Dynamics CRM 3.0 (patched with roll up v2) 2. Microsoft SQL 2000 Standard Edition (updated with SP4) 3. Microsoft SQL 2000 Reporting Services (patched with SP2) Few months ago, the CRM reports was encountered an error "The CRMLocale is null..." when opened. However, this issue been resolved without know how. After CRM reports has resotred, I'd upload new custom report to CRM, but no data is display in new custom report. Then, I go to Report Man...

windows service with ui
How could I make a windows service that has a user interface like window? And I have a Doc/View MFC program, could I transform it to a windows service? Please help me, thanks everybody. "liangxj" <liangxj1982@gmail.com> wrote in message news:e8uVnbU9FHA.3760@TK2MSFTNGP14.phx.gbl... > How could I make a windows service that has a user interface like window? > > And I have a Doc/View MFC program, could I transform it to a windows > service? Typically you don't. Typically the service has no GUI, and the GUI is a separate application which communicates with ...

eConnect error -
I want to use eConnect for the purpose of inserting Orders into Great Plains via a storefront application, but I am running into a couple of issues. I am new to eConnect and had some difficulties installing the eConnect .Net Incoming Service, but was finally able to install it. I tried using the "CSharp eConnect Sales Order Example" article from MSDN to see if I could properly insert a simple order into the TWO database. I read and looked through several of the posts, but I can't find a solution to the error that I am receiving. When ever I call eConnect_EntryPoint in the ...

link Customer to image in database
Dear All I need to add image to each customer and save it into database and viewing it in picture control through scrolling into the customers what is done I created a table detail to customer master table with structure Customer Name and Customer Image(with type image) I added the picture control for the new table on the form but I do not know how to enter new image and save it to database I tried copy and paste to the picture control but it is not working please help me to find solution Thanks in advance Will the OLE object that you can attach to notes work? "Moham...

Anyone can resolve this eConnect error?
I am testing eConnect on sample company (Frbrikam, Inc). I use the sample code from the article "eConnect Serialization Example using Visual Basic .NET and ADO .NET" at http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnmbsgp/html/gp_econserial.asp I encounter this error, "The partner transaction manager has disabled its support for remote/network transactions." I thought eConnect will work on sample company (no license needed). If this is the case, how can enable eConnect so the sample code will work? -- Molin Chung @ Dallas, Texas ...

Sites and Services Questions
Bringing up AD in our remote plants and I want to make sure I understand the Subnet portion. Is it as simple as entering the IP and Subnet mask we user per location? Once I create sites and associate subnets to the site do I need to also associate a subnet with the main site (default)? You need to have a Site, Site Link and Subnet. You need to assign subnet to your local site. Not the main site. Site link is between your main site and remote site. You can read more info here: http://technet.microsoft.com/en-us/library/cc787284(WS.10).aspx -- Santhosh Sivarajan...