eConnect 9.0 UserDefinedFields on taSopLineIvcInsert_ItemsTaSopLin

Where are the userdefined fields stored on this type? I notice they are 
developer only also, does this mean they are only accessable from underlying 
code or can they be accessed in the dexerity runtime? ie on a customized 
apply sales documents form?
0
Garick (4)
2/14/2007 3:32:20 PM
greatplains 29623 articles. 5 followers. Follow

5 Replies
698 Views

Similar Articles

[PageSpeed] 29

Garick:

The userdef fields are used to pass values in the the pre and post procs 
related to the eConnect stored procs.  These allow you to write custom 
business logic.  Check the Extending Business Logic section of the eConnect 
Usage chapter of the eConnect Help file for more details.

Dwight

"Garick" <Garick@discussions.microsoft.com> wrote in message 
news:094E131F-7AA3-4408-BE32-AF0148B20936@microsoft.com...
> Where are the userdefined fields stored on this type? I notice they are
> developer only also, does this mean they are only accessable from 
> underlying
> code or can they be accessed in the dexerity runtime? ie on a customized
> apply sales documents form? 


0
2/14/2007 7:51:43 PM
Thanks. that cleared up alot. I am looking to pass several bits of data on 
each sales invoice line to the runtime from econnect now that I see that it 
rules out those particular fields, but I see that there are 5 comment fields 
available that populate sop10202, and as long as they are searchable in the 
runtime I'll be in good shape. 

Also, in know it's off topic, but what is the format of the account number 
string to pass ot in the soptransactiontype-->invoicedistribution. I tried 
something like this "105000-001-100-000-000" and it barks about the account 
not existing. I hate to have to go get the account index from the individual 
segments... Any ideas?

and Thanks

"Dwight Specht" wrote:

> Garick:
> 
> The userdef fields are used to pass values in the the pre and post procs 
> related to the eConnect stored procs.  These allow you to write custom 
> business logic.  Check the Extending Business Logic section of the eConnect 
> Usage chapter of the eConnect Help file for more details.
> 
> Dwight
> 
> "Garick" <Garick@discussions.microsoft.com> wrote in message 
> news:094E131F-7AA3-4408-BE32-AF0148B20936@microsoft.com...
> > Where are the userdefined fields stored on this type? I notice they are
> > developer only also, does this mean they are only accessable from 
> > underlying
> > code or can they be accessed in the dexerity runtime? ie on a customized
> > apply sales documents form? 
> 
> 
> 
0
Garick (4)
2/14/2007 9:37:15 PM
You should be able to pass either the string or the index.  I thought you 
could pass the string with seperators, but you may want to try it without. 
Also, check GP and make certain that account really does exist before you 
start changing your code.

By the way, if you pass a string, it converts it to ACTINDX based on finding 
the string in ACTNUMST in GL00105.

Dwight

"Garick" <Garick@discussions.microsoft.com> wrote in message 
news:63FAF22F-E6CF-4B05-9BA1-18E512CE5AB4@microsoft.com...
> Thanks. that cleared up alot. I am looking to pass several bits of data on
> each sales invoice line to the runtime from econnect now that I see that 
> it
> rules out those particular fields, but I see that there are 5 comment 
> fields
> available that populate sop10202, and as long as they are searchable in 
> the
> runtime I'll be in good shape.
>
> Also, in know it's off topic, but what is the format of the account number
> string to pass ot in the soptransactiontype-->invoicedistribution. I tried
> something like this "105000-001-100-000-000" and it barks about the 
> account
> not existing. I hate to have to go get the account index from the 
> individual
> segments... Any ideas?
>
> and Thanks
>
> "Dwight Specht" wrote:
>
>> Garick:
>>
>> The userdef fields are used to pass values in the the pre and post procs
>> related to the eConnect stored procs.  These allow you to write custom
>> business logic.  Check the Extending Business Logic section of the 
>> eConnect
>> Usage chapter of the eConnect Help file for more details.
>>
>> Dwight
>>
>> "Garick" <Garick@discussions.microsoft.com> wrote in message
>> news:094E131F-7AA3-4408-BE32-AF0148B20936@microsoft.com...
>> > Where are the userdefined fields stored on this type? I notice they are
>> > developer only also, does this mean they are only accessable from
>> > underlying
>> > code or can they be accessed in the dexerity runtime? ie on a 
>> > customized
>> > apply sales documents form?
>>
>>
>> 


0
2/15/2007 5:15:46 PM
Garick:

On the account question - I pass account number in many of the different 
procedures - the only thing to note is you do NOT have to pass the account 
index of the actual account number.  Instead you pass the actual account 
number as it would appear in the ACTNUMST column of the GL00105 table (in 
other words if you have a space or something like that in that column in that 
table you have to pass the blank in your XML document).  The edit checks they 
throw always compare that number you passed to that column in the GL00105 and 
if it isn't found then they throw that account not found error.

Hope that helps some, 

JG

"Garick" wrote:

> Thanks. that cleared up alot. I am looking to pass several bits of data on 
> each sales invoice line to the runtime from econnect now that I see that it 
> rules out those particular fields, but I see that there are 5 comment fields 
> available that populate sop10202, and as long as they are searchable in the 
> runtime I'll be in good shape. 
> 
> Also, in know it's off topic, but what is the format of the account number 
> string to pass ot in the soptransactiontype-->invoicedistribution. I tried 
> something like this "105000-001-100-000-000" and it barks about the account 
> not existing. I hate to have to go get the account index from the individual 
> segments... Any ideas?
> 
> and Thanks
> 
> "Dwight Specht" wrote:
> 
> > Garick:
> > 
> > The userdef fields are used to pass values in the the pre and post procs 
> > related to the eConnect stored procs.  These allow you to write custom 
> > business logic.  Check the Extending Business Logic section of the eConnect 
> > Usage chapter of the eConnect Help file for more details.
> > 
> > Dwight
> > 
> > "Garick" <Garick@discussions.microsoft.com> wrote in message 
> > news:094E131F-7AA3-4408-BE32-AF0148B20936@microsoft.com...
> > > Where are the userdefined fields stored on this type? I notice they are
> > > developer only also, does this mean they are only accessable from 
> > > underlying
> > > code or can they be accessed in the dexerity runtime? ie on a customized
> > > apply sales documents form? 
> > 
> > 
> > 
0
jg (155)
2/16/2007 7:56:02 PM
Thanks once again for your reply. Knowing where to look for something is half 
of the battle. I'll check those tables against my passed accounts and verify 
I'm using the correct syntax. 

Have a great weekend,
Garick

"JG" wrote:

> Garick:
> 
> On the account question - I pass account number in many of the different 
> procedures - the only thing to note is you do NOT have to pass the account 
> index of the actual account number.  Instead you pass the actual account 
> number as it would appear in the ACTNUMST column of the GL00105 table (in 
> other words if you have a space or something like that in that column in that 
> table you have to pass the blank in your XML document).  The edit checks they 
> throw always compare that number you passed to that column in the GL00105 and 
> if it isn't found then they throw that account not found error.
> 
> Hope that helps some, 
> 
> JG
> 
> "Garick" wrote:
> 
> > Thanks. that cleared up alot. I am looking to pass several bits of data on 
> > each sales invoice line to the runtime from econnect now that I see that it 
> > rules out those particular fields, but I see that there are 5 comment fields 
> > available that populate sop10202, and as long as they are searchable in the 
> > runtime I'll be in good shape. 
> > 
> > Also, in know it's off topic, but what is the format of the account number 
> > string to pass ot in the soptransactiontype-->invoicedistribution. I tried 
> > something like this "105000-001-100-000-000" and it barks about the account 
> > not existing. I hate to have to go get the account index from the individual 
> > segments... Any ideas?
> > 
> > and Thanks
> > 
> > "Dwight Specht" wrote:
> > 
> > > Garick:
> > > 
> > > The userdef fields are used to pass values in the the pre and post procs 
> > > related to the eConnect stored procs.  These allow you to write custom 
> > > business logic.  Check the Extending Business Logic section of the eConnect 
> > > Usage chapter of the eConnect Help file for more details.
> > > 
> > > Dwight
> > > 
> > > "Garick" <Garick@discussions.microsoft.com> wrote in message 
> > > news:094E131F-7AA3-4408-BE32-AF0148B20936@microsoft.com...
> > > > Where are the userdefined fields stored on this type? I notice they are
> > > > developer only also, does this mean they are only accessable from 
> > > > underlying
> > > > code or can they be accessed in the dexerity runtime? ie on a customized
> > > > apply sales documents form? 
> > > 
> > > 
> > > 
0
Garick (4)
2/17/2007 4:48:00 PM
Reply:

Similar Artilces:

Explorer v.8.0
Hi, my new Explorer v.8.0 acted bizarrely, weirdly when I reopen it asking too often to restore to the last website after I closed it down... No need of that, I never have that with my previous explorer v.7.0. The new version crashed too often, also it does prevent me to open many new sites, instead I received a message to diagnose again and again explore... I may have accidently played the security under tools/internet option/security. Custom level etc unchecked what I was now supposed to uncheck etc. Can you help me to reset properly, thank you. -- -- Kermor Kermor ...

3.0 Installation Permission Errors
I'm trying to take a look at 3.0 - installation went fine. Now, I'm trying to log into the site and deployment mgr (which apparently also logs into the site) - and it gives me permission / authentication errors. I'm logged in as Domain Admin, which is the account I used to install CRM. I changed the IIS site to allow anonymous access, but apparently, the site is accessing other objects that either: are not getting passed the windows credential (maybe the website isn't picking up the windows credentials and forwrading to the objects??) or don't like the Domain Admin f...

Help with sales report, 0 quantity
Hello. I am trying to print out reports for quantities sold that also show me 0 quantity. I have added all the item numbers that I am interested in and it works great for ordering, but I need to be able to see which ones didnt sell during the period I set. The equals to 0 or less than 1 options dont work. Is there a trick? Thanks, Orlando ...

Money 99 #9
Though it worked before, now when I try to download an account update from my bank, it tries to save it in HTM format, and will not allow any attemp to save it otherwise. Bank says its Money. Any way to fix? I cannot find any help anywhere in Microsoft's Money supposrt? Sounds more like IE to me. Someone in one of the Internet Explorer groups might be able to assist on this. -- Glyn Simpson, Microsoft MVP - Money http://money.mvps.org Check http://support.microsoft.com/default.aspx?scid=fh;EN-GB;mny or http://money.mvps.org/faq for UK tips and fixes for MS Money. To send Microsoft ...

an album with 0 bytes information appeared and cannot be deleted
I have WMP11 on Vista Premium. As I list my albums per alphabetical order, somehow a new album was added after the Z letter, (under "other"). with no content, 0 bytes and worse, it cannot be deleted. How do I delete it? What exactly happens when you try to delete it? Does the album have a name, and are there any tracks with their album title set to that name? Resetting the media library should get rid of this ghost album. To do this, follow the instructions for WMP 11 on Vista at http://zachd.com/pss/pss.html#medialibrary Note that resetting the media library will make y...

eConnect Certification
Is any certification exam available for eConnect? Please reply. Thanks, Karpagavalli. ...

How do I zip sort mailing list when I have 5 digit AND 9 digit zip
I have a mailing list with zips in XXXXX and XXXXX-XXXX all mixed in. When I sort them, it seems to put all the 5 digits on the top half and 9 digits on the bottom half. I have made sure the column settings are set to special/zipcode. I have also tried setting them as Zip Code + 4 but it converts all the XXXXX versions to 0000X-XXXX. What am I doing wrong? Convert to TEXT -- Don Guillett Microsoft MVP Excel SalesAid Software dguillett@gmail.com "Greg" <Greg@discussions.microsoft.com> wrote in message news:97AB96D9-EAE6-4E6F-8AA1-1DE4137EDA06@microsoft.c...

Money 2001 #9
I recently lost everything on my pc...I had to reload Money 2001 and I had a backup on a disk. Please advise how I can copy my disk back onto the program. Thanks. Once Money is reinstalled, try File|Restore? "Steve" <anonymous@discussions.microsoft.com> wrote in message news:53b001c3ac94$f87facc0$a601280a@phx.gbl... > I recently lost everything on my pc...I had to reload > Money 2001 and I had a backup on a disk. Please advise how > I can copy my disk back onto the program. Thanks. ...

eConnect
Currently we arre using eConnect 7.5 to move data between two systems and it seems to work fine but this tools does not wotk with other applications for data integration. Is there any other integration tools that we can use that will work not only with Great Plains but with other applications as well? We are looking into BizTalk, does anyone knows if this will work with Great Plains? Thanks "Mo Quamar" <anonymous@discussions.microsoft.com> wrote in message news:2577601c46074$70786df0$a401280a@phx.gbl... > We are looking into BizTalk, does anyone knows if this >...

eConnect and TA00950...?
We have an install of Great Plains 8, and we're trying to use eConnect 8 via a .Net application to send data in. However, when I try to run the sample code, I keeping getting the following error: "Invalid object name 'Dynamics..TA00950'." Searching around, I can't find much of anything at all about this error message online. Any ideas what's causing this? Having the same problem. Anybody know the answer yet? -- jarn "glass_snake" wrote: > We have an install of Great Plains 8, and we're trying to use eConnect 8 via > a .Net applica...

Will Store Operations 2.0 run on Windows 7
Is there an official word if RMS SO 2.0 will run on a Windows 7 system? I would like to upgrade 1 of my backoffice system to Win 7 end of the month. Thanks for your reply. Not sure about RMS, but POS 2009 runs like a top. I would wait untill you get confirmed compstibility before making the change though. -- Thanks! David D. L.S.B. "Gerd" wrote: > Is there an official word if RMS SO 2.0 will run on a Windows 7 system? > > I would like to upgrade 1 of my backoffice system to Win 7 end of the month. > > Thanks for your reply. > I have been running 2.0 o...

Ingenico i6550 on 2.0.0114
Hi All, I am having a hard time finding any information on installation and configuration of the i6550. Would anyone out there be willing to share their documentation and/or procedures with me? I followed the KB article 935588 but all I get is a blank screen once the device boots. I have gleaned that I need several things to make this work: Form Designer for the device Ingenico OPOS driver newer than 2.4 (?) Better configuration documentation Sample receipt template (?) I would appreciate any detailed documentation that I can get my hands on. Thanks all very much! I installed 7 of th...

Letter Writing error after upgrade to 9.0
We just upgraded to 9.0. When we try and print a letter in the letter writing program we receive a Header Record Delimiters error. It is asking for a field delimiter and a record delimiter. How do we correct this error. If we run this same letter in a Historical Co, the letter writer works. Thank you, Amy Are you referring to Letter Writing Assistant? I haven't seen any errors in LWA. What kind of letter is it? -- Charles Allen, MVP "Amy" wrote: > We just upgraded to 9.0. When we try and print a letter in the letter > writing program we receive a Header Re...

Error with Veritas BE 9.1
Hi all, We have an Exchange 2003 server, with the appropriate remote agent installed. Up until last week or so, the Veritas BE 9.1 sofware, which is based on another server, was backing up Exchange fine. For some reason, i am receiving the following error now on our scheduled backups; "Unable to attach to \\<exch server>\Microsoft Information Store\First Storage Group" When i get in, what i then do is run a seperate dedicated job so that we have a backup of the IS, and strangely enough this works without any errors. No changes were made to the Exch or Backup config for thi...

What is the reference for eConnect PM_Apply_Ex
Hi, Good day. Currently my client need to use eConnect for the Auto Apply function. This scipt/function is called "PM_Apply_Ex". It use in Payable Management module. However, I do not know where is the base from. May I know which DLL that I suppose to add in to my eConnect project in order to use this functions. Your help is very much appreciated. Thanks. :) ThaiKen, this is an easy one however not the reply you are looking for. There is no dll that you can reference for this. The function you describe is a dexterity based script and can be accessed only from Dexterity. GP...

eConnect error
Hello, I have a problem when running an eConnect integration my developpers have written for me. Note that this integration works fine on their test system, and also note that previous versions of this integration (developped with eConnect 9.0, prior to installing hot fix 9.0.2.4) were working fine and still are (somehow proving that my eConnect install is OK). I have installed the hot fix as well, it seemed to install fine, but somehow I have the feeling things stopped working when my developpers started coding with the hot fix. Any idea ? I am getting a bit desperate now... Full error mes...

eConnect error -
I want to use eConnect for the purpose of inserting Orders into Great Plains via a storefront application, but I am running into a couple of issues. I am new to eConnect and had some difficulties installing the eConnect .Net Incoming Service, but was finally able to install it. I tried using the "CSharp eConnect Sales Order Example" article from MSDN to see if I could properly insert a simple order into the TWO database. I read and looked through several of the posts, but I can't find a solution to the error that I am receiving. When ever I call eConnect_EntryPoint in the ...

Visual FoxPro 9
Hi, Does the database stencil in Visio 2003 Prof support Visual FoxPro 9? Thanks in advance. Armstrong Hong Kong ...

Option Buttons #9
I have a form that has option buttons for answering "Yes" "No" questions. About 45 sets. Everything works really well but this form may also need to be printed off and filled in by hand, (and then be entered later). Is there anyway to have all option buttons read false, as apposed to having one read true and the other read false for each set, so when it is printed everything is blank. (Not selected) As it is when printed one or the other has been selected and is therefore the dot is printed. Thanks for the help!! Mike Rogers First, I would think that since you&#...

License issue for e connect 9.0
Hi, Previous versions of e connect had license. But for e connect 9.0, there are no registration keys. We had license for VS2005, We want to use e connect 9.0 with visual studio. Let me know whether we need to get another license for VS2005 when we are using e connect 9.0 (or) With VS2005 , can we use e connect without license as e connect is working for all the companies? If you already had a license for eConnect, you should have received the Developer's Toolkit for GP. The toolkit includes a license for eConnect. -- Charles Allen, MVP "Kiran" wrote: >...

eConnect and
When trying to call the eConnect routine ('‘taPopEnterMatchInvLine’') to populate a POP Shipment\Invoice I get the following error: '4850 Item Number/Vendor Item number is not assigned to the Vendor' I have resorted to manually populating the IV00103 table - but this does not help and I still get the same error as above. Any ideas of what else I could look for to try resolve? P.S. Is the ‘taPopEnterMatchInvLine’ routine the right routine to populate a shipment\invoice or should I be using a different one? If so which one? Thank you Neil Hi Neil, To populate the Shipmen...

Anyone can resolve this eConnect error?
I am testing eConnect on sample company (Frbrikam, Inc). I use the sample code from the article "eConnect Serialization Example using Visual Basic .NET and ADO .NET" at http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnmbsgp/html/gp_econserial.asp I encounter this error, "The partner transaction manager has disabled its support for remote/network transactions." I thought eConnect will work on sample company (no license needed). If this is the case, how can enable eConnect so the sample code will work? -- Molin Chung @ Dallas, Texas ...

Help! #9
My outgoing mail server is not responding. What's happening? ...

MS Dynamics CRM 4.0 for Outlook Installation
Hello, I have successfully installed MS CRM server. When I try to install "MS Dynamics CRM 4.0 for Outlook", it is giving "MS Dynamics CRM for Outlook can not be installed on a computer where MS exchange server versions prior to MS exchange server 2007 are installed". I am using a VM with Exchange Server 2003 with SP 2. Please let me know what am I missing. Thanks, I did the same before and I'm currently setting up a new VPC image without Exchange. As you cannot install Exchange 2007 on a 32-bit OS, I uninstalled Exchange 2003 in my previous image but afterward...

upgrade Money 4.0
Using Money 4.0 with XP. Getting error message when opening the program, but it still works after closing the error message. Interested in upgrading to 2004, but wonder if 2004 will import all account data info from 4.0. Sounds like a simple enough question, but I can't find anything on this, and sure don't want to lose any existing information just for the sake of upgrading. In microsoft.public.money, Jim wrote: >Using Money 4.0 with XP. Getting error message when >opening the program, but it still works after closing the >error message. Interested in upgrading...