Running The Full Mailbox Access script in the DST Calendar update package...

Hi,

   I have a list of users on an exchange server, in legacyDN Format, like 
this:
/O=ORG/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=JUSER


I use that list as the input list when I run ]
cscript grantmailboxpermission.vbs -add domain\domainuser users.txt


However, I get all errors (!!!!) when I do this.  I am running this from a 
command line on the exchange server itself.  The error log says:

Failed to add FullMailbox Access: LDAP://CN=User\, Joe,OU=Normal 
Users,OU=Users,OU=SDXP,OU=All,DC=firm,DC=local

Error: The security ID structure is invalid.



Does the fact that we are using lastname\ ,firstname affect this?

Thanks,



Tom Felts










0
betelgeuse (144)
2/15/2007 6:32:29 PM
exchange.admin 57650 articles. 1 followers. Follow

3 Replies
328 Views

Similar Articles

[PageSpeed] 33

The backslash is an escape character that says that the next character is 
part of the attribute, and from your example it appears to be used properly 
if the common name of the recipient is "User, Joe".

The error message indicates problems with the security identifier it gets 
from the user object, not with the LDAP string.  However, since you didn't 
post the script, I can't tell you more.
-- 
Ed Crowley
MVP - Exchange
"Protecting the world from PSTs and brick backups!"

"Betelgeuse" <betelgeuse@news.postalias> wrote in message 
news:%23rdJn%23SUHHA.192@TK2MSFTNGP04.phx.gbl...
> Hi,
>
>   I have a list of users on an exchange server, in legacyDN Format, like 
> this:
> /O=ORG/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=JUSER
>
>
> I use that list as the input list when I run ]
> cscript grantmailboxpermission.vbs -add domain\domainuser users.txt
>
>
> However, I get all errors (!!!!) when I do this.  I am running this from a 
> command line on the exchange server itself.  The error log says:
>
> Failed to add FullMailbox Access: LDAP://CN=User\, Joe,OU=Normal 
> Users,OU=Users,OU=SDXP,OU=All,DC=firm,DC=local
>
> Error: The security ID structure is invalid.
>
>
>
> Does the fact that we are using lastname\ ,firstname affect this?
>
> Thanks,
>
>
>
> Tom Felts
>
>
>
>
>
>
>
>
>
> 


0
curspice6401 (3487)
2/15/2007 7:09:44 PM
Ed,

    Thanks for the quick response.  The script is in KB930879.

Thanks,

twf


"Ed Crowley [MVP]" <curspice@mvpsnospam.org> wrote in message 
news:%23b$zbTTUHHA.5016@TK2MSFTNGP05.phx.gbl...
> The backslash is an escape character that says that the next character is 
> part of the attribute, and from your example it appears to be used 
> properly if the common name of the recipient is "User, Joe".
>
> The error message indicates problems with the security identifier it gets 
> from the user object, not with the LDAP string.  However, since you didn't 
> post the script, I can't tell you more.
> -- 
> Ed Crowley
> MVP - Exchange
> "Protecting the world from PSTs and brick backups!"
>
> "Betelgeuse" <betelgeuse@news.postalias> wrote in message 
> news:%23rdJn%23SUHHA.192@TK2MSFTNGP04.phx.gbl...
>> Hi,
>>
>>   I have a list of users on an exchange server, in legacyDN Format, like 
>> this:
>> /O=ORG/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=JUSER
>>
>>
>> I use that list as the input list when I run ]
>> cscript grantmailboxpermission.vbs -add domain\domainuser users.txt
>>
>>
>> However, I get all errors (!!!!) when I do this.  I am running this from 
>> a command line on the exchange server itself.  The error log says:
>>
>> Failed to add FullMailbox Access: LDAP://CN=User\, Joe,OU=Normal 
>> Users,OU=Users,OU=SDXP,OU=All,DC=firm,DC=local
>>
>> Error: The security ID structure is invalid.
>>
>>
>>
>> Does the fact that we are using lastname\ ,firstname affect this?
>>
>> Thanks,
>>
>>
>>
>> Tom Felts
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>
> 


0
betelgeuse (144)
2/15/2007 7:14:39 PM
Since this is Microsoft's script I recommend that you open a ticket with 
Microsoft PSS.
-- 
Ed Crowley
MVP - Exchange
"Protecting the world from PSTs and brick backups!"

"Betelgeuse" <betelgeuse@news.postalias> wrote in message 
news:edWWLWTUHHA.5012@TK2MSFTNGP04.phx.gbl...
> Ed,
>
>    Thanks for the quick response.  The script is in KB930879.
>
> Thanks,
>
> twf
>
>
> "Ed Crowley [MVP]" <curspice@mvpsnospam.org> wrote in message 
> news:%23b$zbTTUHHA.5016@TK2MSFTNGP05.phx.gbl...
>> The backslash is an escape character that says that the next character is 
>> part of the attribute, and from your example it appears to be used 
>> properly if the common name of the recipient is "User, Joe".
>>
>> The error message indicates problems with the security identifier it gets 
>> from the user object, not with the LDAP string.  However, since you 
>> didn't post the script, I can't tell you more.
>> -- 
>> Ed Crowley
>> MVP - Exchange
>> "Protecting the world from PSTs and brick backups!"
>>
>> "Betelgeuse" <betelgeuse@news.postalias> wrote in message 
>> news:%23rdJn%23SUHHA.192@TK2MSFTNGP04.phx.gbl...
>>> Hi,
>>>
>>>   I have a list of users on an exchange server, in legacyDN Format, like 
>>> this:
>>> /O=ORG/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=JUSER
>>>
>>>
>>> I use that list as the input list when I run ]
>>> cscript grantmailboxpermission.vbs -add domain\domainuser users.txt
>>>
>>>
>>> However, I get all errors (!!!!) when I do this.  I am running this from 
>>> a command line on the exchange server itself.  The error log says:
>>>
>>> Failed to add FullMailbox Access: LDAP://CN=User\, Joe,OU=Normal 
>>> Users,OU=Users,OU=SDXP,OU=All,DC=firm,DC=local
>>>
>>> Error: The security ID structure is invalid.
>>>
>>>
>>>
>>> Does the fact that we are using lastname\ ,firstname affect this?
>>>
>>> Thanks,
>>>
>>>
>>>
>>> Tom Felts
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>
>>
>
> 


0
curspice6401 (3487)
2/15/2007 9:22:28 PM
Reply:

Similar Artilces:

How do you escape from Access Calendar.
Hi, I using Access' active x calendar control in Access within XP Office pro. The code is working fine, but how do I escape from the calendar if I accidently click on my date field? My code is setup to dispaly the calendar control when I click on the date field. When I click on a date on the calendar, I get the date, assign it to my field, make the calendar invisible, and set focus on my date field. My question is, how do I exist the calendar if I click on the date field by mistake. I tryed to check for the Escape key in the KeyDown event for the Calendar, the KeyDo...

credentials to run this report are not stored
Hi all, I'm getting this problem when I try and create a timed subscription. Error: ...credentials to run this report are not stored..... ok I created another folder under the same folder where I'm having this problem. loaded the report and I have no problem. I even moved the current folder with that report in it. Creted another folder with the same name and still the same problem with that named folder. With a different name for the folder I have no problem??? I'm stuck here.. almost all post just talk about storing the credentials, Already done and works...

Mail addressed to deleted mailboxes
I would like to just reject all incoming mail silently and if possible, send a rejection reply. At this time, any incoming mail addressed to a deleted mailbox is forwarded to the administrator's mailbox and I want to stop this from happening. Any ideas that you have would be appreciated. Thanks. "Patrick McMillan" <patrickm@beelinedel.com> wrote: >I would like to just reject all incoming mail silently and >if possible, send a rejection reply. At this time, any >incoming mail addressed to a deleted mailbox is forwarded >to the administrator's ma...

Can't add additional mailboxes after upgrade 5.5-2003????
Hello, I just recently installed an Ex2003 server in order to migrate from 5.5. I am the only admin in the company so I previously had permissions to open anyones mailbox either as a new profile or as an additional mailbox option in my outlook client. When I try to do this with the handfull of users that have migrated to the new Exchange 2003 server I receive a request to log in. I tried the domain admin account, the exchange admin account, my account nothing seems to work. I must be permissioning something wrong on the new server. How do I fix this so that I have permission to everyon...

update not working
why wont my windows update fail windows update wrote: > why wont my windows update fail No one here has any idea why your windows update won't fail. Strange query anyway. Why do you think it should fail? No one here is certain what operating system is on the system you are (are not) having the issue with. What edition of that operating system? What service pack of that operating system? What version of Internet Explorer? What have you tried to do (to make it fail or if you misspoke, fix the failure)? -- Shenan Stanley MS-MVP -- How To Ask Questions ...

Need only one DLL instance to run...
Hi all, 1: if two apps load the same DLL - LoadLibrary(...) - system will create to different instance of the DLL... Now, in my DLL i've a CList and i need it to be visible to all instance and all apps!!!! Is there a way!? 2: I need the dll to remain loaded till machine reboot!!! Is it possible!? Thanks Ale >if two apps load the same DLL - LoadLibrary(...) - system will create to >different instance of the DLL... >Now, in my DLL i've a CList and i need it to be visible to all instance and >all apps!!!! > >Is there a way!? It'll be difficult to share a ...

run time error 10-22-03
I am having a lot of trouble when I open up word I get run time error 52 in VB. I have tried uninstalling word and reinstalling it. WE have tried deleting the macro but still to no avail can someone help me please? ...

Repost: Error running Report in an Access 2003 db from Access 2007
Ok, clarification - ignore the code from my original post, some of the reports do work. The ones that don't are reports that I have being filtered. Here is the code from one of those buttons: Private Sub Ok_Click() On Error GoTo Ok_Click_Err 'using the customer sub form for customer state report to filter the report, clicking ok will open report for selected state Dim stDocName As String Dim stLinkCriteria As String If Not IsNull(Me.Search_Results) Then stLinkCriteria = "[StateOrProvince] = """ & Me![Search Results] & """"...

Automatically run macro
My name is Mike and i have a question about microsoft excel macro's. Attached is a copy of the excel sheet im working on. Below the excel sheet is the macro I built. Some of the cells contain given values and some cells are calculated from formulas. Cell (G4) is my given value...it is related to cell (C32). The point is, I plug a value into cell (C10) and it runs through the rest of the calcs in the other cells and gives me a value to cell (C32). I built a macro that works as a goal seek pretty much. The macro makes cell (C32) equal to cell (G4) and gives me the value for cell (C10). I wan...

Installing the Exchange Calendar Update tool
Hey guys and gals, Two items of conusion for me: 1. When running the Exchange Calendar update tool (I don't trust my users to even read my email), I have to have access to all users's mailboxes in order to adequately run the tool. Which group do I have to place myself into to do this, or which permission do I need to change. I am in both the Enterprise Admin and Domain Admin roles. This is for an SBS 2003 install. When I run the tool I get errors that mailboxes cannot be accessed. 2. The TZMove.exe tool, which is supposed to be downloaded, but not the installer, which also has ...

"Last Updated" data disappearing
When I update my portfolio, the "Last Updated:" field is completed with the date and time. If I then go to another page such as "Bills" and then return to the Portfolio page, the data has disappeared. I am using the trial version of Money 2006. Money 2003 maintained the "last updated" data until the next update. Is there a way to correct this behavior? In microsoft.public.money, FredQ wrote: >When I update my portfolio, the "Last Updated:" field is completed with the >date and time. If I then go to another page such as "Bills"...

display changing label caption on form as sub runs w/o screen flic
let's say i have this routine Sub Test label1.caption = "Starting ... " 'do events label1.caption = "Getting there ... " 'do events label1.caption = "Finished! ... " End Sub on my form, i have label1 right in the middle what happens is sometimes the message will change, and then sometimes it wont, or it will show the first one, skip the second and jump to the third etc etc etc so it is inconsistent. is there a way to make sure the label caption displays consistently, on time, wh...

New accounts cannot access their mailbox
Hi I am having a problem with new accounts in SBS 2003. When we create new users they are unable to log into there mailbox if you check there "email address" tab in ad the do not receive any email addresses. We have tried loading the latest service packs and patches and rebuilt/reload the RUS but without any success Thanks Kris In news:8A0CEDE8-B192-4278-82EA-85967166E324@microsoft.com, luckr01 <luckr01@discussions.microsoft.com> typed: > Hi I am having a problem with new accounts in SBS 2003. When we > create new users they are unable to log into there mailbox i...

Excel Continuous Running Total
I posted a message earlier and have received a partial solution. I want to keep track of how much stock prices go up or down with a running total of how much they go up or down over several days until the direction changes. For example, if price go up 10 on Mon, 20 on Tues, 30 on Thurs and down 10 on Fri I want my running total column to show a positive number of 60 and then a red number of 10 and continue adding the amount of the total of the down days until the market shows an up day. The formula I am now using total the first and second day but does not do a running total count if t...

Exchange Mailbox Size #2
A request of 1GB mailbox size limit for each user was requested of me for over 10,000 users. We are using the enterprize version 2003; This seems like a foolish request since I've seen how a 250MB inbox re-acts using Outlook, DOG Slow... My question is, is this supported and what issues do you see given a request like this? -Charles "sacredheartu@hotmail.com" <anonymous@discussions.microsoft.com> wrote: >A request of 1GB mailbox size limit for each user was >requested of me for over 10,000 users. We are using the >enterprize version 2003; This seems lik...

Mail Merge using Access then save as PDF
In my organization, we send out letters by the thousands, ususally about 500 at a time, due to the time constraints of the current method. Currently, we process the database, which places the letter contents in a table called Archives. Then we open the Merge Template Word document, and process the mail merge to print each individual letter. Next we have to save each individual letter as a PDF file (Acrobat 8.2 Installed) for record keeping and quality assurance. What we'd like to do is find a way that this can all be done from within Access programmatically. Referen...

Money 2002 will not run
I had been using Money 2002 for approx. 3 yrs on my home pc (Dell Dim 2100, XP Home Ed. w/SP2). Last year, it simply would not launch. No error message, no splash screen, no app opening, no process listed in Task Manager. Just.... nothing.... The only change that was made to the system since M2k2 last ran was upgrading my a/v solution from Trend Micro PC-Cillin to TM Internet Security. I have tried disabling every aspect of the Internet Security product, as well as completely un-installing the app, and then attempting to run Money, but the same thing (nothing) happens. I was considerin...

Update subform field from pop-up form
I have a Form with 2 subforms. I need the ability to change the Child Field on the second subform to a value found in a pop-up form. I have the following structure: FrmMain Primary Key: ClientNo FrmSubVisit Record Source: q_frm_sub_visits_active Field 1: Account Field 2: AccDate Link Child Fields: ClientNo Link Master Fields: ClientNo Default View: Continuous FrmSubEvent Record Source: q_frm_sub_events Field 1: Account Field 2: EventNo Link Child Fields: Account Link Master Fields: txtRelayAccount (text relay on FrmMain from frmSubVisit) Default View: Single Form The “Account” on frm...

Get query from Access
Hello, trying to do a query. So I do the following: Data->get external data->New database query, then from the Choose Data source, I choose MS 97 ACCESS DATABASE*, then I select the database. This brings me to the QUERY wizard-Choose columns When I double click on the table/query I want, it doesn't bring the columns to choose. It changes the + sign to - sign but nothing else. I try a different database, and on this one it does work. So not sure why only on one database it works. Any suggestions? Would appreciate it. thanks, Juan ...

Access 2007 Layout View for reports upgraded from Access 2003
I notice that in Access 2007 only those reports newly created in Access 2007 appear to have access to Layout View. In an ACCDB that had been converted from an Access 2003 MDB the reports that had originally been created in Access 2003 do not have access to this feature. Any attempt to do so is met with a "Layout view is unavailable for this Report." message. Is there any way, short of recreating the report and manually copying over its controls and code, to upgrade such reports so that Layout View is accessible? Hi Benjamin, 1. Open the report in design view 2. Open the property s...

I can access any mailbox using OWA 2003
Hi, Exchange Server 2003 By using OWA I can open anyones mailbox. if I enter http://server/user1 in IE i can see user1's mailbox if I enter http://server/user2 i see user2's mailbox. what security setting must i change so that only the logged in user can see his or her own mailbox. thanks Mandy goto Exchange System Manager, servers, server_name, protocols, http, exchange virtual server. goto properties of exchange, click on acess tab, check basic authentication and intehrated windows authentication. Now, only if someone can answer the question I posted this morning. >...

Re: Workflow just wont run automatically, i have to run them manually
Yes, but i realized what i was doing wrong. I assumed [bad idea] that if i create a case and hit Save & Close the first time, taht the rule will run. In order for the rule to run automatically, it has to be Save, once it saves it, then Save & Close. Thanks for your reply. "Hi, Did you check the workflow monitor to see if the rules get triggered correctly and complete sucessfully ? Have a nice day, St=E9phane Dorrekens " --------------= Posted using GrabIt =---------------- ------= Binary Usenet downloading made easy =--------- -= Get GrabIt for free from http://...

Outlook Still Running
I am running XP Pro with Office 2003 Pro and sometimes when I exit out of Outlook, Outlook.exe and Winword.exe stay as processes still running. Does anyone else have this problem and what can do to make sure this does not happen? Thanks for your help -- Neil Remove ABCD from Email address to reply <neil154ABCD@earthlink.net> wrote: > I am running XP Pro with Office 2003 Pro and sometimes when I exit > out of Outlook, Outlook.exe and Winword.exe stay as processes still > running. Does anyone else have this problem and what can do to make > sure this does not happ...

Transferring Trial version files to full version
I bought a copy of Money Delux & Business and started using it. Recently, I purchased a new laptop, which came with a trial version of Money, for a lengthy road trip. After weeks of inputting expenses for the trip, I tried transferring the files to my desktop version of Deluxs & Business. The results was a total failure. It will NOT restore any backup file made in the trial version. It will NOT read a copy of the (non-backup) file from my laptop. I get a variety of error messages including an invalid source path (not true) and statements that my file(s) are write protec...

Very strange problems while running Great Plains on workstations
I notice that a few workstations in an office I support are having problems when they run Great Plains. Excel, Outlook, Word and Dynamics.exe are showing in the Application event log as being Hanging or Faulting. I also see Fault Bucket errors, but when I search online I cannot find any information online. Here is one of the Fault Bucket errors: 3:15:35 pm 28-Sep-06 Application Hang None 1001 N/A Fault bucket 296734104. Also, these workstations are experiencing problems printing PDF files. Has anyone out there seen this behavior and if so, how can these problems be fixed? Thank you, ...