Problems with Exchange Search in 2007

I'm having problems with Exchange Search in 2007.  Accounts that I have 
migrated from 2003 servers are unable to use Exchange Search in OWA.  They 
get the error message "Search results may take a long time to appear because 
Microsoft Exchange Search is unavailable.  Results will not include matches 
in the e-mail body."  Accounts that are created new with their mailboxes on 
2007 servers do not have this problem.  Test-ExchangeSearch returns False for 
migrated users, True for newly created ones.  The search service is running 
and indexing is enabled for this database.  I used the performance counter to 
make sure the indexing service has completed its crawl of the database.  

Any ideas?  Anyone else see the same behavior?  I'm still in the pilot phase 
of my 2007 migration, so I only have a few accounts that have been migrated, 
but this seems to hold true for all of them, and it's true on seperate 
mailbox servers.  
0
Moore (21)
3/13/2007 5:04:33 PM
exchange.admin 57650 articles. 2 followers. Follow

3 Replies
554 Views

Similar Articles

[PageSpeed] 10

On Mar 13, 10:04 am, D.  Moore <D.  M...@discussions.microsoft.com>
wrote:
> I'm having problems withExchangeSearchin 2007.  Accounts that I have
> migrated from 2003 servers are unable to useExchangeSearchinOWA.  They
> get the error message "Searchresults may take a long time to appear because
> MicrosoftExchangeSearchis unavailable.  Results willnotinclude matches
> in the e-mail body."  Accounts that are created new with their mailboxes on
> 2007 servers donothave this problem.  Test-ExchangeSearch returns False for
> migrated users, True for newly created ones.  Thesearchservice is running
> and indexing is enabled for this database.  I used the performance counter to
> make sure the indexing service has completed its crawl of the database.  
>
> Any ideas?  Anyone else see the same behavior?  I'm still in the pilot phase
> of my 2007 migration, so I only have a few accounts that have been migrated,
> but this seems to hold true for all of them, and it's true on seperate
> mailbox servers.  

Hi there -

We are seeing the same thing.  However, it isn't every account that
we've migrated that is displaying the behavior, only a select few.
There doesn;' appear to be any rhyme or reason for which accounts are
affected.  Very strage.  Please post back if you find a solution and I
will do the same.

Wren

0
3/20/2007 1:59:01 AM
I'm havign exactly the same problem, some mailboxes moved to 2007 from 
Exchange 2003 search fine and some don't, no obvious pattern.

"Test-ExchangeSearch" returns true for the ones that work and false for the 
ones that don't, all mailboxes in the same database.

No obvious way to fix the broken mailboxes and I don't want to start 
migrating user mailboxes to Exchange 2007 until I find out how to fix it.

Anybody come across a way to get search working on all the mailboxes yet?

Thanks

Peter Lawton

<wrenbusiness@gmail.com> wrote in message 
news:1174355941.474895.62540@l75g2000hse.googlegroups.com...
> On Mar 13, 10:04 am, D.  Moore <D.  M...@discussions.microsoft.com>
> wrote:
>> I'm having problems withExchangeSearchin 2007.  Accounts that I have
>> migrated from 2003 servers are unable to useExchangeSearchinOWA.  They
>> get the error message "Searchresults may take a long time to appear 
>> because
>> MicrosoftExchangeSearchis unavailable.  Results willnotinclude matches
>> in the e-mail body."  Accounts that are created new with their mailboxes 
>> on
>> 2007 servers donothave this problem.  Test-ExchangeSearch returns False 
>> for
>> migrated users, True for newly created ones.  Thesearchservice is running
>> and indexing is enabled for this database.  I used the performance 
>> counter to
>> make sure the indexing service has completed its crawl of the database.
>>
>> Any ideas?  Anyone else see the same behavior?  I'm still in the pilot 
>> phase
>> of my 2007 migration, so I only have a few accounts that have been 
>> migrated,
>> but this seems to hold true for all of them, and it's true on seperate
>> mailbox servers.
>
> Hi there -
>
> We are seeing the same thing.  However, it isn't every account that
> we've migrated that is displaying the behavior, only a select few.
> There doesn;' appear to be any rhyme or reason for which accounts are
> affected.  Very strage.  Please post back if you find a solution and I
> will do the same.
>
> Wren
> 


0
Peter
3/29/2007 3:48:36 PM
On Mar 13, 1:04 pm, D.  Moore <D.  M...@discussions.microsoft.com>
wrote:
> I'm having problems with Exchange Search in 2007.  Accounts that I have
> migrated from 2003 servers are unable to use Exchange Search in OWA.  They
> get the error message "Search results may take a long time to appear becauseMicrosoft Exchange Search is unavailable.  Results will not include matches
> in the e-mail body."  Accounts that are created new with their mailboxes on
> 2007 servers do not have this problem.  Test-ExchangeSearch returns False for
> migrated users, True for newly created ones.  The search service is running
> and indexing is enabled for this database.  I used the performance counter to
> make sure the indexing service has completed its crawl of the database.  
>
> Any ideas?  Anyone else see the same behavior?  I'm still in the pilot phase
> of my 2007 migration, so I only have a few accounts that have been migrated,
> but this seems to hold true for all of them, and it's true on seperate
> mailbox servers.  

ResetSearchIndex -Force -All

The above powershell cmd fixed this for me.

0
4/18/2007 2:09:46 AM
Reply:

Similar Artilces:

Problem shortcuts in Word
Hello, I work with Word 2008. In the beginning there is no problem, but suddenly i have problem with shortcuts. When i want to do "cmd c" it make an other shortcuts same thing for "cmd s", "cmd v" and surly some other. But when i write there is no problem "c" is "c"... If somebody have an idea please help me. Thank you. Unless you indicate your specific update level of Office as well as OS X & describe what the keystrokes *are* doing contrary to what you expect there isn't much we can offer. -- Regards |:>)...

encoding problem in Outlook 2007 importing Outlook 2000 personal folders
I use Outlook 2007 to import the pst file of Outlook 2000. The Chinese characters in the subject became unreadable but it's ok to display in message body. In Outlook 2000, there's no problem to display the Chinese characters in the subject. What's wrong with Outlook 2007? What setttings should I change to fix the problem? Thanks. cyl <u8526505@gmail.com> wrote: > I use Outlook 2007 to import the pst file of Outlook 2000. The Chinese > characters in the subject became unreadable but it's ok to display in > message body. In Outlook 2000, there's no problem t...

Outlook 2003 PST problems
I just installed Office 2003 professional on a new computer & am having problems with outlook. I copied my Outlook.pst file into the appropriate directory & although it is recognized the calendar is not working properly. I cannot attach any of the colored labels to my appointments - so everything is pretty much in black & white. I totally uninstalled & reinstalled office... first removing my pst file... but there appears to be an ini file... or something that is retaining some information... does anyone know of a fix for the labels... or how to TOTALLY uninstall office (so I...

Outlook 2007 and Windows 7
After installing Office 2007 on Windows 7 machine, I get no new mail sound, pop up notifications or the new unread mail icon in task bar. Every thing else seems to work fine. Any hints? are the icons in the overflow? -- -- Diane Poremsky [MVP - Outlook] Outlook Tips: http://www.outlook-tips.net/ Outlook & Exchange Solutions Center: http://www.slipstick.com/ Outlook Tips by email: mailto:dailytips-subscribe-request@lists.outlooktips.net EMO - a weekly newsletter about Outlook and Exchange: mailto:EMO-NEWSLETTER-SUBSCRIBE-REQUEST@PEACH.EASE.LSOFT.COM Poll: What v...

Problem with Authentication
The CRM application was running smooth. But now I can't logging. It ask my credentials and than return a 401.1 error. I had already reinstalled the CRM server but it won't work. I'm accessing it in the same local network. I'm running CRM 3.0 in SBS. Best regards, Erico Hi When you open a Internet explorer and type the name of the CRM server, it prompts for user and password ? Are you logged in with domain credentials ( AD user ) ? If you are, so add url of the crm server in Local intranet. Enable "Automatic logon only in intranet", this is under security,c...

Project 2007 Work Field Formula to Exclude Work Done by Resources Not in a Resource Group
I have a workshop task in my project schedule which is worked on by Resources from my company (Resource Group = VENDOR) and resources in the client's company (Resource Group = CLIENT). I need a formula to calculate WORK hours for ONLY the resources in Resource Group = VENDOR. I want to drop any hours that the CLIENT spends on the task and only calculate VENDOR hours. Does anyone have a formula? I am familiar with Project, but have not used formulas before. Could not find a formula to do this in any of the other forums on the net.. Thanks! +------------------------...

Trying to remove the last Exchange 5.5 server from my site
I ran the exchange administrator from my 2003 exchange server and tried to delete the 5.5 server. I get an error message: "Extension 'MSFB' could not be loaded". Has anyone seen this? Thanks, Rusty http://support.microsoft.com/default.aspx?scid=kb;en-us;822450&Product=ech E "Rusty" <anonymous@discussions.microsoft.com> wrote in message news:367e01c3aa25$d8731b40$a601280a@phx.gbl... > I ran the exchange administrator from my 2003 exchange > server and tried to delete the 5.5 server. I get an error > message: "Extension 'MSFB'...

Vista blue screen problem...please help!
I've seen some other threads, here are the dump files: 'RapidShare: 1-CLICK Web hosting - Easy Filehosting' (http://rapidshare.com/files/347103149/Minidump.rar.html) Please, help me out here. -- ceVil It might be better to know at what point the bsod occurs and what the actual err.msg given is "ceVil" <guest@unknown-email.com> wrote in message news:0b9a0c60b90bf6c0be88bda30f2820ab@nntp-gateway.com... > > I've seen some other threads, here are the dump files: > 'RapidShare: 1-CLICK Web hosting - Easy Filehosting' > (...

calendar problem
Dear all, I am using both mail and calendar function in outlook 2002. Everything is ok until recently, when I try to make a new appointment or checking any old appointments, an error message "out of memory or resource, try to close some windows..." pop up. The mail function is still ok. Can anyone tell me how can I solve this? I have already installed sp2. The version of office is the professional one with frontpage. Thanks. tp ...

problem #4
Hi, I am facing this new problem... i.e a user has installed Office 2003 on win2k prof platform.. whenever she is working on a outlook.. she gets a Microsoft error message... saying to send the report or don't send the report... Usually I have seen this problem in IE... But for outlook it is new to me... after clicking on send or don't send report.. the outlook closes. And there are no IE open..... and if atall it is open.. the IE does not close... Need your help regards, KAH What is logged to the Event Viewer regarding this? Try one of the following already; http://www.howt...

Exchange 2003 #6
How do I save the messages on my Exchange (20030 Server rather than the workstations??? ...

95 and 97 problem
For some unknown reason there is Excel 95 and 97 on this pc.When i double click on an Excel file, the pc defaults to the 95 program (Which incidently doesn't work properly). So my question is how do i get the pc to default to 97. Cheers Craig Craig, Have a look at Windows Help. From Windows 2000 Help (Index under Programs Associating with File Types) To change which program starts when you open a file In My Computer or Windows Explorer, on the View menu, click Folder Options. Click the File Types tab. In the list of file types, click the one you want to change. Click Edit. In Act...

Microsoft exchange server #2
I reinstalled Microft Office due to hard drive problems. Now it is asking for "Microsoft Exchange server" and "Mailbox". What do I put in "Microsoft Exchange server" box? What do I put in "Mailbox" box? acanduds@hotmail.com Dick <anonymous@discussions.microsoft.com> wrote: > I reinstalled Microft Office due to hard drive problems. > Now it is asking for "Microsoft Exchange server" > and "Mailbox". > What do I put in "Microsoft Exchange server" box? > What do I put in "Mailbox" box? Were ...

Date problem
I can't believe there's no post on this, but I can't find it. I've tried the solutions I could find (see below) and still get the error: "The expression is typed incorrectly or it is too complex to be evaluated. For example....Try simplifying...." I have a date field, formatted as Date/Time, General Date, default Value = Now(). I like having the date and the time - in case we need it. I want to run a report on calls taken just for one day. I have CallDate: CallDateAndTime in my query, with "criteria" as Between ([Forms]![frmReports]![txtStartDate]) A...

sync problems
I have all of my info on an HP Ipac. I had to reformat the hard drive and I did not make a back-up file. I am trying to move everything back to the computer but it says there is an error with syncing it. How can I move everything from the PDA back to Outlook again? Please help- thanks ...

Office 2007 - HELP
I have used Word for many years and love it - not too thrilled with the changes in Office 2007, but my bigger issue is with Publisher 2007. I have an image that I have used in Word just fine - meaning, the on screen colors are correct and when printed the colors are correct. Someone sent me a Publisher file and asked me to add the image - I did this - now the image is messed up - the colors are correct on screen, but when printed FROM MY computer the image colors are all wrong - but if I transport the file to a different computer it prints fine I have reinstalled Office - no good Any id...

Installation Problem!!
I am having a problem installing MSCRM 1.2. My configuration consists of a Domain Controller running Win 2000 Server SP4 . I am trying to install MSCRM on a member of the domain running Windows 2000 Server SP4. There is a DNS Server on the DC which is integrated with AD, and a SQL Server 2000 running on the Win 2K machine. The install errors out when CRM creates the root business with the message: Setup was unable to install Microsoft CRM Server. Setup was unable to provision your organization. Setup was unable to create the root business. The configuration of ASP.NET seems to be ok, the pr...

Problems Creating a disclaimer in Exchange 2003
I am trying to create a server based disclaimer that will stamp all of my smtp emails going to the internet. I have been following KB article 317680 with no luck. I get an error like the one below. Binding Display Name Specified: smtpscriptinghost ** Registration Failed ** Err.Number (HRESULT) = 0x1AD Err.Description = ActiveX component can't create object ProgID = cdo.ss_smtponarrival COM Category = {FF3CAA23-00B9-11d2-9DFB-00C04FA322BA} Corresponding Event = onarrival ** Have you registered your sink COM class on this machine? I am puttin...

Resource editor problems
Hello all, Under VC++ 7.1... Please consider these two lines: IDC_ARROW_ADD_CANCEL DISCARDABLE "res\\cur00004.cur" IDC_ARROW_ADD_CANCEL CURSOR DISCARDABLE "res\\cur00004.cur" The second is a hand-edited change to the first. Both will compile just fine in the resource compiler. However, after I use a text editor to make this change, I cannot open the .rc file in the resource editor. The resource editor issues the following error open attempting to open the .rc file: error RC2135 : file not found: CURSOR Can anyone shed light on what's going on here? Thanks, Dave ...

Quote won't merge to Word 2007
Attempting to print a quote. Opens up Word 2007 with note to press the CRM button in either the Add-in ribbon or the MailMerge ribbon. It shows up in neither. Macros are enabled. Is this issue isolated to one client? Do you have the CRM Client for Outlook installed? If so you can initiate Mail Merge from the Outlook client as this method does not use a Macro. Regards Dan "mnicks" <mnicks@discussions.microsoft.com> wrote in message news:3EF7E431-ADFE-478B-B79F-886F5ACA19EA@microsoft.com... > Attempting to print a quote. Opens up Word 2007 with note to press the ...

Directory Replication Problem #2
Hi, recently my Exchange Server directory database receives changes from other servers but does not send out its own changes. Check from the knowledge base, to correct the USN discrepancy need to use Authrest.exe (need to amke changes for about 100+ users). Does anybody know where to get this file 'Authrest.exe' for exchange server 5.5? Exchange server 5.5 CD only provide this file for ver.4.0. Have anyone use it before? Regards, "Sharon Tan" <sharon_tansk@yahoo.com.sg> wrote: >Hi, recently my Exchange Server directory database >receives changes from ot...

Oulook Clients Keep Disconnecting from Exchange server
I have a remote location that has a few Outlook clients that are complaining that they keep going into offline mode or get cannot connect to the Exchange server, or get login/pass boxes in Outlook. I don't seem to have this problem with the rest of the network and since the users in question are still logged into the domain and have access to all their shared resources from the server and can still connect to the Internet I can only assume this is an Outlook - Exchange issue. If the users close outlook and re-open it that sometimes works for a bit, same with logging out and back in again...

Cell Format
I have a spreadsheet with cells that I'm trying to type the date into. I type in the date exactly like this: 09/26/03. When I hit "enter" MS Excel displays "37890" in the cell. No matter what I do I can't the cell to show: 09/26/03. I think that somehow I need to "strip" the cell of what it's original format is, but I can't figure out how. I try to use the Date option in the format cell screen but it doesn't work. Curtis I tried this and it didn't work. I also tried the "Text to columns" feature. No success. >...

User Defined Variables in MS query cause a problem to import data
If I use user defined variables in MS query to import data into excel sheet, the query executes but no data gets imported into the excel sheet. If I get rid of the variable the results can be imported into the Excel sheet. ...

Excel 2007 chart text box bug
Just found what looks like a bug with charts in Excel 2007. In Excel 2003 I could add a text box to a chart and then assign a formula to it, say =B30. The value in B30 would then appear in the text box. If I insert say 5 rows and three columns above B30, the fomula would adjust and become =E35. When I do the same in Excel 2007, the formula for the box says as =B30 The workaround is to use range name, ie, =rangename. However, that adds lots of extra steps. And users have to know to do and know that Excel 2007 behaves differently. No logic in the change, so it most likely is a bug. ...