E2K3 Forestprep question

Hello,

I'm preparing to start my "swing" migration from E2K to E2K3.

Because students will be back in a week, I'd like to get the 
ForestPrep/Domainprep steps done now, even though I won't be starting the 
actual migration (first E2K3 server install) for about a month.

In reading what I can find on the E2K to E2K3 migration it appears that 
running ForestPrep and DomainPrep in my site won't cause me any problems 
except that ForestPrep will lock down Top level PF creation (which is already 
locked down) and likely remove the permissions I have added for 'backup' 
exchange account to access the Exchange objects (second account added to use 
the Exmerge utility).

Am I missing anything else that these two steps will do to my Exchange site 
[especially bad things that might disrupt email functionality].

Also, can the DEPLOYMENT TOOLS be run from a non-exchange admin account - 
that is, the Root Admin account that I will run Forestprep from is not an 
exchange admin account.  Do I still need to run the deployment tools prior to 
running Forestprep as I've seen recommended, if so will this work under this 
account.


Site Information
-------------------
- two  E2Ksp3 background (mailbox/public folder) servers
- one  E2Ksp3 foreground (OWA) server
- site was migrated from 5.5 but ADC has been de-installed and site is 
running E2K NATIVE mode.
- E2K servers in User domain, Root domain only exists for AD updates (no 
users) (only these two domains exist in the Forest).
- AD is running on all W2K3sp1 DCs but forest & domains are still running in 
W2K mode)

-- 
Bill
0
BillMT (8)
1/6/2006 5:18:04 PM
exchange.admin 57650 articles. 2 followers. Follow

3 Replies
593 Views

Similar Articles

[PageSpeed] 30

You shouldn't need to run the deployment tools.  My understanding is that 
they simply give you a checklist to run through.

As far as Forestprep, one of the things that it does is place a Deny for the 
Exchange Domain Servers group at the Exchange server level for the Receive 
As permission.  You may recall that with Exchange 2000, if you wanted to 
gain full mailbox access to all mailboxes, all you had to do was add 
yourself to the Exchange Domain Servers group.  This change prevents that. 
Just something to be aware of if you have used this method to grant access 
to all mailboxes.  This may be what you were referrng to with permissions 
removed, not sure.  If that's the case, it's easy enough to give it 
permissions again.

-- 
Ben Winzenz
Exchange MVP
MessageOne
Read my blog!
http://winzenz.blogspot.com
http://feeds.feedburner.com/winzenz (RSS Feed)


"Bill-MT" <BillMT@news.postalias> wrote in message 
news:B3229997-A543-417D-B7A8-ABB65D3D2E74@microsoft.com...
> Hello,
>
> I'm preparing to start my "swing" migration from E2K to E2K3.
>
> Because students will be back in a week, I'd like to get the
> ForestPrep/Domainprep steps done now, even though I won't be starting the
> actual migration (first E2K3 server install) for about a month.
>
> In reading what I can find on the E2K to E2K3 migration it appears that
> running ForestPrep and DomainPrep in my site won't cause me any problems
> except that ForestPrep will lock down Top level PF creation (which is 
> already
> locked down) and likely remove the permissions I have added for 'backup'
> exchange account to access the Exchange objects (second account added to 
> use
> the Exmerge utility).
>
> Am I missing anything else that these two steps will do to my Exchange 
> site
> [especially bad things that might disrupt email functionality].
>
> Also, can the DEPLOYMENT TOOLS be run from a non-exchange admin account -
> that is, the Root Admin account that I will run Forestprep from is not an
> exchange admin account.  Do I still need to run the deployment tools prior 
> to
> running Forestprep as I've seen recommended, if so will this work under 
> this
> account.
>
>
> Site Information
> -------------------
> - two  E2Ksp3 background (mailbox/public folder) servers
> - one  E2Ksp3 foreground (OWA) server
> - site was migrated from 5.5 but ADC has been de-installed and site is
> running E2K NATIVE mode.
> - E2K servers in User domain, Root domain only exists for AD updates (no
> users) (only these two domains exist in the Forest).
> - AD is running on all W2K3sp1 DCs but forest & domains are still running 
> in
> W2K mode)
>
> -- 
> Bill 


0
Ben
1/6/2006 5:50:49 PM
> You shouldn't need to run the deployment tools.  My understanding is that 
> they simply give you a checklist to run through.
>
    Thought so, makes sense.

> As far as Forestprep, one of the things that it does is place a Deny for the 
> Exchange Domain Servers group at the Exchange server level for the Receive 
> As permission.  You may recall that with Exchange 2000, if you wanted to 
> gain full mailbox access to all mailboxes, all you had to do was add 

I did a google search for "full mailbox access to all mailboxes" and 
retrived KBs: 821897, 262054, 823143, 273642 and 322312

Ben - Thanks for letting me know what I needed to look for.
And Thanks MS for this Technet forum and the above KB articles.

I expect to do the FORESTPREP step in my production AD forest after 
digesting all the information I have retrieved. - bill.
0
BillMT (8)
1/8/2006 6:16:03 PM
Hello Bill,

Thank you for posting here!

I am glad to hear that the issue is fixed and thank Ben for experience 
sharing! Ben, I appreciate your efforts on this issue. 

Firstly, the Exchange Server 2003 Deployment Tools were created to 
proactively help with Exchange Server 2003 deployments in a way that PSS 
and customers had not had before. The installation of Exchange Server 2003 
may become long and complex, even in a small organization. These tools may 
help you to resolve issues that might occur so that you do not have to 
contact PSS. These tools also give PSS a way to help you troubleshoot 
Microsoft Exchange Server 2003 Setup issues by helping you gather data to 
troubleshoot a particular problem. Therefore, it is not necessary to run 
the Exchange Server 2003 Deployment Tools in the installation process. 

For more detailed information, you can refer to the following Knowledge 
Base article:

812593 Exchange Server 2003 Deployment Tools overview
http://support.microsoft.com/default.aspx?scid=kb;EN-US;812593

Secondly, after running Exchange 2003 ForestPrep, Admin accounts are unable 
to access all mailboxes. This is due to permissions changes in Exchange 
2003 to tighten the security of mailboxes and only allows access to those 
we really want to give access to. So, this in turn ends up requiring us to 
explicitly go in and give those groups access, where before they had access 
by default.

If you want to remove these denies, you can refer to the following 
Knowledge Base article:

821897 How to assign service account access to all mailboxes in Exchange 
Server
http://support.microsoft.com/?id=821897 

If you need further assistance on this issue, please feel free to let us 
know. I am glad to help. 

We look forward to working with you again here in the newsgroup.



Regards,

Martin Qiu
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security

When responding to posts, please "Reply to Group" via your newsreader so 
that others may learn and benefit from your issue.
=====================================================
Business-Critical Phone Support (BCPS) provides you with technical phone 
support at no charge during critical LAN outages or "business down" 
situations. This benefit is available 24 hours a day, 7 days a week to all 
Microsoft technology partners in the United States and Canada.

This and other support options are available here:

BCPS: 
https://partner.microsoft.com/US/technicalsupport/supportoverview/40010469 
Others: https://partner.microsoft.com/US/technicalsupport/supportoverview/

If you are outside the United States, please visit our International 
Support page:
http://support.microsoft.com/common/international.aspx
=====================================================

This posting is provided "AS IS" with no warranties, and confers no rights.

0
v-mqiu (26)
1/9/2006 9:32:27 AM
Reply:

Similar Artilces:

question on os authenticity
I purchased a laptop with Windows 2000 preinstalled from a dealer who claims to be a Microsoft Authorized Refurbisher. There was no COA attached to the body of the computer and he claims that he was not required to because he owns the license to it, not me. Is this correct? -- julesrh77 Good question but not for this community. You need to post your question in a Windows community. But, I think he's wrong and you should call Microsoft directly to ask them. You can find their phone number by going to www.microsoft.com. -- Charles Allen, MVP "julesrh77" wrote: > ...

Defender question
I used to be able to scan with Windows Defender in a few minutes. Now it takes hours. What's up with that? Chet Is the quick scan or a full scan running? -=- "Chester GS" wrote: > I used to be able to scan with Windows Defender in a few minutes. Now it > takes hours. What's up with that? > > Chet Chester GS wrote: > I used to be able to scan with Windows Defender in a few minutes. > Now it takes hours. What's up with that? More stuff to scan? More applications installed and running? You used to do Quick Scans and now you a...

receipt question
This one should be easy :) If I set the Receipt Count to 2, how do I get the epson TM-T88IV printer to cut inbetween the two copies? Thanks In Store Operations Manager - Receipt Format Properties, set CC Paper Cut Percent (OPOS) to 75 "christian" wrote: > This one should be easy :) > > If I set the Receipt Count to 2, how do I get the epson TM-T88IV printer to > cut inbetween the two copies? > > Thanks ...

Capabilities Question
Hi, Being a developer I thought I would go to the source! Sorry if this is a sort of sales question. Do you think the Service module would cater for a Web Design Company job system? We currently use a SharePoint service to do this but like the looks of Dynamics. Core parts of the system should; 1. Jobs Description 2. Time & Cost Management 3. Job Status (New, Awaiting Customer, etc) 4. Reporting 5. Task logging etc 6. Maintenance Contracts (Ie Pay $x up front and service times deducted from allowance) Do you think Dynamics can handle this and would I need to mod it? Thank...

"If" question
I have a form ... frmExhibitor and from that form I can open frmAccounting displaying only the data the pertains to the exhibitor selected in frmExhibitor. However, I would like to have an if that states if there is data for frmAccounting open to that data, if not then open a new form. How would I do this? margaret, The OpenForm method has a "Where" argument. frmExhibitor should have a key unique identifier, the value of which, pertains to just that record and no others. Example would be CustID. So, when opening frmAccounting use the Where argument... DoCmd.OpenF...

User Form Display Question
My problem is that the User Form is to big to fit on the Screen. It works good on 1 Computer, but when I use A computer with a smaller Screen it becomes way to big. When that happens 30% of the Form is cut off. Is there a code that I can run on UserForm_Initialize that will size it for the Screen. It would be nice if it would size according to the Display settings. I found this code here in the forumn but I can't get it to work. Sub size_form_and_controls() Dim start_height As Long Dim start_width As Long Dim new_height As Long Dim new_width As Long Dim height_ratio...

E2K3 Forestprep question
Hello, I'm preparing to start my "swing" migration from E2K to E2K3. Because students will be back in a week, I'd like to get the ForestPrep/Domainprep steps done now, even though I won't be starting the actual migration (first E2K3 server install) for about a month. In reading what I can find on the E2K to E2K3 migration it appears that running ForestPrep and DomainPrep in my site won't cause me any problems except that ForestPrep will lock down Top level PF creation (which is already locked down) and likely remove the permissions I have added for 'backup...

service pack upgrade question
we are installing a newer service pack and have verified that only 1 of our 3rd party products needs to be upgraded at the same time whats the preferred method to install sp uninstall 3rd party reinstall newer version od 3rd party reboot as needed or uninstall 3rd party run sp install 3rd party reboot as needed How about, Consult with ISV to determine best course for upgrade for "third-party", then install service pack, then upgrade third-party based on ISV recommendations. Best regards, -- MG.- Mariano Gomez, MIS, MCP, PMP Maximum Global Business, LLC http://www.maximumgloba...

CRM Outlook Client installed on Citrix Question w/Flex Profiles
We have begun deploying CRM Dynamics 3.0 in our environment. All of our clients launch Outlook through Citrix MetaFrame XPe FR3 servers. The CRM Outlook client installs correctly the first time and everything works correctly. However, the next time Outlook is launched the CRM toolbar icons and the CRM menu items do not respond. We are using flex profiles with ops files capturing the HKCU settings for CRM. Here is a copy of our ini file: # REMOVE unused sections! [Header] Version = 11.0 Product = Microsoft Office 11.0 # ***************************** Registry Sections *********...

PFMigrate error when attempting to migrate PF from 5.5 to E2k3
All, When we run PFMigrate from our Exchange 2003 server we get an error right away saying: Invalid Paramater '<servername>' The server name does have a dash in it like this: it-server-name any help would be great!! fasteddie After following syntax EXACTLY we got it to work... thanks, Fasteddie "FastEddie" <fasteddie[a]therockwells[dot]net[dot]no[dot]spam> wrote in message news:OjyqXCwAFHA.608@TK2MSFTNGP15.phx.gbl... > All, > > When we run PFMigrate from our Exchange 2003 server we get an error right > away saying: > > Invalid Par...

Newbie to Outlook
I finally made the jump to Outlook (Outlook 2002 from Office XP in this case) from Outlook Express and I have some questions, please. 1) Where do I make a setting so that I will automatically start a download of my mail when Outlook starts? Currently I a) can wait the 5 miuntes for the next send/receive to happen or 2) I can initiate it manually when I start Outlook. 2) I have 2 phyical hard drives on my system. I want to move my entire Outlook profile to a folder on my second HDD. 3) Can I have multiple identities/profiles with Outlook, to keep my personal mail, contacts, and calendar s...

IIF function question
I have this function in my query: URG_IN: IIf([MCAUTH_URG_IN]"",N,[MCAUTH_URG_IN]). The MCAUTH_URG_IN field can be many letters of the alphabet, but if it is blank I want it to be an "N". Can someone tell me what is wrong with this query? Thanks. You omitted the equal sign and quotes around the 'N'. URG_IN: IIf([MCAUTH_URG_IN]="","N",[MCAUTH_URG_IN]). -- KARL DEWEY Build a little - Test a little "LisaK" wrote: > I have this function in my query: URG_IN: > IIf([MCAUTH_URG_IN]"",N,[MCAUTH_URG_IN]). The MCAU...

ostream question, help please!!!
Hi, Can anyone tell how to reset an ostream object? I used .flush() but it doesn't work. e.g. std::ostream outputstream; outputstream<<"s1"; outputstream<<"s2"; what i want is "s2" but not "s1s2", how to solve it ? Any help will be appreciated! Green by the way, can't create a new ostream object due to the special requirement, and ostream is the type i have to use. thanks in advance! flamesky wrote: > Hi, > > Can anyone tell how to reset an ostream object? I used .flush() but it > doesn't work. > > e.g...

VLOOKUP Question/problem
I am trying to use VLOOKUP to populate a cell in an invoice. It looks to a second page with the prices, and they are designated by a # then a letter, like 1A, 1B, 2A, 2B in column B. Column C is a description, then the values I want returned are in column D. My formula is =VLOOKUP(B11,Prices!B4:D82,3) where I enter say 1A into B11 then it should find 1A in the range and return the value from the 3rd column in the same row as the value 1A. Problem is, it works on some and brings up the wrong value on others. I am just trying to get cell B11 to work properly. Why would it bring up the r...

Two Questions
I am not sure if this should go in here or the VBA group but I have 2 questions I am using Powerpoint 2007 Is there a way in VBA to delete all the footer and date placeholders in the slide master og my prsentation. I do not use them and I have a lot of slide master slide in the presentation Also is there a way in VBA to format all pictures in my presentation so that they use the "soft edge rectangle" format and the "rounded Rectangle" picture shape. I have a full day presentation so it is a lot of pictures to change TIA Q2 Code here should help http:...

legality question
hello, I'm implanting a graph control in my program, if ill use ms graph/chart control will it have any legal issues connected to it? any problems in selling? distributing and etc.? It depends upon the company selling graph/chart control. You will need to contact them. Typically its all spelled out in the license agreement that you got when you purchased the control. -- Ajay Kalra [MVP - VC++] ajaykalra@yahoo.com "fima" <fkpkot@gmail.com> wrote in message news:Oy0iH2UPGHA.648@TK2MSFTNGP14.phx.gbl... > hello, > I'm implanting a graph control in my program,...

very general mail question
Hi, I just tried to send an e-mail after copying and pasting the e-mail address from a Contact (from Outlook 2007, Vista Home Premium, SP1). The message could not be sent. There were no error messages and I had no idea why this message could not be sent. For some reason the address was enclosed with single apostrophes ..... 'name@something.com' I tried copying the same e-mail address again and this time those apostrophes did not appear and the message was in fact sent. As a test I tried sending my self a message by enclosing my own valid e-mail address with enclosed with si...

Requey Question?
On my Switchboard [frmMain] I have a Combobox [cmbTaxWarning] it shows clients through a query which Clients have not been taxed My problem is when I go to my Clients form and change him to No Tax then go back to frmMain my combo box dose not show the change unless I close the DB and open it............Any Help Please.....Bob "Bob V" <rjvance@ihug.co.nz> wrote in message news:e50a1Wc7HHA.4304@TK2MSFTNGP03.phx.gbl... > On my Switchboard [frmMain] I have a Combobox [cmbTaxWarning] it shows > clients through a query which Clients have not been taxed > My probl...

E2K3: System Manager Public Folder Admin authentication dialogues
I am in the process of moving from an Exchange 2000 server to 2003. The 2003 server is up and running and part of my clients are on the new box. I used the PFMigrate tool to add replicas of the eixsting E2K public folders to the E2K3 server and it's working great. However, when I go to adminster the public folders (for replication settings, etc) in System Manager on the E2K3 server, it prompts me for authentication on each and every subfolder :-( My authentication is valid and works - but it always prompts me for it. If I Choose "Connect to:" and select the E2K server ins...

Question about antivirus for Exchange 2003
I currently use Mcafee groupshield for exchange 5.5 and while it does block infected attachments, it still sends the email message to the user which generates alot of complaints. I am ugrading to Exchange 2003 and this time I want to get something that is a little more flexible and can block not only the attachment, but the message too. I will look into the latest Mcafee solution, but wanted to hear about the experiences of others on this NG. Thanks NH Hi Ned, I'm using McAfee GroupShield for Exchange 2003. For your information, the software still behave exactly as you mentioned in...

MDI, beginner questions
Im trying to find the best way for me to implement multiple mdi child windows with dialog layout. My application will need several dialog windows with different layout (sort of like photoshops toolbar windows). All windows will only occur once so there is no need for any new/open/save functionality. I only need MDI to keep all windows organized. Could someone please help me with a simple code example? I've read a bunch of usenet posts, but I still can't figure out a suitable approach for my type of app. Thanks! Fredrik wrote: > Im trying to find the best way for me to implement ...

No more BadMail after applying E2K3 SP1?
After applying Exchange 2003 SP1 to one of our gateway servers, I observe 24 hours later that there are no messages in BadMail. Not usually something I'd complain about, but it is unusual. Prior to applying the service pack, I cleaned up this directory. There were almost half million entries there, testimony to the fact that we ordinarily get a thousand BadMail entries a day typically. The directory was so large that I had to use command line del *.* to accomplish the task. The directory itself appears to be fine and I can create files there without problem. The server is routing message...

IMageView Question
BYTE* ImgBuf; How to display this in a MFC SDI app environment?. drawdibdraw, bitblt,etc?. -- Sent by techquest from fastmail in field fm This is a spam protected message. Please answer with reference header. Posted via http://www.usenet-replayer.com there is a function CreateBitmap of class CBitmap that should do the trick but you will need additional info other than a byte pointer u753143310@spawnkill.ip-mobilphone.net (techquest@fastmail.fm) wrote in message news:<l.1068400795.1804840087@netblock-66-159-221-167.dslextreme.com>... > BYTE* ImgBuf; > How to display this i...

SetTimer() question
I'm using the timer function 'SetTimer()' and 'KillTimer()' function to start and stop the animation. The problem is, the animation pauses during the call to the Sleep() function or call to a function that takes a long time to complete processing. What can I do so that the animation does not pause. Thank you Put the long process in a seperate thread. Or Pump messages in between your long process. You can also change your sleep to do something like this void CMyApp::Wait(DWORD HowLong) { MSG Msg; DWORD Start = GetTickCount(); while (Start + HowLong > GetTickC...

Managing E2K3 from my workstation
Hi, I know that I can manage our Exchange Server 2003 from my XP Pro client. Where can I get the necessary tools for this? -- Thanks, Sam Install Exchange System Manager from the Exchange CD "Sam" <Sam@discussions.microsoft.com> wrote in message news:3982475B-22B0-4F25-ABF8-A142D9570661@microsoft.com... > Hi, > > I know that I can manage our Exchange Server 2003 from my XP Pro client. > Where can I get the necessary tools for this? > -- > Thanks, > > Sam You might also want to check on this link. http://support.microsoft.com/kb/815529/en-us...