Does IIS/OWA store messages sent internally in the STM dbase?

Hello,

I'm rolling-out an E2k3 server on a new isolated network for 500 users.
Initially, they'll use OWA until we can get Outlook 2003 deployed on
all the PCs.

Since it's an isolated network, i.e., permanently cut-off from any
other network, messages will only ever be sent from one internal user
to another. Apart from OWA, they'll never use non-MAPI clients. A
couple of internal applications will submit a very small amount of mail
via SMTP - but the messages wil only be automatic notifications to
which users will never respond with a message.

My question is if OWA will use the STM database in that scenario? If
not, I want to put the EDB and STM dbases on the same physicial disk
without taking a significant hit in performance or risk of data loss.

Thanks for any advice,

- Alan.

0
bruguy (167)
10/7/2006 6:58:12 PM
exchange.admin 57650 articles. 2 followers. Follow

4 Replies
493 Views

Similar Articles

[PageSpeed] 56

On 7 Oct 2006 11:58:12 -0700, "Alan" <bruguy@gmail.com> wrote:

>Hello,
>
>I'm rolling-out an E2k3 server on a new isolated network for 500 users.
>Initially, they'll use OWA until we can get Outlook 2003 deployed on
>all the PCs.
>
>Since it's an isolated network, i.e., permanently cut-off from any
>other network, messages will only ever be sent from one internal user
>to another. Apart from OWA, they'll never use non-MAPI clients. A
>couple of internal applications will submit a very small amount of mail
>via SMTP - but the messages wil only be automatic notifications to
>which users will never respond with a message.
>
>My question is if OWA will use the STM database in that scenario? If
>not, I want to put the EDB and STM dbases on the same physicial disk
>without taking a significant hit in performance or risk of data loss.
>
>Thanks for any advice,
>
>- Alan.

I dont think in most cases, there is a good argument for placing stm
and edb files on sep. spindles. 

Each message will have some mapi properties in the rich edb database
regardless, and upon a message being opened by a mapi client or
modified or the mailbox moved to another store, automatic property
promotion to the edb will take place. ( Moving a mailbox promotes the
whole thing to the edb, simply opening a message that is  in the stm
moves everything but any attachment).

To answer the question however, Non-mapi messages, including messages
created in OWA will initially reside mainly in the stm file.  Note
that messages never move from the edb to the stm however, its a
one-way trip to the edb from the stm.

Exch 2007 eliminates the stm file.
0
adavid (8731)
10/7/2006 7:46:59 PM
Thanks for the reply. Very useful info indeed.

I read that if you have a large number of (permanent) POP or IMAP
clients (or I suppose even Entourage clients), then you should put STM
and EDB dbases on different disks. That's why I was wondering which
dbase OWA used.

In my situation, users will initially use OWA then migrate to Outlook
2003 as its deployed. So I guess that most of the messages created in
the intervening period (estimated at 2 months) will automatically be
gradually migrated from STM to EDB as well. Neat!


Andy David - MVP wrote:
> On 7 Oct 2006 11:58:12 -0700, "Alan" <bruguy@gmail.com> wrote:
>
> >Hello,
> >
> >I'm rolling-out an E2k3 server on a new isolated network for 500 users.
> >Initially, they'll use OWA until we can get Outlook 2003 deployed on
> >all the PCs.
> >
> >Since it's an isolated network, i.e., permanently cut-off from any
> >other network, messages will only ever be sent from one internal user
> >to another. Apart from OWA, they'll never use non-MAPI clients. A
> >couple of internal applications will submit a very small amount of mail
> >via SMTP - but the messages wil only be automatic notifications to
> >which users will never respond with a message.
> >
> >My question is if OWA will use the STM database in that scenario? If
> >not, I want to put the EDB and STM dbases on the same physicial disk
> >without taking a significant hit in performance or risk of data loss.
> >
> >Thanks for any advice,
> >
> >- Alan.
>
> I dont think in most cases, there is a good argument for placing stm
> and edb files on sep. spindles.
>
> Each message will have some mapi properties in the rich edb database
> regardless, and upon a message being opened by a mapi client or
> modified or the mailbox moved to another store, automatic property
> promotion to the edb will take place. ( Moving a mailbox promotes the
> whole thing to the edb, simply opening a message that is  in the stm
> moves everything but any attachment).
>
> To answer the question however, Non-mapi messages, including messages
> created in OWA will initially reside mainly in the stm file.  Note
> that messages never move from the edb to the stm however, its a
> one-way trip to the edb from the stm.
> 
> Exch 2007 eliminates the stm file.

0
bruguy (167)
10/7/2006 9:41:07 PM
Initally attachments and certain body parts would be stored in the stm.  As 
you migrated to using outlook, and uses began access via the mapi client, 
those attributes would be promoted to the edb... or ...

You could control the content conversion by doing a movemailbox of those 
users to another store.  This would force the content conversion in a 
predictable way.


"Alan" <bruguy@gmail.com> wrote in message 
news:1160247492.600891.180960@c28g2000cwb.googlegroups.com...
> Hello,
>
> I'm rolling-out an E2k3 server on a new isolated network for 500 users.
> Initially, they'll use OWA until we can get Outlook 2003 deployed on
> all the PCs.
>
> Since it's an isolated network, i.e., permanently cut-off from any
> other network, messages will only ever be sent from one internal user
> to another. Apart from OWA, they'll never use non-MAPI clients. A
> couple of internal applications will submit a very small amount of mail
> via SMTP - but the messages wil only be automatic notifications to
> which users will never respond with a message.
>
> My question is if OWA will use the STM database in that scenario? If
> not, I want to put the EDB and STM dbases on the same physicial disk
> without taking a significant hit in performance or risk of data loss.
>
> Thanks for any advice,
>
> - Alan.
> 


0
John
10/8/2006 12:50:46 AM
Excellent tip! Thanks. We could do that off-peak in batches of say, 100
users, transparently to the users. That would be migrate all of the
messages and not leave any behind.

Would you recommend temporarily turning on circular logging beforehand,
or just rely on the usual daily online backup?


John Fullbright [MVP] wrote:
> Initally attachments and certain body parts would be stored in the stm.  As
> you migrated to using outlook, and uses began access via the mapi client,
> those attributes would be promoted to the edb... or ...
>
> You could control the content conversion by doing a movemailbox of those
> users to another store.  This would force the content conversion in a
> predictable way.
>
>
> "Alan" <bruguy@gmail.com> wrote in message
> news:1160247492.600891.180960@c28g2000cwb.googlegroups.com...
> > Hello,
> >
> > I'm rolling-out an E2k3 server on a new isolated network for 500 users.
> > Initially, they'll use OWA until we can get Outlook 2003 deployed on
> > all the PCs.
> >
> > Since it's an isolated network, i.e., permanently cut-off from any
> > other network, messages will only ever be sent from one internal user
> > to another. Apart from OWA, they'll never use non-MAPI clients. A
> > couple of internal applications will submit a very small amount of mail
> > via SMTP - but the messages wil only be automatic notifications to
> > which users will never respond with a message.
> >
> > My question is if OWA will use the STM database in that scenario? If
> > not, I want to put the EDB and STM dbases on the same physicial disk
> > without taking a significant hit in performance or risk of data loss.
> >
> > Thanks for any advice,
> >
> > - Alan.
> >

0
bruguy (167)
10/8/2006 6:25:19 PM
Reply:

Similar Artilces:

OWA Loading
Hi guys, I have exchange 2003, sp1. I am having problem with OWA, it says loading and sometimes i get only images. I tried searching in this news group, but i couldn't be able to solve the problem, i tried this one on MS http://support.microsoft.com/?ID=280823, it didn't fix the problem too. Any idea? P.S. even after i applied sp1, OWA used to work. Suddenly stops working. Thanks in advance for the help ...

IIS log files filling up my drive
I have a severely under utilized SBS2008R2-sp2 server. It does not support any websites. The files in the web root are the default ones. We use Exchange and store files, and rarely log in remotely. We stopped receiving emails recently and I was asked to find out why. I found the c: drive at 99% full. Exchange is on d: drive. I found 13 gigs of IIS log files and moved them to another drive to fix the problem. But, why is IIS generating so much data? Where can I find information on all the different IIS log file categories? One folder W3SVC1372222313 was a real hog with single ...

IIS Reinstall
Is there a way to remove and reinstall IIS and have it automatically pick up the EXCHANGE Specific stuff for OWA and whatever other ities Exchange has in with IIS? Thanks K You can reset these directories to default permissions but you will need to reinstall Exchange if you want to reinstall IIS. -- John Oliver, Jr MCSE, MCT, CCNA Exchange MVP 2007 Microsoft Certified Partner "Kerry" <Kerry@discussions.microsoft.com> wrote in message news:AFC2BA7F-92B0-4E8F-9E3A-E6231EAF84AF@microsoft.com... > Is there a way to remove and reinstall IIS and have it automatically pick...

You cannot copy or move messages to public folders
I have a few users who get the following error when trying to move messages from their inbox into a public folder - "Can't move the items. You do not have sufficient permission to perform this operation on this object. See the folder contact or your system administrator" I have found the following on microsofts website and have made those changes but it has not solved the issue http://support.microsoft.com/?kbid=330752 has anyone seen this before? I have also downloaded outspy and run this on messages that have failed and on messages that are ok. However im not really su...

How do I move/copy Outlook Express messages from a Win98 PC to an xp for Home PC
Just bouht a new PC with Windows xp for Home. I was able to export to a Zip Cartridge all the Address Book, but when I cannot find a way to export the messages (including all the folders). Could someone tell me a way, or tell me it cannot be done. ...

Corrupted messages within Exchange mailbox
Hi there, We are running Exchange 2000. We have a users' mailbox that is showing up with 2 emails in the inbox that seem to be corrupted. Basically, only the headers show up and the messages can't be moved, opened, or deleted. I would like to perform some kind of clean up on the mailbox, but I'm not sure how to go about that as I'm reasonably new to Exchange. Has anyone got some ideas? Thanks a million! Max What kind of clean up and you talking about? You have a couple of options: ESEUTIL and ISINTEG These are two command line utilities that will require you to take ...

owa
Hello Las week my owa stopped working. I get an 401 and 403 error when I try to access. I've deleted the IIS virtual dirs and cleaned the metabase to restore the IIS to default config. But now, when I try to get the owa page, IIS asks me what is my user and password, I type it and after it shows me a 'site under ocnstruction' page (the default 'site under construction' IIS page). Can anybody help me? Thanks a lot!! Check the default content web page and the home directory is set correctly and available. -- Vinod Kumar "josep LR" wrote: > Hello > ...

urgent (high importance) messages
Is there a way to remote the high importance flag from messages? We have a multitude of users that send all their mail high importance even though the subject is not. Thanks ...

email being sent but not being received
I am using Win7 with Outlook 2007. Comcast is my provider. My computer is about four months old. I can receive e-mails fine but when I send, they are recorded in the sent folder but they are not being received by anyone. I called Comcast and they can't figure it out since everything is working on their end. I have deleted the e-mail account and reset it both manually and let the computer set it. it works for about a week then won't work. I am testing this daily with my Live.com account. HELP!! Outlook was working fine until about a month ago. Are you sure t...

OWA 2003 after upgrade
Hi Wonder if someone can help please? I've recently in-place upgraded our Exchange 2000 standard installation to Exchange 2003 SP2. This resides on a Windows 2000 SP4 standard server. No problems with the upgrade. Everything working fine and dandy. I can access OWA fine, however, it will only display the basic interface and not the premium interface (i.e. no reading pane etc.). This is for both http and https access. I've tried this from various clients inside and outside the LAN and all using web clients IE6 or above. I performed a similar upgrade in a lab environment first a...

Excel and Word Attachments Time Out in OWA
I am having an odd problem in OWA. Many end users are experiencing time out problems when trying to access Word or Excel attachments in OWA on Exchange 2003. It appears to be only Word or Excel as others work fine. OWA is being accessed on a front-end server. However, all attachments work fine when accessed through the back-end server. Any ideas? ...

Problems with OWA 2003
Hi all, perhaps someone can help me here. Our users publish information on Public Folders directly from Office Apps using "File/Send to/Exchange Folder..." option on the menu. This saves the ..doc or .xls file directly on the public folder and not as an attachment (as might happen when you use "Post" from Outlook and attach your file). The problem comes when someone tries to download the file via OWA, the error "403 Forbidden" appears on the screen. If I "Post" a file as an attachment. I can download it without any trouble. Any help will be appreciat...

Where does Outlook 2007 store emails locally?
We are using Outlook 2007 with Exchange server. We have a user who has been moving his emails off of the Exchange server to some folders he created or by Auto Archive feature in Outlook 2007. He basically drag and drop the emails from his Exchange server Inbox to his folders on the left side. The question is, where are all of these folders full of emails located on the local computer? At first I thought it must have been the Auto Archive feature that kicks in every 14 days and created those folders for him to be able to drag and drop, but when I check the following location the archi...

IIS
Hi, I have a functional .aspx page on IIS, I added a IFRAME but nothing is posted in CRM3.0 Thanck You. Hi, Please give some more details for us to comment on your issue. -- PLEASE do click on Yes or No button if this post was helpful or not for our feedback. uMar Khan Email for direct contact: imumar at gmail dot com "ahmed" wrote: > Hi, > I have a functional .aspx page on IIS, I added a IFRAME but nothing is > posted in CRM3.0 > Thanck You. ...

I am not able to send outgoing messages
I am recieving this message when i try to send an email: The message could not be sent. The authentication setting might not be correct for your outgoing e-mail [SMTP] server. For help solving this problem, go to Help, search for "Troubleshoot Windows Mail", and read the "I'm having problems sending e-mail" section. If you need help determining the proper server settings, please contact your e-mail service provider. The rejected e-mail address was 'senders email'. Subject 'Re: Next week?', Account: 'imap.aol.com', Server: 'smt...

Outlook only downloads headers in email, not full message
New computer, first time with Outlook 07. Email messages only download as headers initially. The rest of the message, i.e. the body of the message and any attachments, don't download unless I hit "Send/Receive" again. How do I make it so that I don't have to hit Send/Receive in order to get the whole message. I've already gone into Tools > Send/Receive > Send-Receive Settings and made adjustments there as per Outlook Help, but that didn't fix the problem. Outlook\Tools\Options\Mail Setup\Send/Receive\Edit\Folder Options and set it up there making sur...

How does my wife view her information in outlook that is stored i.
Activated trial version of Office 2003 standard w/new desktop. Wife stored all her contacts, calendar, etc. while in my profile on XP. Log onto her profile today (first time) and see nothing in her Office (calendar, contacts, tasks are blank). How do I tell Office to load the info that has been stored under my XP profile into her Office profile? Shawn <Shawn@discussions.microsoft.com> wrote: > Activated trial version of Office 2003 standard w/new desktop. Wife > stored all her contacts, calendar, etc. while in my profile on XP. > Log onto her profile today (first tim...

Quiet message box with MessageBoxIndirect
I'm trying to make a message box that shows without playing system sound. I've read this could be done with MessageBoxIndirect. I have the following code: MSGBOXPARAMS msg; msg.cbSize = sizeof(msg); msg.hwndOwner = m_hWnd; msg.hInstance = AfxGetInstanceHandle(); //NULL; msg.lpszText = "Hello world"; msg.lpszCaption = "Error"; msg.dwStyle = MB_OK|MB_USERICON; msg.lpszIcon = IDI_ASTERISK; msg.dwContextHelpId = NULL; msg.lpfnMsgBoxCallback = NULL; msg.dwLanguageId = LANG_NEUTRAL; //MessageBoxIndirect returns 0 int ret = MessageBoxIndirect(&msg); //GetLastError r...

Problems accessing other's mailbox using OWA
Hi, I'm running Outlook Web Access (forms based) in Exchange 2003 native mode. Logging into our own mailboxes is fine, but when trying to access another persons inbox, calendar, etc, I get a "Page Cannot be found" error. When in my own mailbox the URL is: https://mailserver/exchange/ In order get into another user's calendar (for example) I'm entering: https://mailserver/exchange/user1/calendar I am listed as a delegate of user1's calendar. Does anyone have any thoughts on what I'm doing wrong? Thanks, Curtis. -- Please reply to news group only. Thank...

ASP.NET 1.1 Website migrated from IIS 6 to IIS 7
Hi all I don't know if this is the correct forum to pose this question. I have an ASP.NET 1.1 web application that I'm required to migrate from an IIS 6 environment (Windows Server 2003) to an IIS 7 environment (Windows Server 2008). I'm experiencing problems with the DHTML menus. In IIS 6 they display the text and the link whereas in IIS 7 it only displays the text, not the link. Is there a patch that I need to install on Windows Server 2008 to rectify this problem? What am I missing? Has anyone else experienced this problem? :confused: I am most confuzzle...

User Mailbox activation through OWA 2003
I have a situation that i need every user created in exchange to have English appearance to folders and interface, you know the default behavior for exchange when a user created, it will not be active until the user login to his mailbox using owa, and takes the user explorer setting lets say french, and transform his interface to french always, can i force exchange to make every new user to have for example French interface (folders) for owa, and dont depend on on user setting. I will appreciate any help in this. - This applied to Exchange 2003 SP2. and windows 2003 DCs Read this artic...

OWA #55
I have been asked by a customer if it is possible to change the http://mydomain.com/exchange to http://mydomain.com/'another name'. I think mostly because their first language is not English, and they would like to use the correct 'mail' translation. Personally I don't see the big issue, but they are the customer, so I want to check and see if it is even feasible before getting back to them. Thanks Mike use multiple hostheaders in IIS /exchange /mail /companymail I think that should do it... Jim "Mick34" wrote: > I have been asked by a customer i...

IIS service
Exchange 5.5 sp4 - does the IIS Admin service need to be running on a plain jane exchange server? We currently have it enabled and started, but want to disable it. I do not know of any problems this will cause, but wanted to verify it. Can someone help and let me know - can I turn this off ? TIA Nancy Stevens Nstevens@tycoint.com I dont see any reason you need it started. On Tue, 15 Jun 2004 17:07:31 -0400, "Nancy Stevens" <nstevens@tycoint.com> wrote: >Exchange 5.5 sp4 - does the IIS Admin service need to be running on a plain >jane exchange server? We curr...

OWA Log in
After upgrading to SP1 When logging in to owa i now have to put domain\username is there a way around this. I all ready set the default domain on the site I changed it in both places i have been serching for days and still no luck as to how to make it work >-----Original Message----- >Did you set it in the Exchange System Manager, or in the IIS Manager? > >-- >Matthew Tisdel >South Carolina > > >"Holden" wrote: > >> After upgrading to SP1 When logging in to owa i now have >> to put domain\username is there a way around this. I all &...

copying all pst folders except draft and sent items from outlook to dard disk
Hi Friends, I have a large 9 pst files, which has many sub folders. I want to copy all the past files from outlook to hard disk except the folders (drafts and send items) I using the code available in the following link site. http://www.vbaexpress.com/kb/getarticle.php?kb_id=875 The above code is copying all the files from selected folder. If the folder contains Drafts and sent items as a sub folders only the sub folder (Drafts and Sent Items) should not copy. I would be greatefull to you if any of you correct the code to avoid drafts and sent items copying outlook to ha...