aqadclmi Error

Hey all,

  When I try and run the aqadclmi command in a batch file or from mapped 
drive I get this:

"CoCreateInstance failed with 0x80040154"

Not being a programmer don’t have a clue what it means. Goggled it but there 
is not a response I can find for this command.

Is there a batch file someone has for doing this?

What we are trying to do is use this command to shutdown the links on our 
bridgehead server if we get a spamm out break during the off hours. The last 
one cost us about 4 days of heck..and allot of peeved off people...

Thanks john


0
Utf
11/20/2009 7:06:01 PM
exchange.admin 57650 articles. 2 followers. Follow

6 Replies
1370 Views

Similar Articles

[PageSpeed] 44

On Fri, 20 Nov 2009 11:06:01 -0800, Tinyski
<Tinyski@discussions.microsoft.com> wrote:

>Hey all,
>
>  When I try and run the aqadclmi command in a batch file or from mapped 
>drive I get this:
>
>"CoCreateInstance failed with 0x80040154"
>
>Not being a programmer don�t have a clue what it means. Goggled it but there 
>is not a response I can find for this command.

I believe this is "Class not registered". Does it work if you run the
tool directly from the command line?
---
Rich Matheisen
MCSE+I, Exchange MVP
0
Rich
11/20/2009 7:43:09 PM
Rich,

  Yes it works if I'm on the server from a dos window, but if I try and run 
a batch job with the command in it from a mapped drive I get the error....If 
I run the batch job from the dos window on the server it works also. 

john

"Rich Matheisen [MVP]" wrote:

> On Fri, 20 Nov 2009 11:06:01 -0800, Tinyski
> <Tinyski@discussions.microsoft.com> wrote:
> 
> >Hey all,
> >
> >  When I try and run the aqadclmi command in a batch file or from mapped 
> >drive I get this:
> >
> >"CoCreateInstance failed with 0x80040154"
> >
> >Not being a programmer don’t have a clue what it means. Goggled it but there 
> >is not a response I can find for this command.
> 
> I believe this is "Class not registered". Does it work if you run the
> tool directly from the command line?
> ---
> Rich Matheisen
> MCSE+I, Exchange MVP
> .
> 
0
Utf
11/20/2009 8:22:01 PM
On Fri, 20 Nov 2009 12:22:01 -0800, Tinyski
<Tinyski@discussions.microsoft.com> wrote:

>  Yes it works if I'm on the server from a dos window, but if I try and run 
>a batch job with the command in it from a mapped drive I get the error....If 
>I run the batch job from the dos window on the server it works also. 

If your use of "mapped drive" means you're trying to run the tool on a
machine that's not the Exchange server whose queues you're trying to
manage, the error you get is because the necessary software isn't
installed on the machine that's trying to run the tool. You can try
installing the Exchange Management Tools on the machine and see if
that fixes your problem.
---
Rich Matheisen
MCSE+I, Exchange MVP
0
Rich
11/20/2009 9:53:59 PM
Hey Rich, did not fix the problem...

  Thank you for the response, here is mapped drive commands that I'm running 
from a batch file:

net use q: \\"Exchange Server"\c$ "password" /USER:"userid" /PERSISTENT:NO
q:
q:\temp\mqueue\stopque1.bat

The "Exchange server" is an exchange server, "userid"  is a full domain 
admin and has full exchange rights.

The batch file I'm testing is on my pc right now and I've loaded the 
exchange management admin program on this pc.

I’ve even thought of trying to schedule a task to run this batch job when 
the error get tripped but I'm going to have to do some really fancy 
programming to get the batch job too add 2 minutes to the at command because 
if I try and schedule this when the error gets tripped the at command thinks 
I want to run the job tomorrow...like I said I don’t claim to be a 
programmer...


"Rich Matheisen [MVP]" wrote:

> On Fri, 20 Nov 2009 12:22:01 -0800, Tinyski
> <Tinyski@discussions.microsoft.com> wrote:
> 
> >  Yes it works if I'm on the server from a dos window, but if I try and run 
> >a batch job with the command in it from a mapped drive I get the error....If 
> >I run the batch job from the dos window on the server it works also. 
> 
> If your use of "mapped drive" means you're trying to run the tool on a
> machine that's not the Exchange server whose queues you're trying to
> manage, the error you get is because the necessary software isn't
> installed on the machine that's trying to run the tool. You can try
> installing the Exchange Management Tools on the machine and see if
> that fixes your problem.
> ---
> Rich Matheisen
> MCSE+I, Exchange MVP
> .
> 
0
Utf
11/23/2009 5:36:01 PM
On Mon, 23 Nov 2009 09:36:01 -0800, Tinyski
<Tinyski@discussions.microsoft.com> wrote:

>Hey Rich, did not fix the problem...

How about using WMI instead?

For example,
http://msdn.microsoft.com/en-us/library/aa143774(EXCHG.65).aspx
or
http://www.tech-archive.net/Archive/Development/microsoft.public.win32.programmer.messaging/2005-11/msg00108.html

---
Rich Matheisen
MCSE+I, Exchange MVP
0
Rich
11/24/2009 12:39:23 AM
Rich, that looks like what I want to do but I'm not a programmer would not 
know the first thing to do with this...  But in the mean time, got the AT 
scheduled task to work with this batch file below...now to see if the AT Task 
will stop the links...

set h=%TIME:~0,2%
set m=%TIME:~3,2%


set/a m2="m + 1"
set t2=%h%:%m2%
set t2

cd c:\temp\mqueue

at \\cdximc %t2% cmd /c "c:\temp\mqueue\aqadmcli linkinfo > 
c:\temp\mqueue\tst.txt"


"Rich Matheisen [MVP]" wrote:

> On Mon, 23 Nov 2009 09:36:01 -0800, Tinyski
> <Tinyski@discussions.microsoft.com> wrote:
> 
> >Hey Rich, did not fix the problem...
> 
> How about using WMI instead?
> 
> For example,
> http://msdn.microsoft.com/en-us/library/aa143774(EXCHG.65).aspx
> or
> http://www.tech-archive.net/Archive/Development/microsoft.public.win32.programmer.messaging/2005-11/msg00108.html
> 
> ---
> Rich Matheisen
> MCSE+I, Exchange MVP
> .
> 
0
Utf
11/24/2009 1:38:01 AM
Reply:

Similar Artilces:

Error log file
Now and again when using Excel, a message suddenly up to say excel.exe has generated errors and Excel will be closed down, also that an error log is being created. Where is that log? Is it in the same place for both XL97 and XL2000? If you search for .log (using windows start button|search), you'll be able to find that log file (drwatson.log, IIRC). But once you find it and open it, you'll be disappointed. There's not much there for a real person. Brian wrote: > > Now and again when using Excel, a message suddenly up to say excel.exe has > generated errors and Exc...

#Error error corrupts records in a table
Hi, I have a database in MS Access 97 which has a form consisting mainly of "Memo" fields. It is accessed by a number of people. Every now and then, if the database is left open or sometimes upon closing it and reopening it, it corrupts some of the fields on the form and displays #Error in the field instead of the actual text. You can then no longer edit any field on the form nor can you edit any field from the back-end in the table linked to the form. You cannot even copy the record directly from the table and paste it back in after removing the #Error message. As a result, you h...

Where to capture error?
In the err_handler of my procedures I use: Call ErrLog("frmMyForm", "Form_Current", "Error " & Err.Number & ": " & Err.Description) I noticed that I can also capture the particular Err.Number and Err.Description in the ErrLog procedure, which would make the ErrLog call shorter: Call ErrLog("frmMyForm", "Form_Current") Is it a good idea to implement it like this or can I run into trouble? Thanks, Lars Since I wrote the ErrorLog routine, http://www.datastrat.com/Code/Error.txt I think I can...

Error flagging message
We run Exchange 5.5 and the clients are Outlook 2k. We have a public folder that receives mail. When our employee goes in and attempts to flag the message for follow-up she receives an error that says "You do not have the permission to send the message on behalf of the specified user". I have given "send as" permissions to her and I've added that folder to her personal address book as I saw suggested in one post on the Internet. This has not helped. Thanks for any help you can provide. Tony What kind of client permissions are set up on the folder? -- r...

error 80070103 and 80010108 and 80070005 and 800F020B
What are the steps to fixing them? Thanks -- Kristen Rios How to ask a question http://support.microsoft.com/kb/555375 MowGreen ================ *-343-* FDNY Never Forgotten ================ banthecheck.com "Security updates should *never* have *non-security content* prechecked PPatty89 wrote: > What are the steps to fixing them? > Thanks ...

Exmerge error
I downloaded exmerge this morning. When I try to run it to play around with it, I get this message "This application has failed to start because EXCHMEM.dll was not found. Re-installing the application may fix this problem." I searched and found the .dll file on the machine. I do not want to re-install Exchange 2003. Can anyone shed some light on this? Thanks in advance. Jim Copy all the Exmerge files to the exchsrvr\bin directory. -- Mark Fugatt Exchange MVP http://www.exchangetrainer.com http://www.msexchange.org "J. Huber" <jimh@great!harvest.com> wrote in me...

SQL Error 'CoProcess' fail accessing to SQL data
I have two companies in my Great Plains Server, i make a backup of first company and restore that in the second. but when a attempt to access to second company whith any user, and I have this error: una obtener/cambiar primero operacion en la tabla 'coProcess' ha fallado al acceder a los datos SQL Hi Before you restored the company1 to company2, did you add the users to have acces to company2? If not you will need to add the users to company 2 within Great Plains system menu (uncheck the SQL options to apply this). Can you logon as the 'sa' user? Regards James &qu...

Authentication Error
Hi, I've been trying to deploy CRM 3, and having a real nightmare. It took quite a few builds to get a fully clean install of it (such as issues with the SQL Reporting Services, etc), but have finally got a clean install of it. We're running CRM 3.0 with SQL Server 2000 SP4 on a Windows 2003 SP1 server - running in a native mode 2003 AD. SQL is running dedicated on the same server as CRM and in Windows Authentication mode. I have a perfectly clean install this time - CRM Services running, SQL no problems, IIS functioning fine as far as I can see, but its the classic! "Authenti...

MSExchangeFBPublish Error #2
Hi I am running Server 2003 with Exchange 2003 and up untill now everything has been running just fine! However I have seen the following event pop up in the Apps Log over the last two nights: Product: Exchange ID: 8277 Source: MSExchangeFBPublish Version: 6.5.6940.0 Component: Microsoft Schedule+ Free/Busy Connector Message: Error while getting sorted message table for duplicate message deletion on virtual machine <name>. The error number is 0x80004005 Can't seem to find anything on this anywhere, can anyone help? Many thanks Dave Dave- Have you looked at http...

error msg 0x800ccc0e
I cannpot send a msg 7 get the above error msg. i have the smtp set correctly. Any help? >-----Original Message----- >I cannpot send a msg 7 get the above error msg. i have >the smtp set correctly. Any help? >. > Try this: http://support.microsoft.com/default.aspx?kbid=302339 >-----Original Message----- > >>-----Original Message----- >>I cannpot send a msg 7 get the above error msg. i have >>the smtp set correctly. Any help? >>. >> >Try this: http://support.microsoft.com/default.aspx? kbid=302339 >. >It does not help as i am no...

Error while importing Contacts from Outlook
Using the Import menu in the CRM web interface, I can select the contact folder from Outlook 2003 that I wish to import. But after it correctly tells me the number of contacts that it's about to import and I click "continue" (or something like that), the system throughs the following error: "A system error occurred while the data was being imported. The import wizard will now close." I've tried different folders, always with the same error. The ActiveX Control is able to see the contacts, as it reports the correct number of records, but it doesn't get ...

Run Time Error #2
We are experiencing the following error when trying to check a client out with an american express: Run-time error '-2147217887 (80040e21)'; Multiple-stop operation generated errrors. Check each status value. Ony happens when the order contains multiple products, and only happens when tendering to american express. All other credit card payments process correctly. Anyone have any ideas? Thanks, David -- Brilliant Lemming 1112 Ocean Drive Suite 200 Manhattan Beach, CA 90266 What type of EDC integration are you using? It kind of sounds like you are using PCCharge or ICVeri...

Outlook error "Compile error in hidden module: AutoExec"
I have just reinstalled Office XP Pro on my pc as I have just upgraded to WinXP. I noticed whenever I opened Outlook now, I get this message "Compile error in hidden module: AutoExec". I could not find the appropriate info relating to this on Help etc. Can someine please help? Thanks? Hi Herbert, do you use Word as Email editor? If so please read this http://support.microsoft.com/default.aspx?scid=kb;EN-US;307410 -- Gestern gings noch, ICH habe nichts gemacht! ;-) Bravestar@Datenschutzministerium.de "Herbert" <anonymous@discussions.microsoft.com> schrieb im New...

What is <IDispatch error #32> error and <Memory is locked.> error?
Hello, I installed an Event Sink as a COM+ Application on my Exchange machine that sends an email to a specific user named "exchangeconnector" whenever something is changed in the calendar of another specific user "exchangeuser". I did the appropriate event registration for this event sink and the events seem to be successfully triggering the event sink, as I can see new events being logged to the system event log when I create new appointments in exchangeuser's calendar. But the problem is that while the event sink tries to send an email to exchangeconnector...

#div/0 error
=Average(If(E4=0,"",S4:X4)) The answer always returns 0.00 even though data to be averaged are in cells. Tried several varations but to no avail I need to get rid of #DIV/0! and leave cells blank or 0.00 (If no values yet) Prefer blank cells Some sells may stay blank for years others change monthly, there are hundreds of #DIV/0! which makes it hard to see values which are important. Thanks for any help.......... Earl On 8 mar, 23:49, Earl1704 <Earl1...@discussions.microsoft.com> wrote: > =Average(If(E4=0,"",S4:X4)) > The answer always returns 0.00 ev...

Workflow Rule using Email Template error
I have a workflow rule that is set to send an email template on a case assign. I am able to email with setting up rules without using the template. The workflow rule fails, giving the following error message: The user I am assigning the case to does have the correct email in the primary email field. Event Type: Error Event Source: MSCRMWorkflowService Description: The description for Event ID ( 5895 ) in Source ( MSCRMWorkflowService ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You ...

MSExchangeSa giving error code 9099 every 5 minutes
Event Type: Error Event Source: MSExchangeSA Event Category: Monitoring Event ID: 9099 Date: 9/30/2005 Time: 5:40:26 PM User: N/A Computer: HCM-MAIL01 Description: The MAD Monitoring thread was unable to read the state of the services, error '0x80070005'. I have been getting this message for the pass 2 days after i install service pack 1 for windows 2003. please advice. Hi bolto, try with this: http://support.microsoft.com/?id=326011 -- Regards, Sasa Milovanovic MCSE:Messaging sasa.milovanovic(at)exchangemaster.net "bolto" <bolto@discussions.microsoft.com> ...

Error on fresh install?
I have Office Professional Edition 2003 with Business Contact Manager. When I open Outlook I receive an error box that states: The file add-in "MINET.ECF" is missing or is not valid. It then suggests using the detect/repair fucntion from the help menu. So I used it, then closed out completely and restarted Outlook only to get the same results. Can anyone tell me what that means or what I need to do? It doesn't seem to prevent the program from running after I acknowledge it but I don't want to get to involved entering contacts until I know it's safe etc. T...

FIX FOR =N/A errors from EOMONTH
I discovered that, after a lot of pain and frustration, a fix for a file corrupted by this error is to simply open it in Open Office calc, and save it down again. I lost three hours figuring this out, but saved about 20 by not having to redo all of the =n/a's. Hope this helps someone. Best, Drew ...

OutLook Error Message Unresolved
Hello, I keep receiving the following error message everytime I open Outlook: "Outlook connector menu and status bar have been disabled by the office safe mode. Please contact msn.support". To date, I have uninstalled and reinstalled outlook connector, opened outlook while in safe mode, and spent 4.5 hours with msn support and hp support. All to resolve what seems to be a simple resolution. Apparrently, this is not the case. I would appreciate any help you could provide. Thanks... ...

Errors oh Errors
Howdy, I'm using CRM 3.0 on SBS 2003. Using the web client to access CRM I get an Error page: Error. An error has occurred. For more information, contact your system administrator. I get this when viewing everything: Activities, Caledar, Companies, Contacts, leads, opps, tickets.. everything, except for Queues. This will show my latest activities, but I cannot click to view any of them. When I run CRM in Outlook with the Mobile client, I can see everything fine! What gives! But this isn't my question. My question is this: where do these errors get logged? Thanks, -- David...

Mail not arriving / categorizer error 9031
Hello, I hope someone can help me with this. I am not receiving mail (sometimes) on one of my mailboxes. All other mailboxes have not reported any problems. It started with emails for this mailbox getting stuck in the queue (in the categorizer). Since this was the only one with the problem and only forwards, I tried to delete the mailbox and gave the smtp address to a distribution group. This helped, so I thought, in that email started comming in again. Now some email gets bounced, of course when a manager is sending to it :-( I have only seen the eventlog for the mailbox in question when ...

EFT for Payables Error
I am helping a client set up the EFT for payables and we are running into a strange error that looks like it should be resolved. The bank/country assigned to the vendors remit to address is missing or inactive. Assign the bank/country region to the address or activate the format. We have gone into the Vendor address (Remit To) and verified that everything is set up correctly. We have also Verified the Check Book Maintenance window and it is set correctly. However when we go to generate a sample EFT we get this meesage. Any ideas? TC, I would try running Checklinks (File>Mainte...

ERROR MESSAGE- STOP:c000021a{Fatal System Error}
Every time I shutdown my computer I get the following error: STOP: c000021a {Fatal System Error} The Windows Logon Process system process terminated unexpectedly with a status of 0x00000000 (0x00000000 0x00000000) The system has been shut down. I can shut down to the point of "Windows is shutting down" and then it goes to a black screen and then to the blue screen with the above message. My computer never powers off no matter how long I leave it, I end up having to pull the power or holding the power button for a while. I have no trouble booting my computer only power...

FRx Report Launcher error
I have a user who up until recently was using Launcher to generate reports. She is no longer able to generate the reports from Luancher but can in Designer. The error she gets is - "The output file could not be created because the destination folder does not exist or cannot be accessed from the Report Server." We're not using Report Server. I can launch the reports in Launcher signed in as 'sa' with no problem. Any ideas what is causing the error? Much thanks, Frank Hamelly, MCP-GP NOVA Solutions LLC Melbourne, FL ...