Dreaded Runtime Error 1004.

I'm encountering the dreaded Error 1004 from the following line of code:

ActiveSheet.Cells(rngCurrRow.Row, colAccount).Value = ""

There are valid values in the parms for .Cells. This was working for a long 
time and now something has changed and I don't know what. I suspect something 
besides this actual line of code like some option or other factor. This runs 
fine on a different system.

I've turned off WS Protection, cell validation, Set General Format.

Any ideas? Thanks,
John S.
0
Utf
12/2/2009 1:52:01 AM
excel.programming 6508 articles. 2 followers. Follow

1 Replies
761 Views

Similar Articles

[PageSpeed] 14

What happens if you do this

'' Ctrl-g to view Immediate window
Debug.Print rngCurrRow.Row
Debug.Print colAccount ' between 1-65536 or 1-1048576 in 2007
Debug.Print TypeName(ActiveSheet)
Debug.Print ActiveSheet.Cells(rngCurrRow.Row, colAccount).Address

Regards,
Peter T



"DocBrown" <DocBrown@discussions.microsoft.com> wrote in message 
news:714C9F94-44DF-4571-B267-E86FF62EFA4C@microsoft.com...
> I'm encountering the dreaded Error 1004 from the following line of code:
>
> ActiveSheet.Cells(rngCurrRow.Row, colAccount).Value = ""
>
> There are valid values in the parms for .Cells. This was working for a 
> long
> time and now something has changed and I don't know what. I suspect 
> something
> besides this actual line of code like some option or other factor. This 
> runs
> fine on a different system.
>
> I've turned off WS Protection, cell validation, Set General Format.
>
> Any ideas? Thanks,
> John S. 


0
Peter
12/2/2009 9:12:09 AM
Reply:

Similar Artilces:

Trigger error
I have a delete trigger that is trying to get information during the delete using the deleted object and I am getting the errors below. The multi-part identifier "deleted.RepCompanyID" could not be bound. The multi-part identifier "deleted.BrandID" could not be bound. The trigger code giving the error is below. p.s. This is from an old database so alternatives in constraint use would be ok. Thanks. DECLARE @RepCompany varchar(200); DECLARE @Brand nvarchar(50); DECLARE @OldInfo varchar(200); SET @RepCompany = (SELECT RepCompany FROM dbo.Rep...

windows XP Excel & the dreaded Taskbar
Hi guys, general question, Windows XP Pro SP1, office 2000 excel 2000 1> when i have documents & programs open on the desktop, there corresponding icons appear within the task bar, when the taskbar option of "Group Similar items" is checked (which it is,) programs and documents that are the same should by rights group together, this is happening BUT ,,,, if i have multiple excel's open they dont group together, everything else does however, but not excel any reason why this would be happening ? is there an excel option or something goofy im missing ? thanks for ...

Microsoft Visual C++ Runtime error
Hi, the first time I log into Outlook each day I get "Microsoft Visual C++ Runtime library/Run time error" message pop up. It also states "C:\Programs\Office\Outlook.exe" and the text says "Application required the runtime to terminate it in an unusual way". When you "OK" it then log back in, all is fine. Anyone have any ideas how to rid myself of this annoying feature? Thanks Chris Hi, (I'm on XP), Outlook 2000-SP3 - I figured out when it happens - I have two identities set up on my machine. If one identity has outlook open, then I s...

runtime error 2001
I added a button on my form that quits application. I used a wizard to make it. When I click on a button it comes up with runtime error 2001 - you cancelled previous operation. If database window is open - button works and closes access, if only forms are visible it gives me the error. Also if I click on debug - it closes access. I'm lost Any idea would be appreciated. Thanks Barb Barb, I can't see your form, but my guess is that some other code on the form is causing error 2001. By the way error 2001 is a very common error. Post back with some details about other code on this...

error reported (0x8007007e and 0x8004210A)
hello, I'm dutch, so my english is not soo good. I've got the errors that are reported in the subject line, can anyone help me with these?? I've got Outlook 2003 just installed. I've got norton internet security 2004. Is it maybe the firewall?? thanks in advance ...

Extender runtime error
Dear All I'm trying to add a new form to the Work Order Entry/Update window in the Return Management series using the cross-dictionary trigger Trigger_RegisterFormByName(), when i try to run test mode or extract it using Chuck file im getting "The object for which the trigger is being registered cannot be found." message the following is the startup procedure: local integer result; local string err; result = Trigger_RegisterFormByName(949, "form SVC_Depot_Entry","WO Information","", script Open_SVC_EC_WOEXTRAS); if result <> SY_NOERR t...

MTA Error
Three of my five servers are displaying this message in the Event log: Event ID: 57, "The limit on the number of associations allowed to and from entity /0=MAIN/OU=DOMAIN1/CN=configuration/CN=SERVERS/CN=MAIN/CN=MICROSOFT MTA has been reached. The limit is 9. [MTA XFER-IN 16 34] [14]" MAIN is the server who collects all mail from the outside and then passes it to the other servers. MAIN does not have this error. MS KB has an article and it says to apply the latest SP. All the servers already have them. The MTA service is running despite the error. Can anyone help? Thanks, Dian...

SMTP communication error
This is an odd issue. When a user running Outlook 2000/Exchange 2003 SP1 sends an e-mail to a user of another domain it goes through without issues. When he replies to a received e-mail from that domain, he gets the following error: Your message did not reach some or all of the intended recipients. Subject: Saturday Sent: 06/08/2004 9:28 AM The following recipient(s) could not be reached: 'katie.payne@corumrealestate.com' on 06/08/2004 9:28 AM There was a SMTP communication problem with the recipient's email server. Please contact your system admi...

HTTP A-S Error
I had setup a test Exchange server and had Exchange Active Sync working very well. I decided to move it into production, followed all the steps and now ... The old users seem fine but if I add a new user (enable sync and so on) it tries to work and on the device gives a variety of errors from 'You are not enabled for this function' to 'server problems'. The server event viewer however states: I can't find any information on this or any fixes. BTW 'XXX' added by me before anyone suggests anything ... Event Type: Error Event Source: Server ActiveSync Event Ca...

Dreaded Runtime Error 1004.
I'm encountering the dreaded Error 1004 from the following line of code: ActiveSheet.Cells(rngCurrRow.Row, colAccount).Value = "" There are valid values in the parms for .Cells. This was working for a long time and now something has changed and I don't know what. I suspect something besides this actual line of code like some option or other factor. This runs fine on a different system. I've turned off WS Protection, cell validation, Set General Format. Any ideas? Thanks, John S. What happens if you do this '' Ctrl-g to view Immediate window...

Runtime error
I have a .XLS document that runs macros correctly on my laptop with MS Office 2007 but when I open it on my desktop with MS Office 2003, gives me the following message: runtime error '438': object does not support this property or method. I have enabled macros when I open the workbook on the desktop. Any ideas how I can get the workbook's macros to work correctly? By the way, the macro is assigned to a button to create a new worksheet. If I click OK, the sheet is created but all the data is not. Thanks. Each version of excel added something that the old version didn&...

#name? error
Whats wrong with this expression in text box on main form reading value of field [SumOfEmp_Act_Prod_Hrs] in subform named 'qry_Emp_TotalHrsWorked subform' - it is getting #name? error =IIf([Forms]![qry_Emp_TotalHrsWorked subform]![SumOfEmp_Act_Prod_Hrs]>1920,"EMP HOURS ARE GREATER THAN 1920","Emp Product Hours Less Than 1920") Are hours in units of time or text? If text your 1920's must be "1920" -- Milton Purdy ACCESS State of Arkansas "Steve Stad" wrote: > Whats wrong with this expression in text box on main...

printing error: limitcheck OFFENDING COMMAND: image
I have been trying to print my document of 17 pages, the first page will print and dthen I get the error: limitcheck, OFFENDING COMMAND: image, STACK: -dictionary-..? This is a postscript error. Might read a PrePressure.com article that addresses this error. http://www.prepressure.com/postscript/troubleshooting/errors/limitcheck -- Mary Sauer MSFT MVP http://office.microsoft.com/ http://msauer.mvps.org/ news://msnews.microsoft.com "supersammy" <supersammy@discussions.microsoft.com> wrote in message news:DBA790E0-0E02-48EB-9801-9EBB4C8DF92F@microsoft.com... >I have bee...

30 redeployment wizard error
I am trying to redeploy 3.0 in two cases. first case: redeploy in the same domain, everything is ok. second case: redeploy to a new domain, problem occurs during redeployment wizard usage. It says "An error occurred when populating Microsoft CRM user groups. Ensure that CRM user accounts are accessible from the current domain and run the wizard again." I created new users in the new domain and manually mapped with previous ones. Since this a test environment, user names, computer name, domain names of both previous and new systems are identical. Please give me recommendatio...

Dexerity Runtime screen very slow launching
Some of our overseas users are experiencing very slow responses when running Great Plains. It takes about 1 minute and 20 or so seconds for the splash screen to appear before the login prompt to GP. Then once in it takes about 20 or over 40 minutes to print a report to the screen. Any suggestions on how to trace the application to determine the background activity? How are your overseas users connecting to GP? Terminal Server? Citrix? Do you have Named Printers enabled? Are you using roaming profiles? If so, are temp directories being roamed? Best regards, -- MG.- Mariano G...

Unable to start processes error in Outlook 2002
I have jsut configured Outlook 2002 for 2 POP3 user profiles and I am getting random errors that "Outlook is unable ot start Processes" after which Outlook restarts. How can I resolve this? Test messages are working fine and whatever I've sent as tests are working fine as well. Also, I can't get Outlook to auto-connect to DSL when sending/receiving, though IE does it wihtout a hitch. All this is running on a modern computer with plenty of RAM, etc. and Win2K. Thanks for any suggestions!!!!!!!!!!!!! ...

UNICODE error
hi all, vc++ 6.0, win xp i am building a project with _UNICODE and UNICODE included in my preprocessor definitions under project setting. however, i got compilation error when i tried to called a function which accepts UNICODE string as parameters: here's my code: ------------------------------------------------------ CString sXslHeader ( _T("xml-stylesheet") ); m_pContHandler->processingInstruction( sXslHeader, wcslen( m_sXslHeader ), sXslHeaderParam.GetBuffer(sXslHeaderParam.GetLength()), ...

using macro to save a file produces runtime error 4198
I upgraded from Win-XP/Office 2003 to Win-7/Office 2007; the code below ran fine in Word 2003 but in Word 2007 generates runtime error 4198. The variables and directory location are valid. The parameters for FileName are updated for Word 2007; the grammer for the FileName appears correct (no grammer errors when macro runs as is, but grammer errors if I change the string.) When I substitute an actual file name in place of the variables, the code runs w/o error, but the Debug.Print statements generate correct strings. I feel kind of dumb- but what is different about use of variab...

visual c++ runtime error!
So i'm migrating from express to outlook and right at the end of its importing everything after it asks me if I want outlook to be my default e-mail, I get a fatal ("unusual") error from "Microsoft Visual c++ runtime library" from outlook.exe: Runtime error! I had also just upgraded (smooth as silk) from ME to XP. Any ideas? ...

Averageif error in 2007??
I have been using the averageif formula in 2007. According to the help file the "range" or "average_range" can include arrays, However when I have attempted to set an array for evaluation only the first column is evaluated in the result. I only discovered this when I compared it to my old method which was to use an array function "average(if". Is this a problem with the averageif formula or am I missing something? Larry Syntax AVERAGEIF(range,criteria,average_range) Range is one or more cells to average, including numbers or names, arrays, or references ...

transferred docs to new computer, getting errors on some
Version: 2004 Operating System: Mac OS X 10.6 (Snow Leopard) Hi - I transferred word and excel documents (Office 2004) from eMac OSX 10.3.9 to minimac 10.6.3, with a memory stick. I have updated word on the new mac. <br> Some word and excel documents won't open because of error:Might not be a valid work document; Excel unable to read file. <br> I compared the &quot;get info&quot; on a document that WILL NOT open and the &quot;get info&quot; on a doc that WILL open: <br> In the preview section for the WILL NOT open document there is Word logo in bl...

Edit Links Error Message
I have a document with charts in it that originally came from another source. When I try to do an "Update Fields" on the entire document (Ctrl-A first, then F9), I get a message that says the linked file is not available and tells me to use the Edit Links command. I click OK, but this message comes up repeatedly for each link in the document, then finally allows me to do the update. Once that is done, however, Word stops working and I have to close the document and start over. I have gone to Edit Links (Microsoft Office button > Prepare > Edit Links to Files) a...

Payment error
I am receiving the following error message when doing a manual payment against and AP invoice: Distributions haven't been updated for your change. Use the Payables Transaction Entry Distribution window to update the cash account distribution. I have gone into the posted AP invoice and it all looks correct to me. At this point, I am wondering what the problem is and why this is happening. Thanks! Laura Laura, Have you double checked to make sure the distributions in your manual payment are correct? The error is referring to the Payables Entry Transaction Distributions in the M...

Avoiding the dreaded metadata.
So, I have a series of tables with different columns (but some 'common') e.g. Sales order items (oritem) Process order stock requirements (orstkall) Picking note items (pickitm) Miscellaneous manual stock reservation ( Each table can provide a requirement for stock based on status of item. I therefore have another table (allocation) which contains the outstanding requirements for stock, from which I need to create a relation back to each of these tables. Allocations for a particular row in any of these tables are stripped and rebuilt frequently. Each of these has ...

Runtime Printing Problem
Hi all I have an Access2002 db with a Form and Subform in a one-to-many relationship. In addition I have a report base on a query which has 2 parameters which in turn point to the form and subform. On the subform I have a cmd button to trigger the report to run. In Access 2002 full version it works fine in Runtime version it prints the report less data. Anyone met this before or know what the cause is? TIA Regards johnb It would really help if you would post the code your are usong to open the report. johnb wrote: >Hi all >I have an Access2002 db with a Form and Subform in a on...