SOAP Exception - Deserializer Problem

Hi,

In my C# code, I have defined a Map object which is sent as part of a
request to a web service, here's an extract of the part of the code:
-

            Map map = new Map();
            map.item = new mapItem[4]
            {
                new mapItem(),
                new mapItem(),
                new mapItem(),
                new mapItem()
            };
            .................

But when I submit the request containing the Map object, the compiler
throws an error with the following message:-

org.xml.sax.SAXException: No deserializer for {http://xml.apache.org/
xml-soap}mapItem

I am not sure if this error is based on the web service or if it is my
code.

0
honguin (1)
8/10/2007 8:46:15 AM
dotnet.xml 7266 articles. 0 followers. Follow

1 Replies
663 Views

Similar Articles

[PageSpeed] 3

<honguin@googlemail.com> wrote in message 
news:1186735575.494235.240120@x35g2000prf.googlegroups.com...
> Hi,
>
> In my C# code, I have defined a Map object which is sent as part of a
> request to a web service, here's an extract of the part of the code:
> -
>
>            Map map = new Map();
>            map.item = new mapItem[4]
>            {
>                new mapItem(),
>                new mapItem(),
>                new mapItem(),
>                new mapItem()
>            };
>            .................
>
> But when I submit the request containing the Map object, the compiler
> throws an error with the following message:-
>
> org.xml.sax.SAXException: No deserializer for {http://xml.apache.org/
> xml-soap}mapItem
>
> I am not sure if this error is based on the web service or if it is my
> code.

Do you use anything like "org.xml.sax" in your code? If not, I'd suspect 
this is from the web service, which is likely to be written in Java.

It's also likely that your mapitem class is being serialized into the wrong 
namespace.
-- 
John Saunders [MVP]

0
John
8/11/2007 11:00:28 PM
Reply:

Similar Artilces:

IMAP Connection problems
I am running... Server: Windows SBS 2008 SP2 Client: Windows 7 Ultimate / Outlook 2007 SP2 / Windows Live Mail (I have uninstalled the AV to eliminate any problems that might be causing.) I have enabled IMAP on the server I have configured port 143 on the firewall to be forwarded to the server I have checked via telnet that I can connect to the server on port 143 and all seems fine. But when I put the settings into Outlook or Windows Live Mail I have problems connecting to the server. In Outlook when I click test settings I get 'Log onto incoming mail server (IMAP): Gen...

problem!
When I run outlook today - the customize outlook today button does not work - It has in the past - I like to set up folders on this page - to monitor (and filter) incoming e-mails. It just won't let me customize anymore. I have tried repairing, uninstalling and reinstalling. Any ideas? ...

Stacked Column Problem
Runing Excel 2000 on Windows 2000. I have a table of data containing 2003 productivity data by month for 3 teams, each of which has 3 members. The table is arranged with the months January through December on the top row. The first column on the right of the table is the team name (cells merged to span three rows corresponding to team members), the second column contain's the team members' names. The next 12 columns contain monthly production data for each team member on the row corresponding with their name. I am trying to come up with a way to create a separate stacked li...

E2K3 Memory Problem
Approximately every two weeks my Exchange 2003 server's total memory usage creeps up from its reboot level of about 1.5 Gb to 2.5 Gb (4Gb of RAM installed). At this point the he Microsoft Exchange Information Store service terminates and logs a 7034 event (see below). Once the server is rebooted, everything works fine, but the memory starts creeping back up. My memory configuration has been optimized based on the configuration recommendations listed in KB article 815372. Has anyone else run into this problem and can tell me what may be causing the problem and how to correct it? ...

Strange permissions problem
Hi al Im running Exchange 2003 on windows 2003, this server is also my only DC. I upgraded the domain from AD 2000 and exchagne 2000 to AD 2003 and exchange 2003. I happened to notice one day when looking at the built in administrators group on the server that the everyone account was in the built in admins group on the domain. The account had a red arrow pointing up from it to the Enterprise admins group which is alos in the built in admins group. I removed the everyone account from the built in admins group. When i did i started recieveing errors in the application log on the server. I was ...

Unhandled script exception:
When im entering a transaction, i have a default currency ID: , but im choosing other currency from the lookup. Im also updating the exchange table. after entering the same, i receive the following POP up error. But it dosent prevent me from posting or proceeding. Is it because, i need service pack 5, please advice. Type mismatch in return from script 'Set_Calling_Windows_X_Information_2 of form MC_Exchange_Rate_Entry'. ...

soap call
I am getting this very ambiguous error when I am making SOAP call. Open failed. Please check the connection information. HTTP Error (null) Unknown: This error code is not recognized. Has anyone seen this before? Thanks. ...

Block all emails except...
Is it possible to block all emails, or send them to the junk email folder, except the ones from Contacts? TIA. depends on your version of outlook... -- Diane Poremsky [MVP - Outlook] Author, Teach Yourself Outlook 2003 in 24 Hours Coauthor, OneNote 2003 for Windows (Visual QuickStart Guide) Author, Google and Other Search Engines (Visual QuickStart Guide) Outlook Tips: http://www.outlook-tips.net/ Outlook & Exchange Solutions Center: http://www.slipstick.com Join OneNote Tips mailing list: http://www.onenote-tips.net/ <ashkaan57@hotmail.com> wrote in message news:1122059071....

VISIO 2000 Problem
Dear All Please advise the following case The VISIO program fail to open the VISIO files and hang up (Get No Responding in the Task manager) in Windows 98, I have already tried to uninstall and reinstall all components of VISIO 2000 from CD-ROM Those files have no problem to be opened in other PC. Michael Lam System Administrator "K" Line Air Services (HK) LTD ------=_NextPart_0001_8629F87B Content-Type: text/plain Content-Transfer-Encoding: 7bit Hello Micheal, Try the following: 1. Put the visio installation CD/Located the visio installation source files location...

Problem with CFTPConnection
Hi I've an application that connects to an FTP Server and uploads a big directory (size over 500 MB). Now what happens is that after sometime the application stops uploading files and stays idle. The FTP server connection timeout value is set to 2 minutes. So the server seeing the connection idle for two seconds, disconnect the session and no more file is uploaded. On debugging I found out that after some time CFTPConnection.PutFile() method hangs on some random file and stays like that for 5 minutes (default send timeout value of CFTPSession). During this time the server connection timeo...

sqlcrl exception
We have an sqlclr Stored procedure that invokes a web service. SqlServer sits on on one machine and the web service on another within the same lan. Everything works fine until the web service machine is rebooted - at which point all attempts to use the SP bomb with the exception below until we restart the Sql Service. I am probably wrong but it sounds like a connection to the webservice is being opened once and held open for all subsequent requests. When the webservice machine is rebooted the connection is broken causing this exception. MySP was created by using 'Add Web...

NEED HELP:Soap error: operation requested in the Soap message with soapAction isn't defined in the WSDL file.
Hi all, I need some help. We have an application which is using SOAP to relay messages between two applications. We are having a problem, which started to only occur intermittently, but now happens all of the time. When communicating between the apps, we receive this message... Soap error: The operation requested in the Soap message with soapAction <http://tempuri.org/FormAPI/action/COutlookForm.isCateringAvailable> isn't defined in the WSDL file. This may be because it is in the wrong namespace or has incorrect case. The SOAP sender application is a VB6 COM dll hosted in a...

Soap client
Hello. How could I consume Web services created using c# with soap client written on c++6.0 ? I can't use .net on client app. Thanks in advance. Look for the COM-based SOAP Toolkit on the MSDN download web site [0]. Check out the MSDN Library [1] for some articles on interoperability issues. -- HTH Christoph Schittko [MVP] Software Architect, .NET Mentor [0] http://www.msdn.microsoft.com/downloads/default.asp?URL=/downloads/sample.asp?url=/msdn-files/027/001/948/msdncompositedoc.xml [1] http://msdn.microsoft.com/library "Ulan" <usametov@hotmail.com> wrote in messa...

Addition problem, number always 2 cents off...Help
I have a little problem with my SUMs I have 200 to 300 rows of A * B = C Then I tell it to do a =sum(d1:d300) All the cells are formated to currency, two decimal places. when I add up the numbers with an adding machine I'm always 2 - 22 cents off. (2 cents on this sheet, 22 cents on another sheet....) Can anyone help Thank you WTG The issue is very likely to be rounding - that the product of each multiplication has fractional cents that Excel considers in the SUM() function, even though you don't see them fractional cents on screen You can either modify your multiplication f...

catching system errors / exceptions (and knowing what)
I know this will probably get to nowhere, but is there a way to do this ? I mean, with C++ catch-throw, not with Win32 SEH. The reason I don't want to use it is that I rely heavily on STL objects, which throw standard C++ exceptions, and I hear it's not a good idea to mix this with SEH. They can of course be caught with catch (...) but is there a way of knowing inside it that the exception was raised by a system problem (such as null-pointer access, divide by 0 etc.) and which one it was ? If not, maybe they throw some specific exception type ? I tried to catch a DWORD but it didn'...

WDDM driver problem
Hi, Approximately one week ago I have posted a question about WDDM driver initializing. The question title include a typo, WDDM instead of WDDK. I don't know whether it is the reason for not getting any response. Please advice on how to get some help. Maybe another mailing list/forum or maybe some other official channel will help with getting the necessary support. I will appreciate any help in this mater because it actually block my progress. Thanks Ron Rondis <RonRondis@discussions.microsoft.com> wrote: > >Approximately one week ago I have posted a que...

Problems with paste.
I am trying to paste an object that is larger than one page. Without copying this object over and over just to get it all, how would I be able to copy and paste so it would wrap itself onto the other pages. Are you talking about a text box or an image? -- Don Vancouver, USA "J, Dodge" <J, Dodge@discussions.microsoft.com> wrote in message news:92C5742E-A9E4-47C2-9CB0-66D8EA2C9DD7@microsoft.com... >I am trying to paste an object that is larger than one page. Without >copying > this object over and over just to get it all, how would I be able to copy > and...

Dividing a problem into parts and can't get the parts back togethe
I have three tables in a Master/Detail/Detail relationship. They are titled Label / Product / ProductPart. One Label can have one or more Products and each Product can have one or more ProductParts. The ProductParts have two attributes: Category and Application Number (productpart_category, productpart_app_no). Usually (95% of the time), the Category and Appliction Number is the same for all the ProductParts for a given Label. This makes it easy to return a result table (after a search of the 20,000 labels) like this: Label Id | Label Name (taken from Label table) | Category ...

Summing problem
Hi I have have few columns which have several rows. Each column has been added up using the Sigma tool (S). When I try to add up ( = A+B+C...) those sums I end up with zero value no matter what I do? Any ideas? Thanks Kalevi Hi Kalevi, > I have have few columns which have several rows. Each column has been added > up using the Sigma tool (S). When I try to add up ( = A+B+C...) those sums I > end up with zero value no matter what I do? > Any ideas? > You mean =A10+B10+C10 ? (or =SUM(A10:C10)) Regards, Jan Karel Pieterse Excel MVP www.jkp-ads.com Just a guess .. Perha...

Problem with CFTPFindFile
Hi I'm enumerating the directories on the FTP server. The problem i'm getting is that the FindFile() function returns 0 if the Folder Name on the server has a space in it. Though that folder does have subfolders. Does anyone know wats the reason for it. Regards Usman ...

Links in same spreadsheet problem
I have a multi-tab spreadsheet with simple links referencing differen cells. The problem I am having is that it the spreadsheet goes through report generator and it changes the tab names, creating broken links. Any ideas in solving this problem -- dyun1dyun ----------------------------------------------------------------------- dyun1dyun1's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=3708 View this thread: http://www.excelforum.com/showthread.php?threadid=56853 Excel should change the tab names in the linking formulas. Sheet1!A1 in Sheet2 should change t...

Problem changing wallpaper on Vista
I am trying to change the wallpaper on Vista. I have a sub that works on XP with .jpg and .bmp images... Private Sub SetActiveDesktopWallpaper(ByVal sFileName As String, ByVal lStyle As Long, ByVal fForce As Boolean) Dim ad As ActiveDesktop Dim co As COMPONENTSOPT Dim wpo As WALLPAPEROPT Set ad = New ActiveDesktop 'check if AD is enabled co.dwSize = Len(co) ad.GetDesktopItemOptions co, 0& With wpo .dwSize = Len(wpo) .dwStyle = lStyle End With With ad ' set wallpaper style... .SetWallpaperOpt...

problem to add post????
What problem? -- Ajay Kalra [MVP - VC++] ajaykalra@yahoo.com "Charlie Hoo" <Charlie@newsgroups.nospam> wrote in message news:uekMZ61KGHA.1272@TK2MSFTNGP10.phx.gbl... > > Hi Charlie, Welcome to MSDN Newsgroup! I don't see any content in your message. How is it going? Thanks very much. Best regards, Terry Fei Microsoft Community Support Get Secure! - www.microsoft.com/security Register to Access MSDN Managed Newsgroups! http://msdn.microsoft.com/subscriptions/managednewsgroups/ This posting is provided "AS IS" with no warranties, and confers no ri...

audio problem
I have a problem with audio private sub playing(Byval somefilename as string) My.Computer.Audio.Play(My.Resources.somefilename,AudioPlayMode.Background) end sub private sub choose if good then playing("wav1.wav") else playing("wav2.wav") end sub wav1.wav and wav2.wav are audio files that I put in resources and good is a boolean variable but in my.comp..... somefilename is not accepted and gives a error Is there a solution? Thanks for any response andrews schrieb: > I have a problem with audio > > private sub playing(Byval somefilename as...

Problem with Bar graph
I created a bar graph to show the progress of sales of tickets for our fundraiser. All is fine and well until I update any of the data. When I change any of the numbers, then return to the main view, the whole graph is expanded too far to the right. It's as if the box for the graph has been expanded toward the right, and the graph fills in. I have not changed anything other than updating the number of tickets sold. Am I missing something, or is the program just copping an attitude with me? Any help would be appreciated! Are you using the Insert, Object, Microsoft Graph Char...