Slow load of first node, xmltextreader

Hi!
I have a problem with reading a xmlfile from a url. I am confused by
the long loading time of the first node.
When the first node has been loaded, the rest of the nodes is parsed
very fast.

I am on a c# 2003 environment.

The url returns an xml of appr 80 kB.

It takes 1,5 seconds from first,start to first, stop.

It takes appr. 0,5 seconds to generate the xml on the remote host.

I'll be very happy for any assistance on this!

/fredrik

// Gets the xml from the Url using XmlTextReader
Trace.Write("init reader","start");
XmlTextReader reader = new XmlTextReader(searchxmlurl);
Trace.Write("init reader","slut");
Trace.Write("first","start");
 reader.MoveToContent();
Trace.Write("first","stop");

0
9/21/2007 9:00:40 AM
dotnet.xml 7266 articles. 0 followers. Follow

0 Replies
428 Views

Similar Articles

[PageSpeed] 7

Reply:

Similar Artilces:

Build is slow.
Hello. The environment is 6.0 vc++. When one DLL has 1700 source codes. Build is slow. debug start takes time. Please teach a good solution. Thanks, Buy a faster computer. ;) AliR. "teratera" <teratera@discussions.microsoft.com> wrote in message news:23DF80A8-723F-43A3-A5D9-7722EEA97578@microsoft.com... > Hello. > > The environment is 6.0 vc++. > When one DLL has 1700 source codes. > > Build is slow. > debug start takes time. > Please teach a good solution. > > Thanks, > "teratera" <teratera@discussions.microsoft.com>...

network diagrams for load balancing configurations
Hi, I noticed that cisco haven't got any icons for their CSM module load balancing products. I was wondering whether anyone had any good examples of diagramming such a network setup, basically including Virtual IPs, server clusters, failover conditions, that sort of thing. At the moment im not sure where to start, and have just being creating block level objects referring to those concepts. Thanks, T ...

Slow Navigating Folders for attachments!!
Using Outlook-2002. Recently, since about a month ago, when I try to save attachments or attach files to messages and attempt to navigate to the folder of interest (after I click on the attach button), navigation is VERY slow - like if I click on a sub-folder, it may take over a minute for that sub-folder to open. It doesn't matter if other apps are running, or if I'm just changing to a different drive, or to the root directory. Everything takes minutes! It renders it useless :-( Any ideas? ...

Word 2003
It takes sometimes 10 seconds when I press crtl+c (copy) or crtl+x (cut) in a text inside Word 2003. Even if it is only one word it takes a lot of time just to copy or cut or paste it. That does not happen in Excel or Power Point only in Word. Please can anybody help me to solve this very annoying issue? Thank you very much indeed, Anderson From reading other postings on this forum, it seems that poor AddIns can cause this latency. I have also found that doing a clean up of the temp files seems to help as well. Hope this helps DeanH "Anderson" wrote: ...

Slow Slow Slow
When I click between different emails in my inbox, it takes ages for it to appear on the display. My internet connection is super fast. I have recently had to reinstall Office XP and I think a setting has been changed somewhere. I have an anti-virus but it never slowed it down like this before. To put in perspective, I've had 120 spams today and its took 37 minutes to delete them because of this problem. I have ran a virus check and its fine. Any thoughts on a registry tweak?? Cheers Carl Carl Sheldon <ccshell@courtlands5.freeserve.co.uk> wrote: > When I click between differe...

Switch Last Name First Name to First Name Last Name
Hello, Access 2003. I have a single field called "Name" in a table called "Members". There is about 300 records in a Last Name First Name format, example Doe John Moore Dave Johnson Jacob Mario (Some names have Middle Names or Sir's) How could I run a query to change the names to First Name Last Name? Or if you recommend in Excel how would I do this? John Doe Dave Moore Jacob Mario Johnson Thanks. Iram On Thu, 3 Jun 2010 16:35:15 -0700, Iram <Iram@discussions.microsoft.com> wrote: >Hello, > >Access 2003. I have a si...

slow loading, slow updating
I am using MS Money in a non-standard application. I am maintaining ledgersin checkbook fashion for 100 accounts, each set up as a separate checking account. Each of those has 3 transactions set up as automatic bill pays. Other than that, there are very few entries, averaging 6 per year at most. The program takes about 5 minutes to load. Corrections, such as posting bill payments, takes approx 10 seconds to cycle through: Open, edit, enter, wait........ Open, edit, enter, wait.....etc. I am not doing any online updating or anything like that. Is there anything I can do to speed this ...

Load a DLL procedure
Hi, I am having difficulties to load some procedures from a certain DLL. While I am able to load couple of them, I fail on some others. For example, I succeed to load lr_message procedure: ---------------------------------------------------------- From the DLL h file: #if defined(cplusplus) || defined(__cplusplus) extern "C" { #define PROTO(x) x #endif #ifdef _WIN32 /* LR_FUNC is used for the call-back functions of the compiled Vuser */ #define LR_FUNC CALLBACK /* LR_MSG_FUNC is used for the message functions */ #define LR_MSG_FUNC WINAPIV #else #defin...

Driver isn't loaded
Hello, To my wince6-project, I added a new driver (PIO). When I examine [HKEY_LOCAL_MACHINE\Drivers\active], the PIO driver isn't listed. The driver looks like this: PIO_Init PIO_Deinit PIO_Open PIO_Close PIO_Read PIO_Write PIO_Seek PIO_IOControl PIO_PowerUp PIO_PowerDown I added a registry key: [HKEY_LOCAL_MACHINE\Drivers\BuiltIn\P4xxIO] "Prefix"="PIO" "Dll"="p4xxio.dll" "Index"=dword:0 "Order"=dword:2 I verified the presence of "p4xxio.dll" in the windows f...

Slow Viewing e-mails
Suddenly it's very slow to view e-mails in Outlook 2002. Any kind of e-mail, with or without attachments. It worked fine until a few days ago. Anyone have any ideas? Found an answer to the problem in another post. Simply turning of the Messenger Integration fixed everything. /Johan >-----Original Message----- >Suddenly it's very slow to view e-mails in Outlook 2002. >Any kind of e-mail, with or without attachments. It >worked fine until a few days ago. Anyone have any ideas? >. > On 25 nov 2003 Johan wrote: > Found an answer to the problem in another pos...

why GetFieldValue() is so slow
I get connected a vfp6 dbf file, and the total record number is about 50000, I want to export specified field value ( most of their type are string), and the result is correct, but it works toooooo slow, and I find the function GetFieldValue takes most time. my code is: while(!m_Rs.IsEOF()) { for(index=0; index < m_ListDest.GetCount(); index++) { strLine=m_pSortItem[m_pSortList[index]]; m_Rs.GetFieldValue(m_pSortList[index], strVal); strVal.TrimRight(_T(' ')); if(strVal == "" && m_isFilter) continue; strLine.Insert(0, _T('[')); ...

When is the first worksheet activated?
The attached workbook (zipped) contains two empty Worksheets (Sheet1 an 2). I wanted to test when the first WorkSheet (say Sheet1) get activated, Therefore I added several Event procedures, each containin a simple Debug.Print statement. To my surprise the Activate event NEVER fired when opening th workbook. The sequence of recorded event was as follows: WorkBook_open WorkBook_Activate WorkBook_Window_Activate WorkBook_Window_WorkSheet_Sheet1_Activate The latter statement caused by a WorkSheets("Sheet1").Activate metho coded in the Window_Activate event. Even then, the Debug.Pr...

Outlook 2003 Pro with XP Pro Too Slow with McAfee 2004
I just bought a new high-end brandname laptop with XP Pro. In it, I: - installed Office 2003 Pro, - installed McAfee Internet Security Center 6.0 2004 (including Firewall, AntiVirus, Privacy Service, Spamkiller), and - downloaded and installed all latest MS and McAfee software updates, by the books. Hoping to lessen intra-computer response, I opted out some sub-features in McAfee. The installations were easy. Without McAfee, Outlook 2003 was fast, reliable. After installing and working with McAfee, Outlook 2003 is miserably slow in most operations (send/receive, clicking on ema...

Exchange 2000 very slow
My Exchange 2000 SP4 is very slow and every computer keep showing the Outlook Send/Receive Progress window. This is happen every morning. I have to restart the Exchange Server twice a day, once in the morning and later in the afternoon. Once I do that then everything is ok until the afternoon around 3:30pm. Could someone please tell what could be causing this problem and how can I solve the problem? Thanks in advance, Look for any processes that start to eat more ram throughout the day. if you see one find out what app it is from and check the manufacturer for an update. Sounds li...

Can't load the how to get started stuff in money 2002, running XP
How do I get the "how to get started" stuff to load in Money Help. I am trying to convert from Quicken to Microsoft Money 2002, running on a Gateway desktop using Windows XP Home. I have imported six quicken files to Money and now need to learn how to use Money. Anybody got some ideas for me? In microsoft.public.money, shirleyg wrote: >How do I get the "how to get started" stuff to load in Money Help. I >am trying to convert from Quicken to Microsoft Money 2002, running on >a Gateway desktop using Windows XP Home. I have imported six quicken >files to Mon...

slow printing
Just installed new dell for boss with win2k and office 2k, all update including w2k sp4 and off2k sp3. User now states that his HP4000 laser prints slow compared to his win98 that this machine replaced. The slow printing only seem to occur in excell - other programs seem fine. Any suggestions would be much appreciated. Thanks Bob Page ...

Loads of problems thanks to Windows 2003 Server SP1
Hi, I have encountered quite a lot of problems with Win 2k3 Server SP1 and they keep coming up to my annoyance! The problem I have now is not being able to apply a manual workflow rule in MS CRM 1.2. According to the KD Article ID 898654 there is a hotfix but one has to contact microsoft support!? Why not make this hotfix available for us all? I don't feel like paying ms support for something cause by a sp! my experience is that if you are calling MBS support to get a hotfix they should not charge you for the call. I would contact then to discuss further. -- John O'Donnell Mic...

Slow or no communication at all
Hello all. Since I'm new around here, please let me know if this is the right place to post this. I've been checking these forums for a long time now, but fortunately I always found what I was looking for and never had the need to post. For that, I want to thank you all for the tremendous work (and help) everyone participating here have been given throughout these years. The problem that brings me here today, relates not entirely to the SBS 2003. What happens is that we have several MAC OS machines connecting to several shares in a SBS 2003. Everything was ok untill one o...

Money 2006 to 2008
I got the dreaded notice that I needed to update so that I could continue my services. Was running 2006. No problems. Upgraded to Money Plus 2008. I really am using just the basic features for now. It takes *forever* to open. Once I do an online update and it completes, it takes about twice or three times as long to return control to me as 2006 did. Any way to speed it up? I'm running Vista on a not too ancient dual core 2.2 GHz with 4 GB RAM. In microsoft.public.money, Grouch wrote: >I got the dreaded notice that I needed to update so that I could >continue my services....

loading file contents
Hi First forgive me about my language if i have mistakes, english is not my native tongue. I'll try to ask again because i've got responses with to many different ways suggesting how to do a simple task. I have a SDI application project with menu bar, in the menu there is the open item, i want to load/open a file through the browse window, take the contents of that file and send it to a function which i've allready wrote, so i assume i need to put a code under the the "open" item, next to the "ToDo", so i've attempt to use the cfile class- open with ...

HRP Dictionary, please load
Bringing up a new instance of GP 8.0 I get the following message when I launch any tool having to do with employees or payroll: "The Human Resources Integrated with Payroll module is registered, but no HRP dictionary is available on this machine. To access the additional Human Resources information, please load the dictionary." I would, if I knew how :) You need to install the HR Module. You have it registered but have not installed it. "Roland Alden" wrote: > Bringing up a new instance of GP 8.0 I get the following message when I > launch any tool having to d...

Default-First-Site-Name / Servers and DNS question
Hi, I check my Active Directory Sites and Service, and under the Sites/ Default-First-Site-Name/ Servers, we have 3 servers. 1 root DC IP 192.168.1.1, and 2 node DCc, IP 192.168.15.1 and 192.168.16.1 respectively. However, I check the DNS service on the root DC 192.168.1.1, under the zone Mycom.com, and found no A record for the server 192.168.15.1, after I demote another DC 192.168.2.2 to a member server recently. But we still have a subzone Mzone for 192.168.15.1. How do I fix this problem? Thanks for help. Jason Hello Jason, In AD sites and services you hav...

Outlook runs slow
After downloading and installing an optional backup add-in from the microsoft website, i have noticed that outlook runs very slow now. Whenever i recieve new emails, there is a long delay when i select it to when the email actually appears. As well as when i delete it or adjust them in any way. This has caused me to delete wrong emails because i can't tell which one is selected because the delay in highlighting and bringing up the current email. Anyon have any idea why this is happening? Thanks for any help, Adam If you have Outlook 2002, try going to Tools -> Options -> Other...

the first time for trying
I am not clear about this function. Please stop following me in my newsgroup. I do not feel safe with your stalking. Thanks -Aaron On Mar 22, 9:42=A0am, "zhmq" <mqia...@126.com> wrote: > I am not clear about this function. ...

why is synchronizing so slow in Outlook Live
I am using Outlook Live and find that the synchronizing of my folders is exceedingly slow. I can understand that at home (26.4 Kbps), but at work I'm on a 384 DSL connection. Further, it is not uncommon to simply get "stuck" at, say, 20 of 93 messages. Perhaps related, perhas not, is the fact that when I send and receive on my hotmail account, I get hung up at 99% done. ...