missing type in xs:attribute

What type is used when I not specify it on xs:attribute?

for example

<?xml version="1.0" encoding="utf-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">
<xs:complexType name="XXX">
        <xs:attribute name="name" use="required"/>
    </xs:complexType>
</xs:schema>

Lars
0
Lars
4/14/2010 1:57:08 PM
dotnet.xml 7266 articles. 0 followers. Follow

1 Replies
1310 Views

Similar Articles

[PageSpeed] 47

Lars Schouw wrote:
> What type is used when I not specify it on xs:attribute?
> 
> for example
> 
> <?xml version="1.0" encoding="utf-8"?>
> <xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">
> <xs:complexType name="XXX">
>         <xs:attribute name="name" use="required"/>
>     </xs:complexType>
> </xs:schema>

A predefined simple base type, see 
http://www.w3.org/TR/xmlschema-2/#dt-anySimpleType

And http://www.w3.org/TR/xmlschema-1/#declare-attribute defines that 
that type is used in the absence of any type attribute or simpleType 
child element of an xs:attribute.


-- 

	Martin Honnen --- MVP Data Platform Development
	http://msmvps.com/blogs/martin_honnen/
0
Martin
4/14/2010 3:30:16 PM
Reply:

Similar Artilces:

Missing files
Hello I accidentaly deleted some folders from my E:drive. I realised what I had done, opened the recycle bin, and restored them. All Ok except for the E:Videos folder, which did not appear in the recycle bin ! It's not a disaster, as I have the folder backed up, but I'm puzzled ? Ideas pls ? Thanks KK On 19/05/2010 15:15, KRK wrote: > Hello > > I accidentaly deleted some folders from my E:drive. I realised what I > had done, opened the recycle bin, and restored them. > > All Ok except for the E:Videos folder, which did not appea...

Outlook 2007 Missing Mail
I have an office where we are noticing that if we look in Vista Mail that MS outlook 2007 has missed many emails. Program restarts and reboots don't seem to correct the problem, and both programs are using the same IMAP settings. Is there a "helpful" little option in Outlook that prevents it from looking a all email receieved to an account? Does anyone else have the same problem? are there any similarities between the ones it misses? -- "nano" <nano@discussions.microsoft.com> wrote in message news:DC22F7E7-ACB7-4824-A0A1-3329D3C622EA@microsoft.com.....

Primary Attribute of a New Entity
I'm having some difficulties wrapping my head around the required primary attribute of a new entity. I am trying to create a software module entity that has a parental relationship with an account, and can do a lookup into the products table. In the simpliest sense, those are the only two fields that I need. However, the system is forcing me to create, use and enter a third piece of data which is the primary attribute of the entity. Is there some way that I can suppress or at least hide this additional field? Is there a purpose for this field that I am not seeing? Thoughts appre...

Missing Emails #2
From time to time my users report that so-and-so sent them an email but they never got it. Last night my VP sent 2 emails from home and never got them. 1. We have Exchange 2000 server, all clients are Outlook 2. We have Symantec anti-virus for exchange server now I have checked the following: 1. in the Exchange logs [reading them in Excel] I can see the 2 messages arrive and seem to process normally -- HELO,MAIL, RCPT, DATA, QUIT are the 5 lines in the log; the datum on the HELO record says =+sccrmhc13.comcast.net. the Quit record as cs-uri-query of 240. 2. I have searched through...

I am typing in WHITE.. with Double spacing.. how do i reset plz ?
...

Missing Folders after Sync
After connecting to the Exchange Server, several folders that were created to store messages disappeared. They are not on the server or any .pst file in my system. Any idea how I can find them and restore? Where were they located? -- Robert Sparnaaij [MVP-Outlook] www.howto-outlook.com Tips of the month: -What do the Outlook Icons Mean? -Create an Office 2003 CD slipstreamed with Service Pack 1 ----- "Marc" <mhyoung@yahoo.com> wrote in message news:8a8201c4854a$3d473f10$a601280a@phx.gbl... > After connecting to the Exchange Server, several folders > that were c...

Bin Transfer Entry window missing
I am trying to enable multiple bins in GP 9.0 in the sample company. I clicked on Multiple Bins, ran reconcile and checklinks, but I cannot find the window to do a Bin Transfer Entry (Bin to Bin Transfer). I am looking under Transactions >> Inventory, and "transaction entry" is listed, as well as "Transfer Entry", as well as several other options, however, "Bin Transfer Entry" is not listed. Does anyone know how I can go about getting that option? Thanks, KJ Enter a transfer entry from site A to site A and complete the line. -- Richard L. Whaley Author...

Missing Fonts in Word Art
When I open up a Pub 2003 document on a computer that did not create the document, the fonts that are missing on the current computer are listed as the document is opened. These missing fonts are only those used in text boxes, not the fonts used in word art. The word art just defaults to an arial font. When I open the "edit text" menu in word art, the font box is blank. Do I have a setting wrong or is this just how it is with Publisher 2003? Thanks, -- ~~~~~~~~~~~~~~~~~~ Brad Lyon bradnospam@ldgpv.com PIPster wrote: > When I open up a Pub 2003 document on a computer ...

XmlSerialization and extensibility of derived types
Lets say I have designed my solution as a "base" assembly and a bunch of "implementation" assemblies. The goal is that I can add new implementation assemblies dynamically by declaring them in a config file. For example... Base Assembly: public abstract class A {} public class B { public A a; ) Implementation Assembly #1: public class A1 : A {} Now lets say I create an instance of B and set the field "a" to an instance of type A1 (a class I dynamically created as per my configuration file). How can I correctly serialize/deserialize B to disk? I h...

Missing Message Text
Yesterday, Windows Live Mail started doing something strange. I type the message, then press "send." The first lines of the message somehow are removed. The recipient sees only part of the message and only part of the message shows up in my sent messages folder. The first part is just gone. Seems to be only on messages that are replies. Any ideas on what the problem is, or how to correct it, would be appreciated. Never heard of this . . . . . are you on version 14.0.8089.0726? Regardless, try a reinstallation. "DeVere" <DeVere@discussions.microsoft...

user's messages-profile missing when connected to new domain-help
HI, Please be patient as the story is long: I migrated my users from a workgroup to a Client/Server network about a month ago. A network using Windows 2000 active Directory. All the clients workstations are Wondows 2000 professional. Before migration, I exported the emails, etc. to a .pst file and after migration imported the same file and all was fine. Last over the weekend our Active Directory server crashed by a Virus supposedly and we had to rebuil the servers, and couldn't have the users logon on to the network to the export/import scenarion again. After the server were re...

Missing Sata Sources
Hi there When I click Data, Get External Data, New Database Query..., there are no data sources listed in the Database list under <New Data Source>. Even the defaults e.g. dBase Files, Microsoft Access Database, Excel Files, etc are not listed. I am using Windows XP Professional with Office 2000. How can I fix this? Thanks Michael ...

Error on creating new attribute
Hi all: I am trying to simply create a new attribute in MSCRM using the tools provided in the app (Settings->Customization->Customize Entities->Account), and it fails with the oh-so-helpful message "An error has occurred, contact your system administrator". I checked the windows event logs, nothing. I also tried to enable debug tracing in MSCRM but that didn't tell me much either. Has anyone seen this before and know how to fix it? I tried creating attributes for several different entities, different types, different names, etc. but no joy. Thanks in advance fo...

How do I type in a form that I made?
I made a master copy of a form I made in publisher. I want to be able to type in the blanks on the form without the lines moving. Does anyone know how to do this? Thank you! -- Stella Put the form on the master page (ctrl+m), create text boxes on the publication page. This is the best Publisher can do. Word can do fill-ins. -- Mary Sauer MSFT MVP http://office.microsoft.com/ http://msauer.mvps.org/ news://msnews.microsoft.com "Eeyorepofl47" <Eeyorepofl47@aol.com> wrote in message news:2BE70163-CD59-4517-93D0-4E2364A859EF@microsoft.com... >I made a master copy of ...

What am I missing?
Have PC. Onlyprofile on it is administrator.Me. What am I missing on System Restore. There are partitions that I do not need,or want, for System restore to monitor. But "Drive Settings" in 'System Properties/System Restore' the choices are greyed out. ie; Turn off System Restore(disable by Group Policy) and Turn off System restore on this drive in Drive Settings. I have checked in services in administratyive tools. Botj System restore and RPC and started and on auto. Maybe one could show me what I'm missing. I'm getting too old to remember this stuff...

RMA ( Credit) Missing Line Items
This is a multi-part message in MIME format. ------=_NextPart_000_0056_01C87CA9.5D5D6C20 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Two RMA documents were received and then set as "Ready to Close". Both = documents show, in GP, as "History" but missing the line items. Checked the SQL tables and both RMA documents are in the "open" tables = (SVC05000 and SVC05200) and the line items are in the tables and appear = to be linked to the header. =20 How do we get the line items to appear on the RMA docu...

Missing .dll on opening
Upon opening Outlook 2002 I get a message that I am missing MociExt.dll but I cannot get it to reload during any sort of fix or reinstall of Outlook. Any ideas? This started occuring after a recent update I did to Office. John, I don't believe that's a file installed by Office/Outlook. So, my guess is that you have an Outlook add-in that's causing this problem. Please do the following steps to confirm this assumption: 1. Exit Outlook. 2. Press and hold the CTRL key as you launch Outlook. 3. When prompted to start in Safe mode click Yes. Does the error occur? If not, please...

Windows XP Home Edition Config\System Missing
Hi: My 15 year-old daughter has a Gateway system that is 4 years old, running XP Home. Today she encountered a black screen on start-up that essentially states Windows XP could not start because the following file is missing or corrupt: \WINDOWS\SYSTEM 32\CONFIG. We can't find the Operating System CD for Windows XP Home, and my XP Professional OS disc I read cannot be used instead. I have a read a resolution that requires ijnsertion of the OS XP Home disc; boot from CD; Windows set-up initializes and press "R" to repair recovery console; hard drive is examined; pe...

Scanpst missing
Outlook says there is problem with c:\users\xxx\appdata\local\microsoft\outlook\outlook.pst and to run scanpst.exe. I have Vista and after searching computer cannot find the file. Is there a way to download this file? My computer is french so I don't always knowthe translations It's there. Are you using 64bit vista? if so, office is in the 32 bit programs file. See http://www.outlook-tips.net/beginner/scanpst.htm -- Diane Poremsky [MVP - Outlook] Outlook Tips: http://www.outlook-tips.net/ Outlook & Exchange Solutions Center: http://www.slipstick.com/ Outlook T...

Font missing
I created a document in Publisher and printed it. Opened document a week later and received 'font missing' error message. In the Format...Font dialong box the font's name is there with the word (missing) next to it. Where did it go? Are you using a font manager? Maybe the link was broken. Do you have the font somewhere else on your computer? If so install/re-install it. -- Mary Sauer MSFT MVP http://office.microsoft.com/ http://msauer.mvps.org/ news://msnews.microsoft.com "andy" <andy@discussions.microsoft.com> wrote in message news:9390E623-E0FE-498A-AA6...

IMF Console missing??
Hello i just have one question , simple i hope! I use my pc (windows xp pro SP2) with a custom console to administer my domain , exchange , dns , etc... Everything is working fine. Last month i installed on my exchange , the IMF from microsoft. When i am logging on to my exchange machine localy or through RDC i can see in exchange system manager below SMTP ,the IMF icon and i am able to change setting install filters and so on... When i open my console from my pc and use exchange system manager console (i have installed exchange management tools and sp1) i cannot see IMF icon below SMTP Vitu...

integrated processing & credit/debit tender types
I am considering using integrated card processing with RMS (currently I use a standalong credit terminal I own and a tender type I created called "Credit and Debit"). I have the following questions: - Will RMS detect the proper card type when it is swiped, or does the cashier have to arrow down to the right tender type? If so it would help eliminate errors in choosing the wrong tender type (e.g. VISA, when it was really Mastercard). - Because of our fee rate structure with our card processor, we process debit cards as credit cards below a certain sales amount because it is c...

Missing Email #4
I am running a 2003 exchange server and one of my users sayes he isn't getting some mail that people say they are sending him. There is a mailbox listed in mailboxes called "Systemmailbox - {GIUD}" there are items listed in there. Could this be the missing mail? And is there anyway to see what these items are. Thanks for any help Damian It won't be in the System Mailbox. The System Mailbox contains schema information. There's generally no reason to ever need to access it unless PSS is instructing you to. As far as your user, make sure that you have message t...

Toolbars Missing, And option to Add Missing
Hi, My Problem is that my normal 'Formatting' toolbar is missing. When I right click on the 'Standard' toolbar to add/view the 'Formatting' the only options i have is: 'Task Pane' & 'Customize'. In 'Customize' the only tool bars listed is the 'Task Pane' & 'Work Sheet Menu Bar' Anyone know how to resolve my Problem... Please Pull-down View > Toolbars There should be about 15 bars listed. if not then select Customize > Toolbars and then push the reset button. -- Gary''s Student "SmeetaG"...

Assigning XML string as the content of an attribute
Hi. I want to assign an XML string to an XML attribute. This XML string must undergo "escape" conversion so that the < and & symbols are converted in to escaped equivalents. Does the .Net library have a conversion method that does this? Note that I want to construct the resulting XML string myself without having to use an XmlDocument. E.g. string myXml = "<root><record/><record/></root>"; string myDoc = "<doc myXml='" + Converter.escapeMyXml (myXml ) + "'/>"; -- McGeeky http://mcgeeky.blogspot.com ...