Installing 3rd party controls (TreeViewAdv)

I'm new to VS/C# and am trying to install a 3rd party TreeView control
that supports columns. I can compile the source application just fine.
It shows the controls on the left, but when I switch to a new project
they are gone.

I'm sorry for such a noobish question but hopefully this might help
others out.



P.S. Yes, I have searched google but it's possible I'm using the wrong
search terms. Oh, and the URL for the control in question is:
https://sourceforge.net/projects/treeviewadv
0
Magus
4/20/2010 5:03:09 PM
dotnet.languages.csharp 1931 articles. 0 followers. Follow

5 Replies
926 Views

Similar Articles

[PageSpeed] 55

"Magus" <mr.magus@gmail.com> wrote in message 
news:23d0bcae-9c24-4e91-a46f-291bec68d1fd@h21g2000vba.googlegroups.com...

> I'm new to VS/C# and am trying to install a 3rd party TreeView control
> that supports columns. I can compile the source application just fine.
> It shows the controls on the left, but when I switch to a new project
> they are gone.

By "on the left" do you mean that you see the control in the toolbox? This 
is because the project is either the tree view control itself or a sample 
project which references it. However, your "regular" toolbox is unaware of 
the control. To fix this, start a new project and right-click the group in 
the toolbox where you want this control to appear. Then select Choose 
Items..., find your control in the list, and check the box. Now it will 
appear in all future projects. 


0
Jeff
4/20/2010 5:46:11 PM
On Apr 20, 1:46=A0pm, "Jeff Johnson" <i....@enough.spam> wrote:
> "Magus" <mr.ma...@gmail.com> wrote in message
>
> news:23d0bcae-9c24-4e91-a46f-291bec68d1fd@h21g2000vba.googlegroups.com...
>
> > I'm new to VS/C# and am trying to install a 3rd party TreeView control
> > that supports columns. I can compile the source application just fine.
> > It shows the controls on the left, but when I switch to a new project
> > they are gone.
>
> By "on the left" do you mean that you see the control in the toolbox? Thi=
s
> is because the project is either the tree view control itself or a sample
> project which references it. However, your "regular" toolbox is unaware o=
f
> the control. To fix this, start a new project and right-click the group i=
n
> the toolbox where you want this control to appear. Then select Choose
> Items..., find your control in the list, and check the box. Now it will
> appear in all future projects.

I did "Choose Items" but it isn't listed.

Here are the steps I've done:

(3rd party control)
open solution, build, run.
save, close solution.
(new solution)
new solution, choose items, <nothing listed>
clicked browse, chose dll created in obj directory from 3rd party
control.
in toolbox right click, show all. it's listed but grey'd out.
0
Magus
4/20/2010 6:25:21 PM
On Apr 20, 1:46=A0pm, "Jeff Johnson" <i....@enough.spam> wrote:
> "Magus" <mr.ma...@gmail.com> wrote in message
>
> news:23d0bcae-9c24-4e91-a46f-291bec68d1fd@h21g2000vba.googlegroups.com...
>
> > I'm new to VS/C# and am trying to install a 3rd party TreeView control
> > that supports columns. I can compile the source application just fine.
> > It shows the controls on the left, but when I switch to a new project
> > they are gone.
>
> By "on the left" do you mean that you see the control in the toolbox? Thi=
s
> is because the project is either the tree view control itself or a sample
> project which references it. However, your "regular" toolbox is unaware o=
f
> the control. To fix this, start a new project and right-click the group i=
n
> the toolbox where you want this control to appear. Then select Choose
> Items..., find your control in the list, and check the box. Now it will
> appear in all future projects.

I have compiled the TreeViewAdv source, saved and closed solution.
Opened new solution, right clicked toolbox, choose items, no new
controls.
So i then clicked browse, and chose the dll created in obj/debug.
I right clicked the toolbox, show all, and it's listed but grey'd out.

No idea what I'm doing wrong. Am I supposed to place the source in a
specific place?
0
Magus
4/20/2010 6:41:17 PM
I have compiled the TreeViewAdv source, saved and closed solution.
Opened new solution, right clicked toolbox, choose items, no new
controls.
So i then clicked browse, and chose the dll created in obj/debug.
I right clicked the toolbox, show all, and it's listed but grey'd out.

No idea what I'm doing wrong. Am I supposed to place the source in a
specific place?

0
Magus
4/20/2010 7:04:28 PM
"Magus" <mr.magus@gmail.com> wrote in message 
news:aed56373-5e0d-4186-884d-43a232991766@j12g2000vbl.googlegroups.com...

>I have compiled the TreeViewAdv source, saved and closed solution.
> Opened new solution, right clicked toolbox, choose items, no new
> controls.
> So i then clicked browse, and chose the dll created in obj/debug.
> I right clicked the toolbox, show all, and it's listed but grey'd out.
>
> No idea what I'm doing wrong. Am I supposed to place the source in a
> specific place?

Did you really mean obj\Debug? Because you should be using the file in 
bin\Debug. Forget about the obj folder. 


0
Jeff
4/20/2010 7:16:51 PM
Reply:

Similar Artilces:

RE-Installing
I have a question..I have a client and they want us to test things on a machine beofre he moves it out into the lanes... is there a way that I can install on a machine thats not going to be a lane for testing purposes then be able to transfer it to a lane with no problems? I think you just need to get the demo version first for testing "Angelique" <Angelique@discussions.microsoft.com> wrote in message news:D134D852-6149-4027-9399-66A5BA4B06D9@microsoft.com... >I have a question..I have a client and they want us to test things on a > machine beofre he moves it out ...

Also Can't Install Latest Update
Version: 2008 Operating System: Mac OS X 10.5 (Leopard) Processor: Intel I'm using a registered version of Office 2008, version shows 12.0.0. Have been trying to install the latest patch 12.1.0 with no success. It sits for ages on the 'examining additional volumes' stage (there are no additional volumes) and then eventually puts the red exclamation mark on my disk with the note, "..a version of the software required is not on this computer.." I have tried the Autoupdater and the standalone download. Have tried with nothing else running (shift key held whilst logging-in)...

How to tell what Updates have been Installed?
I just tried the Microsoft AutoUpdate and it says there are no updates for your software at this time. I then clicked on the "View Installed Update" button and shows no history. Just blank page. My Entourage version is 12.0.1 and I think this is the current version. Should the 12.0.0 to 12.0.1 update be displayed on the installed updates page? How can this update be added to the blank installed updates page? There were some issues with 12.0.1, obviously--it doesn't show on my machine either. I don't know for sure, but I would expect that 12.1 will be a combo updater...

Failed to install: Business Data Lookup Snap-in for CRM 3.0
Hi, I went through the Installation wizard without errors or warnings. The Business Data Lookup Snap-in for Microsoft CRM toolbar does not appear in Word or Excel. I have tried to do as was instructed in readme-file, but it wont help. I should click View -> Toolbars -> Business Data Lookup Snap-in for Microsoft CRM, but the toolbar is the same than before (no Business Data Lookup). Any ideas???? -Sam- ...

Value Pak Installer
Does anyone know how I would access Value Pak installer for Mac Office X? Can it be downloaded from the Microsoft web site, and if so, where? Thanks. On 3/6/04 6:59 am, in article 176a901c4492f$f578ed10$a301280a@phx.gbl, "Brian" <anonymous@discussions.microsoft.com> wrote: > Does anyone know how I would access Value Pak installer for Mac Office X? > > Can it be downloaded from the Microsoft web site, and if so, where? > > Thanks. For Office vX, the value pack is on the installation CD. For Office 2004, there is no separate value pack. -- Barry Wainwrigh...

Installation #4
I am not sure that I am in the right place but I am trying to install Disc2 of Office 2000 Pro on Windows Xp. I keep getting a Not Responding prompt after I key in the Product Key Code. It identifies a file or something that is ---- SzAppName: msiexec.exe I really could use some help getting this resolved. I was able to install Disc1 with Word and such on it. I would like to install Disc2 that has Publisher and Small business tools. Please advise ASAP. Thanks, Paul Hi Paul (prh@insightbb.com), in the Microsoft� newsgroups you posted: || I am not sure that I am in the right place bu...

Do I need to install Office 2003 updates for Window 7?
I have a new computer with Window 7 operating system. I used my original disk and product code to install Office 2003 and it seemed to go well. Now I am wonering if I need to go back and install Office 2003 updates. I am primarily worried about Office 2003 security but thinking maybe Windows 7 takes care of that. If Windows 7 does not, which ones need to be used to update and how do I get access to them? "Gracious" <Gracious@discussions.microsoft.com> wrote in message news:27918728-D48A-4CB9-B530-5EEFBEF82337@microsoft.com... > I have a new computer with ...

Installer for my access application
Hello, All! I searching for installer for my program. It must support creating link like "path to msaccess.exe" "path to myprog.mde" /wrkgrp "path to users.mde" Is anybody know best solution for this??? Thank you in advance. With best regards, Alek Luchnikov. E-mail: alekluch---FORSPAMERS---1983@mail.ru ================================================= Look at Inno setup. It's free. "Alek Luchnikov" <alekluch---FORSPAMERS---1983@mail.ru> wrote in message news:um$uMd7dIHA.4728@TK2MSFTNGP03.phx.gbl... > Hello, All! > I searching f...

Fresh install, crystal issue.
During an install on an Enterprise server 03 SP1, I have run into DEP or Data Encription Protection. This stops each of the crystal services upon install and therefor after the install we recieved the infamous crystal license error. We checked and the APS service is not started and will not start no matter what we try. Also there is three tables missing from the Crystal database: APS_IdNumbers2, APS_InfoObjects2 and APS_VersionInfo. I am guessing that the missing tables is the reason the APS wont start, If I copied these three tables from another database would this work for getting ...

Installing XP over Linux
I am trying to install Windows XP on a Dell laptop that currently has Linux Ubuntu installed. After booting up with the Windows CD in the drive, it loads various Windows files, but eventually stops on a blue screen message advising me to run CHKDSK, but won't respond after that. I suspect that Windows is seeing the Linux partitions as disk corruption, but how can I get past this? "Kev" <ijk@ntlworld.com> wrote in message news:G2dSn.24841$US6.20663@hurricane... >I am trying to install Windows XP on a Dell laptop that currently has Linux >Ubunt...

Compare value to Lookup table min & max, return contents of 3rd ce
Hi Excel 2003 As per the example created below I'm using a formula to return a number value (in D1) that can be anywhere between 0.00 & 6.00 (including 0.00 & 6.00) I want my formula (in E1) to compare the value (D1) to min & max values in a table (A4:A9), so whichever min & max my value equals or falls between, it will return the value in a 3rd cell adjacent the appropriate min & max cells(C4:C9) : A B C D E 1 4.75 Pink 2 3 Min Max 4 0.00 0.99 Blue 5 1.00 1.99 Green ...

Writing an activex control to proxy calls to an unregistered activex control
Hi all, One of my clients needs to support using two versions of an activex control within Internet Explorer. However, both versions of the control register to the same CLSID meaning that it is not possible to run both concurrently without some intervention. One idea that I had was to create a new activex control under a different CLSID (and associate that CLSID with a different mimetype) so that requests to the new mimetype will be sent to the new activex control, which will in-turn proxy those requests to the unregistered version of the activex control. Has anyone had experience doing any...

CRM SBS install error
I installed CRM on SBS 2003 and had 1 problem with the Reporting Server being incorrect. But the CRM Setup Wizard tool would not run (kept getting an exception). So, I tried a repair of the CRM setup - no good. Then did an uninstall, and re-install. The install will not work - I keep getting the following error: Action Microsoft.CRM.Setup.Server.RegisterFaxService failed. The configuration registry key is invalid. I have not seen any posts that mention an error like this. Any idea what to try now? Thanks, Tom Were you installing on SBS 2003 premium? "TommyK" wrote: ...

Cannot see installed fonts in programs after installing with Font
OS 10.4 with current updates. Installed a TTF using the Font Book and it shows there correctly. But when going into Word for example, type in text, highlight it, click on the font format and the new font that was installed will not show in the list. I have already tried deleting the font cache, then rebooting and reinstalling the font thru the Font Book and just manually copying to the /Library/Fonts folder. Althought it sounds like you may already be aware of what it refers to, below is an excerpt from; http://www.macreviewzone.com/archive/hardcider/guestreviews/swope/osx_fonts.sht...

Compare 2 Sheets and Extract Unique Info to a 3rd Sheet
I have two sheets of stock data from a stock screener, both same parameters, just different time frames (i.e., one sheet is newer whenever I import new a new screen from the Internet), which will pull different stocks as time passes. I'm trying to compare the two sheets and extract the stock data (a whole row's worth of data, not just a cell) that is unique to the "Last Import" sheet. This would allow any new stocks identified on the screener to be transferred to a new sheet (called "Filtered List"). That way I don't have to research the same stocks over and ove...

Issue installing KB916803
Hi, I currently have a problem trying to install the above hotfix. I am trying to test this hotfix with Exchange 2003 server running SP2. I have downloaded the SP2 version of the hotfix from MS, but when I try to run it on my Exchange BE server, I get an error back telling me that the version of Exchange I have is too old, and that I need to install SP2 (even though that is what is installed)! I have tried reinstalling SP2, which didnt fix the problem. I then tried installing on a FE server, which had the same issue. I have now tried this in four different E2k3 SP2 servers, and all ...

Internet Printing: Printer Installation Failed. The driver files are not available for the current CPU platform
Hi. I have a SBS 2003 machine, I have 2 shared printers set up on it for remote users to print via IPP. Both printers are connected to Windows XP workstations. When I browse to https://servername/printers, I see all the printers. I can use the Connect link to install one of the printers on my workstation however if I select the second printer and click on Connect I eventually get the error: Printer Installation Failed The driver files are not available for the current CPU platform. Please contact your administrator to install proper driver files on the server. I've v...

CDC functions on top of a static control in a dialog
Hi all, I'm tring to add a little simple animation to a bitmap resource that's displayed in a static control. I had used a timer to trigger an animation function but nothing appears if I'm trying to paint in the area of the bitmap (otherwise it shows fine). I suspect that the static is receiving a wm_paint message after I've done my animation. So... without subclassing my static control and handling the paint myself, is there a way I can add code to the dialog class to handle the paint messages of its controls? Thanks. (ps eVC 4 on a Fujitsu Teampad but I reckon embedded MFC...

client installation
i have installed crm 3 server and it working fine. when i try to install the client i get this message :Action microsoft.crm.setup.client.installabpaction failed exception from hresult:08004010f can you help please gil Gil; What version of windows/outlook is installed? Which version of the outlook client are you installing (laptop or desktop)? Are you installing from the CD, or across a network share? At what point does it fail? Dave "Gil Gilon" <Gil Gilon@discussions.microsoft.com> wrote in message news:07D48A61-81B4-4B1C-BF43-9A45A01C5BB7@microsoft.com... &g...

DOES ANYONE KNOW HOW TO INSTALL SPELL CHECK?
Go to www.c360.com. You can download a small spellcheck "add-on" that works with iespell. It's free and it works well. Regards, John ...

Excel won't start after install
After installing office XP excell goes through the motions but never actually starts...help Jon, Try the following: Go to the Windows Start menu, choose Run, and enter Excel.exe /regserver -- Cordially, Chip Pearson Microsoft MVP - Excel Pearson Software Consulting, LLC www.cpearson.com "Jon" <anonymous@discussions.microsoft.com> wrote in message news:010701c3aad2$20f75500$a301280a@phx.gbl... > After installing office XP excell goes through the > motions but never actually starts...help ...

Excel 2003 installation error
I have been using my PC with excel program for 3 years and when I tried to open an excel spreadsheat today and it would not open. "Installation error: file not found" appeared. File not found was SKU011.CAB and I have not been able to reinstall as I don't have the installation CD as I bought the PC second hand with programs on it. Can anyone help? If you have access to another computer you could save the file from one computer to a disc and copy it in to the appropriate file folder in the computer with the error. "derk22" wrote: > I have been using my PC wit...

installing updates. Never ends
when i did a restart, windows notified me it was installing updates and not to turn off the power as windows would restart itself. I keep getting a message the 2 of 3 updates installed. next says do not turn off computer.\\ well what do I do when the update never ends? TIA Snooky wrote: > when i did a restart, windows notified me it was installing updates > and not to turn off the power as windows would restart itself. > > I keep getting a message the 2 of 3 updates installed. next says > do not turn off computer.\\ > > well what do I do when the...

Office 2004 Mac install issue
Hi, Just visited a client with the following setup: 1 x brand new G5 iMac running Mac OS 10.4 1 x 2nd hand eMac 1 x copy of teacher version (3 licences) of Office 2004 Mac. The install on the iMac was faultless. The eMac is a different issue. As it was 2nd Hand we restored it to "out of the box" with the supplied DVD's (no old data remained on the machine). That brought it to 10.3.9. we then upgraded it to 10.4 using a fresh copy bought by the client. Trying to install Office the following happened. Using the setup assistant, the first screen was OK (telling us to be logge...

Installation of Money 04 with anti-virus
When I started to install Money 2004, I got a message saying that my McAfee Virus Scan might interfere with Money setup, and "can prevent you from using Money to download stock prices and other info..." Any advice? Take the message seriously. And search the archives of the newsgroup at http://groups.google.com; use advanced search and search newsgroup microsoft.public.money. "Clarence" <anonymous@discussions.microsoft.com> wrote in message news:08e201c3ce58$bc73dea0$a001280a@phx.gbl... > When I started to install Money 2004, I got a message > saying that my...