Work Flow problem

Here is what I want, I have a custom picklist in my contact form. I would
like for an email to be launched to a given user when a given item is
selected from that picklist.

So in other words, lets say I have a picklist on the contact form, called
"status". When a user modifies this contact and changes the "status"
picklist from null to "Prospect", it will send an email to their manager.

Here is what I've done, I create a new rule under Contacts. The event I
choose is "Change Status" (later I try Manual). And I place a wait
condition:
When contact status is changed
wait
    Contact.CFPstatus = Prospect
end wait
E-mail Doe, John: Change made to contact, please review

I save it. Activate it. Open a contact, change the "status" field to
Prospect, save it, and nothing happens. I go back to this rule, and change
it:
When contact status is changed
if
    Contact.CFPstatus=Prospect
then
    E-mail Doe, John: Change made to contact, please review
end if

I save it, activate, etc, etc, and still nothing. I tried both these ways
under manual, and still nothing. Now if I run it manually, (ie through
Actions, Apply Rule), it will launch.

I see no errors in the workflow monitor or in the event log for CRM or
Exchange.

any help would be greatly appreciated

tia,
 Gary


0
gary.rey (2)
8/28/2003 9:39:15 PM
crm 35858 articles. 1 followers. Follow

4 Replies
460 Views

Similar Articles

[PageSpeed] 24

Gary,

The problem you are running into is that the "Change Status" event is NOT
tied to your custom field, it is tied the the standard Status field (Active,
Inactive, etc).  As a result, your workflow is not firing since the status
on the contact hasn't changed.

Unfortunately, there isn't any way to do what you are looking to do within
the supplied Workflow.  It does a lot in certain areas, but it is definately
lacking others.

Matt

"Gary" <gary.rey@NOOOOSPAM.virtium.com> wrote in message
news:ezwg6xabDHA.656@tk2msftngp13.phx.gbl...
Here is what I want, I have a custom picklist in my contact form. I would
like for an email to be launched to a given user when a given item is
selected from that picklist.

So in other words, lets say I have a picklist on the contact form, called
"status". When a user modifies this contact and changes the "status"
picklist from null to "Prospect", it will send an email to their manager.

Here is what I've done, I create a new rule under Contacts. The event I
choose is "Change Status" (later I try Manual). And I place a wait
condition:
When contact status is changed
wait
    Contact.CFPstatus = Prospect
end wait
E-mail Doe, John: Change made to contact, please review

I save it. Activate it. Open a contact, change the "status" field to
Prospect, save it, and nothing happens. I go back to this rule, and change
it:
When contact status is changed
if
    Contact.CFPstatus=Prospect
then
    E-mail Doe, John: Change made to contact, please review
end if

I save it, activate, etc, etc, and still nothing. I tried both these ways
under manual, and still nothing. Now if I run it manually, (ie through
Actions, Apply Rule), it will launch.

I see no errors in the workflow monitor or in the event log for CRM or
Exchange.

any help would be greatly appreciated

tia,
 Gary



0
Matt
8/28/2003 10:37:12 PM
Gary,

Although I have learned a lot from Matt's postings, and 
he is correct that your status field is not tied to the 
Change Status event, I do believe you can do what you 
want here.  The trick is not to use the "Change Status" 
event, but to use the "Create" event, and add a WaitFor 
Condition.  (Sounds very bizarre, I know, but it works 
like a champ.)

The "logic" behind this is that the workflow runs when 
you create the object, then waits for the condition to be 
satisfied.  In this way you can create many workflow 
rules based on "Update" events that you wouldn't think 
are supported. 

If you change the type to Create, and enter the same 
logic you show in your example, it should work...

One caveat: this will generate a boatload of active 
workflow rules, because it will remain active until that 
condition is satisfied, which may be never.  (What is 
really needed is a way to clean up the 'orphan' active 
rules that still exist even after the object has been 
closed, or deleted.)

But give the create/wait for condition methodology a 
shot!  Good luck,

Dave
0
Dave
9/3/2003 12:35:16 AM
Dave,

That's an interesting approach and it should work.  I give you credit for a
creative work around.

I would be concerned though about the number of "active" workflow instances
that would be created.  Especially, as you've noted, since there isn't a way
to clean these out.  Over time, this could have serious impact on the
performance of the server as it will incur more and more overhead in
monitoring these instances.

Matt

"Dave Carr" <davidlcarr@earthlink.net> wrote in message
news:04c501c371b3$3efcdeb0$a601280a@phx.gbl...
Gary,

Although I have learned a lot from Matt's postings, and
he is correct that your status field is not tied to the
Change Status event, I do believe you can do what you
want here.  The trick is not to use the "Change Status"
event, but to use the "Create" event, and add a WaitFor
Condition.  (Sounds very bizarre, I know, but it works
like a champ.)

The "logic" behind this is that the workflow runs when
you create the object, then waits for the condition to be
satisfied.  In this way you can create many workflow
rules based on "Update" events that you wouldn't think
are supported.

If you change the type to Create, and enter the same
logic you show in your example, it should work...

One caveat: this will generate a boatload of active
workflow rules, because it will remain active until that
condition is satisfied, which may be never.  (What is
really needed is a way to clean up the 'orphan' active
rules that still exist even after the object has been
closed, or deleted.)

But give the create/wait for condition methodology a
shot!  Good luck,

Dave


0
Matt
9/3/2003 7:12:31 PM
Wow, thanks Steve! It worked!

 But you both make a good point about cleanup. But we really need this
process........so hopefully I can assuming that a cleanup of the workflow is
in the not so distant future.

-Gary

"Matt Parks" <Matt.Parks@removetoX_XRevereGroup.Com> wrote in message
news:%23uMng9kcDHA.1884@TK2MSFTNGP10.phx.gbl...
> Dave,
>
> That's an interesting approach and it should work.  I give you credit for
a
> creative work around.
>
> I would be concerned though about the number of "active" workflow
instances
> that would be created.  Especially, as you've noted, since there isn't a
way
> to clean these out.  Over time, this could have serious impact on the
> performance of the server as it will incur more and more overhead in
> monitoring these instances.
>
> Matt
>
> "Dave Carr" <davidlcarr@earthlink.net> wrote in message
> news:04c501c371b3$3efcdeb0$a601280a@phx.gbl...
> Gary,
>
> Although I have learned a lot from Matt's postings, and
> he is correct that your status field is not tied to the
> Change Status event, I do believe you can do what you
> want here.  The trick is not to use the "Change Status"
> event, but to use the "Create" event, and add a WaitFor
> Condition.  (Sounds very bizarre, I know, but it works
> like a champ.)
>
> The "logic" behind this is that the workflow runs when
> you create the object, then waits for the condition to be
> satisfied.  In this way you can create many workflow
> rules based on "Update" events that you wouldn't think
> are supported.
>
> If you change the type to Create, and enter the same
> logic you show in your example, it should work...
>
> One caveat: this will generate a boatload of active
> workflow rules, because it will remain active until that
> condition is satisfied, which may be never.  (What is
> really needed is a way to clean up the 'orphan' active
> rules that still exist even after the object has been
> closed, or deleted.)
>
> But give the create/wait for condition methodology a
> shot!  Good luck,
>
> Dave
>
>


0
Gary
9/4/2003 5:19:36 PM
Reply:

Similar Artilces:

Address list problems
I am receiving loads of these error messages. LDAP returned the error [32] Insufficient Rights when importing the transaction dn: CN=Recipient Update Service (Enterprise Configuration),CN=Recipient Update Services,CN=Address Lists Container,CN=holtswell,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=holtswell,DC=LOCAL changetype: Modify msExchReplicateNow:FALSE I have found this article http://support.microsoft.com/default.aspx?scid=kb;en-us;254030 I checked the write permissions on the exchange enterprise server group and can confirm I have 4 entries with write permission th...

Send to Onenote on Windows 7, driver won't work?
I downloaded the driver from David Rasmussen, but every time I open OneNote after printing to XPS I get the message "Unhandled exception has occured in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately. Object reference not set to an instance of an object." If I click continue it still doesn't work. This was one of my favorite features - PLEASE PLEASE PLEASE find me a way to use OneNote! I lived off of it last year. Rilli wrote: > I downloaded the d...

Hyperlinks to DB dont work now that DB is converted
We have converted all our Access 97 databases to Access 2000- not without a lot of issues. Most of them have now been researched and resolved, some re-coded, etc. We have one issue that we cannot resolve. We used to have hyperlinks on our Intra-net to several Access Databases. These were essentially "shortcuts" to the databases so that the general population could have easy access. Now that we did our Access conversion, the hyperlinks on our intranet do not work. Clicking on the link gives an option to open the file from its current location or download it to a local loc...

"Page setup" "sheet" in Excel problem
When attempting to print row titles on each page I am having difficulty. In the preview mode I click "setup" "sheet", but I am unable to enter to rows that I want repeated. Any suggestions In Normal, Page Break Preview, or Page Layout view, choose File/Page Setup... In article <475FACA6-B203-4F67-9F4B-147FDE132132@microsoft.com>, Vern T <Vern T@discussions.microsoft.com> wrote: > When attempting to print row titles on each page I am having difficulty. In > the preview mode I click "setup" "sheet", but I am unable to enter to ro...

auto caps don't work
in outlookk 2003, even tho i have set tools, options, spelling to autocorrect the first word of a sentence. it doesn't do it. i have never had this problem before, but now i have a new laptop and can't get this feature to work. -- tom martin Are you using Word as your editor? If so, your settings are there. Otherwise, learn to type. http://www.broderbund.com/jump.jsp?itemID=4713&itemType=CATEGORY&path=1%2C2%2C4713&ysmchn=GGL&ysmcpn=Typing&ysmcrn=sr2br29go633go202pi10ai50&ysmtrm=sr2br29go633go202pi10ai50+mavis+beacon&ysmtac=PPC&ovtac=PPC&SR=s...

Problem with file links changing
Good day all. Excel 2007. I have a number of workbooks in memory some having file links referencing a data file also in memory. I have code which firstly saves the current data file (constantly updating) at month end run and then "Saves As" to another directory with a different file name. It then closes the new file and re-opens the original so that processing can continue for the new month. However, my problem is that all files with links to the original data file have now changed to reference the Saved As file!! e.g. VLookup and HLookup. I have tried various avenues ...

Haveing problems inserting a row
Here is the problems I am working off of 3 different workbooks that are linked together Every time that I insert a new row, the forumlas do not update. I there a way for me to insert a new row so that it will change th forumlas?? I am hopping this could be done? thanks for any help you can give me Turb ----------------------------------------------- ~~ Message posted from http://www.ExcelTip.com ~~View and post usenet messages directly from http://www.ExcelForum.com ~~Now Available: Financial Statements.xls, a step by step guide to creating financial statements On Thu, 4 Dec 2003 22:0...

Outlook send problem
Outlook 2002, Win 2000. Suddenly, my Outlook will not send any messages. I deleted my email account & set it up again. When I hit "test account settings" it does everything correctly and sends the test message successfully. But then I go in and send a message and it sits in the outbox, then returns a message that it has timed out waiting for a response from the smtp server. Any ideas? Thanks so much. Hi Loy, maybe in this two articles is your answer http://support.microsoft.com/?kbid=836562 http://support.microsoft.com/default.aspx?scid=kb;en-us;302357 "Loy Mil...

working with temporary working files..
I keep getting the message that I cannot save a temp. working file. This work has been save on a cd and transfered back on to my desk top. Help ...

How does hibernate work
I have a question on the details of how hibernate works. I know it's saving everything in memory to the hiber file. Since power seems to be truly off at hibernation I assumed the flag to tell the PC to resume from the hiber file rather than normal booting must be either saved on disk or flashed to a bit of bios rom space, or maybe in space maintained by the clock battery. But the cure for a laptop that is stuck in a loop of constantly resuming from hibernating is to unplug it and take the battery out for a while so where actually is the flag to signal the system that it's in hi...

Search does not work for one workbook
I have workbook, but search (spotlight) often does not work for it. Drives me crazy. What can this be. I see peoples names in there. Kevs OS 10.6.2 INTEL imac Office 2004 Hi Kevs: It could be the file format the workbook is saved in. What extension does the file-name have? The extension tells the system what kind of data a file contains, which controls which importer Spotlight uses to read the file: if there is no extension you could get strange results. Cheers On 6/01/10 2:47 AM, in article C7689F21.5718F%forums55@verizon.net, "forums55@verizon.net"...

Non-working work week
Is there any way to make an entire week a non-working work week? As in, a task is going to take 25 days, but the 4th of July occurs in the middle and you want to show that during that week (or 2), no work will occur. Besides creating a new task or extending the task during. Thanks in advance! Hi RVE, Open up the calendar, "Tools", 'Change working time..', then simply select the days you want as non working. Make sure that the calendar you change is the Project calendar and is the basis for all other calendars such as individual resource calendars. Hope thi...

black blocklist problem
I tried to implement blacklist in exchange 2003 SP2 using message delivery properties-Connection filtering and enabled it in SMTP connector. The problem: when I added a few rules in blacklist my exchange started block all e-mails with spam notification. For example when I added the following domains: xvinject42.com,backwards.com,mailcity.com,a-ok5.com, exchange blocked all business e-mails that came to our server. I tried to search knowledge base, but find noting. I am using Symantec mail filtering v4.6 and I got the same result if I use black list under anti-spam option: I think Symantec...

GP8 Manufacturing
Hello Everybody. Our Shop works 5 days a week (closed weekends). We have a WC that works 6 days a week (down Sundays only). We have setup both the Shop and WC Calendars to reflect this reality. We would expect that, when scheduling an MO that routes thru this WC, the WC calendar will override the Shop Calendar? However, our tests are not showing this to be true - We use a Backwards Infinite Scheduling Method and it always skips the weekend when calculating the start day of an MO regardless of the WC. Does anyone have any experience working with the WC Calendars? Please share your wis...

OMA Problems #2
Hi, I wonder if anyone can help. We have a Front end / back end setup with OWA working fine with and without forms based authentication. I understand there is a problem with SSL/Forms based authentication, so to get OMA working we have disabled this. However we get the following error messages:- Event Type: Error Event Source: MSExchangeOMA Event Category: (1000) Event ID: 1503 Date: 19/02/2006 Time: 20:15:14 User: N/A Computer: FRONTEND Description: An unknown error occurred while processing the current request: Message: Index was out of range. Must be non-negative and less than the ...

Graphing work and remaining work over time
I would like to generate a graph showing total actual work and remaining work for a top level task over time (week), This would enable me to show the projected remaining work through the duration of the project as it decreases from N to 0, and show the actual work completed though the duration of the project as it increases from 0 to N. The canned visual reports don't allow me to do this (that I can see anyway). Maybe I'm missing something. I also can't see how to customize a visual report that will do what I want. Using Microsoft Project 2007 (not the Server edit...

Problem with custom formats
I have a client that is trying to export an excel spreadsheet to an Access database The excel spreadshheet has some custom formats to aid in the speed of data entry. The problem is this. For Instance: Cell A1 is formated Custom 5_??"/"32. When you go to that cell and enter 8 .... 5 8/32 is displayed. However the actual value in the cell is 8. When I import this cell into Access I get 8. I actually need 5 8/32 even if it is a text field. I tried all the cut and paste and special paste options to no avail. Is there any way to capture the literals in the format of the cell...

Simple problem of combo box
Hi, I have access 2000 as front end for SQL server 2000. On the form I have a combo box which lists values from a table. The problem is I want to restrict user from entering only the values in the drop down box. Any help will be greatly appreciated. Thanks ...

outlook2003 send button does not work
send button does not work i have tryed a new email acc. and reinstalling with no luck. now i am useing express and then export to outlook ...

send email problem
i'm trying to send email from contact screen & got the error sending mail - contact admin -- where can i look to diagnose ?? check the CRM Web server event logs to see if it reports an error. Also check the registry on the CRM web box and mail sure the mail url which should point to your exchange server appears correct. -- John O'Donnell Microsoft CRM MVP http://www.mscrmfaq.us "HT" <HT@discussions.microsoft.com> wrote in message news:64E093DB-E4CF-4A32-8BF0-B4D227FDF0A5@microsoft.com... > i'm trying to send email from contact screen & got the err...

Drag and Drop does not work
Hi all. This is funny: When I try to drag and drop a message from "Inbox" to "Backup" I get an error message. When I right click and select "move to folder"- it does work. ANY CLUES? TIA Guy Not a single one. No Outlook version = no clues. -- Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. All unsolicited mail sent to my personal account will be deleted without reading. After furious head scratching, Guy Cohen asked: | Hi all. | | This is funny: | When I try to drag and drop a message from "Inbox" ...

Internet Explorer E-mail links are no longer working in Outlook?
Hi, As soon as I click an e-mail link in Internet Explorer, another Outlook pops up. It used to just open a fresh new e-mail screen with the persons address already in the "TO:" line ? I can't figure out what I did wrong. Thanks, Rich ...

SunTrust Auto-Download Not Working after Banking Upgrade
I have been automatically downloading transactions from SunTrust since I installed MS$ 2007 Deluxe last year. I have done this without having to signup (for a fee of 5.95/month) with SunTrust for MS$ support. AFter the MS Banking Upgrade, I had to re-establish my SunTrust account with MS$. But, now I'm told (by MS$) that I don't have a SunTrust on-line account. Any thoughts? Anyone? I have been having issue as well with Suntrust, even if you get it to work you will find that its basically useless now downloading and duplicating pending transactions repeatedly, this is where I am ...

Spell check not working.
Version: 2004 Operating System: Mac OS X 10.6 (Snow Leopard) Processor: Intel I reinstalled SL and all my MS office apps and updates. I noticed that spell check does not detect spelling errors. Auto spell check is on and even when I manual invoke spell check it does not detect errors. <br><br>I see a progress bar at the word that is intentionally misspelled and the only dictionary that I see and it is check is a custom dictionary. <br><br>Should I reinstall Word? <br><br>Thanks in advance. No, reinstalling is not a fix on a Mac in the overwhelming m...

Y axis fixed value problem
Hi, I'm working with fairly large datasets, ~10k lines in 6-10 columns. The data are elevations taken on the hour, every hour for a year or two. When I graph these in 2007, I use a connected scatter plot, just as I would in 2003. Excel happily works with the data and creates the graph, but doesn't always get the vertical axis scaling how I want it. As soon as I try to fix the values for this axis where I need them, the program slows to a crawl. Spreadsheet functions still work fine, but anything involving the chart is slow. For example, a right click on the series in the ...