Problem creating new customeraddress records

We're trying to write a data migration tool using the 3.0 SDK to
migrate some data to CRM 3.0.  I am getting an error when assigning a
GUID (of type 'contact') to the parent id field *of the
custommeraddress* class:

******************
customeraddress_add.parentid = new Lookup();
customeraddress_add.parentid.type = EntityName.contact.ToString();
customeraddress_add.parentid.Value = new Guid(snew_contactid);

TargetCreateCustomerAddress target = new TargetCreateCustomerAddress();
target.CustomerAddress = customeraddress_add;
CreateRequest create = new CreateRequest();
create.Target = target;
CreateResponse created = (CreateResponse)service.Execute(create);
******************

The description of the error returned is always "The specified entity
was not found.".  I step through the code and I see that snew_contactid
is indeed valid and correct (I can use qa to find this record in the
SQL database, for example).

To experiment further, I tried adding the 'parentid' attribute to the
customeraddress form.  After saving and publishing the changed form,
*every customeraddress in the 'More Addresses' tab comes up with a big
error stating "The specified entity was not found."  I'm starting to
wonder if this unexpected behavior is just a coincidence...

We're trying to import multiple addresses per contact, so it's
important that we figure out a way to do this (and the CRM webservice
is highly preferable).  Any ideas on how to resolve this?  Your
suggestions and help are greatly appreciated.

-Erik

0
ealmquist
5/24/2006 12:06:38 AM
crm 35858 articles. 1 followers. Follow

2 Replies
661 Views

Similar Articles

[PageSpeed] 10

Hi
In your code your are missing setting a system required field namely 
'objecttypecode'. Having the parentid field displayed on the form, doesn't 
relates at all to its creation through SDK.
Objecttypecode field tells the type of entity with which the customer 
address is associated.
Make the following changes to your code, and I hope it will work.

******************
> customeraddress_add.parentid = new Lookup();
> customeraddress_add.parentid.type = EntityName.contact.ToString();
> customeraddress_add.parentid.Value = new Guid(snew_contactid);

    customeraddress_add.objecttypecode = new EntityNameReference();
    customeraddress_add.objecttypecode.Value = 
EntityName.contact.ToString();

> TargetCreateCustomerAddress target = new TargetCreateCustomerAddress();
> target.CustomerAddress = customeraddress_add;
> CreateRequest create = new CreateRequest();
> create.Target = target;
> CreateResponse created = (CreateResponse)service.Execute(create);
> ******************

Revert back if any issue

Regards,
Nitin


<ealmquist@gmail.com> wrote in message 
news:1148429198.178561.48420@i40g2000cwc.googlegroups.com...
> We're trying to write a data migration tool using the 3.0 SDK to
> migrate some data to CRM 3.0.  I am getting an error when assigning a
> GUID (of type 'contact') to the parent id field *of the
> custommeraddress* class:
>
> ******************
> customeraddress_add.parentid = new Lookup();
> customeraddress_add.parentid.type = EntityName.contact.ToString();
> customeraddress_add.parentid.Value = new Guid(snew_contactid);
>
> TargetCreateCustomerAddress target = new TargetCreateCustomerAddress();
> target.CustomerAddress = customeraddress_add;
> CreateRequest create = new CreateRequest();
> create.Target = target;
> CreateResponse created = (CreateResponse)service.Execute(create);
> ******************
>
> The description of the error returned is always "The specified entity
> was not found.".  I step through the code and I see that snew_contactid
> is indeed valid and correct (I can use qa to find this record in the
> SQL database, for example).
>
> To experiment further, I tried adding the 'parentid' attribute to the
> customeraddress form.  After saving and publishing the changed form,
> *every customeraddress in the 'More Addresses' tab comes up with a big
> error stating "The specified entity was not found."  I'm starting to
> wonder if this unexpected behavior is just a coincidence...
>
> We're trying to import multiple addresses per contact, so it's
> important that we figure out a way to do this (and the CRM webservice
> is highly preferable).  Any ideas on how to resolve this?  Your
> suggestions and help are greatly appreciated.
>
> -Erik
> 


0
Nitin
5/28/2006 12:02:08 PM
This worked!  Thank you so much for this helpful post!

0
ealmquist
5/30/2006 5:13:52 PM
Reply:

Similar Artilces:

more than two MX record
Hi gurus I have and exchange 2000 server, two statics ip, two routers.- each router has it own Ip address.- my mx record points to one of my public IP and all email comes through this using one of my router, then my router push all email to my spam firewall and my firewall push those emails to my exchange server. I want some of my outside user to send email using the other router and bypass my spam firewall. do I just create another MX record pointing to the next static ip and use my router to forward those email directly to my exchange server my MX record mail.domain.com can I cr...

Problem shortcuts in Word
Hello, I work with Word 2008. In the beginning there is no problem, but suddenly i have problem with shortcuts. When i want to do "cmd c" it make an other shortcuts same thing for "cmd s", "cmd v" and surly some other. But when i write there is no problem "c" is "c"... If somebody have an idea please help me. Thank you. Unless you indicate your specific update level of Office as well as OS X & describe what the keystrokes *are* doing contrary to what you expect there isn't much we can offer. -- Regards |:>)...

encoding problem in Outlook 2007 importing Outlook 2000 personal folders
I use Outlook 2007 to import the pst file of Outlook 2000. The Chinese characters in the subject became unreadable but it's ok to display in message body. In Outlook 2000, there's no problem to display the Chinese characters in the subject. What's wrong with Outlook 2007? What setttings should I change to fix the problem? Thanks. cyl <u8526505@gmail.com> wrote: > I use Outlook 2007 to import the pst file of Outlook 2000. The Chinese > characters in the subject became unreadable but it's ok to display in > message body. In Outlook 2000, there's no problem t...

Outlook 2003 PST problems
I just installed Office 2003 professional on a new computer & am having problems with outlook. I copied my Outlook.pst file into the appropriate directory & although it is recognized the calendar is not working properly. I cannot attach any of the colored labels to my appointments - so everything is pretty much in black & white. I totally uninstalled & reinstalled office... first removing my pst file... but there appears to be an ini file... or something that is retaining some information... does anyone know of a fix for the labels... or how to TOTALLY uninstall office (so I...

How do I link data workbooks to a create a graph?
I am attempting to take workbooks from the last 4 months, each with a daily data sheet, and link Mondays, Tuesdays, Wednesdays, etc. to time of day and staffing levels. I want the final result to be charts that show the relationship between staffing levels, incoming call volume, and time of day. hi Andrea, Many things are possible in Excel & I'd say that you could probably find a way of linking all the workbooks. However, I think any "easier" approach would involve opening each file & copying the data from each sheet in each file to a single sheet in one file (with...

Outlook 2007 and Windows 7
After installing Office 2007 on Windows 7 machine, I get no new mail sound, pop up notifications or the new unread mail icon in task bar. Every thing else seems to work fine. Any hints? are the icons in the overflow? -- -- Diane Poremsky [MVP - Outlook] Outlook Tips: http://www.outlook-tips.net/ Outlook & Exchange Solutions Center: http://www.slipstick.com/ Outlook Tips by email: mailto:dailytips-subscribe-request@lists.outlooktips.net EMO - a weekly newsletter about Outlook and Exchange: mailto:EMO-NEWSLETTER-SUBSCRIBE-REQUEST@PEACH.EASE.LSOFT.COM Poll: What v...

Problem with Authentication
The CRM application was running smooth. But now I can't logging. It ask my credentials and than return a 401.1 error. I had already reinstalled the CRM server but it won't work. I'm accessing it in the same local network. I'm running CRM 3.0 in SBS. Best regards, Erico Hi When you open a Internet explorer and type the name of the CRM server, it prompts for user and password ? Are you logged in with domain credentials ( AD user ) ? If you are, so add url of the crm server in Local intranet. Enable "Automatic logon only in intranet", this is under security,c...

calendar problem
Dear all, I am using both mail and calendar function in outlook 2002. Everything is ok until recently, when I try to make a new appointment or checking any old appointments, an error message "out of memory or resource, try to close some windows..." pop up. The mail function is still ok. Can anyone tell me how can I solve this? I have already installed sp2. The version of office is the professional one with frontpage. Thanks. tp ...

Create a Variable from First 4-5 chars of a existing value ??
In a current table, the values in a particular field are all items like: MD45 Tuesday PM or TX341 Friday AM or FL12 Monday PM ...in other words...2 parts seperated by a space. The first part is always a State Abbrv. followed by either a 2 or 3 char. number. That first part will always be 4-5 characters long (or...everthing before the first Space). I'm needing to create a varible that is the First Part of the existing value.. ..in other words...the variable would need to be (from the above examples)... MD45 or TX341 or FL12 I'm kind of familiar with LEFT command. Would usin...

Vista blue screen problem...please help!
I've seen some other threads, here are the dump files: 'RapidShare: 1-CLICK Web hosting - Easy Filehosting' (http://rapidshare.com/files/347103149/Minidump.rar.html) Please, help me out here. -- ceVil It might be better to know at what point the bsod occurs and what the actual err.msg given is "ceVil" <guest@unknown-email.com> wrote in message news:0b9a0c60b90bf6c0be88bda30f2820ab@nntp-gateway.com... > > I've seen some other threads, here are the dump files: > 'RapidShare: 1-CLICK Web hosting - Easy Filehosting' > (...

In Word 2000 how do I undo Skip Record If
In creating my first mail merge file I thought the "Skip Record If" might work for me. I will be running this mail merge on a monthly basis and used a date in the Compare To: box which will only work for the current month. How do I undo the "Skip Record If" so I can sort my data through the recipient list? -- Thanks, ChrisR Your post in the mailmerge.fields newgroup has been answered. Please do not post the same question separately to multiple newsgroups. -- Hope this helps. Please reply to the newsgroup unless you wish to avail yourself of my se...

problem #4
Hi, I am facing this new problem... i.e a user has installed Office 2003 on win2k prof platform.. whenever she is working on a outlook.. she gets a Microsoft error message... saying to send the report or don't send the report... Usually I have seen this problem in IE... But for outlook it is new to me... after clicking on send or don't send report.. the outlook closes. And there are no IE open..... and if atall it is open.. the IE does not close... Need your help regards, KAH What is logged to the Event Viewer regarding this? Try one of the following already; http://www.howt...

95 and 97 problem
For some unknown reason there is Excel 95 and 97 on this pc.When i double click on an Excel file, the pc defaults to the 95 program (Which incidently doesn't work properly). So my question is how do i get the pc to default to 97. Cheers Craig Craig, Have a look at Windows Help. From Windows 2000 Help (Index under Programs Associating with File Types) To change which program starts when you open a file In My Computer or Windows Explorer, on the View menu, click Folder Options. Click the File Types tab. In the list of file types, click the one you want to change. Click Edit. In Act...

Can not Create cases
I'm having a problem creating cases. Everytime I try to create a new case I get the message Duplicate Record. A record of this type with this name already exists. Please choose a different name and try again. No what I use for the account, title or subject. Even Log Error Category: None Event ID 3 Description MSCRM Platform Error Report: ---------------------------------------------------------------------------- ---------------------------- Error: The statement has been terminated. Error Message: The statement has been terminated. Error Details: Details on this error have not be...

Can an activity be created and managed by a Team Member?
Hello, I was thinking that TM where allowed to create and manage activities because in the Security Team Member Group the “Create New Proposal or Activity” box is checked. But when trying it, a problem occurred. They are allowed to fill the Summary Information for a new activity, but after clicking on the save button, nothing appear in the Proposal and Actities view, neither in the project Center. Looking at it from an administrator account the activities do exist but are not visible for the TM who created them. So what’s the problem? ...

Date problem
I can't believe there's no post on this, but I can't find it. I've tried the solutions I could find (see below) and still get the error: "The expression is typed incorrectly or it is too complex to be evaluated. For example....Try simplifying...." I have a date field, formatted as Date/Time, General Date, default Value = Now(). I like having the date and the time - in case we need it. I want to run a report on calls taken just for one day. I have CallDate: CallDateAndTime in my query, with "criteria" as Between ([Forms]![frmReports]![txtStartDate]) A...

sync problems
I have all of my info on an HP Ipac. I had to reformat the hard drive and I did not make a back-up file. I am trying to move everything back to the computer but it says there is an error with syncing it. How can I move everything from the PDA back to Outlook again? Please help- thanks ...

Office 2007 - HELP
I have used Word for many years and love it - not too thrilled with the changes in Office 2007, but my bigger issue is with Publisher 2007. I have an image that I have used in Word just fine - meaning, the on screen colors are correct and when printed the colors are correct. Someone sent me a Publisher file and asked me to add the image - I did this - now the image is messed up - the colors are correct on screen, but when printed FROM MY computer the image colors are all wrong - but if I transport the file to a different computer it prints fine I have reinstalled Office - no good Any id...

Installation Problem!!
I am having a problem installing MSCRM 1.2. My configuration consists of a Domain Controller running Win 2000 Server SP4 . I am trying to install MSCRM on a member of the domain running Windows 2000 Server SP4. There is a DNS Server on the DC which is integrated with AD, and a SQL Server 2000 running on the Win 2K machine. The install errors out when CRM creates the root business with the message: Setup was unable to install Microsoft CRM Server. Setup was unable to provision your organization. Setup was unable to create the root business. The configuration of ASP.NET seems to be ok, the pr...

Extender-Create a new data entry window
Is it possible to create a new extender form or window (not sure of the terminology) to enter data into Dynamics? Specifically the Sales Forecast Window in Manufacturing is terrible for entering data, everytime you move to the right, it the scrolling window jumps back to the top and you have to find the item again. Anyway, I would like a new window to enter a sales forecast, is this possible? thanks -- Doug Unfortunately Extender data is stored in Extender tables and cannot be stored in the Sales Forecast tables. I agree with you that the data entry screen is horrible. I am tal...

Problems Creating a disclaimer in Exchange 2003
I am trying to create a server based disclaimer that will stamp all of my smtp emails going to the internet. I have been following KB article 317680 with no luck. I get an error like the one below. Binding Display Name Specified: smtpscriptinghost ** Registration Failed ** Err.Number (HRESULT) = 0x1AD Err.Description = ActiveX component can't create object ProgID = cdo.ss_smtponarrival COM Category = {FF3CAA23-00B9-11d2-9DFB-00C04FA322BA} Corresponding Event = onarrival ** Have you registered your sink COM class on this machine? I am puttin...

Resource editor problems
Hello all, Under VC++ 7.1... Please consider these two lines: IDC_ARROW_ADD_CANCEL DISCARDABLE "res\\cur00004.cur" IDC_ARROW_ADD_CANCEL CURSOR DISCARDABLE "res\\cur00004.cur" The second is a hand-edited change to the first. Both will compile just fine in the resource compiler. However, after I use a text editor to make this change, I cannot open the .rc file in the resource editor. The resource editor issues the following error open attempting to open the .rc file: error RC2135 : file not found: CURSOR Can anyone shed light on what's going on here? Thanks, Dave ...

Directory Replication Problem #2
Hi, recently my Exchange Server directory database receives changes from other servers but does not send out its own changes. Check from the knowledge base, to correct the USN discrepancy need to use Authrest.exe (need to amke changes for about 100+ users). Does anybody know where to get this file 'Authrest.exe' for exchange server 5.5? Exchange server 5.5 CD only provide this file for ver.4.0. Have anyone use it before? Regards, "Sharon Tan" <sharon_tansk@yahoo.com.sg> wrote: >Hi, recently my Exchange Server directory database >receives changes from ot...

Cell Format
I have a spreadsheet with cells that I'm trying to type the date into. I type in the date exactly like this: 09/26/03. When I hit "enter" MS Excel displays "37890" in the cell. No matter what I do I can't the cell to show: 09/26/03. I think that somehow I need to "strip" the cell of what it's original format is, but I can't figure out how. I try to use the Date option in the format cell screen but it doesn't work. Curtis I tried this and it didn't work. I also tried the "Text to columns" feature. No success. >...

User Defined Variables in MS query cause a problem to import data
If I use user defined variables in MS query to import data into excel sheet, the query executes but no data gets imported into the excel sheet. If I get rid of the variable the results can be imported into the Excel sheet. ...