Failure sending an email from CRM 4.0

Hi everybody,

We are using CRM Dynamics 4.0 and we are facing a problem when a workflow 
tries to send an email, it's kind of weird because yesterday was working 
properly.

I tried to get trough checking the Exchange but the CRM is allowed to send 
Emails so that is working properly I guess.

Also I've restarted the Email Router service and I get the same error.

And finally I've changed in the Microsoft.Crm.Tools.EmailAgent.xml file the 
SchedulingPeriod from 1000 to 30 but nothing happens.

I found many errors from the MSCRMEmail source in the Event Viewer and the 
error description says as follow:

#61042 - Unable to process the email with the subject "Completar tarea de 
instalación y captura de datos de instalación del cliente MARIA FELIX TRIGO 
HERNANDEZ CRM:0232417" para SMTP: http://172.16.5.118/MARCATEL y con entrega 
a través de 172.16.5.51. System.Net.Mail.SmtpException: Failure sending mail. 
---> System.FormatException: Invalid length for a Base-64 char array.
   at System.Convert.FromBase64String(String s)
   at 
System.Net.Mail.SmtpNegotiateAuthenticationModule.GetSecurityLayerOutgoingBlob(String challenge, NTAuthentication clientContext)
   at System.Net.Mail.SmtpNegotiateAuthenticationModule.Authenticate(String 
challenge, NetworkCredential credential, Object sessionCookie)
   at System.Net.Mail.SmtpConnection.GetConnection(String host, Int32 port)
   at System.Net.Mail.SmtpTransport.GetConnection(String host, Int32 port)
   at System.Net.Mail.SmtpClient.GetConnection()
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   --- End of inner exception stack trace ---
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at 
Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(email emailMessage)
   at 
Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.ProcessMessage(email emailMessage)
   at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()


Any idea about the problem?...
0
gosfe25 (1)
9/18/2009 11:59:01 PM
crm 35858 articles. 1 followers. Follow

1 Replies
887 Views

Similar Articles

[PageSpeed] 30

Check the encoding.. Can you send the direct emails from CRM app?
See 
http://blogs.msdn.com/knom/archive/2008/04/16/hacking-system-net-mail-smtpclient.aspx


"gosfe25" wrote:

> Hi everybody,
> 
> We are using CRM Dynamics 4.0 and we are facing a problem when a workflow 
> tries to send an email, it's kind of weird because yesterday was working 
> properly.
> 
> I tried to get trough checking the Exchange but the CRM is allowed to send 
> Emails so that is working properly I guess.
> 
> Also I've restarted the Email Router service and I get the same error.
> 
> And finally I've changed in the Microsoft.Crm.Tools.EmailAgent.xml file the 
> SchedulingPeriod from 1000 to 30 but nothing happens.
> 
> I found many errors from the MSCRMEmail source in the Event Viewer and the 
> error description says as follow:
> 
> #61042 - Unable to process the email with the subject "Completar tarea de 
> instalación y captura de datos de instalación del cliente MARIA FELIX TRIGO 
> HERNANDEZ CRM:0232417" para SMTP: http://172.16.5.118/MARCATEL y con entrega 
> a través de 172.16.5.51. System.Net.Mail.SmtpException: Failure sending mail. 
> ---> System.FormatException: Invalid length for a Base-64 char array.
>    at System.Convert.FromBase64String(String s)
>    at 
> System.Net.Mail.SmtpNegotiateAuthenticationModule.GetSecurityLayerOutgoingBlob(String challenge, NTAuthentication clientContext)
>    at System.Net.Mail.SmtpNegotiateAuthenticationModule.Authenticate(String 
> challenge, NetworkCredential credential, Object sessionCookie)
>    at System.Net.Mail.SmtpConnection.GetConnection(String host, Int32 port)
>    at System.Net.Mail.SmtpTransport.GetConnection(String host, Int32 port)
>    at System.Net.Mail.SmtpClient.GetConnection()
>    at System.Net.Mail.SmtpClient.Send(MailMessage message)
>    --- End of inner exception stack trace ---
>    at System.Net.Mail.SmtpClient.Send(MailMessage message)
>    at 
> Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(email emailMessage)
>    at 
> Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.ProcessMessage(email emailMessage)
>    at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()
> 
> 
> Any idea about the problem?...
0
Hemant (8)
11/30/2009 6:56:02 PM
Reply:

Similar Artilces:

communication failure
I am receiving a Microsoft exchange directory ID: no: DS_E_COMMUNICATIONS_PROBLEM when trying to open an inbox. Make sure the Exchange services are started. ...

Sending a page as a message
I'm trying to send a publication as a message, and when sent from one computer, it is always received as plain text. When sent from a different computer it sends ok. The email client is Outlook 2003, default format is html. Creating a new document and sending it in the same manner works fine on the computer that doesn't send the message in question. Can someone point me in a direction to look. Some folks have HTML messages disabled and will only receive in plain text. -- Mary Sauer MSFT MVP http://office.microsoft.com/ http://msauer.mvps.org/ news://msnews.microsoft.com &qu...

Customer Source failure
Has anyone else had problems viewing the tax updates, service packs and just about everything else on CS? I have had a ticket open with MS for more that 2 weeks and they still cannot resolve the problem. They say they are aware of the problem, and even told me it was fixed once (it was not). I pay a fair amout of $ in maintenance not to be abe to access these documents and updates. Whats the deal? ...

Can't send if text entered in message body
I'm having a strange send error. If I just put the recipient address and a subject, the email will send. If I add ANY text to the message, when I click "Send & Receive" it starts to send, I get the progress bar, then it just sits there until it errors out. I'm totally stumped by this one...any help out there? Thanks, Rod ...

sending email
Hi there - wonder if anyone can help - am a fairly new user to Outlook - when i send messages that are formatted the result to the user has strange symbols with o and p and : and < in it - the message was in html text. when i changed to rich text, it sent the message with a winmail attachment - what is going wrong? thanks mary Use Plain Text for sending to non-Outlook users. Outlook Rich Text Format creates a winmail.dat file for non-Outlook users. --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the (insert latest virus name...

CRM 4.0 for Outlook
We are in the process of implementing CRM 4.0. OUr users are using the CRM for Outlook client with Outlook 2007. One of our users opened some CRM contacts using the Outlook contact interface. She added some categories to the contacts and saved them. She noticed that the icon in her contact list changed from the CRM "two-person" icon to the Outlook "card" icon. The contact is still in CRM. My two questions are: 1. Why did the icon change and how do we change it back? 2. I don't see anyplace for the Outlook categories to be saved in CRM. Where are they saved...

live email
Have several email files. Some times same emails go to several different files. Need to combine all emails in different files into one? Confused on many different subjects. Is there a live person to talk with to get my windows live working right. Please On Fri, 25 Jun 2010 10:15:06 -0700, itsalataone <itsalataone@discussions.microsoft.com> wrote: >Is there a live person to talk with to get my windows live working right. >Please I'm sure Microsoft has a number you can call to talk to a person. What's the limit on your credit card? -- To reply via e-mai...

Chart will put 0 data points on graphs for non-zero cells
I am attempting to make a chart with data from column A1-A7 using a scatter chart. The corresponding Y values in B1-B7 don't always have data in some cells. For example, if cells B1 & B2 are coded with if statements like: =IF(ISNUMBER(B1),$C$22-B1,"") The "blank" that is returned is forced to zero on the chart. If I have the conditional statement FALSE out, or TEXT out, the chart still forces the data point to zero. Any suggestions?? Regards, Matt -- rollinn95z ------------------------------------------------------------------------ rollinn95z's Prof...

Sending emails determined to be SPAM by OE
I have been trying to send an email with a photo attached and OE considers the email to contain SPAM and the server will not process the email. I have sent many photo attachments in the past with no problems. Not sure what has changed. Is there a setting in OE that I need to change. If so, I will probably need some help in finding that setting since I am somewhat technology challenged. Thanks, Bob OE does not have the ability to do what you say. It is just a tool. Where do you see a reference to spam? Do you get an error message? Please post the error message in its entirety. You ...

DHCP failure
Hi, Currently we have a DHCP service installed on a DC. This issues Ip's until 10.10.250.100 (from .1) I want to install DHCP service on another server that will issue Ip's from 10.10.240.101 to say 10.10.250.150. Is their anything else I need to be aware of? Thanks Hello biren, Assuming that the x.240.x.x is a typo, no. You have to make sure, as already done, that they didn't overlap or configure it according to: http://technet.microsoft.com/en-us/library/cc780311(WS.10).aspx Doesn't matter if you use 80/20 or 50/50. Best regards Meinolf Weber ...

How to remove a new field added in CRM 1.2 ???
I just start customizing CRM 1.2 and after adding a New field in Deployement Manager I found that I made a mistake in the Name. Now I can't and I don't know how to remove the field, do I have to delete the newly added field directly in SQL ?? Thanks for your help Regards, Alain Nezer There is no supported way to remove a field one you have added it to CRM. Later versions of CRM will allow you to remove unused fields etc. -- John O'Donnell Microsoft CRM MVP http://www.mscrmfaq.us "Alain Nezer" <a.nezer@skynet.be> wrote in message news:OhtzbRrRFHA.576@TK2MSF...

disappearing emails 02-22-10
When I am in my email account I can look at an email and all of a sudden it is gone. I have checked the deleted and junk folders and it isn't in them. This has happened several times in the past two wookes. Where do I find them or how do I stop this from happening? -- Daf Go to whatever folder you are seeing this in and: View | Current View. Show All Messages should be checked, not Hide Read Messages. -- Bruce Hagen MS-MVP [Mail] Imperial Beach, CA "Daf" <daf@discussions.microsoft.com> wrote in message news:5BE92109-9FF...

Missing Emails #3
Exchange 2K3 on Win2K3. Some emails for a user disappeared. She has emails up to Oct 27 4:27am and then Dec 15 5:27pm onwards. All other emails are gone - they are not in deleted folder (tried in recover deleted and nothing there) and they are not in exchange mailbox (checked via OWA). Autoarchive is clicked off - anyway - autoarchive would have taken out emails for entire Oct 27 or Dec 15th. I can hopefully restore the mailbox from backup but would prefer to investigate the cause as this person is senior in the org chart and would not want to have this happen again. Anyone who exper...

Emails #18
Ikeep on receiving emails that i have already downloaded and read,why is this?this also makes Outlook too slow Wakuyana <Wakuyana@discussions.microsoft.com> wrote: > Ikeep on receiving emails that i have already downloaded and read,why > is this?this also makes Outlook too slow There are many reasons, but you don't give any details, like Outlook version, acount number and type(s), account settings (like whether or not you leave message copies on the server) and the like. -- Brian Tillman ...

How to send email in my MFC program?
Dear All, How to send email in my MFC program? Thanks! Best Regards, Crystal have a look at ShellExecute(....) in the msdn -- kg muechel Crystal There is support in CDocument for sending mail. Lookup MAPI in MSDN. Dave Hart "Wing Yee" <linwingyee@hotmail.com> wrote in message news:u%23%23bAhYwEHA.2012@TK2MSFTNGP15.phx.gbl... > Dear All, > > How to send email in my MFC program? > > Thanks! > > Best Regards, > Crystal > > only this? is there any thing else to send emails? winnicki You can call the MAPI SDK directly, but since you ...

Adding CRM 3.0 CAL to existing SBS
OK I try it again. Since 4 weeks we are looking for a solution, nobody can face the problem. We have an existing and working installation of CRm 3.0 with 13 customers added. 6 weeks ago my customer deceided to add 7 more Users to the 3.0. (Not a new installation or something like that) After talking with MS we bought 7 CRM 4.0 CAL´s (the 3.0 CAL´s arent available anymore) Now you need a PID th activate a 3.0 CAL (a 4.0 CAL doesn´t have this PID) And now!! SINCE 4WEEKS NOBODY AT MICROSOFT CAN GIVE US THIS KEY. We talked to several Servicehotlines an people arroud the world....

Windows Vista/Windows XP Application Load Failure
Hello, I seem to be having an issue with Visual Studio 2005 Professional on Windows Vista Ultimate. It seems to me that whenever I build an MFC application (which contains several DLLs and an exe), the application runs beautifully on Windows Vista (e.g. my development machine). However, when I attempt to run it on Windows XP I essentially get a failure to load DLL/Merge Module issue. Upon inspection of the event viewer on XP I see the following error as being logged: Dependent Assembly Microsoft.VC80.CRT could not be found and Last Error was The reference assembly is not installed o...

Sending emails
I have Exchange 2K3 installed on Windows 2k3 server and the email works great receiving email from the internet and also from the intranet. However, when I send an email outside the network, I get the following message back in a day or two that says it was delayed. This is an automatically generated Delivery Status Notification. THIS IS A WARNING MESSAGE ONLY. YOU DO NOT NEED TO RESEND YOUR MESSAGE. Delivery to the following recipients has been delayed. randallcovert@yahoo.com Any help would be greatly appreciated. Randy Covert randallcovert@yahoo.com 866 551-4953 480 325-0808...

cell displays 0 when formula is valid
I have a VLOOKUP. The wizard box shows the formula result but it appears as "0" in the cell. Formatting is general. Why doesn't the result display in the cell? Please post your formula, inputs and expected result -- Kind regards, Niek Otten Microsoft MVP - Excel "jto" <jto@discussions.microsoft.com> wrote in message news:8824D2CD-40AC-4F39-B6F2-A23BC703883F@microsoft.com... >I have a VLOOKUP. The wizard box shows the formula result but it appears >as > "0" in the cell. Formatting is general. Why doesn't the resu...

rules to move delivery receipts \ failure notifications
Hi, is it possible to move, redirect of autoforward delievery receipt emails? We have a custom app that sends out mail and all replies, including delivery receipts, undeliverables etc.. come back to an exchang inbox. The exchange inbox, needs to re-disperse the delivery reciepts or failuresin to a corresponding public folder. It seems that the delivery receipts in most cases come up as a different message class, (Report.IPM.Note.DR), others come up as regular messages (IPM.Note). It appears that rules don't work on the Report.IPM.Note.DR ones...Has anyone ever seen this or know...

CInternetSession Assertion Failure #2
Hi! I'm a biginner c++ programmer that needs help. Here is my code: #include <AfxInet.h> int main() { CInternetSession mySession; return 0; } This program compiles fine but ouputs the following output error: "Debug Assertion Failed! Program: C:\WebSearcher\Debug\play_around1.exe File: afxwin1.inl Line: 27 When I take a look at afxwin1.inl, the problem originates from the following lines: // Inlines for AFXWIN.H (part 1) #ifdef _AFXWIN_INLINE // Global helper functions _AFXWIN_INLINE LPCTSTR AFXAPI AfxGetAppName() { ASSERT(afxCurrentAppName != NULL); return afxCurr...

Email DLookup to show all records
I have composed an email which is generated from a command button. I have used DLookup to create the subject using Job Reference and title from a query. What I now need to do is to list all applicants that the query throws up within the email. I have used the DLookup function which only shows the first Applicant Name, however for the example I have used there are 3 applicants. Any suggestions on how I can do this? Here's the details of the vba behind the button, if further details are needed to be able to help please let me know DoCmd.SendObject acSendNoObject, "", "",...

HELP with adding email accounts
I have Outlook 2000 and I am trying to add email accounts for my various businesses. I can add one and the other two give me the error message 0x800ccc0d. I run Windows XP and I am on DSL. Can anyone advise? Hi Wendy, WORKAROUND To work around this problem, use one of the following methods, depending on your situation. Method 1: Confirm that your e-mail server settings are correct For information about the correct settings for your e-mail server, contact your Internet service provider (ISP) or system administrator. Note Some ISPs do not permit message routing through another SMTP ser...

Email between computers
My boss works off of a desktop and a laptop, the laptop can not read any of the email that the desktop is showing.........what do I need to do to correct this so that he can work from anywhere and still get all of his emails What type of mail account is being used, eg pop, imap, exhange? Only imap or exchange can sync between the two "blonde needing help" <blonde needing help@discussions.microsoft.com> wrote in message news:C6CE4E82-6713-4124-8ED5-4FBEE6CF2D7B@microsoft.com... > My boss works off of a desktop and a laptop, the laptop can not read any > of ...

SEND doesn't Send
1) When I finish composing an email message and click the SEND button, the message only goes into the Outbox. It doesn't get Sent. If I click Send/Receive it then will get sent from the Outbox. 2) Also, although I have automatic send/receive scheduled to occur every 5 minutes, (I'm checking it under Options right now) messages never get sent from the Outbox and messages never get received from my ISP mail server unless I click Send/Revceive. Microsoft would appreciate any help in making their s/w more reliable, and so would I. Thanks in advance, Mike Make sure Outlook is...