CRM authentication issues

Hi all

We seem to be having a problem with our CRM system.  
Since we installed the product we persistantly got the 
following error message: 

Event ID 11 KDC Error
There are multiple accounts with name 
host/anc2003dc02.ancorisltd.local of type 
DS_SERVICE_PRINCIPAL_NAME.

From an initial correspondance, I was told to use LDP and 
ADSI edit to remove the duplicate SPN which I completed 
successfully and this stopped the error from happening.

Since then, we have been unable to connect to the CRM web 
site using the http:\\servername as before.  We can 
connect to the system remotely, however IIS presents us 
with a login screen every time, even when the web site 
and server is set to Integrated Authentication. You can 
also connect to the servername when logged on to the 
server using http:\\localhost\servername.  I have checked 
ADSIEdit and all the SPN's seem to be inserted ok.  

DNS and WINS seem to be working OK.    

I have tried various troubleshooting methods, 
Kerberostray (to check the tokens on the client). 
CSScript (to determine the authentication type), 

Does anyone have any ideas?

Regards

Jonathon
0
Jonathon
9/6/2004 6:30:19 PM
crm 35858 articles. 1 followers. Follow

4 Replies
736 Views

Similar Articles

[PageSpeed] 55

------=_NextPart_0001_B090594E
Content-Type: text/plain
Content-Transfer-Encoding: 7bit

Hi Jonathon,

The reason you were getting the initial KDC 11 errors is because Microsoft 
Internet Information Services (IIS) is not enabled for both Kerberos and 
NTLM authentication.  

Follow this Microsoft Knowledge Base article for complete instructions on 
how to configure IIS to support both Kerberos and NTLM authentication. 

http://support.microsoft.com/?id=215383 

Thank you,

Tami J. Lemar
Microsoft Business Solutions Support

This posting is provided "AS IS" with no warranties, and confers no rights.

------=_NextPart_0001_B090594E
Content-Type: text/x-rtf
Content-Transfer-Encoding: 7bit

{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fprq2\fcharset0 MS Sans Serif;}}
\viewkind4\uc1\pard\f0\fs20 Hi Jonathon,
\par 
\par The reason you were getting the initial KDC 11 errors is because Microsoft Internet Information Services (IIS) is not enabled for both Kerberos and NTLM authentication.  
\par 
\par Follow this Microsoft Knowledge Base article for complete instructions on how to configure IIS to support both Kerberos and NTLM authentication. 
\par 
\par http://support.microsoft.com/?id=215383 
\par 
\par Thank you,
\par 
\par Tami J. Lemar
\par Microsoft Business Solutions Support
\par 
\par This posting is provided "AS IS" with no warranties, and confers no rights.
\par 
\par 
\par }
------=_NextPart_0001_B090594E--

0
tlemar
9/9/2004 12:26:31 PM
Hi,
We've got pretty much the same problem with KDC 11 errors and we followed 
the same processes that Jonathon documented, using advice from other MS 
newsgroups.  I just tried the advice offered to Jonathon in this post, and 
the number of KDC 11 errors dropped dramatically, but we're still getting 
them.  One each hour for each of two serviceprincipalname entries.  One is 
"cifs" at 21 minutes past each hour and the other is "host" at 46 minutes 
past each hour.  We're running CRM 1.2 on SBS2003.  Further Suggestions?
TIA - Gerry H

"Tami Lemar" wrote:

> Hi Jonathon,
> 
> The reason you were getting the initial KDC 11 errors is because Microsoft 
> Internet Information Services (IIS) is not enabled for both Kerberos and 
> NTLM authentication.  
> 
> Follow this Microsoft Knowledge Base article for complete instructions on 
> how to configure IIS to support both Kerberos and NTLM authentication. 
> 
> http://support.microsoft.com/?id=215383 
> 
> Thank you,
> 
> Tami J. Lemar
> Microsoft Business Solutions Support
> 
> This posting is provided "AS IS" with no warranties, and confers no rights
0
Utf
11/10/2004 8:38:07 PM
I just installed CRM12 on a SBS2003 and now have KDC event 11 errors showing. 
The events are for both the host and cifs. 

I have not done anything at this point to fix. What I want to know is why 
this occurred to begin with? There were not any reported errors during the 
install.

Did you happen to try what Tami suggested in the thread?

--- floyd


"Gerry H" wrote:

> Hi,
> We've got pretty much the same problem with KDC 11 errors and we followed 
> the same processes that Jonathon documented, using advice from other MS 
> newsgroups.  I just tried the advice offered to Jonathon in this post, and 
> the number of KDC 11 errors dropped dramatically, but we're still getting 
> them.  One each hour for each of two serviceprincipalname entries.  One is 
> "cifs" at 21 minutes past each hour and the other is "host" at 46 minutes 
> past each hour.  We're running CRM 1.2 on SBS2003.  Further Suggestions?
> TIA - Gerry H
> 
> "Tami Lemar" wrote:
> 
> > Hi Jonathon,
> > 
> > The reason you were getting the initial KDC 11 errors is because Microsoft 
> > Internet Information Services (IIS) is not enabled for both Kerberos and 
> > NTLM authentication.  
> > 
> > Follow this Microsoft Knowledge Base article for complete instructions on 
> > how to configure IIS to support both Kerberos and NTLM authentication. 
> > 
> > http://support.microsoft.com/?id=215383 
> > 
> > Thank you,
> > 
> > Tami J. Lemar
> > Microsoft Business Solutions Support
> > 
> > This posting is provided "AS IS" with no warranties, and confers no rights
0
Utf
11/30/2004 3:09:02 PM
I had the KDC 11 errors and tried dozens of things before sorting it out.

I did exactly the same as Jonathan at first and deleted the duplicate SPN, 
and the KDC errors stopped but CRM stopped working.  Put the SPN back in and 
CRM worked but KDC errors returned.

I fixed the problem by replacing the duplicate SPN (sbs2003.mydomain.local) 
with the host name of the CRM website (crm.mydomain.local) - KDC errors stop 
and CRM still works!


"Floyd" wrote:

> I just installed CRM12 on a SBS2003 and now have KDC event 11 errors showing. 
> The events are for both the host and cifs. 
> 
> I have not done anything at this point to fix. What I want to know is why 
> this occurred to begin with? There were not any reported errors during the 
> install.
> 
> Did you happen to try what Tami suggested in the thread?
> 
> --- floyd
> 
> 
> "Gerry H" wrote:
> 
> > Hi,
> > We've got pretty much the same problem with KDC 11 errors and we followed 
> > the same processes that Jonathon documented, using advice from other MS 
> > newsgroups.  I just tried the advice offered to Jonathon in this post, and 
> > the number of KDC 11 errors dropped dramatically, but we're still getting 
> > them.  One each hour for each of two serviceprincipalname entries.  One is 
> > "cifs" at 21 minutes past each hour and the other is "host" at 46 minutes 
> > past each hour.  We're running CRM 1.2 on SBS2003.  Further Suggestions?
> > TIA - Gerry H
> > 
> > "Tami Lemar" wrote:
> > 
> > > Hi Jonathon,
> > > 
> > > The reason you were getting the initial KDC 11 errors is because Microsoft 
> > > Internet Information Services (IIS) is not enabled for both Kerberos and 
> > > NTLM authentication.  
> > > 
> > > Follow this Microsoft Knowledge Base article for complete instructions on 
> > > how to configure IIS to support both Kerberos and NTLM authentication. 
> > > 
> > > http://support.microsoft.com/?id=215383 
> > > 
> > > Thank you,
> > > 
> > > Tami J. Lemar
> > > Microsoft Business Solutions Support
> > > 
> > > This posting is provided "AS IS" with no warranties, and confers no rights
0
Utf
12/3/2004 11:17:02 AM
Reply:

Similar Artilces:

Account Overview report issue?
Hi, I am trying to run the Account Overview report (open an Account, run the report from there). It chugs over it for a second or two, then I get the following 2 errors: Error: subreport could not be shown. Note: The maximum number of accounts in this report cannot exceed 10. The account I am running this on does not have any subaccounts and has a total of 4 contacts. Has anyone seen similar errors with this report? Thanks for any help... Jon DearJon What language are you running in? Is your environment SQL 2005? Go to the Reports section and look at the "Hidden" repor...

Exchange 2003 over HTTP RDP Issue
Hello everyone! A problem with Exchange 2003 over HTTP/RDP SERVER SIDE: I have a single Windows 2003 Server running IIS with Active Directory installed. The Server also has Exchange 2003 Installed and it is working perfectly. There are NO other Servers in the domain, this is a stand alone Server. I have purchased a Certificate and installed it on the Server from Verisign. The FQDN on the internet for this Server is www.domain.com, and the certificate is assigned to www.domain.com The Server is called computer.domain.com, and the windows firewall is turned on. The only ports that are ...

How do I track emails ONLY using tokens in CRM 4.0?
The pattern matching or "intelligent" matching of email content is misapplying inbound emails to non-related cases. I want to turn this feature OFF ASAP and return to ONLY tracking through tokens in the subject line. I can turn OFF tokens but not the smart matching. A configuration option would have been nice. I think you turn on the tokens, and then your users have to use the option to only track "E-mail messages in response to CRM e-mail" - that's how you prevent CRM from using 'smart' matching. Dave Ireland "Forrest_Adam" <ForrestAd...

Access Form Printing issue
Hi Guys, I have an issue wiht ACCESS Form printing. One Form with Pivot table with 50+ pages, when I do a print preview, It shows me 50+ pages, but after 36th page, all following pages are empty. And when do the printing, all pages after 36, are empty too. Any suggestion would be appriciated. Thanks Tony Forms aren't intended for printing. That's what reports are for. There's very little built into Access to allow you to manipulate how a form prints. -- Doug Steele, Microsoft Access MVP http://I.Am/DougSteele (no private e-mails, please) "Tony" <Tony@discu...

CRM Field Names
Is there a list on field names that CRM creates in the database in order to use them for setting up workflow? ...

CRM 3.0 and CRM 4.0
Dear All, We were implementing MSCRM for a very protential CRM customer (Education). Even they haven't signed the contract but we already started developing on the CRM 3.0, 3 weeks ago. A lot of customisation + .NET developing required on the version 3 but now we knew that we're reinventing the wheels as some of them will be already built in the V4 which one will be realease very soon (Q1-2008?) If we place order to MS now, we will receive the V4 earlier than Q1-2008, but it is V4, not V3 So now we decided moving the developing on V4 directly because no guarantee what we wer...

CRM and MapPoint
I have a client that has MapPoint 2004. They would like to have the ability to map all of their current clients in certain areas, also with the ability to make indication of future growth in these same areas. Currently, they can only map one facility at a time. They would like to be able to map all of their existing and future facilities for a spcific service area on one map. Does anyone know of a solution for accomplishing this? Thanks, -Rick Not a mappoint expert by any means but I think there are 2 choices: 1. Export data from CRM (can probably just use the excel export option)...

What are Basic Routine and Major Issues for Exchange 5.5
Taking over System Admin position for Win2000/Exchange 5.5 network, 200 users with XP on the clients. Have been in other areas of IT for last 2 years. Could someone describe their basic daily/weekly routine with Exchange 5.5 and what are the top 10 major issues/challenges/peculiarities with Exchange 5.5 I don't have a top ten, although you can find lots of info on the many good Exchange blogs out there...there are things you might want to get into a routine of doing: checking event logs checking messaging queues watching disk space do test restores occasionally to a recovery server, t...

Organizational Settings in CRM 3.0
Is it possible to hide viewing of Organizational Settings from non System Administrator users? ...

OWA Issue #2
I have some internal and external client that can connect to the owa side but get errors on the page which stops them from accessing mail and vieng anything but the subject line. All the clients are running eplorer 6 with all the service packs. The look identical in every way Sounds like there may be some issues with either the Security or Privacy options in Internet Options. I'd check the configuration of a working workstation then compare it against a workstation that isn't working. Also what what particular error message are they getting on that page? >-----Original Messag...

Cannot access CRM homepage on another machine
Hi, I have installed CRM 1.2 on a Windows Server 2003 SP1 machine. I can work with CRM on this machine using http://localhost. But when I try to access the homepage on another computer by typing http://CRMserver or http://IP address of CRM server I cannot access it. Can anyone please tell what do I have to configure to access the homepage on another machine? Thanks and Regards, Harshad ...

Reset CRM
Hi, How can I reset CRM database? I create contacts, acounts, invoices, etc., and i want delete all. Tnhank's, RS You cannot reset the database. You could restore the database if you took a backup before you started adding data. You can also go into the system and start deleting records. Can I ask why you need to do this? Have you been experimenting with CRM and now want to go to a live server? -- John O'Donnell Microsoft CRM MVP http://www.microsoft.com/BusinessSolutions/Community/CRMFaqLanding.aspx "Ricardo" <anonymous@discussions.microsoft.com> wrote in mes...

Vista CRM 3.0 Desktop client
Can someone tell me where I can find the CRM 3.0 Desktop client which works with Vista & Office 2007? Thanks You can download it using the following link. http://www.microsoft.com/downloads/details.aspx?FamilyID=740e1b3b-11c3-4aef-b2e3-8309e0cf1bb0&DisplayLang=en Magui "circulent" <circulent@discussions.microsoft.com> wrote in message news:27D9D594-593F-4C1D-9E61-09F946FFA8BB@microsoft.com... > Can someone tell me where I can find the CRM 3.0 Desktop client which > works > with Vista & Office 2007? > > Thanks ...

How works conflictresolution with the offline outlookclient and ms crm?
Hi Does somebody know how the conflictresolution works if one ore more offlineclients synchronise to the server. How does it work if diffrent offlineclientds did some changes on the same field? Does someone know a good description about this problem? Thank's Michel Consider a situation where a field has been changed. 1. Two offline clients making a change 2. One offline and the second online client making a change when the client goes online the data present in the client is synchronised and saved irrespective of the time when the last changes were made to the field. "Hope...

CRM registration can not be done!
After CRM installation and valid internet connection via LAN, I could not succeed to register CRM 3.0. Is there anybody who had this problem before and solve it?? When you fill in the registration details, if you specify the implementation was done by a partner company, make sure you fill in data in all fields for the partner company, otherwise the registration process can fail -- David Jennaway - Microsoft Dynamics CRM MVP Web: http://www.excitation.co.uk "Pleiades" wrote: > After CRM installation and valid internet connection via LAN, I could > not succeed to registe...

Migrating CRM to CRM
We had to delete the OU from the Active Directy, and now cannot get to our data. Reading through the posts it looks as though we have to use the DMF to convert our data because of the GUIDs that are hard-coded in the files. Unless someone knows of a utility that I can use to change the GUIDs in the Active Directory - but we tried a number of different things. So, is there an easy method to import CRM data into CRM? I tried using SQL DTS to the cdf_entities, but this is like pulling teeth, and don't know if I am going to be losing any data. Anyone have any insight into getti...

PDF's not traking in crm
when tracking a pdf file in CRM we get an error saying that we can not track it. the files are small so it is not an issue with them being to big. we can track other types of attachments with no problem. in the event viewer we get an error with the event ID: 5983. i did a google on it and find a solution for the old 3.0 version(which was to update to a later 3.0 version). we are on 4.0 with the latest updates. thanks for your help Hi, There is a problem attaching an email which has an attachment with an '&' in the file name. Could this be your problem? Rob "Tyler Ba...

Crm grid error
I've created a custom entity called Billed hours and associated it to the case entity (which is the parent). It doesn't allow me to open the instance of the billed hours entity in the associated view and when i select it and try to delete it, it says: "You must select one or more records before you can perform this action". I'd appreciate any help :) ...

Mail Merge Issue
When I connect my word label template to my excel database, I get the same label (name,address, etc.) on 3 seperate labels. When I open the data file up in the edit mode, while in Word, triplicates, duplicates, etc. do not appear, so I'm confused. How do I correct this please? Thank you. -- Paul ...

Upgrading to CRM 3.0 Problems
Hello, We're upgrading from CRM 1.2 to 3.0 and are coming across an error we can't get past. After entering all the information it brings up the system requirements screen where it goes through everything to make sure the install will be smooth. Everything checks out except for IIS. The exact error is "The Web site's NTAuthenticationProviders must be Negotiate,NTLM" We've researched the error on the web and found the adminscripts command to make the site Negotiate,NTLM and the get command does show it to be just that but when we restart IIS and start the ins...

ACT to MS CRM 3.x Migration using Scribe Insight
Hi, I have installed Scribe Insight and Scribe Adapter for Microsoft CRM (trial version for now). I can't seem to find a nice step by step document to on how to use this software. First of all, does ACT need to be installed on the server where CRM and Scribe are running or can it just use an ACT file? Has anyone used Scribe successfully without having taken the training? Is the training recommended? mscrmuser wrote: > Hi, > > I have installed Scribe Insight and Scribe Adapter for Microsoft CRM > (trial version for now). I can't seem to find a nice step by step > ...

HELP: Strange Contacts disappearing issue Outlook 2002
Hi, On my boss computer. Running Win XP Pro and Office 2002 (10.6515.6626) SP3, stand alone POP3 based. He has 2,970 contacts in the Contacts folder, sometimes not all contacts show! You have to go to FIND and in the "look for" box just leave it blank and in "Search in" select "contacts" then hit the "Find Now" button... after a few seconds, ALL contacts show ! This is happening now a lot... what is strange also is that on the status bar, it shows 2,970 Items allways, before and after the "find" solution. Isn't that strange ?? I am going...

CRM 3.0 Changing CRM Mailbox
When I installed CRM/the Email router, I specified it to use the administrator mailbox. I now want to move it to a dedicated CRM mailbox, where cna I find this setting if it's not under Settings/Organisation Settings/System Settings/Email ?? Thanks Hi Adam, I believed that you have to use the Microsoft CRM-Exchange Email Router -> Rule Deployment Wizard to update the mailbox information. Make sure the logon to start that email router Service able to access that mailbox. Darren Darren Liu wrote: > Hi Adam, > > I believed that you have to use the Microsoft CRM-Exch...

Announcements in Crm
Can u set it that announcements shows to all users when they log on,as there is no workflow for announcements. is there any way to intergrate a ticker at the bottom of Crm to show information? not without making unsupported changes to the announcement section. ============================== John O'Donnell Microsoft CRM MVP http://www.crowecrm.com "Zombie9" <Zombie9@discussions.microsoft.com> wrote in message news:B0ED5A80-84DE-42E3-BDD2-9D25CD846E93@microsoft.com... > Can u set it that announcements shows to all users when they log on,as > there > is no w...

Smartlist from View issue
When I created a new view and a Smarlist (GP 9) based on this view, for some reason no data shows up. GP briefly shows "Exploring" and quickly changes to "Completed" w/o showing any data. I've had this same issue previously and it was related to permissions not being set correctly but I've set this new one the same as the one that is now working but it's still not showing any data. FYI, I've enabled access to the view via both "Tools->SmartList Builder->Security->SQL Table Security" and "Tools->Setup->System->SmartLis...