Requery ONLY works in timer 0.5 sec later !!!

Requery ONLY works in timer 0.5 sec later  !!!


Hello everyone and thank you for your time,



I have a simple form with a subform with a CANCEL button on it.  The
problem is that if I don't use the DoCmd.Requery command, the form
advances to the next record even though the previous one was still
empty.  If I put the DoCmd.Requery on the bottom or the top of the
Cancel code it dose not work, the ONLY way I have my form working
properly at the moment is like so....



Private Sub Cancel_Click()


    Me.TimerInterval = 500
    DoCmd.SetWarnings False
    DoCmd.RunCommand acCmdDeleteRecord
    DoCmd.SetWarnings True


End Sub




Private Sub Form_Timer()

    DoCmd.Requery
End Sub




This has solved my problem and everything is ok, it's just that I'm
not feeling comfortable using Timer event and would appreciate if
someone could tell me what my problem is and how to put that requery
command on the cancel button.



Thanking you all in advance.

0
6655326
8/8/2007 10:50:18 AM
access 16762 articles. 2 followers. Follow

0 Replies
1007 Views

Similar Articles

[PageSpeed] 46

Reply:

Similar Artilces:

Question #5
Hello All: I would like to accomplish the following and need some direction. We have several T1's coming into our sitre from different vendors. To create a "failover" if you will for our exchange environment, I'd like to place a server on each line, replicate etc, and have the ability to receive mail even if one line goes down. Multiple DNS entries of course, but what has to be done on teh Exchange side to execute this design. Thanks This is not an Exchange issue as much as a routing issue. Talk to your network guys. On Sun, 13 Feb 2005 09:40:08 -0500, "DJ&...

Requery Question????
I have a form that changes with a parameter that is entered through a combo box. The syntax of the parameter follows: Forms!frmWhatState![cboStateCode] This parameter is entered in underlying crosstab queries that supply my main form named frmStateCriteria. In an effort to try to broaden the amount of information supplied by this form, I have added tab controls and subforms to the main form and the form now displays monthly/quarterly totals filtered by the State Code. My form displays the correct result set and totals by state as requested. The problem occurs when I change the Stat...

Combo Box Requery
I'm having a hard time with my replies posting so I am going to submit a new question. I apologize it's a repeat. I made the change to the row source for the combo box and will see the correct data the first time I click the dropdown. I would expect this because I haven't done the second and third part yet. Since I posted I've had to add the subform to a Control Tab and I'm having a hard time with the following: Me.subformcontrol.Form.thecombobox.Requery. I have a main form called frmVendors, a Combo Box on it called cboVendorSearch, a Tab Control ca...

APOP to POP, 6.0 --> 8.0
Hello, I have a test environment I'm using to prepare for an upgrade in the next month or two. I created a test server with a duplicate of our existing data for Great Plains 6.0 with Intellisol Advanced Purchase Order Processing (APOP). I then upgraded great plains to 7.5, and without considering APOP, went on to 8.0. Now I realize that APOP was not converted to POP (admittedly, I didn't give it any thought before the trial upgrade). Is there a document on customersource that will help me find how to convert the Intellisol purchasing data to Great Plains? I have searched a...

search does not work properly?
When seraching for mail the search gives no results if you check it manually the email you are looking for is 4 weeks earlier. 2 hours of work time lost for that manual search. Hard to say what is going on without any configuration details. For Instant Search troubleshooting steps see; http://www.msoutlook.info/question/47 -- Robert Sparnaaij [MVP-Outlook] Coauthor, Configuring Microsoft Outlook 2003 http://www.howto-outlook.com/ Outlook FAQ, HowTo, Downloads, Add-Ins and more http://www.msoutlook.info/ Real World Questions, Real World Answers ----- "Sys-admin-to...

Microsoft Dynamics CRM 4.0 videos on channel9.msdn.com
As we get closer to an RTM of Microsoft Dynamics CRM 4.0 we have started to put together some screencasts talking about the technology. If there's something you would like to see discussed in a screencast let us know. http://channel9.msdn.com/Showpost.aspx?postid=361020 http://channel9.msdn.com/Showpost.aspx?postid=364853 ======================= John O'Donnell Microsoft Dynamics ISV Architect Evangelist http://blogs.msdn.com/usisvde ...

Outlook Calendar to MS Works
MS Works can import a .vcs file but Outlook cannot export to a .vcs file. How can I export Outlook's calendar info to the MS Works calendar? Thanks, Irish Irish <anonymous@discussions.microsoft.com> wrote: > MS Works can import a .vcs file but Outlook cannot export > to a .vcs file. How can I export Outlook's calendar info > to the MS Works calendar? Unfortunately, you can only save vCalendar (.vcs) files one appointment at a time in Outlook. Select the appointment you want and click File>Save As. In the "Save as Type" drop-down choose "vCalendar...

grace period when opening Bank Rec in GP 10.0
Hello: In GP 10.0, you are asked a question regarding an 8-day grace period. Why is this? childofthe1980s ...

Refresh, requery, or what?
I have a form with a subform. The data source for the subform is a table. On the main form is a command button which, when clicked, opens a pop up form. When the pop up form is filled in and closed, I want the information in the subform to be updated to include the information added in the pop up form without having to close and reopen the main form. Can someone clarify for me the VBA code to do this. I'm obviously not understanding the differences between Repaint, Requery, Refresh, ShowAll, etc. Also, I have difficulty with syntax when referring to controls in subforms. Can someon...

0.8349816 Want It? ... 0.1447402
0.2154644 Want It? ... 0.2688711 0.8349816 Now Visit http://www.clicklinknow.com/ss/ 0.1447402 test hgdgjxjgxc <iwantsex@0.2688711nowathome.com> �������/�������� � �������� ���������: news:ebsBm5i0HHA.4476@TK2MSFTNGP06.phx.gbl... > 0.2154644 Want It? ... 0.2688711 > > 0.8349816 Now Visit http://www.clicklinknow.com/ss/ 0.1447402 > ...

Purge Deleted Messages does not Work!
Hi, I'm using Outlook 2002 to connect to an IMAP server, however recently the Purge Deleted Message is failing to work. It asks if I'm sure then just doesn't to anything?! Any ideas? stevie ...

Rules Are Not Working
I set up a rule to move emails with the words <<POTENTIAL- SPAM>> in the subject line (a feature of my ISP) to the "Junk E-mail" folder. Here's how the rule reads: Apply this rule after the message arrives with <<POTENTIAL-SPAM>> in the subject and on this machine only move it to the Junk E-mail folder The rule doesn't work when I receive incoming mail; however, it DOES work when I run the rule from the Rule Wizard. Any suggestions on getting it to work on incoming email? Thanks, J make sure you properly setup the rule to scan email 'wh...

Code does not work : CRichEditCtrl
Hi, the following code is not working.. CHARFORMAT cf; cf.crTextColor=RGB(0,0,255); COLORREF ref=RGB(0,0,255); cf.dwMask=CFM_COLOR; cf.dwMask= CFM_UNDERLINE|CFM_COLOR; richRecvBox.SetSel(1,100); richRecvBox.SetSelectionCharFormat(cf); Help me ! there is no change of color, only underline works, whats the issue here ? Dwaach Hello Not sure whats wrong (Perhaps not setting cbSize?), however this is a snippet of code that works for me (View is rich edit)... CHARFORMAT2 cf; View.SetSel(1,20); View.GetSelectionCharFormat(cf); cf.cbSize = sizeof(CHARFORMAT2); cf.dwMask = C...

Producing empty cell rather than #DIV/0!
I'm averaging a number of cells, some of which contain the value #DIV/0! because the cells' formula divides empty cells. The AVERAGE function can't handle #DIV/0!. Is there any easy way to avoid this? I'm thinking of an IF function such that if the formula's answer is #DIV/0! it instead enters an empty cell. I'm sure this is possible, but having a hard time getting things together. Any help appreciated! Thanks, Andrew post your formula and/or have a look in help index for ISERR -- Don Guillett SalesAid Software dguillett1@austin.rr.com <agbiggs@hotmail.com> ...

CRM 3.0 on 2008 Terminal Server
Has anyone tried to setup CRM 3.0 outlook client on a windows 2008 terminal server? I am using Outlook 2003 and during the install receive the message "Windows 2000 SP4 and above supported" Simon I was under the impression that CRM 3.0 is not supported in a Terminal Server environment. However if you search the blogs, there is plenty of documentation and scripts on how to achieve this. "Simon" wrote: > Has anyone tried to setup CRM 3.0 outlook client on a windows 2008 terminal > server? > > I am using Outlook 2003 and during the install receive the...

Outlook Express 5 and 6
Issue: proprly subscribed to newsgroups, but only those threads display at sync which I have responed to. 1. Sync, OE tells me that say 10 new posting to the group, I review and only find 6 new posts, press catch up and the other four now display as read. Go to another group and come back the 4 are gone. 2. Resteat NG, and do the catch up again, post a reply to group and then go out and come back and that thread now displays. Short issue: only threads I have replied to display. Why.... Now this is only happening on my system at home Win98 using OE6. Using same config at work but XP and ...

OWA
We are using Exchange 5.5 and Outlook Web Access. We recently applied a number of Microsoft critical updates to that server and now many of our staff can't get access to their email from home. In some cases they are using Macs and the browser Safari, or Netscape, or various versions of the Microsoft operating system and IE. Does anyone know how to fix this? J. Frasier Software Support Specialist Jefferson County Public Library "Jane Frasier" <jane@janefrasier.com> wrote in message news:%23g%23Krp8DFHA.1188@tk2msftngp13.phx.gbl... > We are using Exchange 5.5 and...

'Search' not working right
When using Start>Search to 'Search the internet', the results show in the left pane but clicking on the links opens them in the left pane also instead of the right pane. How can I solve this, please? Regards JJ www.google.com JJ wrote: > When using Start>Search to 'Search the internet', the results show in the > left pane but clicking on the links opens them in the left pane also > instead > of the right pane. How can I solve this, please? Sorry, don't understand your reply. If you're asking me to use Google then I am already. ...

Spell Check won't work
I have just upgrade to Office Prof 2003 XP. This has upgrade us from Publisher 2000 to 2003. In Publiser the spell checker will not work with a message "Publisher can not load speller or dictionary" Re run set up. I have tried that and also updated for any patches but no luck spell checker will not work. Spell Checker works in Word. Any ideas please? Cheers Chris Hi info@airchartertaupo.co.nz (info@airchartertaupo.co.nz), in the Microsoft� newsgroups you posted: || I have just upgrade to Office Prof 2003 XP. This has || upgrade us from Publisher 2000 to 2003. || || In Publ...

problem in ADO with Microsoft Jet 4.0 OLE DB
hi, I am using ADO to connect an acess database. When I modify an integer field and use Update to update it , it throws an unhandled exception. Is there a problem in ADO with access. I have had no problem in using SQL server. thanks, Behzad "Behzad" <b@b.c> schreef in bericht news:ucCIxiXwEHA.3336@TK2MSFTNGP11.phx.gbl... > hi, > I am using ADO to connect an acess database. When I modify an integer field > and use Update to update it , it throws an unhandled exception. Is there a > problem in ADO with access. I have had no problem in using SQL server. > &g...

Linking #5
Hi folks, This might be an easy one but it has been bugging me for hours already. I have a workbook (seri.xls) with 6 worksheets namely: Frontpage,Input,PartsData,LookupLists,PivotTable,MsiaChart. I have created two links from my website which will open the respective worksheet view blabla link to PartsData worksheet view status link to MsiaChart worksheet (but i dun prefer this method as users can unhide other sheets in the same workbook) Is there a way i can create two separate workbook one for PartsData worksheet in workbook A and one for MsiaChart worksheet in workbook B. Thus i can li...

Requerying
One of the fields of a table is sorted. SELECT tblConfigGrupos.lintIndexKMaster, tblConfigGrupos.strNomeGrupo, tblConfigGrupos.boolInactive, tblConfigGrupos.lintNGrupo FROM tblConfigGrupos ORDER BY lintNGrupo; If I change the content of one lintNGrupo field in one record, I should issue a Me.Requery to sort it again so that the new sort is displayed. To what event should I associate the command? (Is this the right way to do it?) Thanks H. Martins Try the form's AfterUpdate event. -- Doug Steele, Microsoft Access MVP http://I.Am/DougSteele (no e-mails, please!) "H. Martins&q...

Make XP work like Vista
It's been said the rules of programming that apply to Vista should apply to XP, even tho they don't. How would I tweak XP to enforce those rules while having the admin kind of priv with Vista. Is that possible? -- 2025 If you do not believe in time travel, your beliefs are about to be tempered. http://www.facebook.com/group.php?gid=43606237254 "C. Kevin Provance" <*@*.*> wrote: >It's been said the rules of programming that apply to Vista should apply to >XP, even tho they don't. How would I tweak XP to enforce those rules while...

how do I stop Access from dropping 0 on zip codes starting w/0?
I'm running reports in Access from an Excel database which includes zip codes starting with 0. Access drops of the 0 because it's in the first position. If I change the zip code to text in Excel, then Access doesn't show the entry at all. How do I get a zip starting with 0 to show in Access (Example 03492). Thanks hi Gigi, gigi wrote: > I'm running reports in Access from an Excel database which includes zip codes > starting with 0. Access drops of the 0 because it's in the first position. > If I change the zip code to text in Excel, then Access doesn&#...

I cant get it to work
My Computer died and I had to redownload everything on my computer. Even outlook. I redownloaded it and now I have no messages or anything. It won't let me get mail or send any. Is there a way to get my old email account back? Yes we had to format the whole thing again. Where would I find the .pst? Would it be in the file outlook express? >-----Original Message----- >Depends what you mean by 'died' - did you have to format? >If not yr origonal *.pst file should be still there. >In OL, File/Open/pst file then browse for yr origonal *.pst >David > >"...