problem with Dev Ashish table reconnect code

Hello,I am strugling to get http://www.mvps.org/access/tables/tbl0010.htmcode to work in my case. The code runs with the follwing errors: Error#: 3070 The microsoft office access database engine does not recognize'TableName' as a valid field name or expressionAnd then it end up in endless errors which can only be stopped by cntrl+alt+break and the stopped. Error #: 10 - this array is fixed ortemporarily locked.I start the code in immediate window with fReconnectODBC ENTERI have changed "qc03" to my DSN but I have no serevr name in ODBC.INIin registry. May be that is a problem?What am I supposed to put in as Server value?  'You can follow the same steps to check for multiple DSNs    strTmp = fReturnRegKeyValue(HKEY_CURRENT_USER, _                        cREG_PATH & "\qc03", "Server")    If strTmp = vbNullString Then Err.Raise cERR_NODSNMaybe I am starting the code wrong way?What can be a problem here?ThanksAivars
0
Aivars
3/26/2007 9:06:16 AM
access 16762 articles. 3 followers. Follow

2 Replies
886 Views

Similar Articles

[PageSpeed] 23

I think the Error 3070 is caused by a mistake in Dev's code: I think it should be rs.FindFirst "LocalTableName='" & .strTableName & "'"To what DBMS are you trying to connect that there aren't Server entries associated with the DSN? Realistically, though, those first few lines are strictly to check that the DSN actually exists on the machine. You should be able to use some other approach for determining that.On the other hand, you might consider going DSN-less, and eliminating DSNs completely. I show one way to do that at http://www.accessmvp.com/djsteele/DSNLessLinks.html-- Doug Steele, Microsoft Access MVPhttp://I.Am/DougSteele(no e-mails, please!)"Aivars" <aivarse@apollo.lv> wrote in message news:1174899976.038853.69950@l77g2000hsb.googlegroups.com...> Hello,> I am strugling to get http://www.mvps.org/access/tables/tbl0010.htm> code to work in my case. The code runs with the follwing errors: Error> #: 3070 The microsoft office access database engine does not recognize> 'TableName' as a valid field name or expression>> And then it end up in endless errors which can only be stopped by cntrl> +alt+break and the stopped. Error #: 10 - this array is fixed or> temporarily locked.>> I start the code in immediate window with fReconnectODBC ENTER>> I have changed "qc03" to my DSN but I have no serevr name in ODBC.INI> in registry. May be that is a problem?> What am I supposed to put in as Server value?>  'You can follow the same steps to check for multiple DSNs>    strTmp = fReturnRegKeyValue(HKEY_CURRENT_USER, _>                        cREG_PATH & "\qc03", "Server")>    If strTmp = vbNullString Then Err.Raise cERR_NODSN>> Maybe I am starting the code wrong way?> What can be a problem here?>> Thanks> Aivars> 
0
Douglas
3/26/2007 10:54:36 AM
Thanks Douglas,It works now!LocalTableName was a problem! When I started stepping carefullythrough the code it showed up.And in my case I am linking to Interbase through Firebird driver andregistry entry to Interbase server is called Dbname in registry.Will try your approach with DSN-less later.Thanks againAivarsDouglas J. Steele wrote:> I think the Error 3070 is caused by a mistake in Dev's code: I think it> should be>>  rs.FindFirst "LocalTableName='" & .strTableName & "'">> To what DBMS are you trying to connect that there aren't Server entries> associated with the DSN? Realistically, though, those first few lines are> strictly to check that the DSN actually exists on the machine. You should be> able to use some other approach for determining that.>> On the other hand, you might consider going DSN-less, and eliminating DSNs> completely. I show one way to do that at> http://www.accessmvp.com/djsteele/DSNLessLinks.html>> --> Doug Steele, Microsoft Access MVP> http://I.Am/DougSteele> (no e-mails, please!)>>> "Aivars" <aivarse@apollo.lv> wrote in message> news:1174899976.038853.69950@l77g2000hsb.googlegroups.com...> > Hello,> > I am strugling to get http://www.mvps.org/access/tables/tbl0010.htm> > code to work in my case. The code runs with the follwing errors: Error> > #: 3070 The microsoft office access database engine does not recognize> > 'TableName' as a valid field name or expression> >> > And then it end up in endless errors which can only be stopped by cntrl> > +alt+break and the stopped. Error #: 10 - this array is fixed or> > temporarily locked.> >> > I start the code in immediate window with fReconnectODBC ENTER> >> > I have changed "qc03" to my DSN but I have no serevr name in ODBC.INI> > in registry. May be that is a problem?> > What am I supposed to put in as Server value?> >  'You can follow the same steps to check for multiple DSNs> >    strTmp = fReturnRegKeyValue(HKEY_CURRENT_USER, _> >                        cREG_PATH & "\qc03", "Server")> >    If strTmp = vbNullString Then Err.Raise cERR_NODSN> >> > Maybe I am starting the code wrong way?> > What can be a problem here?> >> > Thanks> > Aivars> >
0
Aivars
3/26/2007 12:20:00 PM
Reply:

Similar Artilces:

Problem shortcuts in Word
Hello, I work with Word 2008. In the beginning there is no problem, but suddenly i have problem with shortcuts. When i want to do "cmd c" it make an other shortcuts same thing for "cmd s", "cmd v" and surly some other. But when i write there is no problem "c" is "c"... If somebody have an idea please help me. Thank you. Unless you indicate your specific update level of Office as well as OS X & describe what the keystrokes *are* doing contrary to what you expect there isn't much we can offer. -- Regards |:>)...

encoding problem in Outlook 2007 importing Outlook 2000 personal folders
I use Outlook 2007 to import the pst file of Outlook 2000. The Chinese characters in the subject became unreadable but it's ok to display in message body. In Outlook 2000, there's no problem to display the Chinese characters in the subject. What's wrong with Outlook 2007? What setttings should I change to fix the problem? Thanks. cyl <u8526505@gmail.com> wrote: > I use Outlook 2007 to import the pst file of Outlook 2000. The Chinese > characters in the subject became unreadable but it's ok to display in > message body. In Outlook 2000, there's no problem t...

Outlook 2003 PST problems
I just installed Office 2003 professional on a new computer & am having problems with outlook. I copied my Outlook.pst file into the appropriate directory & although it is recognized the calendar is not working properly. I cannot attach any of the colored labels to my appointments - so everything is pretty much in black & white. I totally uninstalled & reinstalled office... first removing my pst file... but there appears to be an ini file... or something that is retaining some information... does anyone know of a fix for the labels... or how to TOTALLY uninstall office (so I...

Problem with Authentication
The CRM application was running smooth. But now I can't logging. It ask my credentials and than return a 401.1 error. I had already reinstalled the CRM server but it won't work. I'm accessing it in the same local network. I'm running CRM 3.0 in SBS. Best regards, Erico Hi When you open a Internet explorer and type the name of the CRM server, it prompts for user and password ? Are you logged in with domain credentials ( AD user ) ? If you are, so add url of the crm server in Local intranet. Enable "Automatic logon only in intranet", this is under security,c...

Vista blue screen problem...please help!
I've seen some other threads, here are the dump files: 'RapidShare: 1-CLICK Web hosting - Easy Filehosting' (http://rapidshare.com/files/347103149/Minidump.rar.html) Please, help me out here. -- ceVil It might be better to know at what point the bsod occurs and what the actual err.msg given is "ceVil" <guest@unknown-email.com> wrote in message news:0b9a0c60b90bf6c0be88bda30f2820ab@nntp-gateway.com... > > I've seen some other threads, here are the dump files: > 'RapidShare: 1-CLICK Web hosting - Easy Filehosting' > (...

pivot table grand totals not showing for all columns...
i have a pivot table that shows the grand total for some columns, but not for others... there are no differences in the data layout, yet this happens? any clues as to why? and how I can get the grand totals to show for all fields. thanx in the PivotTable floating toolbar, click PviotTable, then Table Options, select 'Grand totals for columns' option. ...

calendar problem
Dear all, I am using both mail and calendar function in outlook 2002. Everything is ok until recently, when I try to make a new appointment or checking any old appointments, an error message "out of memory or resource, try to close some windows..." pop up. The mail function is still ok. Can anyone tell me how can I solve this? I have already installed sp2. The version of office is the professional one with frontpage. Thanks. tp ...

problem #4
Hi, I am facing this new problem... i.e a user has installed Office 2003 on win2k prof platform.. whenever she is working on a outlook.. she gets a Microsoft error message... saying to send the report or don't send the report... Usually I have seen this problem in IE... But for outlook it is new to me... after clicking on send or don't send report.. the outlook closes. And there are no IE open..... and if atall it is open.. the IE does not close... Need your help regards, KAH What is logged to the Event Viewer regarding this? Try one of the following already; http://www.howt...

SQL 2005 patition table
Hi, I have 20 million (5 type record ids -- 2-3gb)records need to be loaded into a table daily. Is it a good idea to have a a patiotion table seperated by reciord type id. 1. It will be faster for retrieval in performance? 2. What is the drawbacks ot have a partitioned table instead of regular table? Thanks, Mecn My opinion is 1) It will be fatser if the user searches on particular typeid , if he/she searches on typedid 1 and 5 then it will 'scan' two partitions 2) You have to have some experience to maintain partitons "Mecn" <mecn@yahoo.com> ...

95 and 97 problem
For some unknown reason there is Excel 95 and 97 on this pc.When i double click on an Excel file, the pc defaults to the 95 program (Which incidently doesn't work properly). So my question is how do i get the pc to default to 97. Cheers Craig Craig, Have a look at Windows Help. From Windows 2000 Help (Index under Programs Associating with File Types) To change which program starts when you open a file In My Computer or Windows Explorer, on the View menu, click Folder Options. Click the File Types tab. In the list of file types, click the one you want to change. Click Edit. In Act...

Date problem
I can't believe there's no post on this, but I can't find it. I've tried the solutions I could find (see below) and still get the error: "The expression is typed incorrectly or it is too complex to be evaluated. For example....Try simplifying...." I have a date field, formatted as Date/Time, General Date, default Value = Now(). I like having the date and the time - in case we need it. I want to run a report on calls taken just for one day. I have CallDate: CallDateAndTime in my query, with "criteria" as Between ([Forms]![frmReports]![txtStartDate]) A...

sync problems
I have all of my info on an HP Ipac. I had to reformat the hard drive and I did not make a back-up file. I am trying to move everything back to the computer but it says there is an error with syncing it. How can I move everything from the PDA back to Outlook again? Please help- thanks ...

Office 2007 - HELP
I have used Word for many years and love it - not too thrilled with the changes in Office 2007, but my bigger issue is with Publisher 2007. I have an image that I have used in Word just fine - meaning, the on screen colors are correct and when printed the colors are correct. Someone sent me a Publisher file and asked me to add the image - I did this - now the image is messed up - the colors are correct on screen, but when printed FROM MY computer the image colors are all wrong - but if I transport the file to a different computer it prints fine I have reinstalled Office - no good Any id...

Installation Problem!!
I am having a problem installing MSCRM 1.2. My configuration consists of a Domain Controller running Win 2000 Server SP4 . I am trying to install MSCRM on a member of the domain running Windows 2000 Server SP4. There is a DNS Server on the DC which is integrated with AD, and a SQL Server 2000 running on the Win 2K machine. The install errors out when CRM creates the root business with the message: Setup was unable to install Microsoft CRM Server. Setup was unable to provision your organization. Setup was unable to create the root business. The configuration of ASP.NET seems to be ok, the pr...

Directory Replication Problem #2
Hi, recently my Exchange Server directory database receives changes from other servers but does not send out its own changes. Check from the knowledge base, to correct the USN discrepancy need to use Authrest.exe (need to amke changes for about 100+ users). Does anybody know where to get this file 'Authrest.exe' for exchange server 5.5? Exchange server 5.5 CD only provide this file for ver.4.0. Have anyone use it before? Regards, "Sharon Tan" <sharon_tansk@yahoo.com.sg> wrote: >Hi, recently my Exchange Server directory database >receives changes from ot...

Using Checkboxes to add data to a table.
I have been having trouble developing this form for a couple of days. It seems the solution should be simple but so am I. I have an input form with four text boxes. I need to use the same data and create a new line in the table for up to but not always 9 different company positions. I was given a possible way of keeping the info on the form for the next position using the AfterUpdate event and setting the default back to the same box. But in using his suggestion I get #NAME? for the boxes with text when I select the next new record. The boxes with numbers come back the way he said it wo...

Problems Creating a disclaimer in Exchange 2003
I am trying to create a server based disclaimer that will stamp all of my smtp emails going to the internet. I have been following KB article 317680 with no luck. I get an error like the one below. Binding Display Name Specified: smtpscriptinghost ** Registration Failed ** Err.Number (HRESULT) = 0x1AD Err.Description = ActiveX component can't create object ProgID = cdo.ss_smtponarrival COM Category = {FF3CAA23-00B9-11d2-9DFB-00C04FA322BA} Corresponding Event = onarrival ** Have you registered your sink COM class on this machine? I am puttin...

Resource editor problems
Hello all, Under VC++ 7.1... Please consider these two lines: IDC_ARROW_ADD_CANCEL DISCARDABLE "res\\cur00004.cur" IDC_ARROW_ADD_CANCEL CURSOR DISCARDABLE "res\\cur00004.cur" The second is a hand-edited change to the first. Both will compile just fine in the resource compiler. However, after I use a text editor to make this change, I cannot open the .rc file in the resource editor. The resource editor issues the following error open attempting to open the .rc file: error RC2135 : file not found: CURSOR Can anyone shed light on what's going on here? Thanks, Dave ...

Pivot Table #56
I am trying to create a Pivot table in Excel, using Microsoft Query linking to SQL database. SQL stores the date as Date/Time. It becomes impossible to group in Excel using Pivot Table, by date/time. I want to create a record in Microsoft query using the date field, but convert to Date only as dd/mm/yyyy and retain the format as Date and not as Text. I have tried Left(Date,11) and Convert(VARCHAR,1,101), none of them work. Could someone help me with the correct syntax. Microsoft query does not recognize MID. Thanks Krish ...

Cell Format
I have a spreadsheet with cells that I'm trying to type the date into. I type in the date exactly like this: 09/26/03. When I hit "enter" MS Excel displays "37890" in the cell. No matter what I do I can't the cell to show: 09/26/03. I think that somehow I need to "strip" the cell of what it's original format is, but I can't figure out how. I try to use the Date option in the format cell screen but it doesn't work. Curtis I tried this and it didn't work. I also tried the "Text to columns" feature. No success. >...

User Defined Variables in MS query cause a problem to import data
If I use user defined variables in MS query to import data into excel sheet, the query executes but no data gets imported into the excel sheet. If I get rid of the variable the results can be imported into the Excel sheet. ...

Filter Table in Subform Control according to TextBox control value
Hi all, I have put Subform control on a Form1 and in Source Object of that Subform I selected Table1 from drop down list. I also got Text box control on Form1. In the first column of the Table1 which appearing in Subform I got Ticket No. What I need that when i type that Ticket No in Text box control the Table1 in Subform should get filter on that Ticket No row. Please can any friend can help More information about the tables would help. I will use tblMain as the name of the Record Source for Form1. Are tblMain and Table1 related? If so, on what field? Typically you would set t...

outlook web access redirect problem
hi, I have been trying to redirect outlook web access (OWA) from the IIS root folder to the /exchange folder. I have followed the instructions on going into the web site and redirecting to a folder but I just get the following URL when I browse to the root of my webserver : http://webmail/exchange/exchange - it's like it's doubling up somehow. I have it set to : A redirection to a URL redirect to: /exchange client will be sent to: A directory below URL entered I just can't work it out... any ideas... cheers Baronne Which instructions did you follow? I wrote the below articl...

Problem after sorting
In my Excel 2007 workbook I have two sheets The "Master Names" sheet has columns: (A) First|(B) Last (C) First (B) Last (concatenated) The "Selected Names" sheet contains (A) cells which link to selected (C) First Last (concatenated) cells in the Master Names sheet. Everything links and displays fine except when I add names to the bottom of the Master Names sheet and then sort using (B) Last name column. When I do this I get a 0 (zero) in the (A) First Second cells in the Selected names sheet and other cells in this sheet have the wrong name. Obviously I am doin...

IF AND problem
Need to isolate problems on 1600 rows Worksheet Row Dept Hrs. Dollars A5 120500 600 9000 A6 120600 400 8000 A7 130600 240 A8 130400 160 A9 140600 320 6400 A10 140200 100 2000 A11 140600 240 (Found out the dept has 2 leading blanks) Isolate problems on 0600 criteria pointing out when b has value and c = 0. OK if both are 0. A7 and A11 should stand out.. =IF((MID(A1,5,4)="0600")=AND(b1>=0=AND(c1>=0)),"NO","ok") Does this work for you: =IF(RIGHT(A...