Using a parameter in a report

Hi,

I am using Access 2007.  I have created a report where the RecordSource is 
set to something like the following:

SELECT MyTable.Tag1, MyTable.Tag2 FROM MyTable WHERE MyTable.Tag1 = 999;

The WHERE clause is hard coded so that it only looks for records where Tag1 
= 999.  Rather than having this hard-coded, I would like to make use of a 
parameter so that when I run the report, it will ask me to enter the Tag1 
value I want to use for filtering the report.  

If anyone can tell me how to do this or point me towards something I can 
read that would be helpful, I'd really appreciate it.

Thanks in advance,
Paul

-- 
Paul Kraemer
0
Utf
5/24/2010 3:09:01 PM
access.reports 4434 articles. 0 followers. Follow

2 Replies
1472 Views

Similar Articles

[PageSpeed] 26

Hi Paul,

Try this: ........ WHERE MyTable.Tag1 = [Enter Tag1 Value]

Steve
santus@penn.com


"Paul Kraemer" <PaulKraemer@discussions.microsoft.com> wrote in message 
news:B46728A5-92C2-461E-B37A-CFF190517607@microsoft.com...
> Hi,
>
> I am using Access 2007.  I have created a report where the RecordSource is
> set to something like the following:
>
> SELECT MyTable.Tag1, MyTable.Tag2 FROM MyTable WHERE MyTable.Tag1 = 999;
>
> The WHERE clause is hard coded so that it only looks for records where 
> Tag1
> = 999.  Rather than having this hard-coded, I would like to make use of a
> parameter so that when I run the report, it will ask me to enter the Tag1
> value I want to use for filtering the report.
>
> If anyone can tell me how to do this or point me towards something I can
> read that would be helpful, I'd really appreciate it.
>
> Thanks in advance,
> Paul
>
> -- 
> Paul Kraemer 


0
Steve
5/24/2010 3:18:18 PM
I don't care for parameter prompts. Consider adding a text box (or maybe a 
combo box) on a form to use for the criteria. Then your SQL might look like:

SELECT MyTable.Tag1, MyTable.Tag2 
FROM MyTable 
WHERE MyTable.Tag1 = Forms!frmMyCriteria!cboTag1;

-- 
Duane Hookom
Microsoft Access MVP

NOTE: These public News Groups are ending June 1st. Consider asking 
questions at http://social.answers.microsoft.com/Forums/en-US/addbuz/threads?


"Paul Kraemer" wrote:

> Hi,
> 
> I am using Access 2007.  I have created a report where the RecordSource is 
> set to something like the following:
> 
> SELECT MyTable.Tag1, MyTable.Tag2 FROM MyTable WHERE MyTable.Tag1 = 999;
> 
> The WHERE clause is hard coded so that it only looks for records where Tag1 
> = 999.  Rather than having this hard-coded, I would like to make use of a 
> parameter so that when I run the report, it will ask me to enter the Tag1 
> value I want to use for filtering the report.  
> 
> If anyone can tell me how to do this or point me towards something I can 
> read that would be helpful, I'd really appreciate it.
> 
> Thanks in advance,
> Paul
> 
> -- 
> Paul Kraemer
0
Utf
5/24/2010 3:40:01 PM
Reply:

Similar Artilces:

Reports issue #2
Hi all, I have two different CRM setups, and I'm running through the same issue. It's impossible to generate reports from CRM. Here are the configurations : 1) Windows Server 2008 w/ CRM 4.0, and a windows server 2003 w/ SQL 2005 & Report Server 2) Windows Server 2008 w/ CRM 4.0 and SQL 2008 with Report Server Both Windows2k8 are domain controllers, and in the first setup the two servers are in the same domain. My report services are running with the network service account. When I want to get a report from CRM, I got the following message : "Reporting Error. The repor...

Outlook using imap is receiving but not sending
Messages are being put in Sent folder and Send/Receive shows no errors but emails are not actually getting sent. This is a new install of Outlook on a new computer. Have I messed up the setup? "Theatre Girl" wrote in message news:64BB711F-FE56-440C-A850-DADCA8C3BA00@microsoft.com... > Messages are being put in Sent folder and Send/Receive shows no > errors but > emails are not actually getting sent. This is a new install of > Outlook on a > new computer. Have I messed up the setup? IMAP is not a sending protocol. It is used for receiving mails (out of your ...

Line charts using temperature and time factors
I want to create a line chart showing comparisons of heating and time. For example one item is held @ 30deg for 10secs then 100degs for 30secs while the comparison is plotted to show the difference. Help appreciated. try x-y scatter chart data-columnwise. Excelon_Ls <Excelon_Ls@discussions.microsoft.com> wrote in message news:6B9F5547-A35C-4272-9FDC-F2CE6122D783@microsoft.com... > I want to create a line chart showing comparisons of heating and time. For > example one item is held @ 30deg for 10secs then 100degs for 30secs while the > comparison is plotted to show the diff...

Spending by Category Report on Home Page
I have Customized my Spending by Category Report to not include Taxes and some other stuff (under the Reports tab). However, I also have the Spending by Category report show up on my Home Page. This report does not include the customizations I made under Reports, so it shows ALL categories. Anyone know how to make the Home Page report be the same as the other one? Thanks! Hi, The report on the home page is not customizeable. I believe this is rather meant to give you a general overview of your spending. Infact if you watch closely at regular intervals the all the homepage charts ...

E-Mail Report
I see alot of answers to E-Mailing a report, but I can't find anything to send an E-Mail with the report data being in the body of the E'mail, I don't want to send the report as an attachement. Can this be done? Thanks DS ...

HOW TO USE HYPERLINK within a droplist?
I have a question aabout this: eg. I set row A with validation list "yes/no", i want that if choose "yes", then open a word document named "checklist.doc". Instead of using a validation list, you could use a "yes" button and a "no" button. The yes button can be linked to a macro to open the word document. The no button can be linked to a macro the will type the text "Go to next step" or something like that. "Bonny" wrote: > I have a question aabout this: > eg. > I set row A with validation list "yes...

using forms
Vista Home Premium 32 / Outlook 2007 I have created some forms that used to work. No more. On selecting a form, I get "The form required to view this message cannot be displayed. Contact the administrator. To my knowledge, I am the administrator. This is a stand-alone PC in my residence. If I go to Manage User Accounts, it shows only 2 accounts - LastName Administrator and Guest. I have googled my problem and found references to FRMCACHE.DAT which I am told to delete and restart Outlook. Did that. Opened Outlook and tried to open a form. Same error. And FRMCACHE.DAT was not ...

Problems with accessing Reports in CRM 3.0
This is the error I get when I try to access Reports from the Workplace thru the web client. Any suggestions????? Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. Stack Trace: [InvalidOperationException: Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'. The request failed with the error message: -- <html> <head> <title>Configura...

Possible incorrect number of sent emails reporting
Hi, I have a strange issue - 'possibly'. I have a 2 week report from a client's SBS 2003 Exchange server, and I see a spike in the number of sent emails from a particular user - over 800 sent over a 2 week period. Since that time, we have turned on SMTP logging and upon reviewing a recent 5 day report from that log, I only count around 75 emails sent from the same user over those 5 days. My client wants to know why those 800+ emails are showing from the Exchange server performance report, and if that report is incorrect. The trends in the outgoing SMTP logging for that server ...

Using Spanish on Publisher
I have copied and pasted a document in Spanish from Word to Publisher. Prompts keep coming up telling me that it cannot "hyphenate" this document. I'm guessing that it means since it's in another language it needs something to be able to spell-check, etc. I really don't care about checking the spelling, but the pop-ups keep interferring with my arranging the flyer I desperately need to get completed. It tells me to put in the disk and download the "hyphenate" feature. Can I download this from the net since I have no disks. Publisher came with my n...

I used Omsgclas.exe Utility and my contacts don't use then new form
I created a new form for contacts. I followed the three steps in the document How to Update Existing Items to Use a New Custom Form. I can click on Action and do new contact and the new form is used. I used Omsgclas.exe utility to change the message class of the contacts. It shows as changed. However, when I click on an old contact (previous to changing the form), A message form comes up (not the old contact form and not my new contact form). Anyone have any help how to get my new form pulled up for old messages? Note: I had a form with a ' in the name, I made a new form w...

FormulaR1C1 using variables
I want to do this but can't: ActiveCell.FormulaR1C1 = "=MyFunction(R[variable]C[variable])" What are my options? Try something like ActiveCell.FormulaR1C1 = _ "=MyFunction(R" & CStr(variable) & "C" & CStr(variable) & ")" Cordially, Chip Pearson Microsoft Most Valuable Professional, Excel, 1998 - 2010 Pearson Software Consulting, LLC www.cpearson.com On Wed, 21 Apr 2010 13:52:01 -0700, Cheah <Cheah@discussions.microsoft.com> wrote: >I want to do this but can't: > >ActiveCell.Fo...

cloning canned smartlist report into smartlist builder
Hi, Can anyone tell me a way to clone a smartlist report into smartlist builder (so we can build upon that?) Thanks! There is no way to do this. You will have to recreate all the canned SmartLists in SLB. I wrote a product feedback to deliver the canned SmartLists as standard XML files that can be loaded and deployed into SmartLists a while aback and you can feel free to join in and vote to add this feature. https://connect.microsoft.com/dynamics/feedback/ViewFeedback.aspx?FeedbackID=360762 Best regards, -- MG.- Mariano Gomez, MIS, MCP, PMP Maximum Global Business, LLC http://www.maxi...

Using lookup formula using more than one cell
I have a spreadsheet which lists clients by first name, last name, postcode and phone number - all in separate columns e.g. Andy Roberts M56 7HN 0161 428 3856 I have these all in one worksheets and in a named range called "Clients" On a separate worksheet (within the same workbook) I log all my enquiries. What I want to be able to do is type in to a cell the first name then in the next cell the last name and the following cells get populated with postcode and phone number based on BOTH of the first two cells by looking up the "Clients" range. I can get it...

Using XML with ASP.NET
I want to know where can I find Tutorials/Articles to learn implementing XML with asp.net. I am working on ASP.NET using C# from last one month. I have idea about XML but had not implemented yet with ASP.NET. Thanks in advance. Thanks Vinod Jajoo ...

Using secured OMA
Hi, Please help me with my misunderstanding. When I try ro connect by t68i or z600 (WAP 2.0) to OMA directly with SSL required, using mydomain.com/oma, of course, I get 403 error. When I use https://mydomain.com/oma I get "Couldn't reach the indicated web server." altough it works fine with Pocket PC. What's wrong? What should I configure to establish secured connection from mobile phone? Best regards, Vit Knyshevich. "Vit Knyshevich" <abuse_vit_knysh@hotmail.com> wrote: >Please help me with my misunderstanding. When I try ro connect by t68i or >z60...

Compile error using CTypedPtrList
Hi, I am having problems at compile time using the following line: CTypedPtrList<CPtrList, CString*> m_ClientList ; When compiled I get the following errors: emailcfgdlg.h(114) : error C2143: syntax error : missing ';' before '<' emailcfgdlg.h(114) : error C2501: 'CTypedPtrList' : missing storage-class or type specifiers emailcfgdlg.h(114) : error C2059: syntax error : '<' emailcfgdlg.h(114) : error C2238: unexpected token(s) preceding ';' I am using the version 6 of the compiler with SP5. Now I think this is something to do with the c...

Using resources, how to ?
Hi guys, I am using MS Visual Studio 2005 Express ( yes, the one that u can download for free from MS website ) and I have a "little-big" problem with my program. First of all let me say that I created a simple console program, with his main and few functions, and I wish that my ..exe file can drop another .exe when launched. The other exe is another compiled program, and I wish to handle it from my main program as resource. There are some topics about handling resources, but I cannot find anything of good; I know how to use LoadResource, FindResource, etc, but both fail since I am...

scatter plots using pivot table data
In older versions of Excel, you could directly create xy scatter plots using pivot table data. In Excel 2000, the chart wizard says you can't use an xy scatter plot with pivot table data. Why????? Is there any way around this limitation? Dan - Don't tell the pivot table you're making a regular chart. Select a cell away from the PT and start the chart wizard. Select the XY Scatter type you want in step 1. In step 2, use the Series tab to select the ranges for the names, X values, and Y values of each series in your chart. Make sure you don't select one of the PT but...

Allow temporarily use of right click
I have made a databse in which I have disabled the right-click option. However, I have a form which opens reports, and I want to temporarily allow (only for the opened report) the right click option so the user can save and print the report. I have also no clue how to create a custom menu with only a few of the normal right-click options I hope my question is clear. Thanks -- Message posted via http://www.accessmonster.com "greeknl via AccessMonster.com" <u30909@uwe> wrote in message news:71abb764263d9@uwe... >I have made a databse in which I have disabled the right-c...

Calendar Report in CRM
I'm trying to write a report in CRM that will display data in a calendar format. I've been banging my head on this for weeks and I haven't turned up anything online. I have some dates with titles attached I just want a calendar to display those titles on those date. I wouldn't think it would be that hard but it is. Help! ...

Using two pictures from clipart as my background
I can't seem to get more than one clipart as my background. When I try to add another one, it overrides the first one. I want two pictures, each on half the page, and faded. Thanks. On Jan 13, 7:31=A0pm, Michele <Mich...@discussions.microsoft.com> wrote: > I can't seem to get more than one clipart as my background. When I try to= add > another one, it overrides the first one. I want two pictures, each on hal= f > the page, and faded. Thanks. You can place multiple pictures on your slide (or slide master), but each slide can only contain one as it's ...

How to use interfaces
Hi ... How can you show in an UML diagram using visio that you have 1 class who uses the interface implementet by another ?? ex: C# public class MyClass : ImyInterface { //some code } //And then in another class you will do something like: private ImyInterface imi = new MyClass(); can you show this via UML shapes in Visio ?? thanks in advance ... -- ------------------------------- Med Venlig Hilsen Tonni Schm´┐Żcker Tonni@cool.dk ...

Using stationary when Word is used as the editor
Hello, I am having a problem with stationary when using word as the email editor. What is required is for a logo to be placed as a backgroun image in the top right hand corner. this works fine in outlook using this code: <HTML> <HEAD> <STYLE> BODY { font-family: Arial; font-size: 10pt; color: 000000; background-position: right top; background-repeat: no-repeat; background-image: url(Pic.jpg); } </STYLE> </HEAD> <BODY> </BODY> </HTML> However when Word is used as the email editor the background image is no longer placed in the top righ...

newbie here. How do I rearrange how a report looks?
Hi, I have Access 2007. I have created a report with business name, address, etc... along with a list of different types of employees (administrative, clerical, etc..). I am trying to create a report with the Business name and details all in one block (sort of how it would look like if you were creating mailing labels) and under that I want to create columns title administrative, clerical etc... with the names of employees under each column. Right now, my report is totally in columns, and the list of employees is seperated my commas instead of being under each other - like i...