Results show as a minus. WHY?

I have an application that was developed by another developer using VB.net 
which reside in a SQL table. I need to use some of the data from this table, 
however the data shows as -0.5 or - 0.99 or -1.70 etc in my Access tables. 
How can I get those numbers to show as a percentage with only one decimal 
point to the left? Example: 3.6% or 31.4 %. Any help would be greatly 
appreciated. No matter what I do it shows that dang "-" at the beginning.
0
Utf
7/10/2007 11:02:00 PM
access.reports 4434 articles. 0 followers. Follow

1 Replies
1480 Views

Similar Articles

[PageSpeed] 0

You can use the Abs function to strip off the negative

Abs([YourTable].[YourField])

And you can format that as percentage either using the control's format 
property or using the format function.  Personnally I would use the format 
property to control the display of the data and the Abs() function in the 
underlying query

Field: YourField: Abs([YourTable].[YourField])

In some versions of Access you may not be able to alias the field to the 
same name as the field.  In most cases you can do so AS LONG AS you use the 
Table and Field name when you want to refer to the field and not its alias.

-- 
John Spencer
Access MVP 2002-2005, 2007
Center for Health Program Development and Management
University of Maryland Baltimore County
..

"TKM" <TKM@discussions.microsoft.com> wrote in message 
news:438C67F4-3B61-4832-B4DD-A162B5A0BB6D@microsoft.com...
>I have an application that was developed by another developer using VB.net
> which reside in a SQL table. I need to use some of the data from this 
> table,
> however the data shows as -0.5 or - 0.99 or -1.70 etc in my Access tables.
> How can I get those numbers to show as a percentage with only one decimal
> point to the left? Example: 3.6% or 31.4 %. Any help would be greatly
> appreciated. No matter what I do it shows that dang "-" at the beginning. 


0
John
7/11/2007 12:28:49 PM
Reply:

Similar Artilces:

Sent messages are not showing in Sent Items folder
Exch 5.5 server with Outlook 2002. User selected and deleted all messages in the Sent Items Folder. Since that time, sent messages no longer appear in the folder. All settings appear correct and there are no filters applied to the folder. Anyone have any thoughts? Thanks! ...

MS Word 2002
I have MS office 2002 programs on my laptop (Windows Vista) and for some reason, whenever I go to click something on the menu bar - for instance File, Edit, or View - the drop-down won't show up. All I get is a vague outline of the right-hand side of the drop down. Same with text color, font style, etc. I can still use it, sort of; if I know that the Save As option is n number of spaces down when I click File, I can use the down-arrow key to move that many spaces. The thing is, I don't have all that memorized, and I really want to fix this. It's on all the Windows p...

Exchange user account email properties not now showing in AD
I created a Windows 2000 active directory user and also an Exchange 2000 mailbox for that user which successfully worked. However when I open the properties on the user in AD i can see the exchange property tabs such as exchange advanced, exchange features, exchange general, email addresses but within the email addresses tab, the email address assigned from the recipient policy doesn't is not shown and is blank. I've tried to replicate AD, create the user account, updated and rebuilt the RUS, tried to connect to exchange using outlook however i haven't been able to locate th...

Show addresses in the 'To' field
I have multiple users with multiple email accounts associated with their inbox. We just migrated from Exchange 5.5 and Outlook 97 to Exchange 2000 and Outlook 2002. Now the mail goes into their mailbox showing itself as being addressed to their mailbox name. I need to show the email addresses they were addressed to. For instance, Bob's mailbox shows everything as 'To' Bob, when I need it to reveal if it was delivered to information@domain.ca or bsmith@domain.ca. Anyone know how to set the view so I can tell without having my users muddling in their options and trying to...

Data Access Page Show Multiple Records
Hi, I'm guessing this is going to be a pretty dumb question but I am trying to generate an Access Data Access Page. I am using the create wizard to create the page and I chose to have a field as a grouping level. What I am wanting to know is how I can have the page show multiple records of the grouping level instead of one at a time? I have thousands of records and one at a time is very time consuming. Thanks in Advance, Rob ...

If the result of a formula is negative make equal to zero
I do have a worksheet that calculates sales profits or losses quarterly in 3 different locations. For each quarter I do have a formula that gives me the increase or decrease amounts during the last couple of years. For the total result I need a formula that converts or ignores the negative results. Any calculation result with a minus sign in the formula should be equal to zero, so it's not included in the final quaterly total. Could somebody help me with it? Thanks! =IF(yourformula<0,0,yourformula) Regards Trevor "Nrippe" <Nrippe@discussions.microsoft.com> wro...

Email from CRM showing sender's email address, not display name
We recently installed CRM 4.0 as an upgrade from 3.0. When an email activity is generated and sent, the resulting email in Outlook only shows the senders email address in the From field, not the Display Name. As a matter of fact, the display name is not even included in the message header. We are using the CRM Email Router to send using SMTP. This happens whether the email is from a User or Queue. Anyone seen this yet? Is this a CRM issue or an Exhange issue. I seen it and then it disappeared :) publish the email router again . are you generating email through workflow? send emai...

Minus Stock
We have situations that we have to sell items before entring the receiving and costing. If we use the 'Override Shortage' Option GP allows to sell the items but how it does the costing and calculate the COGS. what is the best solution? Thank You When ever you sell an item, COGS is charged with the current value of the item. This value is changed for average/perpetual items upon the receipt of new stock and for standard/periodic items when the costs are revalued. Its actually a bit more complex but lets jump to the bottom line. If you are on a perpetual cost, no issue. Other...

How do I show hidden column and row headings in excel?
How can I display hidden column and row headings in excel? Excel displays only unhidden rows and columns, and their headings. But if you make the width or height small enough, it might still be possible to see the heading and not the data. However, this becomes more difficult as you move to column AB or row 101. "Mildred" <Mildred@discussions.microsoft.com> wrote in message news:D7D83F4B-289A-49A6-9057-23365EAFB300@microsoft.com... > How can I display hidden column and row headings in excel? ...

Report Showing Different U of M
Is there a report where I can see my item numbers not in the base unit of measure? For example, see items by 'case' as opposed to 'each'. Thanks in advance! Craig YES! It's a 3rd party solution and I'm being worthless tonight beause I can't recall the name. Hopefully someone will be able to help me out. It does exist, I've seen it and used it. Let me know if nobody comes through with the vendor and I'll hunt it down fo you. leslievail@earthlink.net LV "Craig" wrote: > Is there a report where I can see my item numbers not in the ba...

Inbox showing messages count but nothing is showing on right pane
In Outlook 2002 after deleting all messages in the inbox, the inbox message count will show that you have two messages in the left pane, but the messages pane on the right is empty. Any idea why this is happening. Hope I explained my question clearly Conduct an advanced find on the inbox and include any type of Outlook file - what shows up in the results box? --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the (insert latest virus name here) virus, all mail sent to my personal account will be deleted without reading. After searchi...

Inventory Adjustment Posted did not hit the GL, Shows only ZEROS
Hi everyone, A strange situation here One of my User made an adjustment entry in Inventory. It made all the necessary adjustments in Inventory but Posted with ZERO Dollar to GL. I can see the Entry but amounts are not the there. only ZEROS. I have run reconciliation and check links both on Financial but nothing came up. Any idea how to maneuver this monster ? Was the adjustment an increase or a decrease? if an increase, did they enter $0.00 as the cost? Frank Hamelly MCP-GP, MCT, MVP East Coast Dynamics www.eastcoast-dynamics.com get your GPtip42today at www.gp2t...

HELP!
We are experiencing a weird problem: Outlook 2003 is downloading email from a POP3 server, but then nothing is showing up the user's Exchange Inbox. Outlook is setup with one or more POP3 accounts and an Exchange account. Email is checked via the POP3 accounts and delivery is set to the Exchange mailbox. This allows us to send and receive email from several different accounts but have all downloaded email in Exchange so it's accessible via OWA. This is working for most users and it *was* working for the user currently experiencing the problem above. I can verify that messages...

subform not showing data
I created a tab control on a form to hold multiple subforms. I dragged the form onto the tab control to create the subform. When I look at records entered, only the main form shows data. I have another form/subform (only not on a tab) which works fine and I've been unable to find any differences in the setup. Can someone tell me what I'm missing? Thanks! "Loni - RWT" <LoniRWT@discussions.microsoft.com> wrote in message news:AD808524-B1D3-479C-AF6F-99A42D1D9FE3@microsoft.com... >I created a tab control on a form to hold multiple subforms. I dragged the > f...

Showing the percentage of a total in Excel
I would like to add a percentage to a figure but wish to show the amount added rather than the total. For example: $1000.00 + 25% = $250.00 At the moment I can only get the formula to show: $1000.00 + 25% = $1250.00 Any help would be much appreciated! So, how about =A1*.25? ******************* ~Anne Troy www.OfficeArticles.com "jakeyboy" <jakeyboy@discussions.microsoft.com> wrote in message news:F9C22D37-5294-4FA2-8153-B2171EE05162@microsoft.com... > I would like to add a percentage to a figure but wish to show the amount > added rather than the total. > >...

Using an IF statement, based on 2 COUNTIF results (I think)
I'm using Excel 2003 so I hope I'm not limited here. We are performing a space usage survey and I need to compile the data results. Each location has 70 entries over the course of 10 days. I have a column for "group work" where the value is either 1 or 0. I have another column for # of people observed in a particular office. What I'm trying to do is the following: Get a count of instances where "# of people" = 1 and "group work" = 0 I'm doing a lot of countif statements, but I don't see how to do a countif with an and operato...

Move Mailbox failure results in maildata on source and target servers (Exchange 5.5)
Hi all, I have two Exchange 5.5 SP4 servers running in the same site. Due to priv.edb corruption on one of the servers, I started moving mailboxes to the second server. A few of the moves failed without explanation. The only potentially related even was something about rules synchronization, but Google and MS KB searches yielded nothing. Here's the problem: - Moved USER mailbox from SERVER_X to SERVER_Y - Move failed at some point - "Mailbox resources" on SERVER_Y shows that USER has approx. 1.4GB on SERVER_Y, but USER doesn't show up in "Server Recipients" - ...

Graphics and pics don't show in Publisher
I have a Publisher document that I put graphics and pictures in and they show fine on every machine I use but one. I cannot see the grahics items although they are there. Anyone know what setting could possible be wrong? I don't see the lines around the box, the grahpic itself, but it is there and prints. Patrick Read the third FAQ here: Q: Why can I not see images/shapes/lines when editing my publication? http://ed.mvps.org/Static.aspx?=Publisher/FAQs -- Mary Sauer MSFT MVP http://office.microsoft.com/ http://msauer.mvps.org/ news://msnews.microsoft.com "PatrickW"...

Inbox in Outlook 2003 always shows one unread e-mail
I did a search first, but couldn't find anything that applied to me. We use Outlook 2003 and until today everything was fine. Starting this morning however, my personal Inbox shows that I have one unread e- mail, but there is nothing in there. I have done an advanced find on my entire Mailbox and tried using the Search Folders for Unread Mail with no luck. This is really annoying because no matter how many e- mails I get, it continues to show just the one unread mail. Any help would be great, Richard Could be a Read Receipt. "Richard.M.Henry@gmail.com" wrote: > I did ...

customers show up in manager but not POS?
We recently started experiencing a problem where certain customers at random would show up when searching for customers in the customer list in store ops manager, but will not show up in the list to select from when in POS. We reindex the database regularly. Any idea what could possibly be causing this? Thanks for the help Kevin The customer(s) aren't set as global. Go to FILE, CONFIG, OPTIONS, CUSTOMER OPTIONS. You should enable GLOBAL CUSTOMERS FOR MULTI-STORE and NEW CUSTOMERS DEFAULT AS GLOBAL CUSTOMERS. Then, you may need to run a SQL QUERY to flip the Global Customer flag...

How can OL2000 show picture directly?
Post your questions in the body, not the Subject. By design, Outlook does not display attached images inline. Outlook is a business application. OE is targeted to consumers and the needs of the two groups are different in this area. Exchange Administrators consider inline display a security issue and don't want it. Outlook only shows images inline with HTML mail items or RTF mail items with OLE embedded images. Images in plain text mail items only show as attachments (that you can open or save). -- Russ Valentine [MVP-Outlook] "Litchee" <wonfer@hotmail.com> wrote...

Inactive Accounts Not Showing in View After Find
After searching for an inactive account, the results in the view do not include that account. However, if you page right in the Inactive Accounts view, you can locate that account. Would like either the All Accounts view or the Inactive Accounts view to be searchable for an inacative account. -- Thanks, Justin ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote for this suggestion, click the "I Agree" button in the message pane. If you do not see the button, follow this link to open the suggestion ...

words no fully showing up
When I use a pulldown menu on a web page, the words are covering each other up. It's like the space used is too small. Could this have anything to do with my resolution? On Jan 5, 7:46=A0pm, chaos <ch...@discussions.microsoft.com> wrote: > When I use a pulldown menu on a web page, the words are covering each oth= er > up. =A0It's like the space used is too small. =A0Could this have anything= to do > with my resolution? Depending on what you use as a browser, you can reset the font size but that may not suit you as far as the rest of the PC looks with th...

Min Max options in Access 2007 adp reports not showing
I have an access adp which I developed in 2003 with sql server 2000. I have with great success developed and deployed this app to run with Access 2003 Runtime. I would like this app to move to the Access 2007 runtime, and most of the testing has gone well and the issues have been minor. One issue remains which my client is being stubborn (and rightfully so) that needs to be addressed. When I open all reports with this statement: DoCmd.OpenReport stDocName, acPreview, , stLinkCriteria or DoCmd.OpenReport stDocName, acViewPreview, , stLinkCriteria the reports op...

New user does not show in global address book
But another user created at the same time does. I can find no difference in their configurations. Exchange 2003 (Mixed mode) with IMC running on a (soon to vanish) Exchange 5.5 server. I have tried recreating the user but he still did not show up. The "hide from lists" checkbox is not checked. Help! Thanks. Are you Using Outlook 2003 in cache mode? If not, how long have you waited? On Wed, 27 Oct 2004 15:25:24 -0500, "Don Williams" <Don.Williams@NOcMoreMedicalSPAM.com> wrote: >But another user created at the same time does. I can find no difference in ...