Unable to bring back all results from table with query

For a uni assignment we have a designated query that we have to create.

But when I run the query, I get one result returned to me. I should have two 
returned to me, as I have two records in the Problem table.

The SQL is:- SELECT Problem.[Problem Number], User.[User ID], User.[User 
Name], User.[Job Title], User.Email, User.[Telephone No], Asset.[Asset Code 
No], Problem.[Problem Description], Problem.[Current Activity Log], 
Problem.[Solution Description]
FROM [User] INNER JOIN ((Asset INNER JOIN Problem ON Asset.[Asset Code No] = 
Problem.[Asset Code No]) INNER JOIN [Contact Log] ON Problem.[Problem Number] 
= [Contact Log].[Problem No]) ON User.[User ID] = [Contact Log].[User ID];

The thing is that when I do a select all from the problem table I get all 
the results, but I do not when I use the SQL described above.

Any ideas as to what may be causing this?

Cheers in advance
0
Utf
12/2/2009 3:13:01 PM
access.queries 6343 articles. 1 followers. Follow

1 Replies
754 Views

Similar Articles

[PageSpeed] 48

You are using inner joins which means that there must be a matching record in 
both tables or the record won't be returned. 

Try changing the joins from the Problem table to Left or Right joins. If the 
tables are small enough, you should be able to see which table doesn't have a 
matching record.
-- 
Jerry Whittle, Microsoft Access MVP 
Light. Strong. Cheap. Pick two. Keith Bontrager - Bicycle Builder.


"Karrot_Bex" wrote:

> For a uni assignment we have a designated query that we have to create.
> 
> But when I run the query, I get one result returned to me. I should have two 
> returned to me, as I have two records in the Problem table.
> 
> The SQL is:- SELECT Problem.[Problem Number], User.[User ID], User.[User 
> Name], User.[Job Title], User.Email, User.[Telephone No], Asset.[Asset Code 
> No], Problem.[Problem Description], Problem.[Current Activity Log], 
> Problem.[Solution Description]
> FROM [User] INNER JOIN ((Asset INNER JOIN Problem ON Asset.[Asset Code No] = 
> Problem.[Asset Code No]) INNER JOIN [Contact Log] ON Problem.[Problem Number] 
> = [Contact Log].[Problem No]) ON User.[User ID] = [Contact Log].[User ID];
> 
> The thing is that when I do a select all from the problem table I get all 
> the results, but I do not when I use the SQL described above.
> 
> Any ideas as to what may be causing this?
> 
> Cheers in advance
0
Utf
12/2/2009 3:43:02 PM
Reply:

Similar Artilces:

Unable to open Outlook2003. Error: MAPI unable loading msncon.dll
I am trying to set up Outlook 2003 on home computer but keep getting the following message when trying to open application. MAPI was unable to load the information service msncon.dll. Since I am not open to open, I cannot get to the help feature. Please advise Have you downloaded the latest MSN Connector from their site? Or, if not using it, have you uninstalled it? Try opening Outlook in Safe mode (start->run->outlook.exe /safe) and go into the Advanced options and uncheck it from add-in manager or COM add-ins. --� Milly Staples [MVP - Outlook] Post all replies to the group to ...

Unable to Edit/Add records on Form in a New ADP
I just started playing around with rebuilding a MDB file as an ADP. I built a form and subform from scratch, but I'm unable to edit or add records. SELECT Id, LoadDate, TrailerDOTNumber, SealNumber, SealDate, SealId, LoadLocation, LoadStatus, DispatchStatus, DispatchLocationId, DispatchUserId FROM TrailerActivityHeaders ORDER BY LoadDate Recordset Type: Updatable Snapshot I'm getting the 'This recordset is not updatable' Ideas? Never mind... (Does anyone have a spare bandage btw? I cut my head banging it on the wall due to my stupidity...) "D...

Unable to open calendar
Folks, i cannot open or view my calendar. When I start Oultook a Pop Up appears saying "Could not read the Calendar" On clicking Ok, the pop up vanishes and nothing happens. If i then go over to my calendar, it says "Cannot display the folder" I have run Oultook Diagnostics and nothing shows up as irregular. I ran the repair function (off my setuo CD) and nothing happened. I also re-installed Outlook and rebooted my comp and nada. When staring in safe mode i also get he same errors. I am using Off 2007, Win 7 TIA, P "phamiltonsmith" <...

Change Icon for XLT and resulting XLS
Hello, I have created an XLT which is used very frequently at my workplace. There are multiple files on our drive made using this template, and I need a way for them to differentiate themselves from other excel files. After many failed attempts to convince my coworkers to save their resulting spreadsheets using a simple naming convention, I come to this group. Is it possible, at all, for the spreadsheets that are created when the XLT is opened to have a unique icon (I have already created the icon)? I've read many posts here about changing the icons for individual workbooks, for excel...

unable to download emails and unable to stop synchronization
I am going to try one more time to get this fixed. My Outlook 2003 has been unable to download emails. While it is trying, a small box in the tray section shows up and it states that it is trying to synchronize folders. After a time out time Outlook gives me errors. This is the error message. It has these numbers 0X800CCC15 , or 0X8004210A, or 0X8004210B, which these error messages state that either I did not have enough timeout or look and see if server name is wrong. All of you have given me these suggestions. no joy. Thank you very much however. I went ahead and finally found a sect...

in reply outlook, can't find signatures? how to put it back?
Hi I screwed something up here while trying to set up a signature. I went to reply and when i go to auto text there is no signature! Just signature company. Earlier I tried to apply a signature but my name kept coming on? So I remove my name and initials from Autotext (i don't know why) signatures disapeared. I replaced the init. and name but no change. I want to put a signature on some reply email. Help!! And thanks Brad Bylsma. P/S is there a good manual that looks at things from a, how can a newbie screw up stand point? Or better yet how to restore it to before you screwed i...

Relinking tables to a network server
I'm trying to relink tables using code to a network server. The problem is that the users all have different letters for their server. I'm using the following code: Dim db As DAO.Database Dim tdf As DAO.TableDef Dim b As Boolean Dim strPath As String Dim dbPath As String Dim dbname As String On Error GoTo RelinkTables_Error b = True Set db = CurrentDb dbname = "AboveDB_be.mdb" dbPath = "\\eastfps00\accesswork\" strPath = dbPath & dbname 'strPath = DB_PATH & DB_NAME 'Relink each table's connection string For ...

Formatting As Table with OUT header row formatting
I am on Windows XP and Excel 2007. I would like to be able to just format Data rows, however, when I Format As Table, it insists on using a header row or creating one for me. Because it also automatically turns on filtering for the header column it totally screws up my column widths! I have worked hard on these widths and do not want them to change. My end goal is to apply every other row shading that changes to maintain the everyother row shading when I insert or paste rows in the middle somewhere. Thanks in advance for your help, magmike On 1/3/2012 2:30 PM, magmike wrote: > I am on W...

Run a Query using VBA without User Interface
Hello, I have a VBA Macro that Opens an Append Query (see below), which works great, except for the end user has to answer the following MsAccess prompts: 1) You are about to run an append query that will modify data in your table. (They have to click Yes) 2) You are about to append 1 row(s). (They have to click Yes) I'd rather them not have to answer either question. Instead I'd like the Append Query to run and do what it's asked without any human intervention. Can this be done? Please help! VBA Macro Code: DoCmd.OpenQuery "tblTask_List Query", acViewNorm...

unable to scroll the page
on microsoft office frontpage 2003 - when i up loaded my web pages to my web site www.millertimeauction.com , there is no sroll bar for up & down of page - any help what browser? it scrolls for me in IE8 scroll bar will only appear if it needs to -- ~~~~~~~~~~~~~~~~~~ Rob Giordano Microsoft MVP Expression Web "FrontPage Error" <FrontPageError@discussions.microsoft.com> wrote in message news:EC19C7CE-1C5A-4872-A47B-2C04BD7E96A7@microsoft.com... > on microsoft office frontpage 2003 - when i up loaded my web pages to my > web > s...

Dlookup in query
Hi guys, I have a query in which i want to use a dlookup which i have embedded in a function. Strange thing is that the first record returns the correct value and after that i get a invalid use of null.. ?? scenario (for testing purposes) table1: MyDate (set to date time) MyAmount (set to currency - standard - two decimals) table2: Dummy (text field) FutureDate (Set to date time) Created a query with the two fields from table2 both fields added to the querygrid. Third field added as follows: Amount: getprice(FutureDate) Module: function GetPrice(FutureDate) as d...

Unable to start POP3, NNTP, IMAP4...
Dear all, I'm evaluating to install Exchange 2003. After the installation I find the said protocol haven't been started. I tried to start them in "Servers --> Server Name --> Protocols" but no help. Please comment.... Thanks!! Background: Windows 2003, Exchange 2003, Active Directory DC with all roles of FSMO as it's the first DC in the forest. Thank you very much!! -- Are you boring? Let's come to talk together... ^^ news://news.hk4u.com/hk4u.2hit6 Those services are disabled by default in Exchange 2003. Go to Administrative Tools, Services and enable...

Unable to conect
Hi, I have set up my email account to work with aol using the guidlines for outlook 2002 but it is still unable to connect. Any suggestions? Thanks. John <John@discussions.microsoft.com> wrote: > I have set up my email account to work with aol using the guidlines > for outlook 2002 but it is still unable to connect. Any suggestions? Since you pay AOL for their service, my suggestion is to ask AOL. -- Brian Tillman ...

Unable to click on charts & unable to create any new charts Excel
Hi Just started using Microsoft Excel 2007 and I seem to have done something that means the chart option is unavailable. The chart section is now grey and all charts I have created are 'locked' I cannot click on them anywhere. I'm working on a project and need it finished by Monday. Do you mean that if you click on a chart it does not get a border to show it is activated and there are no range-finder borders around the data that makes the chart? This is a bit odd. Have you tried a new workbook to see if the problem is with just this one? My advice with all odd things is...

how do i bring a visual basic form to the spread sheet?
Hi, I have created a form using teh developer tab in excel in vb. The problem is anytime I want to access the form i need to go to the developer tab, click on vb and run it frorm there. What I would like to do is to bring the form to the spreadsheet so that I can run it directly from there. or better yet, be able to run the form independently of the spreadhseet. is that a possibility? Thanks a lot for your help, Maryam add a button to the spreadsheet and attach the code UserForm1.show 'or whatever the form name is You will not be able to run the form independant of ...

Question about DLookUp and how to bring in info from a foreign tab
OK, my database form is based off of a table titled: Show Events, and I want to pull separate data from a foreign table titled: Show Stores. One of the data fields I am trying to pull over from the foreign table is the year that the store joined the organization, which is the field titled: MemberSince. I am using the expression equation in an unbound control: =DLookUp("[MemberSince]","Show Stores","[Count]=1") Count is the field on the foreign table that gives a unique ID number to each store. My problem is that when I scroll through the different pages o...

Combo Box Search By Query
Hi All, Ive Created a Dialog Box With some tick box's and a Combo Box. the Dialog box aint quite working the way i would like it to. the dialog box will open a report which the report has a record source of the query. the tick box on is ment to Included Projects that have Maintenance assigned. but the tick box is set to a yes or no. and the query looks at this field the combo box is the same, the combo lists all the end clients, and it works if i select a client which is assigned to the project, in which case i could return 100 Starbucks Coffee. but lets say i just want to display al...

Making formula result #NA invisible?
Hi All I want to make my #NA values invisible in a table, from which a chart is produced. I have to use NA(), not "", or else the chart doesn't plot correctly. The error values are produced (when a referenced cell is blank) by a formula of the form: =IF(B40="",NA(),24*60*(B40-$C$14)) Diane posted essentially the same problem on 7 August and got a 'workaround' suggestion from DVT as follows: "You could set your formula to return a #NA, then use conditional formatting to make the text "invisible" in that case. The conditional formatting would go...

I am unable to send e-mails -unable to download files from IMAP.
Please help. I am so frustrated with this In news:4564BC25-92D9-4094-A598-A23848856E5F@microsoft.com, ajmtextiles <ajmtextiles@discussions.microsoft.com> typed: > Please help. > > I am so frustrated with this I can understand why you might be frustrated, but you've provided no useful information for anyone to go on, so I doubt anyone can help you. When you post in here, always include your version, SP level, and mode (if applicable) of Outlook - you can find this information in Help | About. Also include the type of mail account(s) you use and any other pertinent de...

MSXML6 C++ unable to locate node
Hi, I am new to using the MSXML functions in C++. I found this on MSDN as an example of what I wanted to do, http://msdn2.microsoft.com/en-us/library/ms765465.aspx. I have tried a number of XPATH examples to try and retrieve the "><Code>12455</Code>", but have been unable to do so. The MSDN example works fine. So, I am wondering if it's a namespace issue? Any help would be appreciated. Thanks. Jeff I have changed the code as follows: int _tmain(int argc, _TCHAR* argv[]) { CString sResponse = "<?xml version=\"1.0\" encoding=\"utf...

Multiplying a cell and displaying the result in the same cell
Hi Is it possible to perform a calculation on a cell (well a column) an replace the data in the cell with the result? I have a spreadshee which uploads data to a database (not sure which type - it's mechanical estimating package) and I need to increase the price colum by a certain percentage. I cannot add or delete any of the column otherwise the upload won't work. Thanks Ro -- robspo ----------------------------------------------------------------------- robspot's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=1532 View this thread: http://www.excelfo...

'OWA was unable to get to your inbox'
Hello, OWA is working fine for everyone on my domain (and has been for years) except for one person. When he logs in it gives the error mentioned above in the subject line. I've checked his exchange account and it doesn't seem to differ from anyone else's... Does anyone know how to solve this problem? Thanks, John Repost in an Exchange group as OWA is a function of Exchange, not Outlook. When you do, include the Exchange/Windows versions, and SP-level for each. -- Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the (in...

Unable to display the folder (have I lost my mail?)
I've just transferred all my mail from my mac via IMAP, and rather laboriously set up all my rules to get all my mailing lists in separate folders etc. Outlook has just decided that it can't display the two biggest folders because e:\documents and settings\administrator\local settings \application data\microsoft\outlook\outlook.pst is in use and cannot be accessed. The file does not exist. I assume my mail is gone and I have to go and throw it at the IMAP server again, but could anyone tell me why this has happened and how to stop it from happening again? Is this all on a Mac?...

Front End Finding Back End
I am currently using Access 2003. My question concerns connecting the front end up with the back end when you implement a new front end for the first time. I will describe the method I have been using. I am sure there must be an easier way with code. If I have a new user, I have them "Map a Network Drive" on their computer. This assigns a drive letter to the folder that contains the Backend. Once that is done, I open the Front End and run a "Check Links" code from Northwind. That allows me to designate the path to the Backend using the "Windows Explorer&q...

Backing up problem
Each time I back up my Money and close out of it, then when I open it back up all of my accounts and information are gone, and then I have to restore my accounts from my backup. Also, when I back up it now takes three disks, where before, it always only took one. I don't have anymore information in it than I did before, so why is it taking 3 now? In microsoft.public.money, Melody wrote: >Each time I back up my Money and close out of it, then >when I open it back up all of my accounts and information >are gone, and then I have to restore my accounts from my >backup....