Ribbon error following previous versions of my application

I have been working on an access database for while. I recently decided to 
edit the ribbon in order to add a new button (a spell check tool). I just 
added a few lines to the USysRibbons table. I did not do anything else. The 
button worked as expected for a while. Something eventually went wrong for 
some reason and I get the below error.

However previous versions of my database (developed just before I edited the 
ribbon and consequently the USysRibbons table) no longer work. It looks that 
THIS ERROR IS FOLLOWING PREVIOUS VERSIONS OF MY DATABASE.

The error I get is as follows:

Error found in Custom UI XML of :C:\Documents and 
Settings\sssssss\desktop\filename.mdb”:

Line:10
Column:46
Error Code 0x80004005
Element ‘{http://schemas.microsoft.com/office/2006/01/customui}command’ is 
unexpected according to content model of parent element  
‘{http://schemas.microsort.com/office/2006/01customui}group’

If I click on “Ok to all” the error no longer shows for that particular part 
of my application until I close and reopen access. 

Below are the ribbons I have. These same ribbons worked great until I 
eventually edited them –the unedited version is shown.


Ribbon1

<customUI xmlns="http://schemas.microsoft.com/office/2006/01/customui">
<ribbon startFromScratch="true">
<tabs>
<tab id="dbMain" label="XXX XXXX" visible="true">
<group id="dbExit" label="Exit">
	<control idMso="FileCloseDatabase" label="Exit"/>
</group>
<group id="dbFindSearch" label="Find/Search">
<control idMso="FindDialog" label="Find"/>
<control idMso="SortUp" label="Sort Up"/>
<control idMso="SortDown" label="Sort Down"/>
<control idMso="FiltersMenu" label="Filter"/>
<control idMso="FilterClearAllFilters" label="Remove Filter"/>
</group>

<group id="dbDelete" label="Delete ">
<control idMso="RecordsDeleteRecord" label="Delete Record"/>
</group>
</tab>
</tabs>
</ribbon>
</customUI>

Ribbon2

<customUI xmlns="http://schemas.microsoft.com/office/2006/01/customui">
<ribbon startFromScratch="true">
<tabs>
<tab id="dbMain" label="XXX XXXX" visible="true">
<group id="dbExit" label="Exit">
	<control idMso="FileCloseDatabase" label="Exit"/>
</group>
<group id="dbFindSearch" label="Find/Search">
<control idMso="FindDialog" label="Find"/>
<control idMso="SortUp" label="Sort Up"/>
<control idMso="SortDown" label="Sort Down"/>
<control idMso="FiltersMenu" label="Filter"/>
<control idMso="FilterClearAllFilters" label="Remove Filter"/>
</group>
</tab>
</tabs>
</ribbon>
</customUI>





0
Utf
1/29/2010 4:15:01 PM
access.modulesdaovba 1670 articles. 0 followers. Follow

1 Replies
910 Views

Similar Articles

[PageSpeed] 46

I have found this website to be helpful in understanding how to write xml 
for custom ribbons.

http://www.accessribbon.de/en/index.php?Access_-_Ribbons:Ribbon_XML___Controls


Jeanette Cunningham MS Access MVP -- Melbourne Victoria Australia

"Jess" <Jess@discussions.microsoft.com> wrote in message 
news:25529483-551B-4E6B-8E2F-AFAC8BC3BF7A@microsoft.com...
>I have been working on an access database for while. I recently decided to
> edit the ribbon in order to add a new button (a spell check tool). I just
> added a few lines to the USysRibbons table. I did not do anything else. 
> The
> button worked as expected for a while. Something eventually went wrong for
> some reason and I get the below error.
>
> However previous versions of my database (developed just before I edited 
> the
> ribbon and consequently the USysRibbons table) no longer work. It looks 
> that
> THIS ERROR IS FOLLOWING PREVIOUS VERSIONS OF MY DATABASE.
>
> The error I get is as follows:
>
> Error found in Custom UI XML of :C:\Documents and
> Settings\sssssss\desktop\filename.mdb":
>
> Line:10
> Column:46
> Error Code 0x80004005
> Element '{http://schemas.microsoft.com/office/2006/01/customui}command' is
> unexpected according to content model of parent element
> '{http://schemas.microsort.com/office/2006/01customui}group'
>
> If I click on "Ok to all" the error no longer shows for that particular 
> part
> of my application until I close and reopen access.
>
> Below are the ribbons I have. These same ribbons worked great until I
> eventually edited them -the unedited version is shown.
>
>
> Ribbon1
>
> <customUI xmlns="http://schemas.microsoft.com/office/2006/01/customui">
> <ribbon startFromScratch="true">
> <tabs>
> <tab id="dbMain" label="XXX XXXX" visible="true">
> <group id="dbExit" label="Exit">
> <control idMso="FileCloseDatabase" label="Exit"/>
> </group>
> <group id="dbFindSearch" label="Find/Search">
> <control idMso="FindDialog" label="Find"/>
> <control idMso="SortUp" label="Sort Up"/>
> <control idMso="SortDown" label="Sort Down"/>
> <control idMso="FiltersMenu" label="Filter"/>
> <control idMso="FilterClearAllFilters" label="Remove Filter"/>
> </group>
>
> <group id="dbDelete" label="Delete ">
> <control idMso="RecordsDeleteRecord" label="Delete Record"/>
> </group>
> </tab>
> </tabs>
> </ribbon>
> </customUI>
>
> Ribbon2
>
> <customUI xmlns="http://schemas.microsoft.com/office/2006/01/customui">
> <ribbon startFromScratch="true">
> <tabs>
> <tab id="dbMain" label="XXX XXXX" visible="true">
> <group id="dbExit" label="Exit">
> <control idMso="FileCloseDatabase" label="Exit"/>
> </group>
> <group id="dbFindSearch" label="Find/Search">
> <control idMso="FindDialog" label="Find"/>
> <control idMso="SortUp" label="Sort Up"/>
> <control idMso="SortDown" label="Sort Down"/>
> <control idMso="FiltersMenu" label="Filter"/>
> <control idMso="FilterClearAllFilters" label="Remove Filter"/>
> </group>
> </tab>
> </tabs>
> </ribbon>
> </customUI>
>
>
>
>
> 


0
Jeanette
1/30/2010 10:43:55 AM
Reply:

Similar Artilces:

Track in CRM Error 03-24-06
I changed the format of the tracking token and now whenever someone tries to track an email in Outlook they get a message saying an error has occured. I tried changing it back, restarting the server, but to no avail. Any suggestions? That is a none bug in the software, you can access the bug information on Microsoft secure site but you can't download the fix. The fix has to be emailed from a MS tech. If you don't have support go ahead and pay for a single occurence and then explain your issue they will send you the fix and refund the money for support. Not sure why they do...

[Fwd: Re: New computer. Newer version of Windows. Printing color Differences]
FYI To correct this problem, you need to download the correct drivers for your printer for Windows 7 (assuming this is your OS). Go to the website of your printer maker and look if they have the correct printer drivers for Windows 7. You haven't said anything about make and model of your printer so I can't help you here. hth Reddawg2566 wrote: > > I just bought a new computer with Windows 7 and Microsoft Office 2007 on it. > Before getting the new system, I had designed all my company letterheads, > paperwork, etc. using Publisher. Well when I go ...

Compile Error
Hi all, The first two lines if this I got from another response on here. I am trying to to step down through a list after each time I go through the copy and pastes and save the file. I get an error " Compile Error Invalid or unqualified Reference" and the For myRow = 1 To ..Range("A65536").End(xlUp).Row is highlighted in yellow.I am starting to get really lost with this part. Any help would be appreciated. Thanks Dim myRow As Long For myRow = 1 To .Range("A65536").End(xlUp).Row Sheets("Contacts").Select Range("B7").S...

2007 Ribbon Bar
Is there any way to hide or customize the 2007 ribbon bar to the same size as any older version of an access menubar? The size of the new ribbon bar forces my form to get cut off on the bottom of the screen. This has been getting many bad reviews from my users and either I need to redesign my form or find a way to get rid of the ribbon bar. I opt to go the easier route (if at all possible) of hiding the ribbon bar. On Tue, 23 Oct 2007 17:44:01 -0700, Secret Squirrel <secretsquirrel@discussions.microsoft.com> wrote: Right click in the area where the tabs are, and choose "Minim...

Printing errors
I have created a new class id in GP 9 and given it everything I can find in regards to printing. We have given it security to the new reports and pointed to them with Edit Launch File but my users continue to get security errors when they attempt to print packing slips and other sales documents. I captured this from the logging in dex.ini that I enabled; /* Date: 02/06/2009 Time: 12:36:24 stmt(16730792):*/ EXEC XXXXXX.dbo.zDP_SY00700SS_1 'SOP_Print_Options' but I cannot find that form/window/file anywhere?/ What am I missing (besides training in this application)!!!! You a...

Error while accessing Organization Forms
Good day, Recently we have not been able to access our Organization Forms folder. When choosing a form we receive the below msg : "The connection to the microsoft Exchange server is unavailable. Outlook must be online or connected to complete this action" When going into ESM to the following location : Start Exchange System Manager. 2. Expand the Organization object. 3. Expand your Administrative Group. 4. Expand Folders. --> We do not see the Public folders. Also, when expanding the exc server, and clicking on Public folders, we see our Org forms. How can I resolve th...

SFO access is denied error
Hi, i have installed the SFO on a Win xp with office 2003. The installation don't had any problems, but in outlook when i click in the crm folder, or any folder in crm the next error occured. Parser Error Message: Access is denied: 'Microsoft.Crm.Platform.ComProxy'. Line 196: <add assembly="System.EnterpriseServices, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/> Line 197: <add assembly="System.Web.Mobile, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/> Line 198: <add assembly="*"/&g...

File Locked Error
Hello, I am encountering an error message when trying to open a shared XL 200 file. The error message indicates that the file is locked. I am unabl to disable shareing or use 'Save As' to get around the issue. Copyin also does not help (evidently the lock flag must be stored in the fil itself). Any ideas what a good workaround is? I'm at a lost. Our IT has bee looking into it since Monday with no luck. Thanks, Stev -- Steve ----------------------------------------------------------------------- SteveS's Profile: http://www.excelforum.com/member.php?action=getinfo&...

New Version
I just recieved a box in the mail with RMS Version 1.3. has anyone been brave enough to try it out yet? Can i install it on top of our existing 1.2 version? Will it erase any settings, macros, etc...? It's always good practice to back up all customized receipt templates/labels/database/etc... You will have to un-install 1.2, then install 1.3 Macros are stored in the database, so my initial thought is no. Be aware 1.3 will NOT work with windows 2000 or older any more, only XP and 2003... "RMSUser" <RMSUser@discussions.microsoft.com> wrote in message news:5CF4E06C-E1...

Outlook
Hey guys After a feq months of using a new mail provider, one of our machines started receiving this message when sending email: Your message did not reach some or all of the intended recipients. Subject: xxxxx Sent: 09/04/2006 11:26 The following recipient(s) could not be reached: '...@....com' on 09/04/2006 11:26 451 Temporary local problem - please try later Things got worse a few days ago when all the messages were bounced back. I really don't know what to do. The settings are the same on all the computers. Also the ISP is the same, SMTP aut...

Public Folder error
I am getting an error in Exchange system manager (E2K03) when I try to view the properties of my public folders. I can see the list of folders, but not properties. Also, I can access the folders via Outlook. "The HTTP service used by Public Folders is not available, possible causes are that Public stores are not mounted and the Information Store service is not running. ID no. c1030af3 Exchange system manager The store is mounted, and the store service is running. Any ideas? I am stumped and it's probably really easy. This can be caused by several different things. * If t...

Insert Into error
Hi All, I've tried to insert some string to my access database using vbscript through SecureCRT. This is my current code: > > # $language = "VBScript" > # $interface = "1.0" > dim qstr > ' Create new instance of Microsoft Access. > Set objAccess = CreateObject("Access.Application") > > ' Open database in Microsoft Access window. > objAccess.OpenCurrentDatabase("E:\Rama_kerjaan\VBScrippt-Access\Code\coba.mdb") > > ' insert the data > qstr = "INSERT INTO gateway (Sortir) values(&...

RIBBON COLOR
Is there any idea how to change the color of a custom tab different from default theme as in the case of Contextual tabs? Sure would oblige if appropriate XML tags, ideas or address of a source on net is provided. -- Thanx in advance, Best Regards, Faraz I don't think you can Faraz, you have a few ribbon theme colours, but all tabs carry that colour AFAICS. HTH Bob "Faraz A. Qureshi" <FarazAQureshi@discussions.microsoft.com> wrote in message news:67C1065B-1AEA-44B8-B595-210CA78EE546@microsoft.com... > Is there any idea how to change the color ...

Relaying Errors
Ok, so for the last several days or so I've been experiencing a problem with my SBS 2003 server. I've been getting a lot of messages bounced back stating that relaying is denied. After a lot of searching and attempting multiple fixes I believe I've discovered the problem, but am unsure of how to fix it. First let me state that I'm completely baffled as to why it started happening. I have made no changes in IP or DNS nor have I patched the server or changed the config. It seems that my server is either attempting to deliver messages to the wrong servers or is simp...

Error 8026
I have a 2-node active/passive Exchange 2003 cluster. A domain controller, one of six, in our only domain was rebooted and it hung on startup. This caused the 8026 error, "LDAP Bind was unsuccessful on directory servername.domain for distinguished name ''. Directory returned error:[0x51] Server Down. DC=dcname1,DC=dcname2". I have multiple dc's, why Exchange trying to bind to one particular dc? Which DC does the RUS point to? -- Neil Hobson Exchange MVP For Exchange news, links, and tips, check: http://www.msexchangeblog.com "Dave G" <DaveG@disc...

error when attaching apple "pages" doc #2
hi whenever i try to attach a "pages" doc to an entourage email i get a mnessage that i need to instal suffit i have stuffit exapnder installed, am running osx and office 2004 i loked at stuffit's site and they want $ for the compression program any ideas? i have "no compression" selected in my preferences thanks ...

Word Application Error
I get error message "The instruction at "0x30a9248e" referenced memory at "0x00000471". The memory could not be "read"." I am trying to edit a document which contains screen prints and link. It's about 14 meg, but only 22 pages. Am I exceeding a size limit? I need to reboot system each time I get the message. Any help???? ...

Error when editing/creating attribute
I am trying to edit an attribute and get this error: "Object reference not set to an instance of an object." I was not having this problem a week ago. Anyone know how to fix this? Thanks, -Rick M ...

How To: Ribbons
Hi, I want to create a custom ribbon menu but load it from code when the database starts (Autoexec), e.g. the ribbon menu is temporary in that I DON'T/CAN'T use the 'USysRibbons' table (ADP and all that, tables are stored in Oracle), so after I've connected to the Oracle server and created a recordset to the menu ribbon table that stores my XML, I then load my menu ribbons by using the code, While not rs.EOF Application.LoadCustomUI rs!MENU_RIBBON_NAME, rs!MENU_RIBBON_XML rs.movenext Wend So the question, what is the code that will hide the curre...

Event Id errors on exchange
Hi, my server and exchange server were working perfectly fine last week and today when we got in the office we could not log into outlook. Here are the errors i got in the event log. We have all the service packs for server 2003 and exchange 2003 installed. EVENT ID 2102 Process STORE.EXE (PID=3600). All the DS Servers in domain are not responding. Event ID 8026 LDAP Bind was unsuccessful on directory server.********.com for distinguished name ''. Directory returned error:[0x51] Server Down. Event ID: 2102 Process MAD.EXE (PID=2224). All Domain Controller Servers in us...

Error in VLOOKUP REFERENCE?
The following formula is in a cell in a worksheet called MODEL. It pulls data from the named range HarvestData. Problem is, if I add a column before "M" in the named range HarvestData, effectively moving data from M to N, my lookup formula obviously no longer works. Does HarvestData need to be a dynamic range (it is not) or does the problem lie in the VLOOKUP? Somehow I need to update the column reference in the VLOOKUP when a column is added or subtracted in HarvestData. Help on this would be greatly appreciated. Mike (VLOOKUP($A17,HarvestData,COLUMN(M14),0) If you have h...

Error 2046
Hi all, Does anyone know how to trap error 2046 and have a custom massage? TIA, Tom I managed. Thanks, T "Tom" <partner1973@yahoo.com> wrote in message news:eG7RkuCnHHA.4188@TK2MSFTNGP02.phx.gbl... > Hi all, > > Does anyone know how to trap error 2046 and have a custom massage? > > TIA, > Tom > ...

Bad Error.
I began trying to make a query that would use information based off a filter query, w/ the goal of creating a report from the new query. To open the report i created a macro and than tried to execute it. Thats when i got the followig: "x locale has detected corruption in this file. To repair the corruption, first make a backup copy of the file. Then, on the tools menu point to database utilities and click compact and repair database. If you are currently trying to repair this corruption than you wil need to recreate this file or restore it from a previous backup." x -->my co...

Error 17092
Version: 2008 Operating System: Mac OS X 10.6 (Snow Leopard) Processor: Intel Email Client: pop I keep getting this error message on an almost daily basis when sending emails to people that that: <br><br>Have a legitimate Email Address <br><br>Are in my Entourage address book <br><br>I have exchanged emails with many times <br><br>I am using the same POP/SMTP server that I have always used. The error will occur on a known user. The solution is to delete the email address in the To field and then retype the email address - which of course ...

IMF UceContentFilter Errors
I'm having problems with the MSExchange.UceContentFilter.xml file. I'm always careful to save it in UNICODE, but I still get the Event Log error: "An error occurred while loading Microsoft Exchange Intelligent Message Filter. The error code is 0x80004005. " However, this doesn't happen consistently. At one point I thought it was choking when I included certain special characters in a filter string (ampersand, square brackets, and # seemed to cause problems). However, I've recently had problems entering even simple text strings--sometimes they work, others they seem...